Upgrade endpoints

This section applies to both managed and unmanaged endpoints.

Prerequisites

  • SafeGuard Enterprise encryption software version 6.10 or later must be installed. Older versions must first be upgraded to version 6.10.

  • SafeGuard Enterprise Database, SafeGuard Enterprise Server, and SafeGuard Management Center must have been upgraded to the latest version. For successful operation, version numbers of SafeGuard Enterprise Database, SafeGuard Enterprise Server and SafeGuard Management Center must match.

  • SafeGuard Management Center 8.0 and SafeGuard Enterprise Server 8.0 can manage SafeGuard Enterprise protected endpoints version 6.0 or later. However, we recommend that you use the same version of encryption software on every endpoint.

  • Make sure that you have Windows administrator rights.

To upgrade SafeGuard Enterprise-protected endpoints:

  1. Log on to the computer as an administrator.
  2. Install the latest pre-installation package SGxClientPreinstall.msi that provides the endpoint with the necessary requirements for a successful installation of the new encryption software.
    Do not uninstall previous pre-installation packages as they are updated automatically.
  3. Install the latest version of the SafeGuard Enterprise encryption software. Depending on your installed version, a direct upgrade might not be supported. Older versions must be upgraded version by version until version 6.10 is reached.

    Windows Installer recognizes the features that are already installed and only upgrades these. If Power-on Authentication is installed, an updated POA kernel is also available after a successful update (policies, keys, etc.). SafeGuard Enterprise is automatically restarted on the computer.

  4. To remove configuration protection completely, it is also necessary to uninstall SGNCPClient.msi (or SGNCPClient_x64.msi).
  5. After installation is completed, restart the endpoint when prompted.

The latest version of the SafeGuard Enterprise encryption software is installed on the endpoints. Next, upgrade the endpoint configuration.

Note: You cannot make changes to your installed modules during an upgrade. If changes are required, see About migrating.