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Device Configuration

Sophos Central Firewall Manager (CFM) enables the organization to monitor and manage multiple Firewall devices
from a central location. Device Configuration allows sorting of the added devices on the basis of different criteria
for better visibility and permits enforcement of global policies for security features like Firewall, VPN, Intrusion
Prevention System, Application filter, Anti-spam and Anti-virus on them. It also allows the administrator to create
and implement multiple Traffic Shaping policies to stop bandwidth abuse in organization to ensure productivity of the
employees.

As soon as an device is added to CFM, CFM connects to the device and starts synchronization process and the
status of the device changes to . In the synchronization process, CFM updates its local copy as per the information
provided by the device. Once the synchronization is successful, status changes to . CFM maintains the mirror or
duplicate copy of the Device configuration. However, the device copy is always considered as the master copy. If due
to any reason, if synchronization process fails device status changes to .

Once the device is added and synchronized, the device sends the information like device health, network information,
various attacks and threats identified by the device to CFM through heartbeat at the regular interval.

Device Configuration has the following Dashboards to view and manage device groups and individual devices:

• Device Group Dashboard
• Device Dashboard

Device Dashboard

Device Dashboard provides a single screen snapshot of the state and health of the selected managed device. To view
the details of individual device, go to Device Configuration and expand the Device Group tree and select any device.

Device Information

Company Name - Name of the company under whose name device is to be registered. For unregistered devices this
field will be blank.

Device Name - Name of the device. Click Edit hyperlink to edit the device details.

Host Name - Host Name as configured on the Sophos XG Firewall device.

Serial Number - Serial number of the Sophos XG Firewall device.

Model - Model number

Location - Name of the place where Sophos XG Firewall device is deployed.

Firmware Version - Firmware version running on the device

Time Zone - Time zone of the device

Date & Time (Time calculated based on CFM time) - Date and time of device in Day Mon DD YYYY HH:MM:SS
format

Last Good Backup - Date and time in Day Mon DD YYYY HH:MM:SS format when last good backup has been
taken.

Last Backup - Date and time in Day Mon DD YYYY HH:MM:SS format when last backup has been taken.

Change Detail - Status of Change Control Settings. If the change control is enabled it displays hyperlink to view
change control for the device.



 | Device Configuration | 4

Connection Information

Device IP/Domain - Address IP address of the device

Connection Status - Current connectivity status

Synchronization Status - Synchronization status. Click ‘Sync now’ hyperlink to start synchronization process.

Communication Mode - Communication mode to manage Sophos XG Firewall device from CFM.

Available Modes:

• Central Management will push updates to this Device
• This Device will fetch updates from Central Management Communicate with Sophos XG Firewall using

Communication protocol – HTTP, HTTPS Port Communication port Test Connection Click “Test Now” to
establish the connection between Sophos XG Firewall and CFM.

Security

Gives security information on Web Virus, Mail Virus, Spam Mails, Web Usage Health, Intrusion Attacks, IPS
Severity, ATP Events and Endpoint Health.

Resource

Gives resource utilization information on CPU, Memory, Disk (Report) and Disk (Config).

Availability

License

Gives license information on Essential Firewall, Network Protection, Web Protection, Mail Protection, Web Server
Protection, Sandstorm, Standard Support and Enhanced Support.

Signature Information (Applicable only if the device is Registered)
IPS Signature Version - IPS signature database version on the device. Click Synchronize button to update IPS
signature database with latest available database version at upgrade server.

Anti Virus Version - Anti Virus engine version on the device. Click Synchronize button to update AV signature
database with latest available database version at upgrade version.

Device Monitoring

Packet Capture - Displays time in Day, DD Mon YYYY at HH:MM:SS format when packet capture information is
fetched from managed devices through CFM.

Connection Capture - Displays time in Day, DD Mon YYYY at HH:MM:SS format when connection list information
is fetched from managed devices through CFM. Connection list provides current or live connection snapshot of
managed device in the list form.

Tools - Click to open Tools page of managed device.

CTR - Displays time in Day, DD Mon YYYY at HH:MM:SS format when CTR is generated for managed devices
through CFM. DHCP Lease - Displays time in Day, DD Mon YYYY at HH:MM:SS format when DHCP Lease
information is fetched from managed devices through CFM.

Live Users - Displays time in Day, DD Mon YYYY at HH:MM:SS format when Live Users information is fetched
from managed devices through CFM.

IPSec Connections - Displays time in Day, DD Mon YYYY at HH:MM:SS format when IPSec Connections
information is fetched from managed devices through CFM. SSL VPN Users Displays time in Day, DD Mon YYYY
at HH:MM:SS format when SSL VPN Users information is fetched from managed devices through CFM.
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Live Connection IPv4 - Displays time in Day, DD Mon YYYY at HH:MM:SS format when IPv4 Live Connections
information is fetched from managed devices through CFM.

Live Connection IPv6 - Displays time in Day, DD Mon YYYY at HH:MM:SS format when IPv6 Live Connections
information is fetched from managed devices through CFM.

CPU usage for last two hours

Displays line graph for CPU usage for last two hours.

Memory usage for last two hours

Displays line graph for Memory usage for last two hours.

Interface Status

Displays status of managed device’s interfaces with details like Interface Name, MTU, Interface Speed, MAC
Address, Status of the interface.

Policy Configuration Tasks

CFM allows following types of configuration:

Group level configuration - Configuration to be applied to all the devices in the group.

Subgroup level configuration - Configuration to be applied to all the devices in the sub group.

Device level configuration - Configuration to be applied to the individual devices only.

For managing and monitoring purpose, CFM groups all the managed devices into various groups. Use All Managed
Devices drop down to view list of all the groups.

By default, CFM is shipped with three default Device Groups:

• All Managed Devices – Displays list of all the devices by name and their status.
• All Firmware Versions – CFM automatically groups all the devices added in CFM as per the device firmware

version.

• All Device Models – To view the device model wise grouping, under the Device Group, click All Device Models
Version.

CFM allows you to create custom Device Groups based on various criteria like Department, Country etc. Please refer
System Management > System Settings > Device Settings > Device Group to create and manage Device Groups.

To see the individual devices, use the Manage Policy menu.
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Manage Policy drop down menu also displays status of the Devices as:

Connected and synchronized

Disconnected and synchronized

Connected and unsynchronized.

Disconnected and unsynchronized

Disconnected

CFM displays details of all the added devices as soon as you log on to Web Admin Console in the form of Dashboard.
CFM provides two types of dashboards:

• Device Group Dashboard – Consolidated dashboard for all the devices of selected device group or device
subgroup

• Device Dashboard – Dashboard for the selected device only

Please note that type of dashboard displayed changes, based on selected device group, subgroup or device. .

Monitor and Analyze

Control Center

The Control Center appears as soon as you logon to the CFM Admin Console. Control Center provides a single screen
snapshot of the state and health of the CFM System and the managed devices.

Device Information

All Managed Devices - Total number of devices in the selected device group or subgroup

Synchronized - Total number of synchronized devices in the selected devices group or subgroup

Unsynchronized - Number of unsynchronized devices in the selected devices group or subgroup

Connected - Total number of devices currently connected to CFM in the selected device group or subgroup

Disconnected - Number of devices in the selected device group or subgroup, which are currently disconnected.

Firewalls waiting for addition - Devices displayed under Discover , which are waiting to be added.

Note:  Firewalls waiting for addition appears only when devices are listed in Discover .
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Device Monitor Summary

Dashboard Monitoring Graph displays critical heath information of the managed Devices in graphical manner. CFM
monitors the managed device based on the following heath parameters and statuses:

• Security: HTTP Attacks, Mail Attacks, Spam Mails, Web Usage Health, IPS Alert.
• Resource: CPU, Memory, Disk (Report), Disk (Config).
• Licensing: Base Firewall, Network Protection, Web Protection, Email Protection, Web Server Protection,

Enhanced Support, Enhanced Plus Support.

The Monitoring Dashboard continuously monitors the managed devices for the wide range of security attacks,
resource utilization and licensing statuses which helps the administrator to take informed decisions in resolving the
risk landscape.

The administrator can set the threshold values for each of the parameters by clicking on Adjust Thresholds hyperlink.
However, if the administrator does not specify the threshold values, the graphs are generated with Device Defaults
based on the table below:

Gateway Status

Gateway Name - Name of the gateway

Gateway IP address - IP address of the gateway

Gateway Status - Status of the gateway

Model Wise Information

This area provides the name of device model along with total number of devices of that model number.

Click the hyperlink to view following details of device model:

• Device Name – Name of device
• Device Key – Device key of the managed device
• Company Name – Name of the company where the managed device is deployed
• Model – Model number of the managed device
• Status - Current state of the device

System Information

System Time - System (CFM) time in Day Date Mon YYYY HH:MM:SS format

Up Time - CFM device up time duration in day, hours and minutes format

CFM Version - CFM version number along with the link to check the availability of new version

Model - CFM Device model number

Device Key - CFM device key

Peer Device Key - If the device is deployed in HA (High Availability) node then it displays device key of auxiliary
device.

Compatible Sophos XG Firewall Versions - List of Sophos XG Firewall device versions which are manageable
through CFM

Live Connected Users - Number of connected users. Click to view details of connected users

Messages

Time - Time of sending alert in date and time format

Message - Alert message(s) generated by CFM system to notify the administrator regarding any alarming situation or
availability of new CFM version.
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Diagnostics
Monitor and Analyze > Diagnostics

Diagnostic menu allows checking the health of your device in a single shot. Information can be used for
troubleshooting and diagnosing problems found in your device.

Use this menu to configure below details:

• Services - View the current status and manage all the configured services.
• Support Access - Allow and manage remote support .
• Policy Test - Apply and troubleshoot firewall and web policies and view the resulting security decisions.

Services
Services page allows you to view and manage the status of configured Services.

You can view the current status and manage all the configured services:

• Anti Spam
• Anti Spam Center Connectivity
• Anti Virus
• Authentication
• DNS Server
• IPS
• Web Proxy
• WAF
• DHCP Server
• DHCPv6 Server
• Router Advertisement Service
• Hotspot

Parameters
Services

Name of the configured service.

Status

Current status of the service.

Manage

Click to start or stop or restart the respective service.

Actions
Start Button

Start the service whose status is ‘Stopped’.

Stop Button

Stop the service whose status is ‘Started’.

Restart Button

Restart service: Only for Authentication Service and Web Proxy Service.

Status
No Web Server configured

No Web Server is configured.
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Note:  The “Start” button is disabled in this case.

Connected

When Internet connectivity available for the Gateway.

Running

Service has successfully started.

Disconnect

When Internet connectivity unavailable for the Gateway.

Stopped

When a service is stopped or when the respective Subscription Module is not subscribed.

Support Access
The Support Access function enables support staff to connect to the WebAdmin of Sophos Firewall OS without
knowing a certain login account. The HTTPS traffic of the Sophos Firewall OS session is proxied by the Support
Access function. Identification of Sophos Firewall OS happens through an access ID which the admin of Sophos
Firewall OS must tell the support staff. All connections between Sophos Firewall OS and the Support Access function
are initiated by Sophos Firewall OS on TCP port 22.

The general process of the access can be described in the following steps:

1. Enable the Support Access on Sophos Firewall OS under Device Configuration > Diagnostics > Monitor and
Analyze > Support Access and click the toggle switch.

2. Confirm the upcoming message with OK.
3. From the drop-down menu Grant Access For select the time the access is valid.
4. Click Apply to update the settings.
5. Confirm the upcoming message with OK.

Sophos Firewall OS establishes a secure control connection to APU and negotiates a unique Access ID.
6. Communicate the Access ID to the support.

The support uses this Access ID to login to Sophos Firewall OS. The control connection remains established until the
specified time, which is displayed next to Access Until.

You can disable the connection manually any time by clicking the toggle switch and confirming the disable message
with OK.

Policy Test
With the policy test tool, you can apply and troubleshoot firewall and web policies and view the resulting security
decisions. For example, you can create a web policy to block all social networking sites for the specified users and
test the policy to see if it blocks only the specified content and users. The results display the details of action taken by
the firewall based on the applicable rules and content filters.

Note:  If policy routing affects connections to the destination, causing the connection to go through a different
network zone, the policy test decision will not reflect the changed zone.

Note:  Policy tester assumes that all web traffic is intercepted in transparent mode.

URL URL to be tested. For example, you can test a social
networking site, which should be blocked by the category
and content filter that are specified in a web policy.

Authenticated User User to be included in the test. For example, you can
specify a user, who is the member of a group that you
have included in a web policy.
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Time and Day Time and day to be included in the test. For example,
you can specify a time that is within the constraints (or
schedule) of a web policy.

Test Method Possible values are:

• Test Firewall Policy. Source IP and zone that you
wish to test.

• Test Web Policy. Web policy that you wish to test.

Protect

Firewall
Firewall rules are security rule-sets to implement control over users, applications or network objects in an
organization. Using Firewall rules, you can create blanket or specialized traffic transit rules based on the requirement.
Firewall rules provide centralized management for the entire set of device security Firewall rules. Sophos Central
Firewall Manager implements single pane of management to secure all enterprise applications using configuration
templates for various types of Firewall rules.

Following sections provide more information on the Firewall section.

• Introduction
• Managing Firewall Rules
• Default Firewall Rules
• Understanding Icons
• Understanding List of Firewall Rules

Introduction

Firewall rules are based on the following configurable templates:

1. Business Application Rule
2. User/Network Rule

Managing Firewall Rules

You can see the entire list of added security Firewall rules from the  Firewall page. Using the same page, you can
update existing firewall rules, or add new firewall rules.

On the Firewall page, the following action buttons can be found.

• IPv4: Select to filter only IPv4 Firewall rules
• IPv6: Select to filter only IPv6 Firewall rules
• Enable Filter: Select to open filter view and apply the following filters for IPv4 or IPv6 Firewall rules:

1. Rule Type - Select to filter rules based on Business, User or Network
2. Source Zone - Select to filter rules based on LAN, WAN, DMZ, VPN or WiFi
3. Destination Zone - Select to filter rules based on LAN, WAN, DMZ, VPN or WiFi
4. State - Select to filter rules based on Unused, Disabled, Changed, New
5. Rule ID - Specify Rule ID to see the specific rule.

• Reset Filter (Available if filter is enabled) - Select to reset all filters
• Disable Filter (Available if filter is enabled) - Select to close filter view
• + Add Firewall Rule - Select to add a new Firewall Rule among Business Application Rule, or User/Network

Rule.
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Default Firewall Rules
The following default Firewall Rules are created with first time deployment of CFM:

1. Auto added firewall policy for MTA

Note:  Default Firewall Rules cannot be deleted.

Understanding Icons

There are various action icons as well as symbolic icons on the Firewall page. Color codes, meanings and associated
actions of icons are shown below.

Icons Meaning

Business Application Rule Enabled

Business Application Rule Disabled

User Rule Disabled + Action - Accept

User Rule Disabled + Action - Drop/Reject

User Rule Enabled + Action - Drop/Reject

User Rule Enabled

Network Rule Enabled

Network Rule Disabled + Action - Accept

Network Rule Disabled + Action - Drop/Reject

Network Rule Enabled + Action - Drop/Reject

Anti-Virus Scanning Disable

Anti-Virus Scanning Enable

Application Control Disable

Application Control Allow All

Application Control Deny All

Application Control Drop
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Icons Meaning

Security Heartbeat Disable / No Restriction

Security Heartbeat Enable - Green

Security Heartbeat Enable - Yellow

Security Heartbeat - No Restriction + No Heartbeat.

Security Heartbeat - No Restriction + Green

Security Heartbeat - No Restriction + Yellow

Intrusion Prevention Disable

Intrusion Prevention Enable

NAT Disable

NAT Enable

Traffic Shaping Policy Disabled

Traffic Shaping Policy Enabled

Web Policy Disable

Web Policy Allow

Web Policy Deny

Web Policy Drop

Routing Enabled

Routing Disabled

Firewall Rule enabled. Click to disable the rule.

Firewall Rule disabled. Click to enable the rule.

Edit Rule

Delete Rule

Color Codes

Red Reject/Drop

Green Accept/Allow

Yellow Drop (In case of policies)

Blue On/Enable
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Icons Meaning

Grey Off/Disable

Understanding List of Firewall Rules

All added Firewall Rules are available in the form of a list. Each Firewall Rule in the list presents quick snapshot of
the rule.

Details of the rule:

• Rule Name: Name of the rule.
• Firewall Rule Features: Status of schedule, Heartbeat, IPS and traffic shaping.
• Source: Source zone.
• Destination: Destination zone.
• What: Displays protected domains/services.
• Action: Status of protected servers, status of web and application protection for user
• ID: Rule ID
• User’s Policy Applied: Status of application filter, web policy, AV and AS scanning, NAT policy and route

through gateway, if configured

To view details of the Source, Destination, What (type of service) and Features, hover over the Features.

Click  for the following options to appear:

•

•

• Edit
• Clone
• Add User/Network Rule
• Add Business Application Rule
• Synchronize
• Delete

User/Network Rule
User/Network Rule is used to define access rights and protection to the network objects/hosts. In a nutshell, if you
want to control traffic by source, service, destination, zone, then use a Network Rule. Additionally, administrator
has the option to attach user identity to a the rule in order to customize access of assorted hosts/servers. Such identity
based rule, is considered a User Rule.

You can view or add a User/Network Policy for IPv4 and IPv6 traffic.

1. Add User/Network Rule (IPv4)
2. Add User/Network Rule (IPv6)

Add User/Network Rule (IPv4)
This page is used to define access rights and protection to the network objects/hosts.

1. Click Firewall and select IPv4 using the filter switch. Now, click on +Add Firewall Rule and select User/
Network Rule.

2. Enter rule introduction.
Rule Name

Specify a name to identify the policy.
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Note:  Rule Name can only be edited while creating a rule.

Description
Specify Policy Description.

Rule Position
Specify the position of the rule from the available options.

Available Options:

Top Bottom

Note:  Rule Position can only be specified while creating a rule.

Action
Select action for the rule traffic from the available options:

• Accept – Allow access (selection appears in green)
• Drop – Silently discard (selection appears in yellow)
• Reject – Deny access (selection appears in red)

Note:  “ICMP port unreachable” message is sent to the source

When sending response it might be possible that the response is sent using a different interface than
the one on which request was received. This may happen depending on the Routing configuration
done on the device.

For example, If the request is received on the LAN port using a spoofed IP Address (public IP
Address or the IP Address not in the LAN zone network) and specific route is not defined, the
device will send a response to these hosts using the default route. Hence, response will be sent
through the WAN port.

Figure 1: About This Rule
3. Specify Source details.

Source Zones
Select the source zone(s) allowed to the user.

Source Networks and Devices
Select the source network(s) allowed to the user.

A new network host can be created directly from this page itself or from Objects > Hosts and
Services > IP Host page.

During Scheduled Time
Select the schedule allowed to the user.

A new network host can be created directly from this page itself or from Objects > Policies >
Schedule page.
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Figure 2: Source
4. Specify Destination & Services details.

Destination Zones
Select the destination zone(s) allowed to the user.

Destination Networks
Select the destination network(s) allowed to the user.

A new network host can be created directly from this page itself or from Objects > Assets > IP
Host page.

Services
Select the services(s) allowed to the user.

A new network host can be created directly from this page itself or from Objects > Hosts and
Services > Services page.

Figure 3: Destination
5. Specify Identity details. Follow this step if you want to configure a User Rule.
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Match known users
Select to enable rule based on user identity.

Show Captive Portal to unknown users
Select the check box to accept traffic from unknown users. Captive portal page is displayed to the
user where the user can login to access the Internet.

Clear the check box to drop traffic from unknown users.

User or Groups.(Applicable only when Match known users is Selected)
Select the user(s) or group(s) from the list of available options.

Exclude this user activity from data accounting. (Applicable only when Match rule based on user identity is Selected)
Select to enable/disable user traffic activity from data accounting.

By default, user’s network traffic is considered in data accounting. Select to exclude certain traffic
user data accounting. The traffic allowed through this firewall rule will not be accounted towards
data transfer for the user.

Figure 4: Identity
6. Specify Malware Scanning details.

Scan HTTP
Enable HTTP traffic scanning.

Decrypt & Scan HTTPS
Enable HTTPS traffic decryption and scanning.

Detect zero-day threats with Sandstorm
Send files downloaded using HTTP or HTTPS for analysis by Sandstorm, it protects your network
against unknown and unpublished threats (“zero-day” threats).

Note:  This option is available when Scan HTTP or Decrypt & scan HTTPS option
is enabled.

Scan FTP
Enable FTP traffic scanning.

7. Enter Web malware and content scanning details (available only if Action selected for the traffic is Accept).
Scan HTTP

Enable HTTP traffic scanning.

Decrypt & scan HTTPS
Enable HTTPS traffic decryption and scanning.

Block Google QUIC (Quick UDP Internet Connections)
Disable QUIC protocol (UDP) traffic for Google services.

Detect zero-day threats with Sandstorm
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Send files downloaded using HTTP or HTTPS for analysis by Sandstorm. Sandstorm protects your
network against unknown and unpublished threats (“zero-day” threats).

Scan FTP for malware
Enable FTP traffic scanning.

Figure 5: Web malware and content scanning
8. Specify Advanced details. (Applicable only when Action for the traffic is Accept)

User Applications

Intrusion Prevention
Select IPS Policy for the rule. A new Web Filter Policy can be created directly from this page itself
or from Objects > Policies > IPS page.

Traffic Shaping Policy
User's Traffic Shaping policy will be applied automatically.

Web Filter (Applicable only if Match rule based on user identity is 'Disabled')
Select Web Filter Policy for the rule.

It controls access to application like IM and P2P, VOIP.

A new Web Filter Policy can be created directly from this page itself or from Objects > Policies >
Web Filter Policy page.

Apply Web Category based Traffic Shaping Policy (Applicable only if Match rule based on user identity is 'Disabled')

Click to restrict bandwidth for the URLs categorized under the Web category.

A three step configuration is required as follows:

a. Create Traffic Shaping policy from Objects > Policies > Traffic Shaping. Here, specify the
Policy Association as 'Web Categories'.

b. Now, assign the created policy for Web Filter.
c. Check to enable Apply Web Category based Traffic Shaping Policy.

Application Control (Applicable only if Match rule based on user identity is 'Disabled')
Select Application Filter Policy for the rule. A new Application Filter Policy can be created directly
from this page itself or from Objects > Policies > Application Group page.

Apply Application-based Traffic Shaping Policy (Applicable only if Match rule based on user identity is 'Disabled')
Click to restrict bandwidth for the applications categorized under the Application category.

A three step configuration is required as follows:

a. Create Traffic Shaping policy from Objects > Policies > Traffic Shaping. Here, specify the
Policy Association as 'Applications'.

b. Now, assign the created policy for Application Control.
c. Check to enable Apply Web based Traffic Shaping Policy.
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Synchronized Security

Minimum Source HB Permitted
Select a minimum health status that a source device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block clients with no heartbeat
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can restrict a source device's access to certain services and networks.

Select the option to require the sending of heartbeats.

Minimum Destination HB Permitted
Select a minimum health status that a destination device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block request to destination with no heartbeat
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can block requests to destinations not sending heartbeat.

Select the option to require the sending of heartbeats.

NAT & Routing

Rewrite source address (Masquerading)
Selectto re-write the source address or specify a NAT policy.

Use Gateway Specific Default NAT Policy (Applicable only if Masquerading is selected and Destination Zone is
selected as WAN)_

Click to override the default NAT policy with a gateway specific policy.

Override default NAT policy for specific Gateway (Applicable only if Use Gateway Specific Default NAT Policy is
selected )

Select to specify gateway and corresponding NAT policy. Multiple Gateways and NAT Policy can
be added.

Use Outbound Address (Applicable when Rewrite source address is selected)
Select the NAT policy to be applied the list or available NAT policies.

A new NAT policy can be created directly from this page itself or from Objects > Policies > NAT 
page.

Default NAT policy is Masquerade.

Primary Gateway
Specify the Primary Gateway. This is applicable only if more than one gateway is defined.

Backup Gateway
Specify the Backup Gateway. This is applicable only if more than one gateway is defined.

DSCP Marking
Select the DSCP Marking. Select DSCP Marking.

DSCP (DiffServ Code Point) classifies flow of packets as they enter the local network depending
upon QoS. Flow is defined by 5 elements; Source IP Address, Destination IP Address, Source port,
Destination port and the transport protocol.
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For available options, refer DSCP Values.

Figure 6: Routing
9. Define logging option for the user application traffic.

Log Firewall Traffic
Click to select logging of permitted and denied traffic.

Figure 7: Log Traffic
10. Click Save to save the settings.

Add User/Network Rule (IPv6)
Use this page to add a new policy for applications accessed by your users.

1. Click Firewall and select IPv6 using the filter switch. Now, click on +Add Firewall Rule and select User/
Network Rule.

2. Enter rule introduction.
Rule Name

Specify a name to identify the policy.

Note:  Rule Name can only be edited while creating a rule.

Description
Specify Policy Description.

Rule Position
Specify the position of the rule from the available options.

Available Options:

Top Bottom

Note:  Rule Position can only be specified while creating a rule.

Action
Select action for the rule traffic from the available options:

• Accept – Allow access (selection appears in green)
• Drop – Silently discard (selection appears in yellow)
• Reject – Deny access (selection appears in red)

Note:  “ICMP port unreachable” message is sent to the source
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When sending response it might be possible that the response is sent using a different interface than
the one on which request was received. This may happen depending on the Routing configuration
done on the device.

For example, If the request is received on the LAN port using a spoofed IP Address (public IP
Address or the IP Address not in the LAN zone network) and specific route is not defined, the
device will send a response to these hosts using the default route. Hence, response will be sent
through the WAN port.

Figure 8: About This Rule
3. Specify Source details.

Source Zones
Select the source zone(s) allowed to the user.

Source Networks and Devices
Select the source network(s) allowed to the user.

A new network host can be created directly from this page itself or from Objects > Hosts and
Services > IP Host page.

During Scheduled Time
Select the schedule allowed to the user.

A new network host can be created directly from this page itself or from Objects > Policies >
Schedule page.
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Figure 9: Source
4. Specify Destination & Services details.

Destination Zones
Select the destination zone(s) allowed to the user.

Destination Networks
Select the destination network(s) allowed to the user.

A new network host can be created directly from this page itself or from Objects > Assets > IP
Host page.

Services
Select the services(s) allowed to the user.

A new network host can be created directly from this page itself or from Objects > Hosts and
Services > Services page.

Figure 10: Destination
5. Specify Identity details. Follow this step if you want to configure a User Rule.
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Match known users
Select to enable rule based on user identity.

Show Captive Portal to unknown users
Select the check box to accept traffic from unknown users. Captive portal page is displayed to the
user where the user can login to access the Internet.

Clear the check box to drop traffic from unknown users.

User or Groups.(Applicable only when Match known users is Selected)
Select the user(s) or group(s) from the list of available options.

Exclude this user activity from data accounting. (Applicable only when Match rule based on user identity is Selected)
Select to enable/disable user traffic activity from data accounting.

By default, user’s network traffic is considered in data accounting. Select to exclude certain traffic
user data accounting. The traffic allowed through this firewall rule will not be accounted towards
data transfer for the user.

Figure 11: Identity
6. Specify Malware Scanning details.

Scan HTTP
Enable HTTP traffic scanning.

Decrypt & Scan HTTPS
Enable HTTPS traffic decryption and scanning.

Detect zero-day threats with Sandstorm
Send files downloaded using HTTP or HTTPS for analysis by Sandstorm, it protects your network
against unknown and unpublished threats (“zero-day” threats).

Note:  This option is available when Scan HTTP or Decrypt & scan HTTPS option
is enabled.

7. Enter Web malware and content scanning details (available only if Action selected for the traffic is Accept).
Scan HTTP

Enable HTTP traffic scanning.

Decrypt & scan HTTPS
Enable HTTPS traffic decryption and scanning.

Block Google QUIC (Quick UDP Internet Connections)
Disable QUIC protocol (UDP) traffic for Google services.

Detect zero-day threats with Sandstorm
Send files downloaded using HTTP or HTTPS for analysis by Sandstorm. Sandstorm protects your
network against unknown and unpublished threats (“zero-day” threats).
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Scan FTP for malware
Enable FTP traffic scanning.

Figure 12: Web malware and content scanning
8. Specify Advanced details. (Applicable only when Action for the traffic is Accept)

User Applications

Intrusion Prevention
Select IPS Policy for the rule. A new Web Filter Policy can be created directly from this page itself
or from Objects > Policies > IPS page.

Traffic Shaping Policy
User's Traffic Shaping policy will be applied automatically.

Web Filter (Applicable only if Match rule based on user identity is 'Disabled')
Select Web Filter Policy for the rule.

It controls access to application like IM and P2P, VOIP.

A new Web Filter Policy can be created directly from this page itself or from Objects > Policies >
Web Filter Policy page.

Apply Web Category based Traffic Shaping Policy (Applicable only if Match rule based on user identity is 'Disabled')

Click to restrict bandwidth for the URLs categorized under the Web category.

A three step configuration is required as follows:

a. Create Traffic Shaping policy from Objects > Policies > Traffic Shaping. Here, specify the
Policy Association as 'Web Categories'.

b. Now, assign the created policy for Web Filter.
c. Check to enable Apply Web Category based Traffic Shaping Policy.

Application Control (Applicable only if Match rule based on user identity is 'Disabled')
Select Application Filter Policy for the rule. A new Application Filter Policy can be created directly
from this page itself or from Objects > Policies > Application Group page.

Apply Application-based Traffic Shaping Policy (Applicable only if Match rule based on user identity is 'Disabled')
Click to restrict bandwidth for the applications categorized under the Application category.

A three step configuration is required as follows:

a. Create Traffic Shaping policy from Objects > Policies > Traffic Shaping. Here, specify the
Policy Association as 'Applications'.

b. Now, assign the created policy for Application Control.
c. Check to enable Apply Web based Traffic Shaping Policy.

NAT & Routing
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Rewrite source address (Masquerading)
Select to re-write the source address or specify a NAT policy.

Use Gateway Specific Default NAT Policy (Applicable only if Masquerading is selected and Destination Zone is
selected as WAN)_

Click to override the default NAT policy with a gateway specific policy.

Override default NAT policy for specific Gateway (Applicable only if Use Gateway Specific Default NAT Policy is
selected )

Select to specify gateway and corresponding NAT policy. Multiple Gateways and NAT Policy can
be added.

Use Outbound Address (Applicable when Rewrite source address is selected)
Select the NAT policy to be applied the list or available NAT policies.

A new NAT policy can be created directly from this page itself or from Objects > Policies > NAT 
page.

Default NAT policy is Masquerade.

Primary Gateway
Specify the Primary Gateway. This is applicable only if more than one gateway is defined.

Backup Gateway
Specify the Backup Gateway. This is applicable only if more than one gateway is defined.

DSCP Marking
Select the DSCP Marking. Select DSCP Marking.

DSCP (DiffServ Code Point) classifies flow of packets as they enter the local network depending
upon QoS. Flow is defined by 5 elements; Source IP Address, Destination IP Address, Source port,
Destination port and the transport protocol.

For available options, refer DSCP Values.

Figure 13: Routing
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9. Define logging option for the user application traffic.
Log Firewall Traffic

Select to enable logging of permitted and denied traffic.

Figure 14: Log Traffic
10. Click Save to save the settings.

Business Application Rule

Business Application Rule

Business Application Rule is used to protect all internally or publicly hosted business applications or servers like
SalesForce, Sharepoint etc. Using Business Application Rule, the administrator can configure protection of the HTTP/
Non-HTTP/Public Non-HTTP servers from unauthorized access over the Internet. In a nutshell, if you are securing a
server or service, use a Business Application Rule to allow internal or external users to access that service.

Business Application Rule can have three configurable templates:

1. HTTP Based Policy - HTTP Based policy is used to protect HTTP or generic web application servers hosted in
the network. HTTP Based policy configuration is essentially WAF implementation but with additional benefit of
defining WAF objects, rules, exceptions from the same page.

Sophos XG Firewall offers several pre-configured templates to address commonly used HTTP based applications.
You can use these to create policy for the web application, that is close to your configuration, then modify it to fit
your needs. Pre-defined HTTP application templates include:

• Exchange Autodiscover
• Exchange Outlook Anywhere
• Exchange General
• Microsoft Lync on page 38
• Microsoft Remote Desktop Gateway 2008 and R2
• Microsoft Remote Desktop Web 2008 and R2
• Microsoft Sharepoint 2010 and 2013

2. Non-HTTP Based Policy - Non-HTTP Based policy is used to protect Non-HTTP servers, like mail or other
servers hosted inside the network (LAN or DMZ). Using Non-HTTP Based policy, you can define access rights of
such servers to users who require access over the WAN or Internet. Additionally, you can use the following Non-
HTTP application template:

• Email Server (SMTP)
3. Email Servers (POP and IMAP) - Email Servers (POP and IMAP) policy is used to protect mail servers which

are hosted publicly (WAN) and require protection.

Adding a Business Application Rule

Click Policies and select IPv4 using the filter switch. Now, click on +Add Firewall Rule and select Business
Application Rule. In the About this Rule section, you can select the Application Template from the list of available
templates.

The application template allows you to choose the rule which suits the configuration of the required business
application. Once you select the template, you can see the configuration page with few fields pre-populated. The pre-
populated values eliminate the need to manually specify the configuartion for securing your business application, but
you may customize the settings according to your network setup or other requirement.

Add Business Application Rule (Web Server Protection (WAF))
(only available for IPv4 policy) This page describes how to configure a policy for controlling access to HTTP-based
business applications.
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1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general rule details.

Application Template
Select Web Server Protection (WAF)  to define an application filter policy for HTTP based
applications.

Description
Specify a description for the rule.

Rule Position
Specify the position of the rule.

Available Options:

• Top
• Bottom

Rule Name
Specify a name for the rule.

Figure 15: About this Rule
4. Specify Hosted Server details.

Hosted Address
Select the interface of the hosted server to which the rule applies. It is the public IP address through
which Internet users access the internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Select to enable or disable scanning of HTTPS traffic.

HTTPS Certificate (only available if HTTPS is selected)
Select the HTTPS certificate to be used.

Redirect HTTP (only available if HTTPS is selected)
Select to redirect HTTP requests.

Domains
(if HTTPS is disabled): Enter the domains the web server is responsible for as FQDN, e.g.
shop.example.com.

(if HTTPS is enabled): According to the selected HTTPS certificate, some domains may be
preselected. You can edit or delete these domains or add new ones.

Figure 16: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
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You can enable path-specific routing to define (a path) to which web servers incoming requests are
forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path  (only available if Path-specific routing is selected)
Click Add Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Web Server  (not available if Path-specific routing is selected)
With this option, you select the web servers that are to be protected. Select a web server from Web
Server list. The selected web server is displayed on the right side of the table under Selected Web
Server(s).

A new web server can be created on the Device Configuration > Protect > Web Server > Web
Servers page.

Figure 17: Protected Application Server(s)
6. Specify Access Permission details (not available if Path-specific routing is selected).

Allowed Client Networks
Select or add the allowed networks that should be able to connect to the hosted web server.

Blocked Client Networks
Select or add the denied networks that should be blocked to your hosted web server.

Authentication
Select a web app authentication profile or click Create new to create a new authentication profile.
You can also create an authentication profile from the Device Configuration > Protect > Web
Server > Authentication Policies page.

Add Web App Authentication on page 174

Figure 18: Access Permission
7. Add path Exceptions for the web servers.

Click Add New Exception to specify a new exception.

Add Exception

Figure 19: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention
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Select an Intrusion Prevention policy for the rule or create a new one. A new IPS policy can
be created directly from this page or from the Device Configuration > Protect > Intrusion
Prevention > IPS Policies page. You can also choose to have None intrusion prevention.

Traffic Shaping
The traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

Select a traffic shaping policy for the rule or create a new one. A new traffic shaping policy can be
created directly from this page or from the Device Configuration > System > Profiles > Traffic
Shaping page. You can also choose to have None traffic shaping.

Application Protection
Select an application protection for the server or create a new one. A new application protection
policy can be created directly from this page or from the Device Configuration > Protect > Web
Server > Protection Policies page. You can also choose to have None application protection.

Figure 20: Policies for Business Applications
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the checkbox
is enabled, the WAF will request uncompressed data from the web servers of this hosted web server
and will pass it on uncompressed to the client, regardless of the HTTP request's encoding parameter.

Rewrite HTML
Select this option to have the device rewrite links of the returned webpages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local
but the hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your webpages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wildcard. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
process.

Rewrite cookies (only available if Rewrite HTML is selected)
Select this option to have the device rewrite cookies of the returned web pages.

Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment depends on the configuration of your web server.

Figure 21: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The business application rule has been created and appears on the Firewall page when the IPv4 filter is set.
Exchange Autodiscover
(Only available for IPv4 policy) This page describes how to configure a rule for Exchange Autodiscover.
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1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general rule details.

Application Template
Select Exchange Autodiscover to configure a policy for an Exchange Autodiscover environment.

Description
Specify a description for the rule.

Rule Position
Specify the position of the rule.

Available Options:

• Top
• Bottom

Rule Name
Specify a name for the rule.

Figure 22: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access an internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Select to enable or disable scanning of HTTPS traffic.

HTTPS Certificate (only available if HTTPS is selected)
Select the HTTPS certificate to be used.

Redirect HTTP (only available if HTTPS is selected)
Select to redirect HTTP requests.

Domains
Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 23: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
You can enable path-specific routing to define (the path) to which web servers incoming requests
are forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
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session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Default: Enabled

Add New Path (only available if Path-specific routing is selected)
Click Add New Path to define a new path.

Add Path

Note:  Add New Path will only be active only after at least one web server and one
hosted web server have been created.

Default: /autodiscover, /Autodiscover, /AutoDiscover

Web Server (not available if Path-specific routing is selected)
Web servers are the application servers to be protected. Select a web server from the list of web
servers or enter a web server and click Create to add a web server.

A new web server can be created directly from this page or from the Device Configuration >
Protect > Web Server > Web Servers page.

Figure 24: Protected Server(s)
6. Specify Access Permission details (not available if Path-specific routing is selected).

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles.

You can also create a new authentication profile on this page or on the Device Configuration >
Protect > Web Server > Authentication Policies page.

Figure 25: Access Permission
7. Add path Exceptions for the web servers.

Click Add New Exception to specify new exception.

Add Exception

Default: /autodiscover/*,/Autodiscover/*

Figure 26: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention

Select an IPS policy for the rule.

A new IPS policy can be created directly from this page or from the Device Configuration >
Protect > Intrusion Prevention > IPS Policies page.
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Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shapping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly from this page or from the Device
Configuration > Protect > Web Server > Protection Policies page.

Default: ExchangeAutoDiscover

Figure 27: Policies for Business Applications
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this checkbox is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the checkbox
is enabled, the WAF will request uncompressed data from the web servers of this hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Default: Disabled

Rewrite HTML
Select this option to have the device rewrite links of the returned webpages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local
but the hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your webpages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wild card. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.

Default: Disabled

Rewrite cookies (only available if Rewrite HTML is selected)
Select this option to have the device rewrite cookies of the returned web pages.

Note:  If Rewrite HTML is disabled the Rewrite cookies option will also be
disabled.

Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.

Default: Enabled

Figure 28: Advanced
9. Click Save.
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Note:  As soon as a new HTTP based policy configuration has been created and saved or an existing
HTTP based rule configuration has been altered and saved, all HTTP based business rules will be
restarted. Any underlying client connection using a HTTP based business rule will get lost and has to be
re-established.

The firewall rule for Microsoft Remote Desktop Gateway 2008 and R2 has been created and appears on the Firewall
page when the IPv4 filter is set.
Exchange Outlook Anywhere
(only available for IPv4 policy) This page describes how to configure a rule for Exchange Outlook Anywhere.

1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general policy details.

Application Template
Select Exchange Outlook Anywhere to configure rule for Exchange Outlook Anywhere.

Description
Specify a description for the rule.

Rule Position
Specify the position of the rule.

Available Options: TopBottom

Rule Name
Specify a name for the rule.

Figure 29: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access an internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Select to enable or disable scanning of HTTPS traffic.

HTTPS Certificate (only available if HTTPS is selected)
Select the HTTPS certificate to be used.

Redirect HTTP (only available if HTTPS is selected)
Select to redirect HTTP requests.

Domains
Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 30: Hosted Server
5. Specify Protected Server(s) details.
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Path-specific routing
You can enable path-specific routing to define (path) to which web servers incoming requests are
forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path (only available if Path-specific routing is selected)
Click Add New Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Default: /rpc, /RPC

Web Server (not available if Path-specific routing is selected)
Web servers are the application servers that are to be protected. Select a web server from the list of
web servers or click Add New Item to add a web server.

A new web server can be created directly from this page or from the Device Configuration >
Protect > Web Server > Web Servers page.

Figure 31: Protected Application Server(s)
6. Specify Access Permission details. (not available if Path-specific routing is selected).

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles. You can also
create a new authentication profile from this page or from the Device Configuration > Protect >
Web Server > Authentication Policies page.

Figure 32: Access Permission
7. Add path Exceptions for the web servers.

Click Add New Exception to specify new exception.

Add Exception

Default: /rpc/*,/RPC/*.

Figure 33: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
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Intrusion Prevention
Select an IPS policy for the rule.

A new IPS policy can be created directly from this page or from the Device Configuration >
Protect > Intrusion Prevention > IPS Policies page.

Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shaping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly from this page or from the Device
Configuration > Protect > Web Server > Protection Policies page.

Default: Exchange Outlook Anywhere

Figure 34: Policies for Business Applications
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the check
box is enabled, the WAF will request uncompressed data from the web servers of this hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Rewrite HTML
Select this option to have the device rewrite links of the returned web pages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local
but the hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your web pages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wildcard. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.

Default: Disabled

Rewrite cookies (only available if Rewrite HTML is selected)
Select this option to have the device rewrite cookies of the returned web pages.

Note:  If Rewrite HTML is disabled the Rewrite cookies option will also be
disabled.

Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.
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Default: Disabled

Figure 35: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The Exchange Outlook Anywhere rule has been created and appears on the Firewall page when the IPv4 filter is set.
Exchange General
(only available for IPv4 policy) This page describes how to configure a rule for Exchange General.

1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general policy details.

Application Template
Select Exchange General to configure a rule for Exchange General.

Description
Specify a description for the rule.

Rule Position
Specify the position of the rule.

Available Options: TopBottom

Rule Name
Specify a name for the rule.

Figure 36: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access an internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Select to enable or disable scanning of HTTPS traffic.

HTTPS Certificate (only available if HTTPS is selected)
Select the HTTPS certificate to be used.

Redirect HTTP (only available if HTTPS is selected)
Select to redirect HTTP requests.

Domains
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Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 37: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
You can enable path-specific routing to define (path) to which web servers incoming requests are
forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path (only available if Path-specific routing is selected)
Click Add New Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Default: /owa, /OWA, /ecp, /ECP, /oab, /OAB, /ews, /EWS, /oma, /OMA, /Microsoft-Server-
ActiveSync

Web Servers (not available if Path-specific routing is selected)
Web servers are the application servers that are to be protected. Select a web server from the list of
web servers or click Add New Item to add a web server.

A new web server can be created directly from this page or from the Device Configuration >
Protect > Web Server > Web Servers page.

Figure 38: Protected Application Server(s)
6. Specify Access Permission details. (not available if Path-specific routing is selected)

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles. You can also
create new authentication profile on this page or on the Device Configuration > Protect > Web
Server > Authentication Policies page.

Figure 39: Access Permission
7. Add path Exceptions for the web servers.

Click Add New Exception to specify a new exception.

Add Exception
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Default: /owa/*,/OWA/*,/ews/*,/EWS/*,/ecp/*,/ECP/*,/oab/*,/OAB/*,/oma/*,/OMA/*,/Microsoft-Server-
ActiveSync?*, /owa/ev.owa*

Figure 40: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention

Select an IPS policy for the rule.

A new IPS policy can be created directly from this page or from the Device Configuration >
Protect > Intrusion Prevention > IPS Policies page.

Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shaping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly from this page or from the Device
Configuration > Protect > Web Server > Protection Policies page.

Default: Exchange General

Figure 41: Policies for Business Applications
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the check
box is enabled, the WAF will request uncompressed data from the web servers of this hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Default: Disabled

Rewrite HTML
Select this option to have the device rewrite links of the returned webpages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local
but the hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your web pages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wild card. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.

Rewrite cookies (only available if Rewrite HTML is selected)
Select this option to have the device rewrite cookies of the returned web pages.

Note:  If Rewrite HTML is disabled the Rewrite cookies option will also be
disabled.
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Default: Disabled

Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.

Default: Disabled

Figure 42: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The Exchange General rule has been created and appears on the Firewall page when the IPv4 filter is set.
Microsoft Lync
(only available for IPv4 policy) This page describes how to configure a rule for Microsoft Lync.

1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general rule details.

Application Template
Select Microsoft Lync to define Application filter policy for HTTP based applications.

Description
Specify the rule description.

Rule Position
Specify the position of the rule.

Available Options:

• Top
• Bottom

Rule Name
Specify a name to identify the rule.

Figure 43: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Click to enable or disable scanning of HTTPS traffic.
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HTTPS Certificate (available if HTTPS is enabled)
Select the HTTPS certificate to be used.

Redirect HTTP (available if HTTPS is enabled)
Click to redirect HTTP requests.

Domains
Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 44: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
You can enable path-specific routing to define (the path) to which web servers incoming requests
are forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path (available if Path-specific routing is enabled)
Click Add Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Web Server (available if Path-specific routing is disabled)
Hosts are the web servers that are to be protected. Select a web server from the list of web servers or
click Add New Item to add a web server.

A new web server can be created directly from this page or from the Device Configuration >
Protect > Web Server > Web Servers page.

Figure 45: Protected Application Server(s)
6. Specify Access Permission details (not available if Path-specific routing is selected).

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles.

You can also create a new authentication profile on this page or on the Device Configuration >
Protect > Web Server > Authentication Policies page.

Figure 46: Access Permission
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7. Specify path Exceptions for the web servers.

Click Add New Exception to specify a new exception.

Add Exception

Figure 47: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention (IPS)

Select an IPS policy for the rule.

A new IPS Policy can be created directly from this page or from the Device Configuration >
Protect > Intrusion Prevention > IPS Policies page.

Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shaping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly from this page or from the Device
Configuration > Protect > Web Server > Protection Policies page.

Figure 48: Policies for Business Applications
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the check
box is enabled, the WAF will request uncompressed data from the Web Servers of this Hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Rewrite HTML
Select this option to have the device rewrite links of the returned webpages in order for the links
to stay valid. Example: One of your Web Server instances has the hostname yourcompany.local
but the Hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your webpages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook Web
Access and/or Sharepoint Portal Server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wildcard. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.

Rewrite cookies (available if Rewrite HTML is enabled)
Select this option to have the device rewrite cookies of the returned webpages.

Note:  If Rewrite HTML is disabled the Rewrite cookies option will also be
disabled.
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Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.

Figure 49: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The Microsoft Lync rule has been created and appears on the Firewall page when the IPv4 filter is set.
Microsoft Remote Desktop Gateway 2008 and R2
(only available for IPv4 policy) This page describes how to configure a rule for Microsoft Remote Desktop Gateway
2008 and R2.

1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general rule details.

Application Template
Select Microsoft Remote Desktop Gateway 2008 and R2 to configure a rule for Microsoft
Remote Desktop Gateway 2008 and R2.

Description
Specify the rule description.

Rule Position
Specify the position of the rule.

Available Options:

• Top
• Bottom

Rule Name
Specify a name to identify the rule.

Figure 50: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access an internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally, over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Click to enable or disable scanning of HTTPS traffic.
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HTTPS Certificate (available if HTTPS is enabled)
Select the HTTPS certificate to be used.

Redirect HTTP (available if HTTPS is enabled)
Click to redirect HTTP requests.

Domains
Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 51: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
You can enable path-specific routing to define (a path) to which web servers incoming requests are
forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path (available if Path-specific routing is enabled)
Click Add New Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Web Server (available if Path-specific routing is disabled)
Web servers are the application servers that are to be protected. Select from the list of web servers or
click Add New Item to add a web server.

A new web server can be created directly from this page or from the Device Configuration >
Protect > Web Server > Web Servers page.

Figure 52: Protected Application Server(s)
6. Specify access permission details. (Available if Path-specific routing is disabled)

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles. You can also
create a new authentication profile from this page or from the Device Configuration > Protect >
Web Server > Authentication Policies page.

Figure 53: Access Permission
7. Specify path Exceptions for the web servers.
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Click Add New Exception to specify new exception.

Add Exception

Figure 54: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention

Select an IPS policy for the rule.

A new IPS policy can be created directly from this page or from the Device Configuration >
Protect > Intrusion Prevention > IPS Policies page.

Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shaping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly from this page or from the Device
Configuration > Protect > Web Server > Protection Policies page.

Default: Microsoft RDG 2008

Figure 55: Policies for Business Applications
b) Specify Advanced Settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the check
box is enabled, the WAF will request uncompressed data from the web servers of this hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Rewrite HTML
Select this option to have the device rewrite links of the returned web pages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local
but the hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your web pages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wild card. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.

Rewrite cookies (Applicable only if Rewrite HTML is enabled)
Select this option to have the device rewrite cookies of the returned web pages.

Note:  If Rewrite HTML is disabled the Rewrite cookies option will also be
disabled.
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Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.

Figure 56: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The rule for Microsoft Remote Desktop Gateway 2008 and R2 has been created and appears on the Firewall page
when the IPv4 filter is set.
Microsoft Remote Desktop Web 2008 and R2
(only available for IPv4 policy) This page describes how to configure a rule for Microsoft Remote Desktop Web 2008
and R2.

1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general rule details.

Application Template
Select Microsoft Remote Desktop Web 2008 and R2 to configure a rule for Microsoft Remote
Desktop Web 2008 and R2.

Description
Specify the rule description.

Rule Position
Specify the position of the rule.

Available Options: TopBottom

Rule Name
Specify a name to identify the rule.

Figure 57: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access an internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).

HTTPS
Click to enable or disable scanning of HTTPS traffic.

HTTPS Certificate (available if HTTPS is enabled)
Select the HTTPS certificate to be used.
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Redirect HTTP (available if HTTPS is enabled)
Click to redirect HTTP requests.

Domains
Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 58: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
You can enable path-specific routing to define (the path) to which web servers incoming requests
are forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path (available if Path-specific routing is enabled)
Click Add New Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Web Server (available if Path-specific routing is disabled)
Web servers are the application servers that are to be protected. Select a web server from the list of
web servers or click Add New Item to add a web server.

A new web server can be created directly on this page or on the Device Configuration > Protect >
Web Server > Web Servers page.

Figure 59: Protected Application Server(s)
6. Specify Access Permission details (available if Path-specific routing is disabled).

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles.

You can also create new authentication profile on this page or on the Device Configuration >
Protect > Web Server > Authentication Policies page.

Figure 60: Access Permission
7. Add path Exceptions for the web servers.

Click Add New Exception to specify new exception.
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Add Exception

Figure 61: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention

Select an IPS policy for the rule.

A new IPS policy can be created directly on this page or on the Device Configuration > Protect >
Intrusion Prevention > IPS Policies page.

Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page itself or from the Device
Configuration > System > Profiles > Traffic Shaping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly on this page itself or on the Device
Configuration > Protect > Web Server > Protection Policies page.

Default: Microsoft RD Web 2008

Figure 62: Policies for Business Application
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the check
box is enabled, the WAF will request uncompressed data from the web servers of this hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Default: Disabled

Rewrite HTML
Select this option to have the device rewrite links of the returned webpages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local
but the hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your web pages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wild card. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.

Default: Disabled

Rewrite cookies (available if Rewrite HTML is enabled)
Select this option to have the device rewrite cookies of the returned web pages.
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Note:  If Rewrite HTML is disabled, the Rewrite cookies option will also be
disabled.

Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.

Default: Enabled

Figure 63: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The rule for Microsoft Remote Desktop Web 2008 and R2 has been created and appears on the Firewall page when
the IPv4 filter is set.
Microsoft Sharepoint 2010 and 2013
(only available for IPv4 policy) This page describes how to configure a rule for Microsoft SharePoint 2010 and 2013.

1. Go to Device Configuration > Protect > Firewall and select IPv4. using the filter switch.
2. Click +Add Firewall Rule and  Business Application Rule.
3. Specify the general rule details.

Application Template
Select Microsoft Sharepoint 2010 and 2013 to configure a rule for Microsoft Sharepoint 2010 and
2013.

Description
Specify the rule description.

Rule Position
Specify the position of the rule.

Available Options:

• Top
• Bottom

Rule Name
Specify a name to identify the rule.

Figure 64: About This Rule
4. Specify Hosted Server details.

Hosted Address
Specify the address of the hosted server to which the rule applies. It is the public IP address through
which Internet users access an internal server/host.

Note:  When a connection is established by a client device and the client accesses
the web server, the web server does not obtain the real client IP address. Reason is
that the connection is made through the Web Application Firewall, so the address of
the interface the WAF uses for the connection is delivered. To receive the real client
IP address, the administrator has to read out the contents of the HTTP header "X-
Forwarded-For".

Listening Port
Enter a port number on which the hosted web server can be reached externally over the Internet.
Default is port 80 for plaintext communication (HTTP) and port 443 for encrypted communication
(HTTPS).
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HTTPS
Click to enable or disable scanning of HTTPS traffic.

HTTPS Certificate (available if HTTPS is enabled)
Select the HTTPS certificate to be used.

Redirect HTTP (available if HTTPS is enabled)
Click to redirect HTTP requests.

Domains
Enter the domains the web server is responsible for as FQDN, e.g. shop.example.com.

Figure 65: Hosted Server
5. Specify Protected Server(s) details.

Path-specific routing
You can enable path-specific routing to define (a path) to which web servers incoming requests are
forwarded.

You can define that all URLs with a specific path, for example, /products/, are sent to a specific
web server. On the other hand you can allow more than one web server for a specific request but
add rules how to distribute the requests among the servers. Additionally, you can define that each
session is bound to one web server throughout its lifetime (sticky session). This may be necessary if
you host an online shop and want to make sure that a user sticks to one server during the shopping
session. You can also configure to send all requests to one web server and use the others only as a
backup.

For each hosted web server, one default site path route (with path /) is created automatically. The
device automatically applies the site path routes in the most reasonable way: starting with the
strictest, i.e., longest paths and ending with the default path route which is only used if no other
more specific site path route matches the incoming request. The order of the site path route list is
not relevant. If no route matches an incoming request, (in case the default route was deleted), the
request will be denied.

Add New Path (available if Path-specific routing is enabled)
Click Add New Path to define a new path.

Add Path

Note:  Add New Path will only be active after at least one web server and one hosted
web server have been created.

Web Server (available if Path-specific routing is disabled)
Web servers are the application servers that are to be protected. Select a web server from the list of
web servers or click Add New Item to add a web server.

A new web server can be created directly from this page or from the Device Configuration >
Protect > Web Server > Web Servers page.

Figure 66: Protected Application Server(s)
6. Specify Access Permission details (available if Path-specific routing is disabled).

Allowed Client Networks
Select the allowed host(s)/network(s).

Blocked Client Networks
Select the blocked host(s)/network(s).

Authentication
Select the web application authentication profile from the list of available profiles.
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You can also create new authentication profile from this page or from the Device Configuration >
Protect > Web Server > Authentication Policies page.

Figure 67: Access Permission
7. Add path Exceptions for the web servers.

Click Add New Exception to specify new exception.

Add Exception

Figure 68: Exceptions
8. Configure advanced settings.

a) Specify Profiles for Business Applications.
Intrusion Prevention (IPS)

Select an IPS policy for the rule.

A new IPS policy can be created directly from this page or from the Device Configuration >
Protect > Intrusion Prevention > IPS Policies page.

Traffic Shaping
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shaping page.

Application Protection
Select an application protection policy for the server.

A new application protection policy can be created directly from this page or from the Device
Configuration > Protect > Web Server > Protection Policies page.

Figure 69: Policies for Business Applications
b) Specify Advanced settings for the added server.

Disable Compression Support
By default, this check box is disabled and the content is sent compressed when the client requests
compressed data. Compression increases transmission speed and reduces page load time. However,
in case of websites being displayed incorrectly or when users experience content-encoding errors
accessing your web servers, it can be necessary to disable compression support. When the check
box is enabled, the WAF will request uncompressed data from the web servers of this hosted web
server and will send it on uncompressed to the client, independent of the HTTP request's encoding
parameter.

Default: Disabled

Rewrite HTML
Select this option to have the device rewrite links of the returned web pages in order for the links
to stay valid. Example: One of your web server instances has the hostname yourcompany.local but
the Hosted web server's hostname on the device is yourcompany.com. Thus, absolute links like
[a href="http://yourcompany.local/"] will be broken if the link is not rewritten to [a href="http://
yourcompany.com/"] before delivery to the client. However, you do not need to enable this option if
either yourcompany.com is configured on your web server or if internal links on your web pages are
always realized as relative links. It is recommended to use the option with Microsoft's Outlook web
access and/or SharePoint portal server.

Note:  HTML rewriting affects all files with a HTTP content type of text/* or *xml*,
where * is a wild card. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the HTML rewriting
feature.
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Default: Disabled

Rewrite cookies (available if Rewrite HTML is enabled)
Select this option to have the device rewrite cookies of the returned web pages.

Note:  If Rewrite HTML is disabled the Rewrite cookies option will also be
disabled.

Pass Host Header
When you select this option, the host header as requested by the client will be preserved and
forwarded along with the web request to the web server. Whether passing the host header is
necessary in your environment however depends on the configuration of your web server.

Default: Enabled

Figure 70: Advanced
9. Click Save.

Note:  As soon as a new HTTP based rule configuration has been created and saved or an existing HTTP
based rule configuration has been altered and saved, all HTTP based business rules will be restarted. Any
underlying client connection using a HTTP based business rule will get lost and has to be re-established.

The rule for Microsoft Sharepoint 2010 and 2013 has been created and appears on the Firewall page when the IPv4
filter is set.
Add Path

Add Path page allows you to define (path) to which real web servers incoming requests are forwarded..

1. Enable path-specific routing and click Add New Path.
2. Specify the path details.

Path
Enter the path for which you want to create the site path route, Example: /products/.

Real Web Servers
Select the Real web servers which are to be used for the specified path.

Authentication
Select the Web App Authentication profile. Click Add New Item to create a new authentication
profile. You can also create Authentication profile from Objects > Assets > Web App
Authentication page.

Allow From
Select or add the allowed networks that should be able to connect to the Hosted web server.

Block From
Select or add the denied networks that should be blocked to your Hosted web server.

Enable sticky session cookie
Select this option to ensure that each session will be bound to one real web server. If enabled, a
cookie is passed to the user's browser, which provokes the UTM to route all requests from this
browser to the same real web server. If the server is not available, the cookie will be updated, and
the session will switch to another web server.

Enable hot-standby mode
Select this option if you want to send all requests to the first selected real web server, and use the
other web servers only as a backup. The backup servers are only used in case the main server fails.

As soon as the main server starts functioning, the sessions will switch back - unless you have
selected the Enable sticky session cookie option.
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Figure 71: Add Path
3. Click Save to complete.

Add Exception

Use Add Exception page to specify path Exceptions for the Web Servers.

1. Click Add Exceptions.
2. Specify Exception details.

Path
Enter the path which you want to exclude.

Operation
Select the operation among AND or OR for Path and Source.

Source
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Specify the source networks where the client request comes from and which are to be exempted
from the selected check(s).

Skip these Checks

Cookie Signing
Click to skip Cookie Signing. Cookie Signing protects a web server against manipulated cookies.
When the web server sets a cookie, a second cookie is added to the first cookie containing a
hash built of the primary cookie's name, its value and a secret, where the secret is only known
by the WAF. Thus, if a request cannot provide a correct cookie pair, there has been some sort of
manipulation and the cookie will be dropped.

Static URL Hardening
Protects against URL rewriting. For that, when a client requests a website, all static URLs of the
website are signed. The signing uses a similar procedure as with cookie signing. Additionally the
response from the web server is analyzed regarding what links can be validly requested next.

Form Hardening
Click to skip Form Hardening. Form Hardening protects against web form rewriting. Form
hardening saves the original structure of a web form and signs it. Therefore, if the structure of a
form has changed when it is submitted the WAF rejects the request.

Antivirus
Select this option to protect a web server against viruses.

Block clients with bad reputation
Based on GeoIPClosed and RBLClosed information you can block clients which have a bad
reputation according to their classification.

Skip these Categories

Path
Select a path from the list or specify a new path fro the specified exception.

Operation
Select the AND/OR operation for the added Path and Source.

Source
Select from the list of added networks as Source

Protocol Violations
Enforces adherence to the RFC standard specification of the HTTP protocol. Violating these
standards usually indicates malicious intent.

Protocol Anomalies
Searches for common usage patterns. Lack of such patterns often indicates malicious requests.
These patterns include, among other things, HTTP headers like 'Host' and 'User-Agent'.

Request Limits
Enforces reasonable limits on the amount and ranges of request arguments. Overloading request
arguments is a typical attack vector.

HTTP Policy
Narrows down the allowed usage of the HTTP protocol. Web browsers typically use only a limited
subset of all possible HTTP options. Disallowing the rarely used options protects against attackers
aiming at these often less well supported options.

Bad Robots
Checks for usage patterns characteristic of bots and crawlers. By denying them access, possible
vulnerabilities on your web servers are less likely to be discovered.
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Generic Attacks
Searches for attempted command executions common to most attacks. After having breached a
web server, an attacker usually tries to execute commands on the server like expanding privileges
or manipulating data stores. By searching for these post-breach execution attempts, attacks can be
detected that might otherwise have gone unnoticed, for example because they targeted a vulnerable
service by the means of legitimate access.

SQL Injection Attacks
Checks for embedded SQL commands and escape characters in request arguments. Most attacks on
web servers target input fields that can be used to direct embedded SQL commands to the database.

XSS Attacks
Checks for embedded script tags and code in request arguments. Typical cross-site scripting attacks
aim at injecting script code into input fields on a target web server, often in a legitimate way.

Tight Security
Performs tight security checks on requests, like checking for prohibited path traversal attempts.

Trojans
Checks for usage patterns characteristic of trojans, thus searching for requests indicating trojan
activity. It does not, however, prevent the installation of such trojans as this is covered by the
antivirus scanners.

Outbound
Prevents web servers from leaking information to the client. This includes, among other things,
error messages sent by servers which attackers can use to gather sensitive information or detect
specific vulnerabilities.

Never change HTML during Static URL Hardening or Form Hardening
If selected, no data matching the defined exception settings will be modified by the WAF engine.
With this option, e.g., binary data wrongly supplied with a text/html content type by the Web
Server will not be corrupted. On the other hand, web requests may be blocked due to activated
URL hardening, HTML rewriting, or form hardening. Those three features use an HTML parser
and therefore to some extent depend on the modification of webpage content. To prevent undesired
blocking, skip URL hardening and/or form hardening for requests affected by blocking; you might
need to do this in another/new exception to reflect dependencies between web servers and/or
webpages.

Accept unhardened form data
Even though having an exception for Form Hardening, it is possible that form data will not be
accepted if the Form Hardening signature is missing. With this option unhardened form data will be
accepted anyway.
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Figure 72: Add Exception

Add DNAT/Full NAT/Load Balancing Rule
This page describes how to configure a DNAT/Full NAT/Load Balancing (Non-web) rule.



 | Device Configuration | 55

A DNAT/Full NAT/Load Balancing based rule is used to protect non-web servers, like mail or other servers hosted
inside the network (LAN or DMZ). Using this rule, you can define access rights of such servers to users who require
access over the WAN or Internet.

1. Go to Device Configuration > Protect > Firewall and select between IPv4 or IPv6 using the default filter.
2. Now, click +Add Firewall Rule and select Business Application Rule.
3. Specify the general rule details.

Application Template
Select DNAT/Full NAT/Load Balancing to configure a rule for generic Non-Web based
applications.

Description
Specify a rule description.

Rule Position
Specify the position of the rule.

Available Options: TopBottom

Rule Name
Specify a name to identify the rule.

4. Specify Source details.
Source Zones

Select a source zone or click Add New Item to define a new LAN or DMZ zone.

Allowed Client Networks
Select the allowed host(s) or add a new one by clicking Add New Item.

Blocked Client Networks
Select the blocked host(s)/network(s).

5. Specify Destination & Service details.
Firewall Version

Choose from the following options:

Available Options: Firewalls running on SFOS v17Firewalls running on SFOS v16.x

Destination Host/Network
Select the destination host/network to apply rule. It is the public IP address through which users
access an internal server/host over the Internet.

Available Options: IP Address: Specified IP address is mapped to a corresponding mapped single
IP address or a range of IP addresses. If a single IP address is mapped to a range of IP addresses,
the device uses a round robin algorithm to load balance the requests.IP Range (only available for
IPv4): Specified IP address range is mapped to a corresponding range a corresponding range of
mapped IP addresses. The IP range defines the start and end of an address range. The start of the
range must be lower than the end of the IP. Select when any of the device port, alias or virtual LAN
(VLAN) sub-interface is required to be mapped to the destination host or network.

Services
Select the services allowed to the user. A new service can be directly created from this page.

Add new item

Name: Enter a name to identify the service.

Type: Select a protocol for the service.

Available Options:TCP/UDP: Enter Source and Destination port. You can enter multiple ports
for the same service. The number of source and destination ports must not exceed 16.IP: Select
Protocol Number for the service. You can select multiple ports for the same service.ICMP: Select
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ICMP Type and Code. You can enter multiple types and codes for the same service. Use Add icon

and Remove icon  to add and delete the parameters respectively. ICMPv6: Select ICMPv6

Type and Code. You can enter multiple types and codes for the same service. Use Add  and

Remove  to add and delete the parameters.

Figure 73: Firewalls Running on SFOS v17

Forward Type
Select the type of external port from the available options.

Available Options: PortPort RangePort List Everything

When Everything is selected, all ports are forwarded. Select other options to enable custom port
forwarding and specify port forwarding details.

Service Port(s) Forwarded (Not Available if Forward Type selected is Everything)
Specify the public port number for which you want to configure port forwarding.

Protocol (Not Available if Forward Type selected is Everything)
Select the protocol TCP or UDP to be used by forwarding packets.

Figure 74: Firewalls Running on SFOS v16.x

6. Specify Forward To details.
Protected Server(s)

From the available options, select the application server(s) on which the web server is to be hosted.

Available options: IP Address – External IP address is mapped to the specified IP address.IP
Range – External IP address range is mapped to the specified IP address range.IP List – External
IP address is mapped to the specified IP list.FQDN – External IP address is mapped to the specified
FQDN. Internal mapped server can be accessed by FQDN. This option is only available for IPv4
Virtual hosts.

Mapped Port Type (Available only if Change Destination Port(s) is selected)
Select the type of mapped port from the available options.

Available Options:PortPort RangePort List

Note:  Not applicable for firewalls running on SFOS v17.
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Mapped Port (Available only if Change Destination Port(s) is selected)
Specify the mapped port number on the destination network to which the public port number is
mapped.

Protected Zone
Select the zone to apply web server rule.

Change Destination Port(s)
Select the check box to specify different mapped port. Clear the check box to use the same Service
Port(s) Forwarded as mapped port.

Figure 75: Forward To

7. Specify Load balancing details.
Load Balancing (only available if IP Range or IP List is selected for Protected Server and IP Address is selected for
Destination Host/Network)

Select the method for load balancing from the available options.

Available Options:Round Robin - In this method, requests are served in a sequential manner where
the first request is forwarded to the first server, second request to the second server and so on. When
a request is received, the device checks to see which was the last server that was assigned a request.
It then assigns this new request to the next available server. This method can be used when equal
distribution of traffic is required and there is no need for session-persistence.First Alive - In this
method, all incoming requests are served by the first server (the first IP address that is configured
in the IP range). This server is considered as the primary server and all others are considered as
backup. Only when the first server fails, the requests are forwarded to the next server in line. This
method is used for failover scenarios. Random - In this method, the requests are forwarded to the
servers randomly. Nevertheless, the device makes sure that all configured servers receive equally
distributed load. Hence, this method is also called uniform random distribution. This method can
be used when equal distribution of traffic is required and there is no need for session-persistence or
order of distribution.Sticky IP - In this method, along with the Round Robin distribution of traffic,
the device forwards incoming traffic according to the source IP address. All traffic from a particular
source is forwarded only to its mapped server. This means that all requests for a given source IP
are sent to the same application server instance. This method is useful in cases where all requests
or sessions are required to be processed by the same server. For example: banking websites, E-
Commerce websites.

Health Check (only available if Load Balancing is enabled)
Click to enable a health check for failover and specify the parameters based on the description
shown below.

Port (Applicable if TCP Probe Health Check Method is selected)
Specify the port number on the server health is monitored.

Acceptable range: 1 to 65535

Interval
Specify the time interval in seconds after which the health will be monitored.

Acceptable range: 5 to 65535 seconds
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Default: 60

Probe Method
Select the probe method to check the health of the server from the available options.

Available Options:ICMP TCP

Timeout
Specify the time interval in seconds within which the server must respond.

Acceptable range: 1 to 10 seconds

Default: 2

Retries
Specify the number of tries to probe the health of the server, after which the server will be declared
unreachable.

Acceptable range: 1 to 10

Default: 3
8. Specify Identity details.

Match known users
Match rule based on user identity allows you to check whether the specified user/user group from
the selected zone is allowed to access the selected service or not.

Click to attach the user identity.

Enable check identity to apply the following policies per user.

Show Captive Portal to unknown users
Select the check box to accept traffic from unknown users. Captive portal page is displayed to the
user where the user can login to access the Internet.

Clear the check box to drop traffic from unknown users.

User or Groups (Available if 'Match known users' is selected)
Select the user(s) or group(s) from the list of available options.

Exclude this user activity from data accounting (Available 'if Match known users' is selected)
Click to enable/disable user traffic activity from data accounting.

By default, user’s network traffic is considered in data accounting. Select to exclude certain traffic
from user data accounting. The traffic allowed through this firewall rule will not be accounted
towards data transfer for the user.

9. Specify advanced settings details.
a) Specify Polices for Business Applications.

Intrusion Prevention
Select the required IPS policy. If Match rule based on user identity is enabled, user’s IPS policy
will be applied automatically, but will not be effective till the respective module is subscribed. A
new IPS policy can be created directly from this page or from the Device Configuration > Protect
> Intrusion Prevention > IPS Policies page.

Traffic Shaping Policy
Select the required traffic shaping policy. If Match rule based on user identity is enabled, user’s
traffic shaping policy will be applied automatically.

You need to select traffic shaping policy for the rule if Match known users is not selected.

A new traffic shaping policy can be created directly from this page or from the Device
Configuration > System > Profiles > Traffic Shapping page.

b) Specify Security Heartbeat details. (only available if IPv4 is selected).
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Minimum Source HB Permitted
Select a minimum health status that a source device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block clients with no heartbeat
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can restrict a source device's access to certain services and networks.

Enable the option to require the sending of heartbeats.

Minimum Destination HB Permitted (Not available if Protected Zone selected is WAN)
Select a minimum health status that a destination device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block request to destination with no heartbeat (Not available if Protected Zone selected is WAN)
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can block requests to destinations not sending heartbeat.

Enable/disable the option to require the sending of heartbeats.
c) Specify Routing details.

Rewrite source address (Masquerading)
Enable/disable to re-write the source address or specify a NAT policy.

Create Reflexive Rule
Enable to automatically create a reflexive firewall rule for the protected host.

A reflexive rule has the same policies as those rules configured for the hosted server but instead of
source zone to destination zone, this rule is applicable on traffic from destination zone to source
zone.

By default, the reflexive rule is not created.

Use Outbound Address (only available if Rewrite source address is enabled)
Select the NAT policy to be applied from the list of available NAT policies.

A new NAT policy can be created directly from this page or from the Device Configuration >
System > Profiles > Network Address Translation page.

The default NAT policy is Masquerade.

MASQ (Interface Default IP): IP Address of the selected Protected Zone as configured in Device
Configuration > Configure > Network > Interfaces will be displayed instead of (Interface Default
IP).

10. Specify the logging option for the user application traffic.
Log Firewall Traffic

Click to enable logging of permitted and denied traffic.
11. Click Save.

The non-web based rule has been created and appears on the Firewall page when the appropriate filter is set.
Email Servers (SMTP)

This page allows you to configure rule for Email Servers (SMTP).

1. Click Policies and select among IPv4 or IPv6 using the filter switch. Now, click on +Add Firewall Policy and
select Business Application Rule.

2. Enter policy introduction for About This Rule.
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Application Template
Select Email Servers (SMTP) to configure rule for SMTP based Email applications.

Description
Specify Policy Description.

Rule Position
Specify the position of the rule.

Available Options: TopBottom

Note:  Rule Position can only be specified while creating a rule.

Rule Name
Specify a name to identify the policy.

Note:  Rule Name can only be edited while creating a rule.

Figure 76: About this Rule
3. Specify Source details.

Source Zones
Click to select the source zone. Click Add New Item to define a new LAN or DMZ zone

Allowed Client Networks
Select the allowed host(s) or add a new one by clicking Add New Item.

Blocked Client Networks
Select the blocked host(s)/network(s).

Figure 77: Source
4. Specify Destination & Service details.

Firewall Version
Choose from the following options:

Available Options: Firewalls running on SFOS v17Firewalls running on SFOS v16.x

Destination Host/Network
Select the destination host/network to apply rule. It is the public IP address through which users
access internal server/host over the Internet.

Available Options:IP Address – Specified IP address is mapped to a corresponding mapped single
or range of IP addresses. If a single IP address is mapped to a range of IP addresses, the device
uses a sticky IP algorithm to load balance the requests.IP Range – Specified IP address range is
mapped to a corresponding range of mapped IP addresses. The IP range defines the start and end of
an address range. The start of the range must be lower than the end of the range.Interface IP (only
available for IPv4) – Select when any of the device port, alias or virtual LAN (VLAN) sub interface
is required to be mapped to the destination host or network.



 | Device Configuration | 61

Services
Select the services allowed to the user. A new service can be directly created from this page.

Add new item

Name: Enter a name to identify the service.

Type: Select a protocol for the service.

Available Options:TCP/UDP: Enter Source and Destination port. You can enter multiple ports
for the same service. The number of source and destination ports must not exceed 16.IP: Select
Protocol Number for the service. You can select multiple ports for the same service.ICMP: Select
ICMP Type and Code. You can enter multiple types and codes for the same service. Use Add icon

and Remove icon  to add and delete the parameters respectively. ICMPv6: Select ICMPv6

Type and Code. You can enter multiple types and codes for the same service. Use Add  and

Remove  to add and delete the parameters.

Figure 78: Firewalls Running on SFOS v17

Forward Type
Select the type of external port from the available options.

Available Options: PortPort RangePort List Everything

When Everything is selected, all ports are forwarded. Select other options to enable custom port
forwarding and specify port forwarding details.

Service Port(s) Forwarded (Not Available if Forward Type selected is Everything)
Specify the public port number for which you want to configure port forwarding.

Protocol (Not Available if Forward Type selected is Everything)
Select the protocol TCP or UDP to be used by forwarding packets.

Figure 79: Firewalls Running on SFOS v16.x

5. Specify Forward To details.
Protected Server(s)

Select from the available options on which the email server is to be hosted.
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Available options: IP Address – External IP address is mapped to the specified IP address.IP
Range – External IP address range is mapped to the specified IP address range.IP List – External IP
address is mapped to the specified IP list.FQDN (available only for IPv4 virtual hosts) – External
IP address is mapped to the specified FQDN. Internal mapped server can be accessed by FQDN.

Note:  For IP Range and IP List, you can also use a single external IP address. The
device will then use load balancing for handling the requests.

Mapped Port Type (Available only if Change Destination Port(s) is selected)
Select the type of mapped port from the available options.

Available Options:PortPort RangePort List

Note:  Not applicable for firewalls running on SFOS v17.

Mapped Port (available only if Change Destination Port(s) is selected)
Specify mapped port number on the destination network to which the public port number is mapped.
Mapped port must have the same number of ports as specified in the public service, or at least have
one port. Mapped Port is disabled if:

• No TCP/UDP service is selected.
• Multiple services are selected.
• Service group is selected.
• Selected service is with TCP/UDP combination.

Protected Zone
Select the zone to which the email server rule applies.

Change Destination Port(s)
Select the check box to specify different mapped port. Clear the check box to use the same Service
Port(s) Forwarded as mapped port.

Figure 80: Forward To

6. Specify Load Balancing details.
Load Balancing (Applicable when 'IP Range' or 'IP List' is selected for Protected Server. Also, Source Zone for Hosted
Server should be 'WAN')

Select the method for load balancing from the available options.

Available Options

Round Robin - In this method, requests are served in a sequential manner where the first request
is forwarded to the first server, second request to the second server and so on. When a request
is received, the device checks to see which the last server that was assigned a request was. It
then assigns this new request to the next available server. This method is can be used when equal
distribution of traffic is required and there is no need for session-persistence.

First Alive - In this method, all incoming requests are served by the first server (the first IP Address
that is configured in the IP Range). This server is considered as the primary server and all others are
considered as backup. Only when the first server fails, the requests are forwarded to the next server
in line. This method is used for failover scenarios.
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Random -In this method, the requests are forwarded to the servers randomly. Although, the device
makes sure that all configured servers receive equally distributed load. Hence, this method is also
called uniform random distribution. This method can be used when equal distribution of traffic is
required and there is no need for session-persistence or order of distribution.

Sticky IP - In this method, Along with Round Robin distribution of traffic, the device forwards
incoming traffic according to the Source IP Address. All traffic from a particular source is
forwarded only to its mapped Server. This means that all requests for a given source IP are sent to
the same application server instance. This method is useful in cases where all requests or sessions
are required to be processed by the same server. For example: Banking websites, E-Commerce
websites.

Health Check (Applicable if Load Balancing is enabled)

Click to enable health check for failover and specify the parameters based on the description shown
below.

Probe Method

Select the probe method to check the health of the server from the available options.

Available Options:

TCP Probe ICMP Probe

Port (Applicable if TCP Probe Health Check Method is selected)

Specify the Port number on the server health is monitored.

Acceptable Range - 1 to 65535

Interval

Specify the time interval in seconds after which the health will be monitored.

Acceptable Range (Seconds) - 5 to 65535

Default - 60

Timeout

Specify the time interval in seconds within which the server must respond.

Acceptable Range (Seconds) - 1 to 10

Default - 2

Retries

Specify the number of tries to probe the health of the server, after which the server will be declared
unreachable

Acceptable Range - 1 to 10

Default – 3

Figure 81: Protected Application Server(s)
7. Specify Identity details.
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Match known users
Match known users allows you to check whether the specified user/user group from the selected
zone is allowed to access the selected service or not.

Click to attach the user identity.

Show Captive Portal to unknown users
Select the check box to accept traffic from unknown users. Captive portal page is displayed to the
user where the user can login to access the Internet.

Clear the check box to drop traffic from unknown users.

User or Groups (available only if Match known users is enabled)
Select the user(s) or group(s) from the list of available options.

Exclude this user activity from data accounting (available only if Match known users is enabled)
Click to enable/disable user traffic activity from data accounting.

By default, user’s network traffic is considered in data accounting. Select to exclude certain traffic
from user data accounting. The traffic allowed through this firewall rule will not be accounted
towards data transfer for the user.

Figure 82: Identity

8. Specify Scanning details.
Scan SMTP

Click to enable/disable scanning of SMTP traffic.

Scan SMTPS
Click to enable/disable scanning of SMTPS traffic.

Figure 83: Scanning

9. Specify Advanced settings details.
a) Specify Polices for Business Applications.

Intrusion Prevention
Select the required IPS policy. If Match rule based on user identity is enabled, user’s IPS policy
will be applied automatically, but will not be effective till the respective module is subscribed.

A new IPS policy can be created directly from this page or from the Protect  > Intrusion
Prevention > IPS Policies page.

Traffic Shaping Policy (not available if Match known users is selected)
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Select the required IPS policy. If Match rule based on user identity is enabled, user’s QoS policy
will be applied automatically.

A new traffic shaping policy can be created directly from this page or from the System > Profiles >
Traffic Shaping page.

Figure 84: Policies for Business Applications

b) Specify Security Heartbeat settings (available only if IPv4 is selected).
Minimum Source HB Permitted

Select a minimum health status that a source device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block clients with no heartbeat
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can restrict a source device’s access to certain services and networks.

Enable/disable the option to require the sending of heartbeats.

Minimum Destination HB Permitted (not available if Protected Zone selected is WAN)
Select a minimum health status that a destination device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block request to destination with no heartbeat (not available if Protected Zone selected is WAN)
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can block requests to destinations not sending heartbeat.

Enable/disable the option to require the sending of heartbeats.

Figure 85: Security Heartbeat
c) Specify Routing details.
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Rewrite source address (Masquerading)
Enable/disable to re-write the source address or specify a NAT policy.

Use Outbound Address (available only if Rewrite source address is enabled)
Select the NAT policy to be applied from the list of available NAT policies.

A new NAT policy can be created directly from this page or from the System > Profiles > Network
Address Translation page.

The default NAT policy is Masquerade.

MASQ (Interface Default IP): IP Address of the selected Protected Zone as configured in
Configure > Network > Interfaces will be displayed instead of (Interface Default IP).

Create Reflexive Rule
Select ON to automatically create a reflexive firewall rule for the protected host.

The reflexive rule has the same policies as those configured for the hosted server but instead of
source zone to destination zone, this rule is applicable on traffic from destination zone to source
zone.

By default, the reflexive rule is not created.

Figure 86: Routing
10. Specify the logging option for the user application traffic.

Log Firewall Traffic
Click to enable logging of permitted and denied traffic.

Figure 87: Log Traffic

Email Clients (POP and IMAP)

1. Go to Device Configuration > Protect > Firewall and select between IPv4 or IPv6 using the default filter.
2. Now, click +Add Firewall Rule and select Business Application Rule.
3. Specify the general rule details.

Application Template
Select Email Clients (POP & IMAP) to define a application filter policy for POP and IMAP based
email clients.

Description
Specify the rule description.

Rule Position
Specify the position of the rule.

Available Options:TopBottom
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Note:  Rule Position can only be specified while creating a rule.

Rule Name
Specify a name to identify the rule.

Note:  Rule Name can only be edited while creating a rule.

4. Specify Source details.
Zone

Select the allowed source zone(s).

Networks
Select the allowed source network(s) . A new network host can be created directly from this page or
from the Device Configuration > System > Host and Services > IP Hosts page.

5. Specify Destination details.
Zone

Select the zone to which the rule applies.

Networks
Select the network(s) to be protected.

A new network host can be created directly from this pager from the Device Configuration >
System > Host and Services > IP Hosts page.

6. Specify Identity details.
Match rule based on user identity

Click to enable a rule based on the user identity.

Show Captive Portal to unknown users
Select the check box to accept traffic from unknown users. Captive portal page is displayed to the
user where the user can login to access the Internet.

Clear the check box to drop traffic from unknown users.

User or Groups (only available if Match rule based on user identity is enabled)
Select the user(s) or group(s) from the list of available options.

Exclude this user activity from data accounting (only available if Match rule based on user identity is enabled)
Click to enable/disable user traffic activity from data accounting.

By default, user’s network traffic is considered in data accounting. Select to exclude certain traffic
from user data accounting. The traffic allowed through this rule will not be accounted towards data
transfer for the user.

7. Specify Malware Scanning details.
Scan IMAP/IMAPS/POP3/POP3S/SMTP/SMTPS

Click to enable/disable scanning of IMAP/IMAPS/POP3/POP3S/SMTP/SMTPS traffic.
8. Specify Advanced settings.

a) Specify Policies for Business Applications.
Intrusion Prevention

Select an IPS policy for the rule. A new IPS policy can be created directly from this page itself or
from the Device Configuration > Protect > Intrusion Prevention > IPS Policies page.

Traffic Shaping (Not available if Match rule based on user identity is selected)
Select a traffic shaping policy for the rule.

A traffic shaping policy allocates & limits the maximum bandwidth usage of the user.
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A new traffic shaping policy can be created directly from this pager from the Device Configuration
> Protect > Intrusion Prevention > IPS Policies page.

b) SpecifySecurity Heartbeat settings (only available if IPv4 is selected).
Minimum Source HB Permitted

Select a minimum health status that a source device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this rule will not be granted to the user.

Block clients with no heartbeat
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can restrict a source device's access to certain services and networks.

Enable/disable the option to require the sending of heartbeats.

Minimum Destination HB Permitted
Select a minimum health status that a destination device must have to conform to this rule. Health
status can be either Green, Yellow or No Restriction. If the health criterion is not met, access and
privileges defined in this policy will not be granted to the user.

Block request to destination with no heartbeat
Heartbeat-capable devices can be required to send information on their health status in defined
intervals - this is called a heartbeat.

Based on that information, you can block requests to destinations not sending heartbeat.

Enable/disable the option to require the sending of heartbeats.
c) Specify Routing details.

Rewrite source address (Masquerading)
Enable/disable to re-write the source address or specify a NAT policy.

Use Gateway Specific Default NAT Policy (only if Masquerading is selected)
Select to override the default NAT policy with a gateway specific policy.

Override default NAT policy for specific Gateway (only if Use Gateway Specific Default NAT Policy is selected )
Select to specify gateway and corresponding NAT policy. Multiple gateways and NAT policies can
be added.

Use Outbound Address (only available if Rewrite source address is enabled and Use Gateway Specific Default NAT
Policy is disabled )

Select the NAT policy to be applied the list or available NAT policies.

A new NAT policy can be created directly from this pager from the Device Configuration >
System > Profiles > Network Address Translation page.

The default NAT policy is Masquerade.

Primary Gateway
Select the primary gateway to route the request. You can create new gateway from this page itself or
from Device Configuration > Configure > Routing > Gateways.

Note:  On deletion of the gateway, Primary Gateway will display WAN Link Load
Balance for WAN Destination Zone and None for other zones. In such case, firewall
rule will not make routing decisions.

Backup Gateway
Select the backup gateway to route the request. You can create new gateway from this page itself or
from Device Configuration > Configure > Routing > Gateways.

Note:  On deletion of the gateway, Backup Gateway will display None.
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9. Specify logging option for the user application traffic.
Log Firewall Traffic

Click to enable logging of permitted and denied traffic.

DSCP Value
DiffServ Code Point (DSCP) uses the 6 bits, thereby giving 2^6 = 64 different values (0 to 63). describes the standard
DSCP values. Remaining DSCP values can be customized as per the QoS requirement.

Decimal DSCP Description

0 Default Best Effort

8 CS1 Class 1 (CS1)

10 AF11 Class 1, Gold (AF11)

12 AF12 Class 1, Silver (AF12)

14 AF13 Class 1, Bronze (AF13)

16 CS2 Class 2 (CS2)

18 AF21 Class 2, Gold (AF21)

20 AF22 Class 2, Silver (AF22)

22 AF23 Class 2, Bronze (AF23)

24 CS3 Class 3 (CS3)

26 AF31 Class 3, Gold (AF31)

28 AF32 Class 3, Silver (AF32)

30 AF33 Class 3, Bronze (AF33)

32 CS4 Class 4 (CS4)

34 AF41 Class 4, Gold (AF41)

36 AF42 Class 4, Silver (AF42)

38 AF43 Class 4, Bronze (AF43)

40 CS5 Class 5 (CS5)

46 EF Expedited Forwarding (EF)

48 CS6 Control (CS6)

56 CS7 Control (CS7)

Intrusion Prevention
Intrusion Prevention provides facilities to add and manage IPS Policies, Custom IPS Signatures and DoS Bypass
Rules. You can also configure DoS settings using Intrusion Prevention.

Following pages are accessible:

• IPS Policies on page 69
• Custom IPS Patterns on page 74
• DoS on page 75

IPS Policies
The IPS  page displays the list of all the pre-defined and custom IPS policies.

The device is a real time Intrusion Prevention System (IPS) system that protects your network from known and
unknown attacks by worms and viruses, hackers and other Internet risks.
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The device at the perimeter of your network analyzes entire traffic and prevents attacks from reaching your network.
Whether it is a worm, a suspicious web request, a hacker targeting your mail server or any other attack - it simply
does not get through.

IPS consists of a signature engine with a predefined set of signatures. Signatures are the patterns that are known to be
harmful. IPS compares traffic to these signatures and responds at a high rate of speed if it finds a match. Signatures
included within the device are not editable.

As per your network requirements, device allows you to define multiple policies instead of one global policy, to
decrease packet latency and reduce the false positives.

IPS policy allows you to view predefined signatures and customize the intrusion prevention configuration at the
category as well as individual signature level. Categories are signatures grouped together based on the application and
protocol vulnerabilities.

The device instead of providing only a single policy (global) for managing multiple networks/hosts, allows to tailor
policy per network/host i.e. allows to define multiple policies for managing multiple networks/hosts.

To enable the Intrusion Prevention System, apply IPS policy from Security Policies. You can create rule to apply:

• single policy for all the users/networks
• different policies for different users/networks or hosts

As Security Policies control all traffic passing through the device and decide whether to allow or drop the connection,
IPS rule will be applied to only that traffic/packet which passes through Firewall.

Category

Signatures are organized in categories such as DNS, Finger, P2P, DDOS, and others. These signature categories are
listed in the policy. You can configure these categories to change the prevention and/or detection settings. To perform
Intrusion Prevention, you need to enable IPS services for each category i.e. you will be able to configure attack threats
for individual signature only if an IPS service for the category is “Enabled”.

Each IPS policy contains a set of signatures that device searches for, logs, blocks and allows to:

• Enable or disable category from IPS protection.
• Enable or disable individual signature in a category to tailor IPS protection based on your network environment.
• Define an action to be taken when the matching traffic pattern is found. Device can either detect or drop the

connection. In either of the case, device generates the log and alerts the Network Administrator.

IPS provides six actions for managing attack threats: (action if signature matches)

• Allow Packet - Allows the packet to its intended destination.
• Drop Packet - Drops packets if detects any traffic that matches the signature.
• Disable - Disables the signature, if it detects any traffic that matches the signature.
• Drop Session - Drops the entire session if detects any traffic that matches the signature.
• Reset - Resets entire session if detects any traffic that matches the signature.
• Bypass Session - Allows the entire session if detects any traffic that matches the signature.

In packet-based actions, the device checks each packet before taking an action while for session-based action, only
the first packet is checked and an action is taken. In case of Reset, TCP reset packet is sent to the originator. In all the
cases, the device generates the log and alerts the Network Administrator.

To save resources and avoid latency, set action as “Bypass Session” as in this, if the initial packets match the signature
then the rest of the session packets will not be scanned at all.

To avoid getting high number of Alerts and save resources, set action as “Drop session” as in this, if the device
identifies attack in the initial packets then it will terminate the entire session instead of scanning all the session
packets.

The page provides option to add a new policy, configure the handling of signatures by category or on a signature-by-
signature basis, or delete the policy.
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The device provides following pre-defined policies. You can directly use policies 1 to 6 without any modifications
while policies 7 to 10 can either be used directly or, can be modified as per your requirements:

1. DMZ TO LAN
2. DMZ TO WAN
3. LAN TO DMZ
4. LAN TO WAN
5. WAN TO DMZ
6. WAN TO LAN
7. generalpolicy
8. lantowan strict policy
9. lantowan general policy
10. dmzpolicy

Create an IPS Policy
Use the Add page to quickly configure a new IPS policy.

The Add page allows you to manually enter details to create an IPS policy.

1. Go to Device Configuration > Protect > Intrusion Prevention > IPS Policies and click Add.
2. Enter details.

Name
Enter a name to identify the IPS Policy.

Template
Select the IPS Policy to be used as a template from the available list.

Available Options:generalpolicylantowan_strictlantowan_generaldmzpolicyLAN to WANLAN to
DMZWAN to DMZWAN to LANDMZ to WANDMZ to LAN

Description
Enter IPS Policy description.

Figure 88: Add IPS Policy
3. Click Save to add the IPS Policy.
4. Once the policy is created, policy rules can be added to take appropriate action for signatures in the policy. Define

rule to configure action to be taken when the matching traffic pattern is found. If the rules are already added, list
of rules are displayed along with its details like signature filtering criteria, action. You can add, update, or delete
the rules.

IPS Policy Rules
Add IPS Policy Rules allows you to manually configure policy rules.

Once the policy is created, policy rules can be added to take appropriate action for signatures in the policy. Define a
rule to configure an action to be taken when the matching traffic pattern is found. If the rules are already added, a list
of rules is displayed along with its details like signature filtering criteria, action.
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1. Go to Device Configuration > Protect > Intrusion Prevention > IPS Policies.
2.

Click the edit button  against the policy to which you wish to add a rule.
3. Click Add.
4. Specify the following:

Rule Name
Enter a unique name for the IPS policy rule.

Figure 89: Rule Detail
5. Enter signature criteria.

Default
Select to view a list of default signatures.

Custom Signature
Select to view a list of custom signatures.

Category
Select IPS signature category from the list of available categories.

Severity
Severity is the level of threat posed by the attack. Select the type of severity from the available
options.

Available Options:

• Select All
• 1 - Critical
• 2 - Major
• 3 - Moderate
• 4 - Minor
• 5 - Warning

Platform
Platform is the OS affected by the attack. Select the platform from the available options:

Available Options:

• Select All
• Windows
• Linux
• Unix
• MAC
• Solaris
• BSD
• Other

Target
Target is the type of device targeted by the attack. Select the target from available options:

Available Options:

• Select All
• Client
• Server
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Smart Filter (available only if Select All is selected)

Enter the partial or full signature name to filter by name.

Figure 90: Signature Criteria
6. Manage the list of matching signatures.

Select All
Select to choose all the signatures listed for the selected criteria.

Based on the signature criteria the signatures are made available.

Select Individual Signature
Select to customize the choice of signatures list for the selected criteria.

Based on the signature criteria the signatures are made available.

Figure 91: List of Matching Signatures
7. Specify the action details.

Action
Select an action to be taken from the available options:

Available Options:Recommended: This action means that you want the OS to handle this alert
level according to best-fit recommendations.Allow Packet: Allows the packet to its intended
destination.Drop Packet: Drops packets if it detects any traffic that matches the signature. Disable:
Disables the signature, if it detects any traffic that matches the signature. Drop Session: Drops the
entire session if detects any traffic that matches the signature. Reset: Resets entire session if detects
any traffic that matches the signature.Bypass Session: Allows the entire session if detects any traffic
that matches the signature.
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Figure 92: Action
8. Click Save.

Custom IPS Patterns
The Custom IPS Patterns page displays the list of all the custom IPS patterns.

Custom IPS Patterns provide the flexibility to customize IPS for diverse network environments. Predefined IPS
patterns included in the device cover common attacks while Custom IPS Patterns protect your network from
uncommon attacks that are due to the use of proprietary server, custom protocol, or specialized applications used in
the corporate network.

Note:  User will be able to create Custom IPS Pattern and configure policies using them, however, the IPS
scanning will work only if 'Network Protection' module is subscribed.

The page provides option to add a new IPS pattern, update the parameters of existing pattern, or delete the pattern.

Adding IPS Pattern
Use Add IPS Pattern page to add Custom IPS Pattern.

The Add IPS Pattern page allows you to add a new Custom IPS Pattern.

1. Go to Device Configuration > Protect > Intrusion Prevention > Custom IPS Patterns and click Add.
2. Enter the IPS Pattern details.

Name
Enter a name to identify the Custom IPS Pattern.

Protocol
Select IPS protocol from the list.

Available Options:TCPUDPICMPALL

Custom Rule
Specify IPS Pattern definition.

Signature definition must begin with a keyword followed by the value enclosed between the double
quotes and must end with semicolon (;)

Format: Keyword: "value";

For example, content: "USER JOHN";
If traffic with the content USER JOHN is detected, action defined in the policy will be taken.

Refer to Appendix B – IPS - Custom IPS Pattern Syntax for more details on creating IPS Pattern.

Severity
Select the level of severity from the available options.CriticalMajorModerateMinorWarning

Recommended Action
Specify action to be taken on the selected policy when matching pattern is found.

Available Actions:

Allow Packet - Check each packet before taking action.Drop Packet - Drop packets.Drop Session
- Terminate entire session instead of scanning all the session packets to save resources and avoid
getting high number of alerts. Reset - Send TCP reset packet to the originator.Bypass Session -
Scan initial packets only. If the initial packets match the pattern then the rest of the session packets
are not scanned and the traffic is allowed to pass.

In all the cases, device generates the log and alerts the Network Administrator.
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Figure 93: Custom IPS Patterns
3. Click Save to add the IPS pattern with the options you have configured.

DoS
Device Configuration > Protect > Intrusion Prevention > DoS

The device provides several security options that cannot be defined by the Security Policies. This includes protection
from several kinds of “Denial of Service attacks”. These attacks disable computers and circumvent security.

Denial of Service (DoS) attack is a method that hackers use to prevent or deny legitimate users access to a service.

DoS attacks are typically executed by sending many rkequest packets to a targeted server (usually Web, FTP, or Mail
server), which floods the server's resources, making the system unusable. Their goal is not to steal the information but
disable or deprive a device or network so that users no longer have access to the network services/resources.

All servers can handle traffic volume up to a maximum, beyond which they become disabled. Hence, attackers send a
very high volume of redundant traffic to a system so it cannot examine and allow permitted network traffic. Best way
to protect against the DoS attack is to identify and block such redundant traffic. Below are some DoS settings which
can be used for identifying DoS attack:

Packet rate per Source

Total number of connections or packets allowed to a particular user.

Burst rate per Source

Maximum number of packets allowed to a particular user at a given time.

Packet rate per Destination

Total number of connections or packets allowed from a particular user.

Burst rate per Destination

Maximum of packets allowed from a particular user at a given time.

How it works

When the burst rate is crossed, device considers it as an attack. Device provides DoS attack protection by dropping
all the excess packets from the particular source/destination. Device will continue to drop the packets till the attack
subsides. Because device applies threshold value per IP Address, traffic from the particular source/destination will
only be dropped while the rest of the network traffic will not be dropped at all.

Time taken to re-allow traffic from the blocked source/destination = time taken to subside the attack + 30 seconds

For example:

Packet rate per Source – 100 packets per second
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Burst rate per Source – 200 packets per second

When user starts sending requests, initially user will be able to send 200 packets per second but once the 200 packets
are received, in the next phase user will be able to send only 100 packets per second. So in the next phase, if user
sends 150 packets per second, device will consider it as an attack and drop 50 (150 -100) packets. Device will accept
traffic from the user only after 30 seconds of dropping the packets.

Threshold values

Device uses packet rate and burst rate values as a threshold value to detect DoS attack. These values depend on
various factors like:

• Network bandwidth
• Nature of traffic
• Capacity of servers in the network

These values are applicable to the individual source or destination requests per user/IP Address and not globally to the
entire network traffic. For example, if source rate is 2500 packets/minute and the network consists of 100 users then
each user is allowed packet rate of 2500 packets per minute

Configuring high values will degrade the performance and too low values will block the regular requests. Hence it is
very important to configure appropriate values for both source and destination IP Address.

DoS Settings

Attack definition can be defined both for source and destination

SYN Flood

SYN Flood is the attack in which large numbers of connections are sent so that the backlog queue
overflows. The connection is created when the victim host receives a connection request and
allocates for it some memory resources. A SYN flood attack creates so many half-open connections
that the system becomes overwhelmed and cannot handle incoming requests any more.

Configure Packet Rate (packets/minute) and Burst Rate (packets/second) for source and destination.

Select Apply Flag checkbox to apply the SYN flood definition and control the allowed number of
packets.

Source Traffic Dropped displays number of source packets dropped in case source packet rate
control is applied.

Destination Traffic Dropped displays number of packets dropped in case destination packet rate
control is applied.

Click SYN Flood to view the real-time updates on flooding. It displays the source IP Address -
which was used for flooding and IP Address which was targeted.

UDP Flood

User Datagram Protocol (UDP) Flood links two systems. It hooks up one system’s UDP character-
generating service, with another system’s UDP echo service. Once the link is made, the two systems
are tied up exchanging a flood of meaningless data.

Configure Packet Rate (packets/minute) and Burst Rate (packets/second) for source and destination.

Select Apply Flag checkbox to apply the UDP flood definition and control the allowed number of
packets.

Source Traffic Dropped displays number of source packets dropped in case source packet rate
control is applied.

Destination Traffic Dropped displays number of packets dropped in case destination packet rate
control is applied.
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Click UDP Flood to view the real time updates on flooding. It displays the source IP Address -
which was used for flooding and IP Address which was targeted.

TCP Flood

TCP attack sends huge amount of TCP packet so that the host/victim computer cannot handle,
thereby denying service to legitimate TCP users.

Configure Packet Rate (packets/minute) and Burst Rate (packets/second) for source and destination.

Select Apply Flag checkbox to apply the TCP flood definition and control the allowed number of
packets.

Source Traffic Dropped displays number of source packets dropped in case source packet rate
control is applied.

Destination Traffic Dropped displays number of packets dropped in case destination packet rate
control is applied.

ICMP/ICMPv6 Flood

ICMP/ICMPv6 attack sends huge amount of packet/traffic so that the protocol implementation of
the host/victim computer cannot handle, thereby preventing legitimate packets from getting through
to their destination.

Configure Packet Rate (packets/minute) and Burst Rate (packets/second) for source and destination.

Select Apply Flag checkbox to apply the ICMP flood definition and control the allowed number of
packets.

Click ICMP/ICMPv6 Flood to view the real time updates on flooding. It displays the source IP
Address - which was used for flooding and IP Address which was targeted.

Dropped Source Routed Packets

Select Apply Flag checkbox to enable. This will block any source routed connections or any
packets with internal address from entering your network.

Disable ICMP/ICMPv6 Redirect Packet

An ICMP redirect packet is used by routers to inform the hosts what the correct route should be. If
an attacker is able to forge ICMP redirect packets, he or she can alter the routing tables on the host
and possibly weaken the security of the host by causing traffic to flow via another path.

Disable the option to prevent the attacker from forging ICMP redirect packet.

Default - Enabled

ARP Hardening

If enabled, device will send an ARP reply only if the destination IP address is a local address
configured on the incoming interface and both the sender and destination IP address are in the same
subnet.

DoS Bypass Rule

The device allows to bypass the DoS rule in case you are sure that the specified source will not be used for flooding
or ignore if flooding occurs from the specified source. By default, VPN zone traffic is also subjected to DoS
inspection. You can also bypass DoS inspection of the traffic coming from certain hosts of VPN zone.

The DoS Bypass Rule page displays list of all the bypass rule. You can filter the list based on IP Family. The page
provides option to add a new rule, update the existing rule, or delete a rule.

Create a DoS Bypass Rule

You can create a DoS Bypass Rule from this page.

1. Device Configuration > Protect > Intrusion Prevention > DoS and click Add under DoS Bypass Rule section.
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2. Enter Bypass Rule details.
IP Family

Select the IP Family of the traffic to be bypassed.

Source IP/Netmask (only IPv4)
Specify Source IP/Netmask.

Specify * if you want to bypass entire network.

Destination IP/Netmask (only IPv4)
Specify Destination IP/Netmask.

Specify * if you want to bypass entire network.

Source IP/Prefix (only IPv6)
Specify Source IP/Prefix.

Specify * if you want to bypass entire network.

Destination IP/Prefix (only IPv6)
Specify Destination IP/Prefix.

Specify * if you want to bypass entire network.

Protocol
Select protocol whose traffic is to be bypassed if generated from the specified source to destination.

Available Options:

TCPUDPICMPAll Protocols

For example, if you select TCP protocol then DoS rules will not be applied on the TCP traffic from
the specified source to destination.

Source Port
Specify Port Number for Source.

Specify * if you want to bypass entire network.

Destination Port
Specify Port Number for Destination.

Specify * if you want to bypass entire network.

Figure 94: Add DoS Bypass Rule
3. Click Save to add a DoS Bypass Rule.
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Web
Use the pages under Device Configuration > Protect > Web Protection to create and manage web filtering policies.

The pages under Web Protection allow you to configure:

• Web Proxy settings
• Web Content Filter settings
• Web Filter Policies
• Custom Web Categories
• URL Groups
• Surfing Quota and schedules
• Manage File Types for filtering policy

Policies
With policies, you can control traffic using rules and advanced settings. The default set of policies describes some
common restrictions.

To create a web policy, click Add Policy.

To expand/collapse any web policy, click ( / ) icon on the web policy.

Note:

•
To use an existing policy as a template for a new policy, click the menu button ( ) and select Clone.

• The default web policy Default Policy will be expanded by default.

To manage policies, click  and select Add Rule, Clone, Edit, Delete, Synchronize and Show Usage Refrences.

Rules

Rules specify the following criteria:

• Users to whom the rule applies. These include groups and individual users.
• Activities that describe the type of usage to restrict. These include user activities, Web categories, URL groups,

file types, and dynamic categories.
• Action (Allow, Warn or Block), HTTP Action and HTTPS Action to take when the firewall encounters traffic that

matches the rule criteria.
• Time Constraint to schedule the time period during which rule should be applied on the network.

The firewall evaluates rules from highest to lowest. For example, a rule that allows all traffic that precedes a rule that
restricts a specific type of traffic takes precedence and the subsequent rule is ignored.

Click on toggle switch next to Constraints section list to enable/disable the rule.

To manage rules, click the menu button ( ) for any rule and select Add Rule Above, Add Rule Below, Clone
Rule Above, Clone Rule Below or Delete.

Add Policy

1. Go to Device Configuration > Firwall > Web > Policies and click Add Policy.
2. Type a name.
3. Click Add Rule.

Tip:  To use an existing rule as a template for a new rule, click the menu button and select Clone.

The firewall creates a default rule that blocks all web traffic for all users. The default rule is disabled.

Figure 95: Add Rule
4. Specify users.
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These include groups and individual users.
a) In the new rule, move the pointer over the user field and click Add New Item.
b) Select users.

Tip:  You can filter the type of users to display by clicking Show Only and selecting a user type.

c) Click Apply selected items.

Figure 96: Select Users
5. Specify activities.

These include user activities, categories, URL groups, file types, and dynamic categories.
a) Move the pointer over the activity field and click Add New Item.
b) Select activities.

Tip:  You can filter the type of activities to display by clicking Show Only and selecting an activity
type.

c) Click Apply selected items.
6. In the Action list, specify an action to take when the firewall encounters HTTP traffic that matches the selected

criteria .
Choose from the following options (where permitted by the action type):

Options
Allow Warn Block

7. (Optional) Specify an action to take when the firewall encounters HTTPS traffic that matches the selected criteria.

Note:  Follow these steps only if you want to specify an action for HTTPS traffic that is different from the
one you specified for HTTP.

a) Move the pointer to the right of the Action drop-down list box.
The firewall displays the HTTPS Use Action action drop-down list box.

Figure 97: HTTPS Use Action
b) Select an option.

HTTPS Use Action
Use Action: Select this option to use the same action that is currently in effect for HTTP traffic. If
you specify a different HTTP action at a later time, HTTPS action will also use that action. Allow:
Always allow HTTPS traffic that matches the selected criteria. Warn: Always display a warning
message when encountering HTTPS traffic that matches the selected criteria. Block: Always block
HTTPS traffic that matches the selected criteria.

8. Move the pointer over the Constraints field and select a schedule.

Tip:  You can create a new schedule by clicking Create new and specifying criteria.

9. Click the on/off switch to enable the rule.

Figure 98: Enable Rule
10. Click and drag the rule handle to position the rule in the hierarchy.

Figure 99: Position Rule

The firewall evaluates rules from highest to lowest. For example, a rule that allows all traffic that precedes a rule
that restricts a specific type of traffic takes precedence and the subsequent rule is ignored.

11. Click Advanced Settings and specify settings for the policy.
Enable logging and reporting

Include this policy in logs and reports.

Prevent downloading of large files
Prevent downloading files greater than the size specified.
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Restrict login domains for Google Apps
Restrict logging in to Google Apps only on the domains specified.

Enable YouTube for Schools
Restrict YouTube content to videos on YouTube for Schools (a limited EDU-only site) and to those
uploaded using the ID specified.

Note:  You must have a YouTube school ID to use this setting.

User Activities
User Activities combine web categories, file types, and URL groups in one container. For example, you can create a
User Activity to associate spyware and malware with a list of URLs. You can include User Activities in web policies
to control access to websites or files that match any of the specified criteria.

To create a User Activity, click Add.

To delete User Activity(ies), select and click Delete.

To synchronize User Activity(ies), select and click Synchronize.

To filter the list, click the Filter button ( ) and specify criteria.

To manage individual User Activites, click  and select Edit, or Delete, Synchronize or Show Usage References.

To use an existing template of User Activity for a new one click  and select Clone.

Figure 100: User Activities

https://www.youtube.com/schools
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Use Show Usage References to view Entity Usage Reference for selected User Activity.

Figure 101: User Activities

Add User Activity

1. Go to Device Configuration > Protect > Web > User Activities and click Add.
2. Type a name.
3. Click Add New Item and select categories.

Choose from the following:

• Web categories
• File types
• URL groups

Note:  In order to match traffic, only one of the categories should return true, since the evaluation is done
using ‘OR’ condition.

Tip:  You can filter the type of categories to display by clicking Contains and selecting a category type.
Click Apply to apply the filter.
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Figure 102: Add User Activity

Categories
The Categories page displays a list of existing Web Categories.

On the Device Configuration > Protect > Web > Categories page you can maintain Categories of sites and assign
them a Classification. There are four classifications that can be used in policy decisions to control web usage. These
categories are:

• Productive
• UnProductive
• Acceptable
• Objectionable

By default there is a list of web categories with set classifications you can use in your policies. On this page you can
edit or delete existing categories, or create and classify a category of your own.

Add Web Category
Create a new Custom Web Category.

On the Add Web Category page you can create a new Custom Web Category for use in policy decisions. To create a
Web Category:

1. Enter a Name for your new category.
2. Select a classification from the Classification drop-down menu.

Available classifications include:

• Productive
• UnProductive
• Acceptable
• Objectionable

3. Select an option for Traffic Shaping Policy.
4. Set the Configure Category option to either Local or External URL Database.

• If you select External URL Database you can enter a URL to a list of custom URLs that you want to include
in the category.

• If you select Local you can enter a list of domains or keywords, either by uploading a text file or by entering
them in the related text box. In the Search/Add text boxes you can enter domains or keywords. The existing
list will match what you type so that you can see if an entry already exists.
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5. Enter a Description to describe your new Web Category.

Figure 103: Add Custom Web Category
6. Click Advanced Settings to configure policies or override the default message for a category.

a) Next to Action, select one or more policies from the Web Filter Policy list. For each policy selected, set the
desired action for both HTTP and HTTPS.

a) Next to Denied Message, select Override Default Denied Message to modify the block page shown if your
Web Category is denied by a policy. This allows you to have present a specific message if a user is blocked.
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Figure 104: Add Custom Web Category
7. Click Save to create your new Web Category.

Related concepts
Firewall on page 10
Firewall rules are security rule-sets to implement control over users, applications or network objects in an
organization. Using Firewall rules, you can create blanket or specialized traffic transit rules based on the requirement.
Firewall rules provide centralized management for the entire set of device security Firewall rules. Sophos Central
Firewall Manager implements single pane of management to secure all enterprise applications using configuration
templates for various types of Firewall rules.

Traffic Shaping on page 306
The Traffic Shaping Policy page displays list of predefined and custom policies and provides option to create a new
traffic shaping policy, schedule traffic shaping policy, update parameters or delete the policy.

Related tasks
Edit Web Category on page 85
Modify an existing Web Category.

Edit Web Category
Modify an existing Web Category.

From the Device Configuration > Protect > Web > Categories page, either click the Name of an existing category
or click the related Manage icon on the right. The Edit Web Category page is displayed.

1. Select the correct Classification for the Web Category.
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2. Optionally, from the Traffic Shaping Policy drop-down, select an existing policy, or Create New.
3. Under Advanced Settings you can select Override Default Denied Message to modify the block page shown

when your Web Category is denied by a policy. This allows you to have present a specific message if a user is
blocked.

4. Click Save.

Related tasks
Add Web Category on page 83
Create a new Custom Web Category.

URL Groups
Create a collection of URLs for use in web filter policies.

Use the Device Configuration > Protect > Web > URL Groups page to create a group of URLs. These groups can
be used in your web filter policies to block or allow custom collections of sites.

On this page you can edit an existing URL Group by either clicking its name under URL Group Name, or by
clicking the Manage icon on the right. To delete an existing URL Group, click the Delete icon.

Related concepts
Web Filter Policies on page 98
The Web Filter Policies page allows you to Add, Delete, or Edit web filter policies.

Firewall on page 10
Firewall rules are security rule-sets to implement control over users, applications or network objects in an
organization. Using Firewall rules, you can create blanket or specialized traffic transit rules based on the requirement.
Firewall rules provide centralized management for the entire set of device security Firewall rules. Sophos Central
Firewall Manager implements single pane of management to secure all enterprise applications using configuration
templates for various types of Firewall rules.

Add URL Group
Add a collection of URLs for use in policies.

On the Device Configuration > Protect > Web > URL Group , click the Add button to bring up the Add URL
Group page.

1. Enter a name for your group in the URL Group Name text box.
2. Enter a description for the group you are creating.
3. Add URLs for this collection.

Figure 105: Add URL Group

Entries must be single domains on separate lines, such as:

example.com
foo.com
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bar.com

4. Click Save.

Edit URL Group
On the Edit URL Group page you can modify an existing URL Group.

1. Set the Calssification for the URL Group.
2. Chose an existing Traffic Shaping Policy, or select Create New.
3. Under Advanced Settings you can select Override Default Denied Message to modify the block page shown

when your URL Group is denied by a policy. This allows you to have present a specific message if a user is
blocked.

Related tasks
Create a New Traffic Shaping Policy on page 307
Use the Add Traffic Shaping (QoS) Policy page to quickly configure a new traffic shaping policy.

File Types
The File Types page allows you to manage file types to be used in filtering policy.

The Device Configuration > Protect > Web > File Types page displays list of both built-in and custom file types
that you can control in policy expressions. For instance, you can restrict access to certain types of files within an
otherwise-permitted category.

A file type group consists of collections of files, identified by either file extenstion or MIME headers. Predefined File
Types are provided, and you can create new collections of file types using templates.

This page lists existing File Types collection. The predefined File Type collections can not be modified. For File
Type groups that you have added, you can edit or delete the by selecting the associated icon under the Manage
heading. To delete multiple File Types, select the associated checkboxes under the Name heading and click Delete at
the top of the page.

Click the Add button at the top to create a new File Type.

Add File Type Category
Create a File Type collection to be used in Internet filter policies.

Use the Device Configuration > Protect > Web > File Type page to create collections of File Types for use in
Internet policies. To create a new File Type collection:

1. Enter a Name for the new collection.
2. Under Template, either leave set to Blank or choose an option from the drop-down menu.

Selections under the Template drop-down will populate the File Extension and MIME Header fields with
information from our predefined File Types. From there, you can add extensions and MIME headers to extend the
definition of your new File Type Category.

3. Add entries to the File Extension and MIME Header text boxes to include those file types in your new category.
4. Add information in the Description text box to provide information about your new category.
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Figure 106: Add File Type Category
5. Click Save to create your new File Type Category.

Exceptions
With exceptions, you can override protection settings for web traffic that matches the specified criteria. For example,
you can create an exception to skip HTTPS decryption for sites that contain confidential data. The default set of
exceptions specifies some common override behaviors.

Override behaviors now include Sandstorm.

Note:  Existing exceptions that skip malware scanning now also skip Sandstorm analysis.

To filter the list, click the Filter button ( ) and specify criteria.

To enable an Exception, click the toggle key ( ).

To create an Exception, click Add Exception.

Tip:  To use an existing exception as a template for a new exception, click the menu button ( ) and select
Clone.

To manage Exceptions, click  and select Clone, Edit, Delete or Synchronize.

Add Exception

1. Go to Device Configuration > Protect > Web > Exceptions.
2. Click Add Exception.
3. Enter Name and Description for the Exception.
4. Specify web traffic criteria:
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Note:  The firewall evaluates all types of criteria specified using the ‘AND’ operator. For example, if
you specify URL patterns and website categories, both types must return true in order to match traffic.
However, within each category, criteria are evaluated using ‘OR’.

URL pattern matches
Match web traffic according to the specified URL or pattern, for example, example.com. Regular
expressions are allowed here. For example, ^([A-Za-z0-9.-]*\.)?example\.com/
matches all subdomains of example.com.

Website categories
Match web traffic according to the specified web categories.

Source IP addresses (end-user's address)
Match web traffic that originates from the specified IP addresses.

Destination IP addresses (web site address)
Match web traffic going to the specified IP addresses.

Figure 107: Add Exception
5. Specify an action to skip when the firewall encounters traffic that matches the criteria.

HTTPS Decryption
Do not decrypt HTTPS for traffic that meets the specified criteria.

Note:  If you disable HTTPS decryption, the firewall will not perform any other check
that relies on decrypted traffic, such as malware scanning or micro-app detection.
However, the firewall will continue to scan HTTP traffic that matches the exception.

Malware Scanning
Skip malware scanning when traffic that meets the specified criteria is encountered.

Sandstorm
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Do not send files that are downloaded using the specified criteria to Sandstorm for analysis.

Policy Checks
Skip policy check when traffic that meets the specified criteria is encountered.

Protection
The firewall provides several methods for protecting against threats and inappropriate web usage. Use these settings
to configure how the firewall scans content for malware and to enable other protection mechanisms.

Malware Scanning

Configure general restrictions for scanning and restricting traffic by type and protocol.

Scan Engine Selection
Specify the type of scanning to apply.

Available Options:

Single Engine: Scan traffic using the primary anti-virus engine (by default, the Sophos engine).
This selection offers optimal performance. Dual Engine: Scan traffic using both engines, first
by the primary and then by the secondary. Using this setting increases security, but may affect
performance.

Malware Scan Mode
Specify batch or real-time scanning for HTTP/HTTPS traffic.

In batch mode, virus scanning will start only after the complete file has been downloaded. While
this mode offers maximum protection, it may result in slower performance. Switch to real-time
scanning to improve performance.

Content that could not be scanned
Specify an action to take when the firewall encounters content that could not be scanned.

Note:  Files that cannot be fully scanned because they are encrypted or corrupted may
contain undetected threats. Blocking offers the best protection.

Do not scan files larger than
Specify the maximum size of files to be scanned for HTTP(S), in MB. Files that exceed this setting
will not be scanned.

Acceptable range: 1 to 256 MB

Default: 1 MB

Advanced Settings
Maximum file scan size for FTP

Specify the maximum size of files to be scanned for FTP, in MB. Files that exceed this setting will
not be scanned.

Acceptable range: 1 to 204 MB

Default: 1 MB

Scan audio and video files
Scan audio and video content for malware and threats. Scanning may cause issues with streaming
audio and video.

Enable pharming protection

Pharming attacks redirect users from legitimate websites to fraudulent websites that have been
created to look like the legitimate site.

Protect users against pharming and other domain name poisoning attacks by repeating DNS lookups
before connecting.
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Search Engine Enforcement

Enforce SafeSearch

Block websites that contain sexually explicit content from Google, Yahoo, and Bing search results.

Note:  This setting is applicable only when the ‘No Explicit Content’ web policy is set
to ‘Block’.

Enforce additional image filters
Restrict image search results to images with a Creative Commons license.

HTTPS Decryption and Scanning

HTTPS Scanning Certificate Authority (CA)
Specify the certificate authority for securing scanned HTTPS connections.

Block unrecognized SSL protocols
Prevent traffic that avoids HTTPS scanning by using invalid SSL protocols.

Block invalid certificates
Connect only to sites with a valid certificate.

Apply
Click to Apply changes.

Advanced
Configure advanced web protection such as caching behavior and proxy settings.

Web Content Caching
Enable web content cache

Keep a copy of frequently visited sites to reduce bandwidth consumption and improve performance.

Always cache Sophos Endpoint updates
Keep a copy of Sophos Endpoint updates to improve performance on your network.

Note:  If this option is disabled you may experience network congestion when many
endpoints attempt to download updates from the Internet at the same time.

Web Proxy Configuration

The firewall intercepts traffic transparently and enforces web protection (for example, policies and malware scanning)
when the web proxy service is enabled for a network zone. By default, the service is enabled for LAN and WiFi
zones. In transparent mode, the firewall allows HTTP traffic on port 80 and HTTPS traffic on port 443 only.

However, you can also configure the firewall to act as a proxy for configured web browsers by specifying a web
proxy listening port. Users who are behind the proxy must specify the LAN or WiFi address and port in the web
proxy configuration settings of their browsers. (Refer to the browser documentation for details.)

Specify the web proxy listening port and allowed destination ports when you want the firewall to act as a web proxy
for configured web browsers.

Note:  IPS policy is applicable on the traffic between proxy and WAN, but not between user and proxy.

Note:  Traffic shaping policy is not applicable on the direct proxy traffic.

Web Proxy Listening Port
Specify the port on which the web proxy will listen for HTTP connection requests.

Allowed Destination Ports
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The firewall may receive requests to connect to remote servers using a non-standard port. Specify
the ports on which the proxy will allow connection. (This setting applies only when the web proxy
listening port is set.)

CAUTION:  Allowing connection on non-standard ports may pose a security risk.

Type a number and click the Add button ( ) to add a trusted port. Click the Cancel button ( )

to delete a trusted port, or the Edit button ( ) to modify a trusted port.

Apply
Click to Apply changes.

Surfing Quotas
The Surfing Quota Policy page displays the list of all the default as well as custom surfing quota policies.

Surfing quota policy defines the duration of Internet surfing time. Surfing time duration is the allowed time in hours
for a Group or an Individual User to access Internet.

Surfing Quota Policy:

• Allows allocating Internet access time on a cyclic or non-cyclic basis.
• Single policy can be applied to number of Groups or Users.

Device is shipped with the following predefined policies: Unlimited Internet Access, 1 Month Unlimited Access, 1
month 100 hours, Monthly 100 hours Cyclic, Daily 1 hour Cyclic, Weekly 7 hours Cyclic. These predefined policies
are immediately available for use until configured otherwise. You can also define custom policies to define different
levels of access for different users to meet your organization’s requirements.

The page also provides option to add, update, or delete surfing quota policies.

Note:  Among all the policies applied, device takes into account the policy that first reaches its threshold
limit.

Create a New Surfing Quota Policy
Use the Add Surfing Quota page to configure a new surfing quota policy.

The Add Surfing Quota page allows you to manually enter details to configure surfing quota policy.

1. Go to Device Configuration > System > Profiles > Surfing Quotas and click Add.
2. Enter the details.

Name
Specify name to identify the Policy. Duplicate names are not allowed.

Cycle Type
Select Cycle type.

Available Options:Cyclic - Once the cycle ends, user is automatically registered for new cycle.
Non-Cyclic - Once the specified time limit ends, user will be disconnected.

Cycle Hours
Specify Cycle Hours. Cycle hours define the upper limit of surfing hours for cyclic types of policies
i.e. Daily, Weekly, Monthly and Yearly.

At the end of each Cycle, cycle hours are reset to zero i.e. for "Weekly" Cycle type, cycle hours will
reset to zero every week even if cycle hours are unused.

Validity
Specify Validity in number of days. Validity defines the upper limit of total surfing days allowed i.e.
restricts total surfing days to valid allotted days.

OR
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Click Unlimited Days, if you do not want to restrict the total surfing days.

Maximum Hours
Specify Maximum Hours. Maximum hours define the upper limit of total surfing hours allowed i.e.
restricts total surfing hours to maximum hours.

OR

Click Unlimited Hours, if you do not want to restrict the total surfing hours.

Description
Provide description for Surfing Quota Policy.

Figure 108: Add Surfing Quota Policy
3. Click Save to add the surfing quota policy with the options you have configured.

Malware Protection

Sophos XG Firewall offers Dual Anti Virus Scanning, wherein traffic is scanned by Two (2) Anti Virus Engines.
Traffic is first scanned by the Primary Engine, and then the Secondary Engine.

Note:  Dual Anti Virus is not available in Device Models SF 100 and SF 200. For them, ONLY Single Anti
Virus CYREN is available.

Note:  You can also view and manage the Anti Virus status on the Device Configuration > Monitor and
Analyze > Diagnostics > Services

General Settings
Primary Anti Virus Engine

Select the Primary Anti-Virus Engine to be used for traffic scanning. For Dual Scan, packets are
first scanned by the Primary Engine and then by the Secondary Engine. For Single Scan, only the
Primary Engine is used.

Available Options

Sophos EngineAvira Engine

Proxy
Device Configuration > Protect > Web > Proxy

The device can also act as a Web Proxy Server. To use your device as a Web Proxy Server, configure the device’s
LAN IP Address as a proxy server IP Address in the browser setting and enable access to Web Proxy services from
Device Access section.
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Note:  You can also view and manage the Web Proxy status on the Device Configuration > Monitor and
Analyze > Diagnostics > Services page.

Below are the screen elements with their description:

Web Proxy Port(Applicable only when the device is configured as Web Proxy)
Specify Port number, which is to be used for Web Proxy.

Default - 3128

Trusted Ports
Device allows the access to those sites which are hosted on standard port, only if deployed as
Web Proxy. To allow access to the sites hosted on the non-standard ports, you have to define non-
standard ports as trusted ports.

Click  icon to add the HTTP trusted ports, Cancel icon  to delete the trusted ports and

Click  icon to modify the trusted ports.

Click Apply to configure Web Proxy settings.

Note:

• Web Proxy enforces Web and Application Filter policy and Malware Scanning Policy as configured in
Security Policies.

• IPS policy is applicable on the traffic between proxy and WAN, but not between user and proxy.
• Traffic Shaping policy is not applicable on the direct proxy traffic.

Content Filter
Device Configuration > Protect > Web > Content Filter

Web Content Filter menu allows to configure and manage web filtering through the device. It also allows to configure
general restrictions for scanning and restricting all the HTTP/HTTPS/FTP traffic. By default, device will not
scan HTTP traffic. You can also define the rule to bypass HTTP scanning of the traffic from specific source and
destination. If virus scanning is enabled and virus is detected, receiver will receive a notifying message. Similarly, you
can define rule to bypass HTTPS scanning based on the web categories.

General Configuration

Use this section to enable the Safe Search feature, caching and Pharming protection useful in filtering Web traffic.
You can also configure Custom Denied Message.

Safe Search - This feature allows you to enforce safe searching into your search engines, thus helping you against
malicious sites.

Pharming Protection - This feature allows you to stop Pharming by various attacker sites by Domain Name
resolution.

Below are the screen elements with their description:

Scanning
Select the type of scanning to be applied.

Available Options:

• Single Anti-Virus (Maximum Performance): Traffic will be scanned using the Primary Anti-
Virus engine.

• Dual Anti-Virus (Maximum Security): Traffic will be scanned using both Anti-Virus Engines,
first by Primary and then by the Secondary Engine. This can increase virus detection, but will
impact performance.

It is recommended to use Single Anti-Virus engine for scanning for the best balance of Security
and Performance.
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Content That Could Not Be Scanned
Specify an action to take when the firewall encounters content that could not be scanned.

Note:  Files that cannot be fully scanned because they are encrypted or corrupted may
contain undetected threats. Blocking offers the best protection.

Enforce Safe Search

Enable safe search so that web sites containing pornography and explicit sexual content are blocked
from the Google, Yahoo, Altavista and Bing search results.

This will be applicable only when access to Porn, Adult Content and Nudity categories are denied in
the Web Filter Policy.

Enable Additional Image Filters
Restrict image search results to images with a Creative Commons license.

Enable Pharming Protection

Enable to protect against pharming attacks and direct users to the legitimate websites instead of
fraudulent websites.

Pharming attacks require no additional action from the user from their regular web surfing activities.
Pharming attack succeeds by redirecting the users from legitimate websites instead of similar
fraudulent websites that has been created to look like the legitimate site.

Caching

Enable Caching When enabled the Web Filter keeps a copy of
frequently visited sites to improve performance
and reduce bandwidth usage

Force caching for Endpoint updates Use this option to enable caching of update data
for Sophos Endpoints.

Note:  If this option is disabled you
may experience network congestion
when many endpoints attempt to
download updates from the Internet at
the same time.

Denied Message

Specify default deny message to be displayed for all the web categories.

Enable Override Default Denied Message to display a customized message for all the web
categories.

Denied Message Image

Specify whether the default or custom image should be displayed on the Denied message page.

Warned Message

Specify default warn message to be displayed for all the web categories.

Enable Override Default Warned Message to display a customized message for all the web
categories.

Top Image

Specify the image which is to be displayed at the top of the message page.

Dimension of Image should be 125 x 70 pixels and jpg file only.

Bottom Image
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Specify the image which is to be displayed at the bottom of the message page.

Dimension of Image should be 700 * 80 pixels and jpg file only.

Preview

Click to view the settings before saving the changes.

HTTP/HTTPS Configurations

The administrator can configure for real time or batch mode scanning of HTTP traffic.

You can configure the maximum file size that can be buffered to the memory for scanning. This will also prevent the
unintentional download of virus file hidden in the fragmented files.

Depending on the scanning policy set at the time of deployment through Network configuration Wizard, device will
scan HTTP and HTTPS traffic. Enable or disable HTTP and HTTPS scanning from security policy.

Use this section to configure general restrictions for scanning and restricting all the HTTP/HTTPS traffic.

Scan Mode
Specify scanning mode to configure for real time or batch mode scanning for HTTP/HTTPS traffic.

In batch mode, virus scanning will start only after the complete file is downloaded. As complete file
is to be downloaded before scanning can start, if the size of the file is large it will take some time.

To avoid the delay, configure scan in real mode if you have to download bulky files.

File Size Threshold
Specify file size threshold (in KB). Files that exceed configured threshold will not be scanned.

Acceptable Range - 1 to25600 KB

Default - 1024 KB

Audio & Video File Scanning
Enable Audio & Video File Scanning for scanning of video and audio streams being downloaded.

Default - Disable

HTTPS Scanning CA
Select the CA for HTTPS Scanning from the available options:

Available Options:

• SecurityAppliance_SSL_CA
• SecurityApplianceSelf Signed CA
• List of custom CAs if added

Default - SecurityAppliance_SSL_CA

Deny Unknown Protocol
Enable to deny traffic that does not follow HTTPS protocol.

Allow Invalid Certificate
If you enable HTTPS scanning, you need to import appliance SSL Proxy certificate in Internet
Explorer, Firefox Mozilla or any other browsers for decryption on SSL Inspection otherwise
browser will always give a warning page when you try to access any secure site. “Invalid Certificate
error” warning appears when the site is using an invalid SSL certificate. Device blocks all such
sites.

Enable if you want to allow access to such sites.
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FTP Configurations

The administrator can define policies to take the appropriate action based on the protocols. Separate policy can be
defined on how to handle SMTP, POP3, FTP and HTTP traffic if infection is detected.

When Device detects a virus, file transfer is stopped and Email message is delivered without the attachment.

Files Greater Than Size
Configure the maximum file size (in KB) for scanning. The files greater than the specified size will
not be scanned.

Acceptable Range - 1 to 20480KB

Default – 1024 KB

HTTP Scanning Rules

Apart from mails, virus can infect your network through HTTP downloads also. Define HTTP scanning rules to
protect against this. The HTTP Scanning Rules section displays list of all the scanning rules. It also provides option to
add a new rule, update the parameters of the existing rules, or delete a rule.

HTTPS Scanning Exceptions

The device allows to bypass the HTTPS scanning for specified web categories. Administrator needs to create an
exception rule and include all the web categories which are to be bypassed from HTTPS scanning.

The section displays list of all the configured exception rules. It also provides option to add a new exception rule,
update the parameters of the existing rule, and delete the rule.

Add HTTP Rule

You can add HTTP Scanning Rule from this page.

1. Go to Device Configuration > Protect > Web > Content Filter and click Add under HTTP Scanning Rules
section.

2. Enter HTTP Rule details.
Name

Provide a name for the HTTP Rule.

Source IP Address
Specify Source IP Address.

Destination IP Address
Specify destination IP Address.

Scanning Rule will be applied on the mails received from the sender using specified source IP
Address and send to the recipient with the specified destination IP Address.

URL Regex.
Provide URL. You can use regular expression for matching the pattern in URL.

Action
Select whether you want to scan or bypass traffic for the specified source/destination IP Address and
URL.
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Figure 109: Add HTTP Rule
3. Click Save to add HTTP Scanning Rule.

Add HTTPS Scanning Exception

You can add HTTPS Scanning Exception from this page.

1. Go to Device Configuration > Protect > Web > Content Filter and click Add under HTTPS Scanning
Exceptions section.

2. Enter HTTPS Scanning Exception details.
Name

Enter name for the bypass rule.

Bypass
Select the web category to be bypassed for HTTPS scanning.

You can directly add a new web category from this page or from Protect > Web > Custom Web
Category

Figure 110: Add HTTPS Scanning Exception
3. Click Save to add HTTPS Scanning Exception.

Web Filter Policies
The Web Filter Policies page allows you to Add, Delete, or Edit web filter policies.

Use this page to create and maintain a set of Web Filter policies. Each policy can filter based on a Web Category,
File Type, URL Group, or Dynamic Category. Default policies are included, and you can create and maintain your
own.

On this page you can view the list of Web Filter polices. Details of each are listed under the related table heading:

• Name: The name of your existing Web Filter Policies. To edit an existing policy, click the Name, or select the
check box and click the wrench icon under Manage.

• Filter icon: Select this icon to filter results. You can limit the policies that are displayed to a keyword search.
• Default Action: Shows the default action configured for the policy.
• Reporting: Displays if reporting is Enabled or Disabled for the policy.
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• Description: Provides a short description for the policy.
• Manage: Includes a edit or delete policies.

Add Web Filter Policy
Create a new Web Filter Policy.

On the Add Web Filter Policy page you can create a new Web Filter Policy to include on the Device Configuration
> Protect > Web > Web Filter Policies page.

1. Enter a Name for the policy.
2. Enter a brief Description for the policy you want to create.
3. Under Clone Web Categories select an existing web category from the dropdown list.

This will populate categories from the existing web category to help create a similar policy.
4. Select the Enable Reporting check box to include this policy in generated reports.
5. Set Download File Size Restriction to the maximum file size that can be downloaded for this policy. Leave this

set at zero for no restriction.
6. Under YouTube Education Filter enter your school ID for YouTube for Schools.

Note:

If specified, then only controlled YouTube content is accessible to students and teachers within school
premises.

7. Under Google Apps domain(s) specify the domains for which you want to allow Google Apps.

Figure 111: Add Web Filter Policy
8. Click Add to configure categories associated with this Web Filter Policy.
9. Click Save.

Related information
YouTube for Schools.

Add Web Filter Policy Category
Create a new Web Filter Policy Category.

On the Add Web Filter Policy Category page you can create a new Web Filter Policy Category to include on the
Device Configuration > Protect > Web > Web Filter Policies > Add > Add Web Filter Policy Category page.

1. Select a Category Type from the drop down list.
2. Select Category from the list or click Add New Item to create a new Category.
3. Select Allow, Deny or Warn (not available for Dynamic Category) for both HTTP Action and HTTPS Action.

https://www.youtube.com/schools
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4. Enable Exception (not available for File Type and Dynamic Category) and configure File Type Category to be
excluded from the policy.

5. Select Schedule for the category. Schedule defines the time period during which Web Filter Policy Category is
applied on the network.

Figure 112: Add Web Filter Policy Category
6. Click Add.

User Notifications
The firewall displays notifications to users when a web policy is set to block access or warn before connecting. Use
these settings to create and preview notifications for multiple firewall devices.

To specify an image to display on notification pages, enable the Use custom images check box and choose images.

To create a block notification, enable the Use custom block message check box and type a message.

To create a warning notification, enable the Use custom warn message check box and type a message.

You can preview current messages by clicking the preview links.

Applications
Application Protection provides facilities to control and manage the applications shipped with the device.

The following pages are accessible:

• Application List on page 106: displays all applications available for use.
• Application Filter  on page 100: enables you to control access to the applications.
• Traffic Shaping Default on page 106: you can configure default Traffic Shaping settings.

Application Filter
The Application Filter  page displays list of all the predefined and custom policies.

An Application Filter Policy controls user’s application access. It specifies which user has access to which
applications and allows defining powerful security policies based on a number of parameters like:

• Individual users
• Groups of users
• Time of day
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The device is shipped with the following predefined application filter policies:

• Allow All: By default, allows access to all the categories except the specified categories. Access to the specified
categories depends on the strategy defined for each category.

• Deny All: By default, denies access to all the categories except the specified categories. Access to the specified
categories depends on the strategy defined for each category.

• Block generally unwanted apps: Drops generally unwanted application traffic. This includes applications such
as file transfer, proxy & tunnel, risk prone, peer to peer networking (P2P) and applications that cause loss of
productivity.

• Block filter avoidance apps: Drops traffic from applications that tunnel other applications, proxy and tunnel
applications, and from applications that can bypass firewall policy. These applications allow users to anonymously
browse the Internet by connecting to servers on the Internet via encrypted SSL tunnels. This, in turn, enables users
to bypass network security measures.

• Block peer to peer (P2P) networking apps: Drops traffic from applications that are categorized as P2P
applications. P2P could be a mechanism for distributing Bots, Spywares, Adware, Trojans, Rootkits, Worms and
other types of malwares. It is generally advised to have P2P applications blocked in your network.

• Block very high risk (Risk Level 5) apps: Drops traffic from applications that are classified under 'very high risk'
applications (Risk Level - 5).

• Block high risk (Risk Level 4 and 5) apps: Drops traffic from applications that are classified under 'high risk'
applications (Risk Level - 4 and 5).

These predefined policies are immediately available for use until configured otherwise. You can also define custom
policies to define different levels of access for different users to meet your organization’s requirements.

The page also provides option to add a new policy, update parameters of the exisiting policy, delete a policy, add a
filtering rule to a policy or delete a filtering rule attached to a policy.

Application Filter Policy
This page lets you configure custom policies to define different levels of access for different users to meet your
organizations's requirements.

The Add  page allows you to manually configure policies.

1. Go to Device Configuration > Protect > Applications > Application Filter and click Add.
2. Enter the Application Filter Policy details.

Name
Enter a name to identify the Application Filter Policy.

Description
Enter description for the Application Filter Policy.

Enable Micro App Discovery
Enable to scan and classify microapps using HTTP protocol for communication. Microapps are
applications that are used withing web browsers.

To allow/deny microapps, you need to specify action accordingly.

Refer Appendix D - Supported Micro-Apps for more details on supported applications.

Template
Select template for the Application Filter Policy.
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Figure 113: Add Application Filter Policy
3. Click Save.
4. Once the policy is added, next step is to add a rule for configuring filtering criteria.

Note:

• Rules can be added for custom policies only.
• If Micro App Discovery is enabled, one has to import SSL CA to avoid Certificate error.

Add Application Filter Policy Rule
Use the Add Application Filter Policy Rules page to configure a new rule for Application Filter Policy.

The Add Application Filter Policy Rules page allows you to manually configure a new rule.

1.
Go to Device Configuration > Protect > Applications > Application Filter and click .

2. Click on the Add button under Application Group Policy.
3. Enter the application filter details.

Category
Select Application Category from the list of available categories.

Risk
Select the level of risk from the available options.

• Select All
• 1-VERY LOW
• 2-LOW
• 3-MEDIUM
• 4-HIGH
• 5-VERY HIGH

Characteristics
Select the characteristics from the available options.

• Select All
• Excessive Bandwidth
• Prone to misuse
• Transfer files
• Tunnels other apps
• Vulnerabilities
• Widely used
• Loss of productivity
• Can bypass firewall policy
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Technology
Select the technology from the available options.

• Select All
• Browser Based
• Client Server
• Network Protocol
• P2P

Smart Filter (available only if Select All is selected)
Enter the partial or full name of the application to be filtered.

Figure 114: Application Filter Criteria
4. Enter the list of matching applications.

Select All
Click to select all the Applications from the list.

Applications are available based on the Application Filter Criteria.

Select Individual Application
Click to select individual applications from the list.

Applications are available based on the Application Filter Criteria.

Search
Specify the name of the application in the textbox to be searched.

This option is available, only if option Select Individual Application is selected.

Name
Displays name of the Applications under the Category selected. You can also select more than one
application using the checkbox.

Description
Displays description of the Application.

Category
Displays category of the Application.

Risk
Displays the risk factor involved with the Application.

Characteristics
Displays the characteristics of the Application.

Technology
Displays the technology utilized for the Application.
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Figure 115: List of Matching Applications
5. Enter the action you want to perform.

Action
Select an Action for the Policy from the available options. Allow Deny

Schedule
Select schedule from the list available in the dropdown list.

Figure 116: Add Application Filter Policy Rules
6. Click Save.

Synchronized Application Control
With Synchronized Application Control, you can manage applications which are discovered on Sophos managed
devices.

Application handling

Known applications appear under the correct application category. Unknown applications appear under the category
Uncategorized or General Internet. You can rename and categorize those applications. Apps can be assigned to
application filters to control them.

Synchronized Application Control supports up to 10,000 apps.

Device Group

You can filter the devices according to a particular Device Group.

All: Displays all the Device Groups available.

Devices

You can filter according to a particular Device, based on the Device Group selected.

All: Displays all the devices available.

Note:  The Device list is populated when a Device Group is selected.
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Cloud Applications
By analyzing cloud application traffic, you can mitigate the risks posed by cloud application usage. You can view
cloud application traffic from connected XG Firewall devices, classify traffic, and apply a traffic shaping policy.
Connected devices are those that are active at the time of request.

To view all cloud application traffic, click Get data usage. The current day's cloud application data from connected
devices is displayed.

Figure 117: List of cloud applications with traffic details

Use the filters to refine the search results by classification and category. For example, you can filter traffic to display
only unsanctioned social networking traffic for a specified period. You can sort the order of the search result by bytes
transferred or users.

Note:  The results include only allowed traffic and only applications that have traffic. Check your blocked
application settings.

Note:  Upload and download count and file type information can be displayed only for traffic where HTTPS
decryption is enabled. Some apps use non-standard methods for sending or receiving file downloads, which
can lead to these data points being empty or appearing inaccurate.

To view traffic details of an application, click . Users, upload data, and download data per connected XG Firewall
device are displayed.

Figure 118: Application-level traffic details

To view traffic by user, click View Device for an XG Firewall. Users, their host IP address, upload data and download
data are displayed.

Figure 119: Device-level traffic details

By default, all application traffic is classified as new. To apply a different classification, click Classify, select a
classification, and click Apply.

Note:  The new classification will be applied only to new traffic for the application.
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To control bandwidth usage by cloud applications, you can apply a traffic shaping policy. For example, you may want
to restrict streaming video traffic.

To control bandwidth usage, click Traffic Shaping, select a policy, and click Save.

Note:  In application-level traffic, to apply the selected classification and traffic shaping policy to an XG
Firewall, click Synchronize.

Application List
The Application List page displays all the applications available for use.

The device can identify and control applications which use standard port 80, 443, non-standard ports, port hopping
or tunnel through encrypted SSL traffic. The feature enables prioritization of applications based on user identity,
time, applications, and bandwidth, allowing great flexibility, visibility, and control. The device also provides
implementation of application-based bandwidth management, accelerating critical applications while blocking
malware-laden sites through Web Filtering. Organizations can group applications as per their requirements into
business-critical, entertainment, communication, collaboration and control access through Security policies.

Note:  Web Protection is a subscription module that needs to be subscribed before use. Check the features
of the module by subscribing free trial subscription of the module. (See System Management > System
Settings >  Maintenance >  Licensing(Only at appliance level))

The device is shipped with a set of predefined applications. This applications are classified based on their risk level,
characteristics and technology, offering more granular controls.

The total number of application signatures included depends on the Application Signatures Database used by the
device. Device Information doclet in the Dashboard provides the version of Application Signatures Database used by
your device.

The application list can be filtered based on name of the application, category of the application, risk, characteristics,
and technology.

Traffic Shaping Default

Use Traffic Shaping Settings page to configure default Traffic Shaping settings. All the bandwidth related data are
displayed only with unit KBps (Kilo bytes per second).

Below are the screen elements with their description:
Total Available WAN Bandwidth

Specify maximum bandwidth limit in KB. It is generally a sum of all WAN links maximum limits.

Default - 100000 KB

Acceptable Range (KB) - 1 to 2560000

Optimize for Real-Time (VoIP)
Enable to give priority to real time traffic like VOIP over all other traffic.

If disabled, priority will be applicable only for excess bandwidth i.e. bandwidth remaining after
guaranteed bandwidth allocation.

Enforce Guaranteed Bandwidth
Administrator can enforce all internet bound traffic to be handled by any Traffic Shaping Policy
applied on it. If there is no policy applied on the traffic then it will be handled by the Default Policy.

Enable to enforce bandwidth restriction on the traffic on which the Traffic Shaping Policy is not
applied.

Disable, if you do not want to enforce bandwidth restriction on the traffic on which the Traffic
Shaping Policy is not applied. It will only handle traffic on which Traffic Shaping Policy is applied.

Default Policy
Default Policy will be applicable on the traffic which does not have any Traffic Shaping Policy
applied.
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Guarantee Specify bandwidth which is the minimum
guaranteed bandwidth that the user can use.

Default – 1 KBps

Acceptable Range (KBps) - 1 to 2560000

Limit Specify bandwidth which is the maximum
bandwidth that the user can use, if available.

Default – 100000 KBps

Acceptable Range (KBps) - 1 to 2560000

Priority Set the bandwidth priority. Priority can be set
from 1 (highest) to 7 (lowest) depending on the
traffic required to be shaped.

Available Options:

1 – Business Critical2 to 5 – Normal6 – Bulky -
FTP7 – Best Effort – e.g. P2P

Show Bandwidth Usage
Click to view Bandwidth Usage.

Wireless
Wireless Protection allows configuration for the following:

This section covers the following topics:

• Wireless Networks: Create and manage Wireless Networks.
• Mesh Networks: Create and manage Mesh Networks.
• Access Points: Provides an overview of the access points known to the device.
• Access Point Groups: This page allows you to organize access points in groups.
• Hotspots: Add/Remove Hotspot and apply filtering policies.
• Hotspot Voucher Definition: Manage different voucher definitions for Hotspot access vouchers.

Wireless Networks
The page provides a list of all configured wireless networks along with their name, SSID, client traffic mode,
encryption mode used and frequency band. New wireless networks can be added and existing ones deleted.

Device Configuration > Protect > Wireless > Wireless Networks

Note:  You can also view the wireless network status on the System > Current Activity > Wireless Client
List page.

The page displays all existing wireless networks. You can add new wireless networks, update or delete them.
Following is a description of the table elements:

Name

Displays the name of the wireless network.

SSID

Displays the SSID of the wireless network.

Status

Displays the Status of the wireless network.

Client traffic

Displays the client traffic of the wireless network.
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Encryption Mode

Displays the encryption mode of the wireless network.

Frequency Band

Displays the frequency band of the wireless network.

Manage

Displays the available managing options for the wireless network:

• Edit: Allows you to edit the wireless network.
• Delete: Allows you to delete the wireless network.

To either add or delete a wireless network, click on the corresponding buttons.

Related tasks
Add a New Wireless Network on page 108
This page describes how to create a new wireless network.

Next Steps for Separate Zone Networks on page 112

Bridge to AP LAN Networks with Local Devices on page 112

Add a New Wireless Network
This page describes how to create a new wireless network.

The Add button on the Wireless Networks page allows to define a new wireless network. This can then be used in
definitions for access points and access point groups.

1. Go to Device Configuration > Protect > Wireless > Wireless Networks and click the Add button.
A new page General Settings opens.

2. Make the following settings:
Name

Enter a descriptive name for the network.

Description
Enter a description for the wireless network that helps you to identify it.

SSID
Enter the Service Set Identifier (SSID) for the network which will be seen by clients to identify the
wireless network. The SSID may consist of 1-32 ASCII printable characters. It must not contain a
comma and must not begin or end with a space.

Security Mode
Select a security mode from the drop-down list. Default is WPA 2 Personal.

We recommend to prefer WPA2 over WPA, if possible. For security reasons, we recommend to not
use WEP unless there are clients using your wireless network that do not support one of the other
methods.

When using an enterprise authentication method, you also need to configure a RADIUS server on
the System > Authentication > Authentication Server or Objects > Assets > Authentication
Server page. As NAS ID of the RADIUS server enter the wireless network name.

Note:  Sophos Firewall OS supports the IEEE 802.11r standard in WPA2 (PSK/
Enterprise) networks to reduce roaming times. Clients also need to support the IEEE
802.11r standard.

Passphrase/PSK
Only available with WPA Personal, WPA2Personal and WPA2/WPA Personal security mode.

Enter the passphrase to protect the wireless network from unauthorized access and repeat it in the
next field. The passphrase may consist of 8-63 ASCII printable characters.

http://en.wikipedia.org/wiki/ASCII#ASCII_printable_characters
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Key
Only available with WEP Open security mode.

Enter a WEP key here that consists of exactly 26 hexadecimal characters.

Client Traffic
Select a method how the wireless network is to be integrated into your local network.

Separate Zone
Default.

The wireless network is handled as a separate network, having an IP address range of its own.
Using this option, after adding the wireless network, proceed as described in chapter Next Steps for
Seperate Zone Networks.

Note:  When switching an existing Separate Zone network to Bridge to AP LAN or
Bridge to VLAN, an already configured WLAN interface will be deleted.

Zone
Select a zone where the wireless network should be broadcasted.

Default: WiFi

IP Address
Assign an IP address to the wireless network.

Netmask
Select a subnet mask for the IP address.

Bridge to AP LAN
You can bridge a wireless network into the network of an access point, that means that wireless
clients share the same IP address range. Using this option, after adding the wirless network, proceed
as described in chapter Next Steps for Bridge to AP LAN Networks.

Bridge to VLAN
Not available for Local WiFi Devices.

You can decide to have this wireless network's traffic bridged to a VLAN of your choice. This is
useful when you want access points to be in a common network separate from the wireless clients.

Bridge to VLAN ID
Enter the VLAN ID of the network that the wireless clients should be part of.

Client VLAN ID
Only available with an enterprise security mode.

Select how the VLAN ID is defined.

• Static: Uses the VLAN ID defined in the Bridge to VLAN ID field.
• RADIUS & Static: Uses the VLAN ID delivered by your RADIUS server: When a user

connects to one of your wireless networks and authenticates at your RADIUS server, the
RADIUS server tells the access point what VLAN ID to use for that user. Thus, when using
multiple wireless networks, you can define per user who has access to which internal networks.
If a user does not have a VLAN ID attribute assigned, the VLAN ID defined in the Bridge to
VLAN ID is used.

3. Optionally, you can make the following Advanced Settings:
Encryption

Only available with WPA, WPA2 or WPA2/WPA encryption modes): Select an encryption
algorithm which can be either AES, TKIP or TKIP&AES. For security reasons, it is recommended
to use AES.

Frequency Band
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Access points assigned to this wireless network will transmit on the selected frequency band(s). The
5 GHz band generally has higher performance, lower latency, and is typically less disturbed. Hence
it should be preferred for e.g. VoIP communication. For an overview which APs support the 5 GHz
band, see chapter Protection > Wireless Protection > Access Points or Objects > Assets > Access
Points.

Time-based Access
Select this option if you want to automatically enable and disable the wireless network according to
a time schedule.

Select Active-Time
Select a schedule definition which determines when the wireless network is enabled. You can add a
new schedule definition by clicking the Add button.

Client Isolation
Clients within a network usually can communicate with one another. If you want to prevent this, for
example in a guest network, select Enabled from the drop-down list.

Hide SSID
If you want to hide the wireless network's SSID, select Yes from the drop-down list. Please note that
this is no security feature.

Fast Transition
Only available with WPA2 Personal/Enterprise security mode.

Wireless networks with WPA2 security use the IEEE 802.11r standard. If you want to prevent this,
select Disabled from the drop-down list.

MAC Filtering
To restrict the MAC addresses allowed to connect to this wireless network, select Blacklist or
Whitelist. With Blacklist, all MAC addresses are allowed except those listed on the MAC List.
With Whitelist, all MAC addresses are prohibited except those listed on the MAC List.

MAC Hosts added under Objects > Host and Services > MAC Host will be displayed in the MAC
List.

Figure 120: Add Wireless Network
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4. Click Save to save your settings and add the wireless network.

Related tasks
Bridge to AP LAN Networks with Local Devices on page 112

Next Steps for Separate Zone Networks on page 112
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Next Steps for Separate Zone Networks

When you created a wireless network with the option Separate Zone, a new corresponding virtual hardware interface
will be created automatically, e.g., wlnet1. To be able to use the wireless network, some further manual configuration
steps are required. Proceed as follows:

1. Enable DHCP for the wireless clients on the respective Sophos XG Firewall device.
For your clients to be able to connect to Sophos Firewall OS, they need to be assigned an IP address and a default
gateway on the respective Sophos XG Firewall device. Therefore, on the Configure > Network > DHCP page,
set up a DHCP server for the interface.

2. Create a Network Policy on the Policies page to provide Internet access to the wireless clients.

Bridge to AP LAN Networks with Local Devices

For Local WiFi Devices you need to make some extra setting on the Sophos XG Firewall device to make bridging to
AP LAN work.

1. Edit the Local WiFi Device on the Protect > Wireless >  Access Points page and select the wireless network.
2. Create a new bridge interface on the Configure > Network > Interfaces page to use the wireless interface in

Bridge mode or Edit the interface and select zone and provide IP Address to use the interface in Gateway mode.
3. If you want to use the interface in Gateway mode then create a DHCP server on the Configure > Network >

DHCP page so that the client can receive an IP.

Mesh Networks
On this page you can create or delete mesh networks. Additionally, you see an overview of existing mesh networks.

On the Device Configuration > Protect > Wireless > Mesh Networks page you can define mesh networks and
associate access points that should broadcast them. In a mesh network, multiple access points communicate with each
other and broadcast a common wireless network. On the one hand, access points connected via a mesh network can
broadcast the same wireless network to clients, thus working as a single access point, while covering a wider area.
On the other hand, a mesh network can be used to bridge Ethernet networks without laying cables. Access points
associated with a mesh network can play one of two roles: root access point or mesh access point. Both broadcast the
mesh network, thus the amount of other wireless networks they can broadcast is reduced by one.

Access points associated with a mesh network can play one of two roles: root access point or mesh access point. Both
broadcast the mesh network, thus the amount of other wireless networks they can broadcast is reduced by one.

• Root access point: It has a wired connection to the Sophos Firewall OS and provides a mesh network. An access
point can be root access point for multiple mesh networks.

• Mesh access point: It needs a mesh network to connect to the Sophos Firewall OS via a root access point. An
access point can be mesh access point for only one single mesh network at a time.

A mesh network can be used for two main use cases: you can implement a wireless bridge or a wireless repeater:

• Wireless bridge: Using two access points, you can establish a wireless connection between two Ethernet
segments. A wireless bridge is useful when you cannot lay a cable to connect those Ethernet segments. While
the first Ethernet segment with your Sophos Firewall OS is connected to the Ethernet interface of the root access
point, the second Ethernet segment has to be connected to the Ethernet interface of the mesh access point. Using
multiple mesh access points, you can connect more Ethernet segments.
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• Wireless repeater: Your Ethernet with your Sophos Firewall OS is connected to the Ethernet interface of a root
access point. The root access point has a wireless connection via the mesh network to a mesh access point, which
broadcasts wireless networks to wireless clients.

To create a mesh network, please refer to Add Mesh Network on page 113.

Following is a description of the table elements.

Mesh-ID

This is the identifier of the mesh network.

Frequency Band

The frequency band on which the associated access points broadcast the mesh network.

Manage

Displays the available managing options for the mesh networks:

• Edit Allows you to edit the mesh networks.
• Delete Allows you to delete the mesh networks.

To either add or delete a mesh network, click on the corresponding buttons.

Add Mesh Network
On this page you can create mesh networks and assign access points to them.
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The Add button on the Mesh Networks page allows to define a new mesh network.

1. Go to Device Configuration > Protect > Wireless > Mesh Networks and click the Add button.
A new page General Settings opens.

2. Make the following settings:
Mesh ID

Enter a unique ID for the mesh network.

Frequency Band
Access points assigned to this network will transmit the mesh network on the selected frequency
band. Generally, it is a good idea to use a different frequency band for the mesh network than for the
broadcasted wireless networks.

Description
Optionally, add a description or other information.

Figure 121: Add Mesh Network
3. Click Save to save your settings and add the mesh network.

Access Point Groups
On the Device Configuration > Protect > Wireless > Access Point Groups page you can organize access points in
groups. The list provides an overview of all access point groups and Local WiFi Devices.

Following is a description of the table elements:

Name

Displays the name of the access point group.

Wireless Networks

Displays the wireless networks the access point group is assigned to.

Access Point

Displays all access points in this group.

Manage

Displays the available managing options for the access point groups:

• Edit Allows you to edit the access point groups.
• Delete Allows you to access point groups.

To either add or delete a access point group, click on the corresponding buttons.

Related tasks
Add an Access Point Group on page 114

Add an Access Point Group

This page describes how you can add an access point group.
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1. Go to Device Configuration > Protect > Wireless > Access Point Groups and click Add.
2. Make the following settings for the new access point group.

Name
Enter a descriptive name for the new access point group.

Wireless Networks
Search for wireless networks and select the wireless networks that should be broadcasted by the
access points of this group.

Note:  For an access point to broadcast a wireless network some conditions have to be
fulfilled. They are explained in chapter Device Configuration > Protect > Wireless >
Access Point Groups section Rules for Assigning Networks to APs.

VLAN Tagging
Select Enable if you want to activate VLAN tagging.

Note:  Make sure that the VLAN interface is assigned to the zone which is selected in
the Allowed Zone box on the System > System Services > Wireless page.

Access Point
Search for access points and select which you want to add to this group.

Note:  Local WiFi Devices cannot be grouped and do not appear in the Access Point
box. Local WiFi Devices appear in the Access Point Groups list.

Figure 122: Add Access Point Group
3. Click Save to save the access point group.

The new access point group will be displayed in the Access Point Groups table.

Hotspots
On this page you can enable the Hotspots feature and define users who are allowed to view and distribute hotspot
access information.

Device Configuration > Protect > Wireless > Hotspots

The Hotspot feature allows cafés, hotels, companies, etc. to provide time- and traffic-restricted Internet access to
guests. The feature is available within the wireless subscription, but also works with wired networks.

Note:  You can also view and manage the hotspot status on the Monitor and Analyze > Diagnostics >
Services page.

Hotspot Generation

In a first step, the administrator creates and enables a hotspot with a specific type of access. The following types are
available:
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• Terms of use acceptance: The guest is presented a terms of use, which you can define, and has to select a
checkbox to get access.

• Password of the day: The guest has to enter a password to get access. The password changes on a daily basis.
• Voucher: The guest gets a voucher and has to enter the voucher code to get access. The voucher can be limited in

the number of devices, in time, and traffic.

Distribution of Access Information to Guests

With the types Password of the day and Voucher, the access information has to be handed out to the guests.
Therefore you can define users who are allowed to manage and distribute access information. Those users receive and
distribute the access information via the Hotspot tab of the User Portal:

• Password of the day: The current password can be sent via email and the users find the password in the User
Portal. The users forward the password to the guests. They can generate or enter a new password. Hereby, the
former password automatically becomes invalid and active sessions will be terminated. Potential other users will
be informed of the new password, either by email or via the User Portal, depending on what is configured for
them.

• Voucher: In the User Portal, users have the possibility to create vouchers, each with a unique code. Different types
of vouchers can be available if specified by the administrator. The vouchers can be printed or exported and given
to the guests. A list of created vouchers gives an overview about their usage and helps to manage them.

Legal Information

In many countries, operating a public wireless LAN is subject to specific national laws, restricting access to websites
of legally questionable content (e.g., file sharing sites, extremist websites, etc.). To meet this requirement, you can
combine the hotspot with the web protection capabilities of the Sophos Firewall OS, which allow you to control
web access by blocking and allowing everything from an entire website category type to a single URL. The Sophos
Firewall OS gives you complete control over what is allowed to be accessed, by whom, and when. That way you
can put the hotspot under heavy restrictions, if national or corporate policies require you to do so. Using the current
feature of Sophos Firewall OS also gives you advanced logging and reporting capabilities. The reporting will show
who visited what site, when, and how many times, allowing you to identify inappropriate usage in case you want to
operate a hotspot without any access restrictions. In addition to that, legal regulations may require you to register your
hotspot at the national's regulatory body.

The page displays all existing hotspots. You can add new hotspot, update or delete them. Following is a description of
the table elements:

Name

Displays the name of the hotspot.

Hotspot Type

Displays the type of the hotspot.

Manage

Displays the available managing options for the hotspot:

• Edit: Allows you to edit the hotspot.
• Delete: Allows you to delete the hotspot.

To either add or delete a hotspot, click on the corresponding buttons.

Related concepts
Hotspot Voucher Definition on page 123
In this chapter you can manage different voucher definitions for voucher type Hotspots.

Hotspot on page 128

Related tasks
Add Hotspot on page 117
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Add Hotspot

This page describes how to add a hotspot.

Note:  A hotspot has to be assigned to an existing interface, typically a WLAN interface. All hosts using
this interface will automatically be restricted by the hotspot. Therefore, before you create a hotspot you
would typically create a wireless network with client traffic Separate Zone, then create an interface for the
respective WLAN interface hardware. For more information see Device Configuration > Protect > Wireless
> Wireless Networks .

1. Go to Device Configuration > Protect > Wireless > Hotspots and click Add.
2. Make the following settings:

Name
Enter a descriptive name for hotspot.

Description (optional)
Enter a description or other information.

Interfaces
Select or add the interfaces which are to be restricted by the hotspot. An interface can only be used
by one hotspot.

Note:  Hotspots will work only on LAN and DMZ member interfaces of the bridge.
You should not select an uplink interface here because traffic to the Internet will
completely be blocked afterwards. Additionally, we strongly advise against using
interfaces used by servers which provide essential services like authentication. You
may irreversibly lock yourself out of Sophos Firewall OS!

Users
Select or add users for administrative settings. Administrative users are allowed to create vouchers
or change the password of the day in the User Portal. By default nobody is allowed to make
administrative settings.

Application Filter Policy (optional)
Select or add an application filter policy for the hotspot.

Web Filter Policy (optional)
Select or add a web filter policy for the hotspot.

IPS Policies (optional)
Select or add IPS policies for the hotspot.

Traffic Shaping Policy (optional)
Select or add a traffic shaping policy for the hotspot.

Redirect to HTTPS (optional)
Enable to redirect users to HTTPS.

Hostname Type
Select the hostname type for the hotspot.

• None (IP Address)
• Custom hostname

Hostname
(if Custom hostname is selected)

Add a hostname for the redirect.

Hotspot Type
Select a hotspot type for the selected interfaces.
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• Terms of Use Acceptance Customers can access the Internet after accepting the terms of use.
Session Expires

Select the time span after which the access will expire. After that, with the hotspot type Terms of
Use Acceptance, the users have to accept the terms of use again to log in. With the hotspot type
Backend Authentication, the users have to authenticate again.

Terms of Use
Add the text to be displayed as terms of use. Simple HTML markup and hyperlinks are allowed.
• Password of the Day A new password will be created automatically once a day. This password

will be available in the User Portal on the Hotspots tab which is available to all users specified
for this hotspot. Additionally it will be sent to the specified email address(es).

Password Creation Time
The assigned time of the day at which the new password will be created. At this time the former
password will immediately get invalid and current sessions will be cut off.

Send Password by Email to (optional)
Add email addresses to which the password shall be sent.

Synchronize Password with PSK of Wireless Networks (optional)
Select this option to synchronize the new generated/saved password with wireless PSK.

Note:  With the new PSK all APs that are configured with a separate zone wireless
network that is also used as a hotspot interface will be reconfigured and restarted. This
means all connections will be dropped.

• Voucher With this hotspot type, in the User Portal tokens with different limitations and
properties can be generated, printed and given to customers. After entering the code, the
customers can then directly access the Internet.

Voucher Definitions
Add or select the voucher definitions you want to use for the hotspot. How to add a voucher
definition is explained on the Voucher Definitions page.

Devices per Voucher
Enter the number of devices which are allowed to log in with one voucher during its lifetime. It is
not recommended to use the unlimited entry.

Terms of Use
(not with hotspot type Terms of Use Acceptance:

Add the text to be displayed as terms of use. Simple HTML markup and hyperlinks are allowed.

Users Have to Accept Terms of Use
(not with hotspot type Terms of Use Acceptance):

Enable this option if you want the hotspot users to accept your terms of use before accessing the
Internet.

Redirect to URL After Login
Enable, so that users will be redirected automatically to a particular URL after entering password
or voucher data.URLs for example could be your hotel's website or a webpage stating your portal
system policies.

URL
Enter URL to which the user will be redirected to.
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Figure 123: Add Hotspot
3. Optionally, customize the hotspot.

Enable Customization
Enable to use a customized HTML file with your own images and stylesheets. Additionally, you can
customize the voucher layout.

Customization Type
Select the customization type.
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• Basic Uses the default login page template. If required, change logo, title, and text.
Logo

Upload a logo for the login page. Supported image file types are jpg, jpeg, png and gif. A maximum
image width of 300 px and height of 100 px is recommended (depending on the title length).

Scale Logo to Recommended Size
If selected, a logo exceeding the recommended width or height will be scaled down and displayed in
the recommended size. If not selected, the logo will be displayed in the original size.

Title
Add a title for the login page. Simple HTML markup and hyperlinks are allowed.

Custom Text
Add an additional text for the login page. You can for example enter the SSID of the wireless
network to be used. Simple HTML markup and hyperlinks are allowed.
• Full Select an individual login HTML page.

Login Page Template
Select the HTML template you want to use for your individual login page. Clicking Browse... opens
a window where you can select and upload the file. In this template, you can use variables that can
dynamically insert information for each hotspot. For example, you can add the company name and
administrator information, the terms of use and the login form. See detailed information in chapter
Login Page Template.

Images/Stylesheet
Add files that are referenced in your login page template, e.g., images, stylesheets, or JavaScript
files. Clicking Browse... opens a window where you can select and upload the files.

Voucher Template
(only with hotspot type Voucher): Clicking Browse...opens a dialog where you can select and
upload a PDF file with the voucher layout. By default, a default template is used. The voucher PDF
file has to be of PDF version PDF 1.5 or lower. It may have any page size and format—both size
and format will be adjusted during voucher creation in the User Portal, depending on page size and
number of vouchers per page specified there.

The PDF file may contain the following variables that will be replaced with the respective values
during voucher generation in the User Portal:

• Wireless network name (SSID): <?ssid0?> (and <?ssid1?>, <?ssid2?> and so on, if the
WLAN has more than one SSIDs)

• Wireless network password: <?psk0?> (and <?psk1?>, <?psk2?> and so on, if the WLAN
has more than one SSIDs)

• Voucher code: <?code?>
• Voucher validity time: <?validity?>
• Voucher data limit: <?datalimit?>
• Voucher time limit: <?timelimit?>
• Comment: <?comment?>
• QR code with the hotspot access data encoded: <?qrX?>. The upper left corner of the QR code

will be placed on the lower left corner of the variable.

Note:  When using variables, the PDF file must include the entire
character sets of the fonts used. When a variable is replaced by
its value, and one of the substitute characters is not available, it
will be displayed incorrectly. We recommend to add the string <?
abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789?
> (for English usage) to your PDF file, which will automatically be removed during
voucher generation.
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Figure 124: Hotspot Customization
4. Click Save to save your settings.

The hotspot is now available and appears in the hotspot list.

You can see if the hotspot is running on the Monitor and Analyze > Diagnostics > Services page. There you can
also stop or start the hotspot.

Related concepts
Hotspot on page 128

Services on page 8
Services page allows you to view and manage the status of configured Services.

Login Page Template on page 121

Login Page Template

This page gives an overview of possible variables of the hotspot login template.

The HTML template for the login page may contain various variables that can dynamically insert information for the
hotspot login page. When the UTM processes a template in order to display a login page, it replaces any template
variables with the relevant value. Valid variables are:

General variables

• <?company_text?>: Default company text
• <?company_logo?>: Default company logo (Sophos logo). The variable will be replaced by the path of the

logo file, usage e.g., <img src="<?company_logo?>">
• <?admin_contact?>: Administrator name or address as defined on Device Configuration > System >

Administration > Notification (Send Notifications to Email Address field)
• <?admin_message?>: Administrator information label (default: For administrative questions please contact:)
• <?error?>: Error message that arose while trying to log in.

Variables used for all hotspot types

• <?terms?>: Terms of use (as defined on Add Hotspot page)
• <?redirect_host?>: Redirect URL that is specified for the hotspot (as defined on the Add Hotspot page)
• <?location?>: URL the user requested
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• <?location_host?>: Hostname of the URL the user requested
• <?login_form?>: Login form suitable for the respective hotspot type: Password text box, Token text box,

Username and Password text boxes, or Accept checkbox, and Login button.

Note:  For creating customized login forms, see User Specific Login Form below.

• <?asset_path?> (only important for customization mode Full): Hotspot specific directory for storage of
images or stylesheets (example usage: <img src="<?asset_path?>/logo.png">)

Variables only used for voucher type hotspots

• <?maclimit?> Number of allowed devices per voucher of this hotspot (as defined on the Add Hotspot page)
• <?numdevices?>: Number of devices used for this voucher
• <?timeend?>: Validity period (as defined on the Add/Edit Voucher Definition page)
• <?time_total?>: Total time quota allowed (as defined on the Add/Edit Voucher Definition page)
• <?traffic_total?>: Total data volume allowed (as defined on the Add/Edit Voucher Definition page)

Templates can contain if variables that make up sections like the ones shown below. Each section has an opening
and a closing variable. The contents of an if section is only displayed on a specific condition.

If Section Meaning

<?if_loggedin?>
<?if_loggedin_end?
>

Section is displayed when the user has successfully logged in.

<?if_notloggedin?>
<?
if_notloggedin_end?
>

Section is displayed when the user has not yet logged in, e.g., because terms of use have
to be accepted or because an error occurred.

<?
if_authtype_password?
>
<?
if_authtype_password_end?
>

Section is displayed when hotspot type is Password of the Day.

<?
if_authtype_disclaimer?
>
<?
if_authtype_disclaimer_end?
>

Section is displayed when hotspot type is Terms of Use Acceptance.

<?
if_authtype_token?>
<?
if_authtype_token_end?
>

Section is displayed when hotspot type is Voucher.

<?if_location?>
<?if_location_end?>

Section is displayed when the user has been redirected.
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If Section Meaning

<?if_redirect_url?>
<?
if_redirect_url_end?
>

Section is displayed when the checkbox Redirect to URL After Login is enabled.

<?
if_not_redirect_url?
>
<?
if_not_redirect_url_end?
>

Section is displayed when the checkbox Redirect to URL After Login is disabled.

<?if_timelimit?>
<?if_timelimit_end?
>

Section is displayed when a validity period is set for a voucher.

<?if_trafficlimit?>
<?
if_trafficlimit_end?>

Section is displayed when a data volume is set for a voucher.

<?if_timequota?>
<?if_timequota_end?
>

Section is displayed when a time quota is set for a voucher.

<?if_maclimit?>
<?if_maclimit_end?
>

Section is displayed when a Devices per Voucher value is specified.

<?if_terms?>
<?if_terms_end?>

Section is displayed when Terms of Use are defined and enabled.

<?if_error?>
<?if_error_end?>

Section is displayed when an error occurred while trying to log in.

User-Specific Login Form

If you want to create your own login form instead of using the pre-defined <?login_form?> variable, consider the
following:

• Enclose the form in the following tags:

<form action="?action=login" method="POST"> ... </form>
• For a Terms of Use Acceptance hotspot, add a checkbox named "accept":

<input type="checkbox" name="accept">
• For Password of the Day or Voucher hotspots, add a text box named "token":

<input type="text" name="token">
• Add a means to submit the form, e.g., a Login button:

<input type="submit" name="login" value="Login">

Hotspot Voucher Definition
In this chapter you can manage different voucher definitions for voucher type Hotspots.
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Device Configuration > Protect > Wireless > Hotspot Voucher Definition

The page displays all existing voucher definitions. You can add new voucher definitions, update or delete them.
Following is a description of the table elements:

Name

Displays the name of the voucher definition.

Manage

Displays the available managing options for the voucher definition:

• Edit: Allows you to edit the voucher definition.
• Delete: Allows you to delete the voucher definition.

To either add or delete a voucher definition, click on the corresponding buttons.

Related tasks
Add Hotspot Voucher on page 124

Add Hotspot Voucher

This page describes how to add a voucher definition.

1. Go to Device Configuration > Protect > Wireless > Hotspot Voucher Definition .
2. Make the following settings:

Name
Enter a descriptive name for the voucher definition.

Description
Enter a description or other information.

Validity Period
Enter the time span for which a voucher with this definition will be valid. Counting starts at the first
login. It is highly recommended to enter a time period.

Note:  The maximum time for the Validity Period is two years.

Time Quota
Here you can restrict the allowed online time. Enter the maximum online time after which a voucher
of this definition expires. Counting starts at login and stops at logout. Additionally, counting stops
after 5 minutes of inactivity.

Note:  The maximum time for the Time Quota is two years.

Data Volume
Here you can restrict the allowed data volume. Enter the maximum data volume to be transmitted
with this voucher definition.

Note:  The maximum data volume is 100 GB.
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Figure 125: Hotspot Voucher Definition
3. Click Save to save your settings.

The voucher definition is now available and appears on the voucher list.

Rogue AP Scan

A Rogue Access Point (AP) is any Wi-Fi access point connected to your network without authorization. It can be a
setup used by an attacker for the purpose of sniffing wireless network traffic and can be used to conduct a man-in-the-
middle attack. It allows anyone with a Wi-Fi-equipped device to connect to your corporate network, leaving your IT
assets wide open for the casual snooper or criminal hacker.

Device can alleviate this by recognizing rogue access points potentially attempting to gain access to your network.

Click Schedule system-triggered scan to enable a schedule to scan and discover authorized APs and rogue APs.
You can select from the pre-defined schedules or create a custom schedule from Configure > System > Profiles >
Schedule.

Discover Access Points

To increase the security capabilities and identify the unauthorized APs, Sophos Wireless Devices provides scanning
capability by which nearby APs can be discovered and administrator can take countermeasures against the most
common types of illicit wireless activity.

To manually scan for the automatic discovery of APs, click “Scan Now”.

All the discovered Access Points detected are regarded as unrecognized until they are identified as authorized or

rogue for operation. To authorize an access point, click the icon  against the AP to be marked as authorized in the

Unrecognized AP table. To mark an access point as rogue, click the icon  against the AP to be marked as rogue in
the Unrecognized AP table.

If you are scanning for the first time after enabling Wireless LAN, all the discovered APs will be listed in
Unrecognized Access Points table. Scanning result is displayed in the form of 3 tables:

Unrecognized Access Points table

Table lists all the discovered nearby APs and displays following information:
Channel

The radio channel used by the access point.

BSSID
The MAC Address of the radio interface of the detected access point.

SSID
The radio SSID of the access point.
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Signal Strength
The strength of the detected radio signal

Security Mode
Mode for encrypting the wireless traffic

Wireless Mode
Wireless protocol

Action

Click the icon  to mark the AP as authorized AP and move in the Authorized AP table. Click the

icon  to mark the AP as Rogue AP and move to the Rogue AP table.

Rogue Access Points table

Table lists all the APs marked as “Rogue” and displays following information:
Channel

The radio channel used by the access point.

BSSID
The MAC Address of the radio interface of the detected access point.

SSID
The radio SSID of the access point.

Signal Strength
The strength of the detected radio signal

Security Mode
Mode for encrypting the wireless traffic

Wireless Mode
Wireless protocol

Action

Click the icon  to mark the AP as authorized AP and move in the Authorized AP table. Click the

icon  to mark the AP as unrecognized AP and move to the Unrecognized AP table.

Authorized Access Points table

Table lists all the APs marked as “Authorized” and displays following information:
Channel

The radio channel used by the access point.

BSSID
The MAC Address of the radio interface of the detected access point.

SSID
The radio SSID of the access point.

Signal Strength
The strength of the detected radio signal

Security Mode
Mode for encrypting the wireless traffic

Wireless Mode
Wireless protocol
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Action

Click the icon  to mark the AP as unrecognized AP and move to the Unrecognized AP table.

Click the icon  to mark the AP as Rogue AP and move to the Rogue AP table.

Wireless
The page allows general configuration of wireless networks.

Device Configuration > Protect > Wireless > Wireless

Following is a description of the different sections of this page:

Download AP Firmware (Displayed only if AP firmware is not available on the device)

Click to download AP firmware.

Note:  Wireless Protection can be used after AP firmware is successfully downloaded.

Global Settings

Enable Wireless Protection

Select the checkbox to enable Wireless Protection.

Allowed Zone

Select network zones that are to be allowed for access point connectivity. These are the zones where access points are
deployed to.

Note:  If the wireless network uses WPA/WPA2 Enterprise Authentication as encryption mode then a
RADIUS server needs to be specified.

Advanced Settings

Notification Timeout

If an access point goes offline you get a notification. The Notification Timeout lets you configure a timeout for the
notification. This means, if you set a delay of 2 minutes, the notification will be sent only if the access point is offline
for at least 2 minutes. After the specified time, the AP will be considered inactive.

Timeout (in minutes)

The notification timeout requires an integer. The default timeout is 0 minutes.

Enterprise Authentication

For enterprise authentication, you need to provide some information of your RADIUS server. Note that access points
do not communicate with the RADIUS server for authentication but only the Sophos Firewall OS . Port 414 is used
for the RADIUS communication between the Sophos Firewall OS and the access points.

RADIUS Server

Select the required RADIUS server from the drop-down list. Servers can be added and configured on Device
Configuration > Configure > Authentication > Authentication Server.

Note:  When your RADIUS server is connected to the Sophos Firewall OS via an IPsec tunnel, you have
to configure an additional SNAT rule to ensure that the communication works correctly. On the Device
Configuration > System > Profiles > NAT Policypage, add the following SNAT rule: For traffic from the
APs' network(s), using service RADIUS, and going to the RADIUS server, replace the source address with
the IP address of Sophos Firewall OS used to reach the RADIUS server.

Wireless Client List
The overview page displays a live snapshot of currently managed APs, broadcasted SSIDs (wireless networks),
wireless clients connected through SSID to AP and mesh networks.
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Device Configuration > Protect > Wireless > Wireless Client List

Following is a description of the table elements:

Show by SSID

The administrator can filter currently connected clients by Access Point or SSID.

Name

Displays the name of the wireless connection.

IP Address

Displays IP address leased for the wireless connection.

MAC Address

Displays the MAC address of the wireless client.

Signal

Displays the signal strength.

Last-TX Rate

Displays the data transfer rate of the wireless client.

Connection Time

Displays the connection time of the wireless client.

Frequency

Displays the frequency of the wireless network to which the AP is connected.

Vendor

Displays the vendor name of the client connected to the access point.

Related concepts
Wireless Networks on page 107
The page provides a list of all configured wireless networks along with their name, SSID, client traffic mode,
encryption mode used and frequency band. New wireless networks can be added and existing ones deleted.

Access Points

Hotspot

On this page you can make additional hotspot settings.

General Voucher Options

Here you can decide if and after which time interval you want to delete expired vouchers from the database. In the
hotspot log you will still find information about deleted vouchers.

Login Page Certificate

To ensure login over HTTPS you can select certificates for the page login. You can generate and upload new
certificates with on the Device Configuration > Protect > Web Server > Certificate page. Select the requested
certificate from the drop-down list and click Apply to activate it.

Walled Garden

Add or select specific hosts or networks to be always accessible by all users, without entering a password or a
voucher code. Hosts can be added on the Device Configuration > System > Hosts and Services > IP Hosts page,
networks can be added via the System > Network menu.
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Clear Walled Garden Configuration

Click Clear Walled Garden Configuration to clear the configuration settings.

Email

This feature requires a subscription. It can be configured but cannot be enforced without a valid Email
Protection subscription.

From Email Protection tab, Administrator can configure SMTP/S, POP/S and IMAP/S settings, Malware and Content
Scanning Policies, Secure PDF eXchange (SPX) and Data Protection (DP) Policies.

The device offers comprehensive Email Security, preventing sophisticated forms of zero-hour threats and blended
attacks involving spam, botnets, phishing, spyware and more. The basic email protection configuration includes
configuring email threshold size for scanning, specifying action to be taken if a virus is detected, blocking mails based
on sender or recipient, blocking mails with certain file types.

Email Policies and Exceptions
This page allows configuration of POP-IMAP Malware Scanning and Email Scanning Policy.

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

This page contains the following sections:

• POP-IMAP Malware Scanning
• Email Policies

POP-IMAP Malware Scanning

The device applies a single policy to all POP and IMAP/S traffic so that whenever a virus gets detected in an Email,
the virus-affected attachment is stripped from the Email and the Email body is replaced with a notification message.

Scanning
Specify the type of scanning to be applied.

Available Options:

• Disable: No scanning applied.
• Single Anti-Virus (Maximum Performance): Traffic will be scanned only by the Primary

Anti Virus Engine. Select the Primary Anti Virus Engine from System >  System Services > 
Malware Protection.

• Dual Anti-Virus (Maximum Security): Traffic will be scanned by both Anti Virus Engines,
first by the Primary and then by the Secondary Engine. Select the Primary Anti Virus Engine
from System >  System Services >  Malware Protection.

Email Policies

Use this section to add, edit, delete and synchronize POP-IMAP Policy, SMTP Malware Policy, SMTP Scanning
Policy and SMTP Profiles. You can filter the list of Policy based on the email sender or recipient.

Mode Switch option
Select the mode from the following for which you want to create Policy:

• MTA
• Legacy

Add Email Policy
Select to create a new Policy from the following:

• POP-IMAP Policy:
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POP-IMAP Scanning Policy can be configured for particular senders and recipients. A Policy
defines the action to be taken if an Email is detected as Spam, Probable Spam, part of Virus
Outbreak or Probable Virus Outbreak. To reduce the risk of losing legitimate messages,
the Spam Quarantine repository - a storage location- provides administrators with a way to
automatically quarantine Emails that are identified as spam. This helps in managing spam and
probable spam quarantined mails so that the user can take appropriate actions on such emails.

Note:  A default editable POP-IMAP Policy default-pop-av is pre-configured in
all Sophos XG Firewall device(s) and applied to all Email traffic as soon as you
subscribe to the Email Protection Module.

• SMTP Profile (available only when MTA mode is enabled):

CFM allows you to create SMTP Profiles for multiple Sophos XG Firewall devices which can
be used to protect multiple Domains on your internal Email Server or multiple Email Servers.
Using these Profiles, Sophos XG Firewall protects the internal server(s) from remote attacks and
additionally provide powerful virus scanning, Email encryption and Email filtering services.

• SMTP Malware Policy (available only when MTA mode is disabled):

SMTP Malware Scanning Policy allows you to define action to be taken on Emails if
they are virus-infected, suspicious or contain a protected attachment. Based on the action
defined in Policy, such Emails can be delivered as it is, dropped, or cured and then delivered
or quarantined. A SMTP Malware Scanning Policy defines: whether to quarantine the
Emailwhether sender, receiver or Administrator are to be notifiedwhether to block the Email
containing a specified file typewhat action is to be taken if Email is infected/suspicious/ contains
a protected attachment: deliver as it is, drop, cure and then deliver A default SMTP Malware
Scanning Policy is pre-configured in the Device and applied to all Email traffic as soon as you
subscribe to the Email Protection Module. It is recommended to create separate Policy fine tuned
to your specific network requirements to minimize the possibility of threats.

Note:  A default editable SMTP Malware Policy default-smtp-av is pre-
configured in all Sophos XG Firewall device(s) and applied to all Email traffic as
soon as you subscribe to the Email Protection Module.

• SMTP Scanning Policy (available only when MTA mode is disabled):

SMTP Scanning Policy can be configured for particular senders and recipients. Policy defines
action to be taken if an Email is detected as Spam, Probable Spam, part of Virus Outbreak
or Probable Virus Outbreak, and lets you specify the action to be performed on the Email.
To reduce the risk of losing the legitimate messages, Spam Quarantine repository - a storage
location, provides administrators a way to automatically quarantine Emails that are identified as
Spam. This helps in managing Spam and probable Spam quarantined mails so that user can take
appropriate actions on such mails.

Add POP - IMAP Scanning Policy

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

The POP - IMAP Scanning Policy page allows you to configure scanning policy to detect incoming and outgoing
Spam in Email traffic and take appropriate action.

1. Go to Device Configuration > Protect > Email > Email Scanning Policy.
2. Click Add POP-IMAP Rule under Email Scanning Policy section.
3. Enter Email Address/Domain Group details.

Sender

Specify Email Address(es) of the Sender(s). You can select from the variants:

• Contains: Specify keywords to be matched with Sender Email Addresses. Rule applies to
Address(es) containing those keywords. For example, if keyword "mail" is specified, rule will
apply to Sender Email Addresses john@hotmail.com, sophosmail@sophos.com, etc.
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• Equals: Specify the exact Email Address(es) of the Sender(s).

You can also add RBLs, list of Email Addresses or keywords using Create New link.

Recipient

Specify Email Address(es) of the Recipient(s). You can select from the variants:

• Contains: Specify keywords to be matched with Recipient Email Addresses. Rule applies to
Address(es) containing those keywords. For example, if keyword "mail" is specified, rule will
apply to Recipient Email Addresses john@hotmail.com, sophosmail@sophos.com, etc.

• Equals: Specify the exact Email Address(es) of the Recipient(s).

You can also add RBLs, list of Email Addresses or keywords using Create New link.
4. Select the Filter Criteria.

Inbound Email is

All the Emails that are received by the users in their inbox are referred as Inbound.

On configuring Inbound Spam, all the Emails received by the users are scanned for spam and
viruses by the Device.

Specified action will be taken if the Device has identified the Inbound Email to be one of the
following:

• Spam
• Probable Spam
• Virus Outbreak
• Probable Virus Outbreak

Source IP/Network Address

Specify IP/Network Address, action will be taken when the Email sender IP Address matches the
specified IP/Network Address.

Message Size

Specify Message Size, action will be taken when the Email size matches the specified size.

Message Header

Specified action will be taken if the message header equals or contains the specified text.

• Contains: Specify keywords to be matched with Message Header. Rule applies to Header(s)
containing those keywords.

• Equals: Specify the exact Header(s) to be scanned.

You can scan message header for Spam in:

• Subject: Specified action will be taken if the header contains the matching subject.
• From: Specified action will be taken if the header contains the matching text in the From

address.
• To: Specified action will be taken if the header contains the matching text in the To address.
• Other: Specified action will be taken if the matching text is found in the headers.

None

Select to create a rule between specific sender and recipient without any conditions. You can set
actions for POP/S-IMAP/S mails only on the basis of sender and recipient.

5. Select the action.

• Accept: Email is accepted and delivered to the intended recipient.
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• Prefix Subject: Email is accepted and delivered to the intended recipient but after tagging the
subject line.Tagging content is specified in spam policy.You can customize subject tagging in
such a way that the recipient knows that the Email is a spam Email. For Example Contents to be
prefixed to the original subject: ‘Spam notification from the Device – ‘Original subject: ‘This
is a test’ Recipient will receive Email with subject line as: ‘Spam notification from the Device -
This is a test’.

6. Click Save.

Add SMTP Policy

This feature is applicable only on Sophos XG Firewall devices where MTA Mode is enabled.

1. Go to Device Configuration > Protect > Email > Email Scanning Policy and click on Switch to MTA Mode.
2. Click Add SMTP Policy under Email Scanning Policy section.
3. Specify values for Domains and Routing Target.

Domain
Select the Domain(s) (Address Group (MTA)) to which the SMTP Policy links. You can also add
new Domain(s) using Create New link. Address Group (MTA) can be configured from Device
Configuration > Protect > Email > Address Group (MTA).

Route By

Select the host to which Emails for the listed domains should be forwarded to, for example, the
Microsoft Exchange Server on your local network. You can choose between different server types:

Available Options:

Static Host:

Select Static Host to define the target route as a static IP address(es) of the internal Email Server.

MX:

Select MX to route mail to your domain(s) by means of MX record(s). If you select this route
type, the Device makes a DNS query requesting the MX record for the recipient's domain
name, which is the portion of the email address following the "@" character. Make sure that the
gateway is not the primary MX for the domain(s) specified above, since it will not deliver mail to

itself.
4. Enable Spam Protection section to configure Spam scanning of Email traffic.

Check for Inbound Spam

All the Emails that are received by the users in their inbox are referred to as Inbound.

If you select Check for Inbound Spam, all the Emails received by the users are scanned for spam
by the Device.

If Email is detected as a "Spam", selected Spam Action is applied.

If Email is detected as a " Probable Spam", which means that the Anti-spam engine has detected the
Email as suspicious but not as Spam, selected Probable Spam Action is applied.
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Check for Virus Outbreak
If you select Check for Virus Outbreak, all the Emails received by the users are scanned for
viruses by the Device.

If Email is detected to cause a virus outbreak, selected Spam Action is applied.

If Email is detected as suspicious but not confirmed as a virus outbreak, selected Probable Spam
Action is applied.

Check for Outbound Spam
Emails that are sent by the user in the network to a remote user on another Email system, are
referred as Outbound.

If you select Check for Outbound Spam, all the Emails sent by the local users are scanned for
spam by the Device before being delivered.

If Email is detected as a "Spam", selected Spam Action is applied.

If Email is detected as a " Probable Spam", which means that the Anti-spam engine has detected the
Email as suspicious but not as Spam, selected Probable Spam Action is applied.

Check for RBL

Click to verify the reputation of the sender IP Address. When enabled, the Device dynamically
checks the sender’s IP Address of all Emails. If the IP Address is found to be responsible for
sending spam email or malicious contents, the Device takes action.

If Email is detected as a "Spam", selected Spam Action is applied.

If Email is detected as a " Probable Spam", which means that the Anti-spam engine has detected the
Email as suspicious but not as Spam, selected Probable Spam Action is applied.

Prefix Subject
Specify prefix that is to be added with the email subject.

Note:  Available when action as Warn is selected.

Spam Action
Select action to be taken if Email is detected as Spam.

Available Options:

None:

Select if no action is to be taken.

Warn:

Email is accepted and delivered to the intended recipient but after tagging the subject line.

Quarantine:

Device does not deliver Email but copies it to the Quarantine. You can view the Email details and
release the Email, if required, from the Quarantine.

Drop:

Email is dropped.

Default: Drop.

Probable Spam Action
Select action to be taken if Email is detected as suspicious but not confirmed as Spam.

Available Options:

None:
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Select if no action is to be taken.

Warn:

Email is accepted and delivered to the intended recipient but after tagging the subject line.

Quarantine:

Device does not deliver Email but copies it to the Quarantine. You can view the Email details and
release the Email, if required, from the Quarantine.

Drop:

Email is dropped.

Default:

Warn.
5. Enable Malware Protection section to configure malware scanning of Email traffic.

Scanning

Specify the type of scanning to be applied.

Available Options:

Single Anti-Virus: Traffic will be scanned ONLY by the Primary Anti-Virus Engine. Select
the Primary Anti-Virus Engine from Device Configuration > System >  System Services > 
Malware Protection. Dual Anti-Virus: Traffic will be scanned by both Anti-Virus Engines, first
by Primary and then by the Secondary Engine. Select the Primary Anti-Virus Engine from Device
Configuration > System >  System Services >  Malware Protection.

Anti-virus Action
Select action to be taken if a malware is detected in an Email.

Available Options:

None:

No action to be taken.

Quarantine:

Device does not deliver Email but copies it to the Quarantine. You can view the Email details and
release the Email, if required, from the Quarantine.

Drop:

Email is rejected and a rejection notification is NOT sent to the Email sender.
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Default: Drop

Notify Sender
If enabled, the original message is withheld by the Device and a notification is sent to the sender
informing that the Email was infected.

Quarantine Unscannable and Encrypted Content

Enable to quarantine emails whose content cannot be scanned.

Unscannable content may include encrypted or corrupt
archives, oversized email, or emails not scanned due to internal

error.
6. Enable File Protection section to configure filtering of specific attachments in Email Traffic.

Block File Types

Select file types to be blocked as an attachment to remove all the files that are a potential threat and
to prevent virus attacks.

More than one file type can be selected using Ctrl/Shift keys.

Device contains a default list of File Types, with each Type containing relevant file extensions.
Refer to Device Configuration > Objects >  Content >  File Type to view the list of file
extensions which can be blocked.

Select All to block Emails with any type of attachments.

Select None to allow Emails with any type of attachments.

MIME Whitelist

If one or more File Type is selected in Block File Type, this field is populated with the
corresponding MIME Headers that belong to selected File Type(s).

Select the MIME Header(s) of the selected File Type(s). Only selected headers are to be allowed
while the rest in the selected File Type are to be blocked during Anti-virus scanning of Email
attachments.

Drop message greater than
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Specify maximum file size in KB of Emails. Emails greater than specified size will be dropped by

Device.
7. Enable Data Protection section to configure confidential data protection in Email Traffic.

Data Control List

Select Data Control List to be applied for scanning and corresponding action, Data Protection
Policies can be configured from Protection > Email Protection > Data Protection (MTA).

Available Options for actions:

Accept: Email is accepted and delivered to the intended recipient. Accept with SPX: Email
is accepted and delivered to the intended recipient after being SPX encrypted. Select the SPX
Template (MTA) to be applied to the Email. You can configure SPX Templates from Protection >
Email Protection > SPX Templates (MTA). Drop: Email is rejected and a rejection notification is
NOT sent to the Email sender.

Notify Sender
Enable to notify the sender of an Email if it is found to contain
sensitive information as per configured Data Protection

policy.
8. Select the action for all traffic applicable to Policy.

Action
Select action for all the traffic applicable to the Policy. Available options are Accept and Reject.
Select SPX Template in case you select Accept.

Default: Accept.

Add SMTP Malware Scanning Policy

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

The Add SMTP/S Malware Scanning Policy page allows you to configure scanning policy to detect malware in
Email traffic and take appropriate action.

1. Go to Device Configuration > Protect > Email > Email Policies and click on Switch to Legacy Mode.
2. Click Add SMTP MAlware Policy under Email Policies section and selectAdd SMTP Scanning Policy.
3. Enter Policy details

Name
Enter a unique name to identify the scanning Policy.

Sender

Select the sender name from the list of users.
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Select Any if the Policy is to be applied on all the senders.

You can also add a new Email address by clicking Create New link.

Recipient

Select the recipient name from the list of users.

Select Any if the Policy is to be applied on all the recipients.

You can also add a new Email Address by clicking Create New link.

Block File Types

Select file types to be blocked as an attachment to remove all the files that are a potential threat and
to prevent from virus attacks.

More than one file type can be selected using ctrl/shift keys.

Device contains a default list of File Types, with each Type containing relevant file extensions.
Refer to Protect >  Web  >  File Type to view the list of file extensions which can be blocked.

Select All to block Emails with any type of attachments.

Select None to allow Emails with any type of attachments.

MIME Whitelist

If one or more File Type is selected in Block File Type, this field is populated with the
corresponding MIME Headers that belong to selected File Type(s).

Select the MIME Header(s) of the selected File Type(s). Only selected headers are to be allowed
while the rest in the selected File Type are to be blocked during Anti Virus scanning of Email
attachments.

Scanning

Specify the type of scanning to be applied.

Available Options:

• Disable (default):No scanning applied.
• Single Anti Virus (Maximum Performance): Traffic will be scanned ONLY by the Primary

Anti Virus Engine. Select the Primary Anti Virus Engine from Protection >  Web Protection
>  Malware Protection or System >  System Services >  Malware Protection.

• Dual Anti Virus (Maximum Security): Traffic will be scanned by both Anti Virus Engines,
first by Primary and then by the Secondary Engine. Select the Primary Anti Virus Engine
from Protection >  Web Protection >  Malware Protection or System >  System Services > 
Malware Protection.

Action
Enable action to be taken on the mails received, from the available options:

• Quarantine: If enabled, copies the Email to the quarantine file list. Email is either delivered to
recipient or dropped, as per configured Recipient Action.You can view the Email details like
sender and receiver of the Email in the Malware Quarantine. Administrator can access the
Quarantine on the Sophos XG Firewall device from System > Current Activity > Malware
Quarantine while user can access from their respective User Portal.

• Notify Sender: If enabled, the original message is withheld by the Device and a notification is
sent to the sender informing that the Email was infected. The sender will receive the notification
only if the Receiver Action is configured as Don't Deliver.

Default - Disable

Delivery Option for Infected Attachment/Protected Attachment
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Recipient
Select the action to be taken on the message that is detected to be Infected, Suspicious or includes a
Protected Attachment.

Available Options:

• Don't Deliver (default value): Receiver will not receive the message and will also not receive
the notification regarding the infected Email.

• Deliver Original: Receiver receives the original Email.
• Remove and Deliver: Infected part of the Email is removed before delivering. Receiver will

also receive the notification stating that the Email was infected and infected portion of the Email
is removed. Not applicable for Blocked Attachments (Block File Type).

Note:  Protected attachments are not scanned but receiver will be notified, if not
specified otherwise.

Administrator
Select the action to notify the Administrator for the message detected to be Infected, Suspicious or
includes a Protected Attachment.

Available Options:

• Don't Deliver:(default value) Administrator will not be notified about the infected Email.
• Send Original: Receiver receives the original Email.
• Remove Attachment: Recipient receives message without attachment and the Administrator

receives the notification that the Email attachment was infected and removed before delivering
Email.

Note:  Protected attachments are not scanned but receiver will be notified, if not
specified otherwise.
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Figure 126: Add Policy
4. Click Save to add the Email Policy.

Add SMTP Scanning Policy

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

The Add Content Scanning Policy page allows you to configure scanning policy to detect incoming and outgoing
Spam in Email traffic and take appropriate action.

1. Go to Device Configuration > Protect > Email > Email Scanning Policy and click on Switch to Legacy Mode.
2. Click Add Email Policy under Email Scanning Policy section and select Add SMTP Scanning Policy.
3. Specify Name for SMTP Scanning Policy.
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4. Enter Email Address/Domain Group details.
Sender

Specify Email Address(es) of the Sender(s). You can select from the variants:

• Contains: Specify keywords to be matched with Sender Email Addresses. Policy applies to
Address(es) containing those keywords. For example, if keyword "mail" is specified, Policy will
apply to Sender Email Addresses john@hotmail.com, sophosmail@sophos.com, etc.

• Equals: Specify the exact Email Address(es) of the Sender(s).

You can also add RBLs, list of Email Addresses or keywords using Create New link.

Recipient

Specify Email Address(es) of the Recipient(s). You can select from the variants:

• Contains: Specify keywords to be matched with Recipient Email Addresses. Policy applies to
Address(es) containing those keywords. For example, if keyword "mail" is specified, Policy will
apply to Recipient Email Addresses john@hotmail.com, sophosmail@sophos.com, etc.

• Equals: Specify the exact Email Address(es) of the Recipient(s).

You can also add RBLs, list of Email Addresses or keywords using Create New link.
5. Select the Filter Criteria.

Inbound Email is

All the Emails that are received by the users in their inbox are referred as Inbound.

On configuring Inbound Spam, all the Emails received by the users are scanned for spam and
viruses by the Device.

Specified action will be taken if the Device has identified the Inbound Email to be one of the
following:

• Spam
• Probable Spam
• Virus Outbreak
• Probable Virus Outbreak

Outbound Email is

Emails that are sent by the user in the network to a remote user on another Email system, are
referred as Outbound.

On configuring Outbound Spam, all the Emails sent by the local users are scanned before being
delivered to other users on the Internet for spam and viruses by the Device.

Specified action will be taken if the Device has identified the Outbound Email to be one of the
following:

• Spam
• Probable Spam
• Virus Outbreak
• Probable Virus Outbreak

Source IP/Network Address

Specify IP/Network Address, action will be taken when the Email sender IP Address matches the
specified IP/Network Address.

Destination IP/Network Address

Specify IP/Network Address, action will be taken when the Email recipient IP Address matches the
specified IP/Network Address.
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Sender Remote Blacklist

Select Remote Blacklist (RBL), action will be taken when the sender is listed in the specified RBL
Group.

Message Size

Specify Message Size, action will be taken when the Email size matches the specified size.

Message Header

Specified action will be taken if the message header equals or contains the specified text.

• Contains: Specify keywords to be matched with Message Header. Policy applies to Header(s)
containing those keywords.

• Equals: Specify the exact Header(s) to be scanned.

You can scan message header for Spam in:

• Subject: Specified action will be taken if the header contains the matching subject.
• From: Specified action will be taken if the header contains the matching text in the From

address.
• To: Specified action will be taken if the header contains the matching text in the To address.
• Other: Specified action will be taken if the matching text is found in the headers.

Data Control List

Specified action will be taken if message contains data matching with the configured Data
Protection Policy. You can create Data Protection Policies from Device Configuration > Protect >
Email > Data Protection Policies.

None

Select to create a Policy between specific sender and recipient without any conditions. You can set
actions for SMTP mails only on the basis of sender and recipient.

6. Select the action.
Action:

Select action to be taken for the SMTP traffic. Available Options:

• Reject: Email is rejected and rejection notification is sent to the Email sender.
• Accept (Not available for Outbound Spam): Email is accepted and delivered to the intended

recipient. Administrator can bind an SPX Template to this action so that the Email is delivered to
the intended recipient after being SPX-encypted.

• Change Recipient: Email is accepted but is not delivered to the intended recipient for whom the
message was originally sent. Email is sent to the recipient specified in the spam policy.

• Prefix Subject (Not available for Outbound Spam): Email is accepted and delivered to the
intended recipient but after tagging the subject line. Administrator can bind an SPX Template to
this action so that the Email is delivered to the intended recipient after being SPX-encypted.

• Drop: Email is rejected but rejection notification is not sent to the Email sender.

Tagging content is specified in To field.

• You can customize subject tagging in such a way that the recipient knows that the Email is a
spam Email.

• For Example

Contents to be prefixed to the original subject: ‘Spam notification from the Device –' Original
subject: ‘This is a test’.

Recipient will receive Email with subject line as: ‘Spam notification from the Device - This is a
test’.
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SPX Template (Legacy): If action is selected as Accept or Prefix Subject, select the SPX
Template to be applied on the Email. You can create SPX Templates from Protection > Email
Protection > SPX Encryption.

Quarantine: If enabled, does not deliver Email but copies the Email to the quarantine file list. You
can view the Email details like sender and recipient of the Email in the quarantined file list.

Select action to be taken for the POP-IMAP traffic.

Available Options:

• Accept: Email is accepted and delivered to the intended recipient.
• Prefix Subject: Email is accepted and delivered to the intended recipient but after tagging the

subject line.Tagging content is specified in spam policy.You can customize subject tagging in
such a way that the recipient knows that the Email is a spam Email. For Example Contents to be
prefixed to the original subject: ‘Spam notification from the Device – ‘Original subject: ‘This
is a test’ Recipient will receive Email with subject line as: ‘Spam notification from the Device -
This is a test’.
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Figure 127: Add Content Scanning Policy
7. Click Save.

Add Exceptions

Exceptions allow you to skip security checks related to spam, malware, and others for

hosts or networks, sender's mail addresses, or recipient’s mail addresses.
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1. Go to Email > Policies and Exceptions and click Add Exception.
2. Enter a name for Exception.
3. Select security checks to skip.

Skip these checks
Select one or more security checks.

In Spam Protection, you can select RBL, Antispam, Greylisting, Recipient Verification, IP
Reputation, or RDNS/Helo. Under Malware Protection, you can select Malware or Sandstorm. In
Other, you can select Data Protection, File Protection, Encryption, or Banner Addition.

Figure 128: Skip these checks
4. Select any of the following to apply the exception:

For these Sources/Hosts
Add source or hosts to skip security checks.

Note:  You do not need to create exception for localhost. By default, messages are not
scanned for localhost.

Or these sender addresses

Add sender’s mail address to skip security checks. Enter a valid email address (abc@example.com)
or a wildcard (*@example.com).

Or these recipient addresses

Add recipient’s mail address to skip security checks. Enter a valid email address
(abc@example.com) or a wildcard (*@example.com).

5. Click Save.

Data Control List

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

This feature is NOT available in SF100 and SF200.

The Data Protection (DP) feature allows you to reduce accidental data loss from workstations by monitoring and
restricting the transfer of files containing sensitive data. Accidental data loss is commonly caused by employees
mishandling sensitive data. For example, a user sends a file containing sensitive data home via email (SMTP). DP
scans outgoing emails including subject line, message body and attachments for sensitive or confidential information.
Based on the outcome, the email can be encrypted using SPX encryption, or the email can be rejected or sent.

To configure DLP, select one or more rule from the Sophos Content Control List (CCL). CCLs provide expert
definitions for common financial and personally identifiable data types, for example, credit card numbers, social
security numbers, postal addresses, or email addresses. Advanced techniques, such as checksums, are used in Sophos
CCLs to increase the accuracy of sensitive data detection.
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Use this page to add, edit and delete Data Protection Policies for Legacy and MTA modes. Use the Mode Switch
option on the page to switch between Legacy and MTA modes.

Add Data Control List (MTA)

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

This feature is applicable to Sophos XG Firewall devices where MTA Mode is enabled.

This feature is NOT available in Device Models SF100 and SF200.

The Add Data Control List page is used to configure policy to scan and detect confidential data in Email traffic and
take appropriate action.

1. Go to Device Configuration > Protect > Email > Data Control List and click Add.

Note:  Ensure that MTA Mode is selected for Data Control List page. Click Turn Off Legacy Mode to
switch to MTA Mode.

2. Enter policy details.
Name

Specify name to identify Data Control List.

Signatures
Select one or more Content Control signature(s) to be added to the policy.

Filter the Content Control List based on Type or Region.

Figure 129: Data Control List
3. Click Save to create policy.

Add Data Control List (Legacy)

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

This feature is applicable to Sophos XG Firewall devices where MTA Mode is disabled.

This feature is NOT available in Device Models SF100 and SF200.
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The Add Data Control List page is used to configure policy to scan and detect confidential data in Email traffic and
take appropriate action.

1. Go to Device Configuration > Protect > Email > Data Control List and click on Switch to Legacy Mode.
2. Click Add.
3. Enter policy details.

Name
Specify name to identify Data Control List.

Signatures
Select one or more Content Control signature(s) to be added to the policy.

Filter the Content Control List based on Type or Region.

Figure 130: Data Control List
4. Click Save to create policy.

Encryption

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

Mode Switch option

Select the mode from the following for which you want to apply SPX Configuration and manage SPX Templates:

• MTA
• Legacy

SPX Configuration
Default SPX Template

Select the default SPX Template. SPX Templates can be created from Device Configuration >
Protect > Email > SPX Encryption. Default Template is used if any user explicitly SPX-encrypts
an Email and no template is selected in Content Scanning Rule.
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User can SPX-encrypt an Email by:

• Manually setting the Email header X-Sophos-SPX-Encrypt to yes.
• Installing the Sophos Outlook Add-on and clicking Encrypt before sending the Email.

If Default SPX Template is selected as None, then SPX encryption is not applied on Email.

Allow Secure Reply for
Enter the maximum time (in days) in which recipient can securely reply to an SPX-encrypted email
using the SPX Reply Portal.

Keep Unused Password for

Specify the expiry time in days of an unused password.

For example, if Keep Unused Password for is set to 30 days, then password will expire at 0 o'clock
after 30 days from being generated if no SPX encrypted message was sent for a specific recipient.

Default: 30 days

Allow Password Registration for
Specify the time in days after which the link to Password Registration Portal expires.

Default: 10 days

Send Error Notification To

Specify whom to send a notification when an SPX error occurs. Select Sender Only to send
notification to the sender or select Nobody if you do not want any notification to be sent. Error
messages will always be listed in the SMTP log.

SPX Portal Settings
Hostname

Specify the IP Address or Domain on which Password Registration Portal is hosted.

Allowed Network(s)
Specify the networks from which password registration requests will be accepted.

Port

Enter the port on which the SPX reply portal should listen.

Default: 8094
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Figure 131: SPX Configuration

SPX Templates

SPX (Secure PDF Exchange) encryption is a next-generation version of email encryption. It is clientless and
extremely easy to set up and customize in any environment. Using SPX encryption, email messages and any
attachments sent to the Sophos XG Firewall device are converted to a PDF document, which is then encrypted with a
password. You can configure the Sophos XG Firewall device to allow senders to select passwords for the recipients,
or the server can generate the password for the recipient and store it for that recipient, or the server can generate one-
time passwords for recipients.

When SPX encryption is enabled, there are two ways how emails can be SPX encrypted:

• User can download the Sophos Outlook Add-in from Sophos XG Firewall's User Portal. After having it installed,
an Encrypt button is displayed in the Microsoft Outlook user interface. To encrypt a message, the user needs to
click the Encrypt button and then write and send the message. Only if something goes wrong, for example the
sender does not enter a valid password, a notification will be sent, if configured.

Note:

If you do not use Outlook you can also trigger SPX encryption by setting the header field

X-Sophos-SPX-Encrypt to yes.
• In the Data Protection feature, you can enforce SPX encryption for Emails containing sensitive data (see Device

Configuration > Protect > Email > Email Scanning Rules.
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The encrypted message is then sent to the recipient's mail box. Using any PDF reader, the recipient can decrypt the
message with the password that was used to encrypt the PDF. SPX-encrypted email messages are accessible on all
popular smartphone platforms that have native or third-party PDF file support, including Android, IOS, Blackberry
and Windows Mobile devices.

The SPX template defines the layout of the PDF file, password settings and recipient instructions. You can also define
different SPX templates. So, if you are managing various customer domains, you can assign them customized SPX
templates containing for example different company logos and texts. Use this section to add, edit and delete SPX
Templates for Legacy and MTA modes.

Add SPX Templates (MTA)

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

This feature is applicable to Sophos XG Firewall devices where MTA Mode is enabled .

This page allows you to define new SPX Templates or modify existing templates.

1. Go to Device Configuration > Protect > Email > Encryption > SPX Templates and click Add.

Note:  Ensure that MTA Mode is selected for Encryption page. Click Turn Off Legacy Mode to switch to
MTA Mode.

2. Enter parameter values for the following basic settings.
Name

Specify the name to uniquely identify the template.

Description
Specify details of the template.

Organization Name
Specify the organization name to be displayed on notifications concerning SPX, sent to the
administrator or the email sender, depending on your settings.

PDF Encryption
Select the encryption standard of the PDF file.

Page Size
Select the page size of the PDF file.

3. Enter Password Settings.
Password Type

Select how you want to generate the password for accessing the encrypted email message.
Depending on which type you select, the sender always has to take care of transferring the password
in a safe way to the recipient, except for Specified by recipient.

Available Options:

Specified by Sender:

Select if the email sender should provide the password. In this case, the sender
has to enter the password into the Subject field, using the following format:
[secure:<password>]<subject text> where <password> is the password to open the
encrypted PDF file and <subject text> is the random subject. Of course, the password will be
removed by the Sophos XG Firewall device before the email is sent to the recipient.

Generated one-time password for every email:

The Sophos XG Firewall device automatically creates a new password for each affected email.
A Notification Email is sent to the Sender containing instructions and the one-time generated
password.
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The HTML content of this Email can be customized from Notification Subject and Notification
Body. You can reset to the default content by clicking Reset button.

Generated and stored for recipient:

The Sophos XG Firewall device automatically creates a recipient-specific password when the first
email is sent to a recipient. This password will be sent to the sender. With the next email, the same
password is used automatically. The password will expire when it is not used for a configured time
period, and it can be reset by the administrator.

The HTML content of this Sender Notification Email can be customized from Notification Subject
and Notification Body. You can reset to the default content by clicking Reset button.

Specified by recipient:

Select if the email recipient should provide the password. In this case, the recipient receives a
Notification Email containing link leading to the Password Registration Portal to register a
password and Sender receives a failure notification. After registration, the recipient is able to view
the current encrypted mail and any future encrypted mails using the same password from this or
other senders from the same organization.

Note:  The Recipient's password generated via Specified by recipient method and
Generated and stored for recipient are mutually exclusive. Recipient will have
to use the respective password when Email is received after SPX Encryption using
different methods.

4. Specify Recipient Instructions:
Instructions for Recipient

The body of the email that is sent from the Sophos XG Firewall device to the email recipient
containing instructions concerning the encrypted email. Simple HTML markup and hyperlinks are
allowed. You can also use variables, e.g.,

%%ORGANIZATION_NAME%%
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Figure 132: Add SPX Templates

Tip:

The Default SPX Template on this tab contains all available variables and provides a useful example of
recipient instructions. The variables used are:

• ENVELOPE_TO: The Recipient for whom password is generated.
• PASSWORD: The password to open SPX encrypted Email
• ORGANIZATION_NAME: The name provided in Organization Name field.
• SENDER: The Sender of the Email.
• REG_LINK: Link of the Registration Portal for registering the password.

5. Enable SPX Portal Settings:
Enable SPX Reply Portal

Click to enable users to securely reply to SPX-encrypted emails using the SPX Reply Portal. You
can also select the option Include Original Body in Reply to include original body.

6. Click Save to save the settings.

Add SPX Templates (Legacy)
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This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

This feature is applicable to Sophos XG Firewall devices where MTA Mode is disabled.

This page allows you to define new SPX Templates or modify existing templates.

1. Go to Device Configuration > Protect > Email > Encryption and click on Switch to Legacy Mode.
2. Click Add under SPX Templates section.
3. Enter parameter values for the following basic settings.

Name
Specify the name to uniquely identify the template.

Description
Specify details of the template.

Organization Name
Specify the organization name to be displayed on notifications concerning SPX, sent to the
administrator or the email sender, depending on your settings.

PDF Encryption
Select the encryption standard of the PDF file.

Page Size
Select the page size of the PDF file.

4. Enter Password Settings.
Password Type

Select how you want to generate the password for accessing the encrypted email message.
Depending on which type you select, the sender always has to take care of transferring the password
in a safe way to the recipient, except for Specified by recipient.

Available Options:

Specified by Sender:

Select if the email sender should provide the password. In this case, the sender
has to enter the password into the Subject field, using the following format:
[secure:<password>]<subject text> where <password> is the password to open the
encrypted PDF file and <subject text> is the random subject. Of course, the password will be
removed by the Sophos XG Firewall device before the email is sent to the recipient.

Generated one-time password for every email:

The Sophos XG Firewall device automatically creates a new password for each affected email.
A Notification Email is sent to the Sender containing instructions and the one-time generated
password.

The HTML content of this Email can be customized from Notification Subject and Notification
Body. You can reset to the default content by clicking Reset button.

Generated and stored for recipient:

The Sophos XG Firewall device automatically creates a recipient-specific password when the first
email is sent to a recipient. This password will be sent to the sender. With the next email, the same
password is used automatically. The password will expire when it is not used for a configured time
period, and it can be reset by the administrator.

The HTML content of this Sender Notification Email can be customized from Notification Subject
and Notification Body. You can reset to the default content by clicking Reset button.

Specified by recipient:
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Select if the email recipient should provide the password. In this case, the recipient receives a
Notification Email containing link leading to the Password Registration Portal to register a
password and Sender receives a failure notification. After registration, the recipient is able to view
the current encrypted mail and any future encrypted mails using the same password from this or
other senders from the same organization.

Note:  The Recipient's password generated via Specified by recipient method and
Generated and stored for recipient are mutually exclusive. Recipient will have
to use the respective password when Email is received after SPX Encryption using
different methods.

5. Specify Recipient Instructions:
Instructions for Recipient

The body of the email that is sent from the Sophos XG Firewall device to the email recipient
containing instructions concerning the encrypted email. Simple HTML markup and hyperlinks are
allowed. You can also use variables, e.g.,

%%ORGANIZATION_NAME%%

Figure 133: Add SPX Templates
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Tip:

The Default SPX Template on this tab contains all available variables and provides a useful example of
recipient instructions. The variables used are:

• ENVELOPE_TO: The Recipient for whom password is generated.
• PASSWORD: The password to open SPX encrypted Email
• ORGANIZATION_NAME: The name provided in Organization Name field.
• SENDER: The Sender of the Email.
• REG_LINK: Link of the Registration Portal for registering the password.

6. Click Save to save the settings.

General Settings

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

Email Configuration allows configuring the general settings on Email traffic. This page contains the following
sections.

SMTP Deployment Mode

MTA mode is available only in Sophos XG Firewall, XG105, Cyberoam CR25iNG, Sophos UTM, SG105, and
higher models.

Click button to switch to MTA/Legacy mode.

In MTA mode, device acts as a mail transfer agent (MTA). In Legacy mode, device acts as a transparent proxy.

When acting as an MTA, device is responsible for routing emails to and from the protected mail server. In this state
device allows you to:

• configure relay of inbound and outbound emails from Email > Relay Settings.
• set up multiple SMTP profiles to protect multiple domains on your internal mail server or multiple mail servers

from Email > Policies and Exceptions > SMTP Policies.
• view email messages that are either waiting for delivery or have produced an error in the Email > Mail Spool.
• view the logs for all the emails processed by the device from Email > Mail Logs.

Default: MTA mode is enabled.

Note:

• On enabling MTA mode, a firewall rule to allow SMTP/SMTPS traffic is automatically created.
• If you have migrated from CyberoamOS to SFOS v16, SFOS v15 to SFOS v16, Legacy Mode will be

enabled by default.

Figure 134: SMTP deployment mode

Outbound Banner Settings

Email Banner Mode
Select the mode of appending banner to outgoing emails.
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Available options:

Inline, no conversion: Appends banner inline.MIME part: Appends banner as a separate MIME
part.Off: Does not append banner.

Note:  For banner to be appended, you need to select Scan SMTP and Scan SMTPS
under Malware scanning in the applicable Business application rules.

Email Banner
Specify banner to be added to all the outgoing Emails. Only text banners are allowed.

Example:

This email contains confidential information. You are not authorized to copy the contents without
the consent of the sender. Please do not print this email unless it is absolutely necessary. Spread
environmental awareness.

Figure 135: Outbound banner settings

SMTP Settings

SMTP Hostname
Specify the SMTP/S hostname to be used in HELO and SMTP banner strings. By default, Device
uses Sophos as hostname.

Note:  For Legacy mode, this hostname is applicable only to system-generated
notification emails.

Don't Scan Emails Greater Than
Specify maximum file size (in KB) for scanning. Files exceeding this size received through SMTP/S
will not be scanned.

Default - 0 KB

Specify 0 to increase the default file size scanning restriction to 51200 KB.

Action for Oversize Emails
Specify the action for Oversize Emails.

Available Options

Accept: All the oversize mails are forwarded to the recipient without scanning.Reject: All the
oversize mails are rejected and sender is notified.Drop: All the oversized mails are dropped, without
notifying the sender.Default - Accept

Bypass Spam Check for SMTP/S Authenticated Connections (Available only in legacy mode)
Enable to bypass Spam Scanning for Email messages received over SMTP/S connections
authenticated by the Email Server.

Verify Sender's IP Reputation
Click to verify the reputation of the sender IP Address. When enabled, Device dynamically checks
the sender’s IP Address of all Emails. If the IP Address is found to be responsible for sending Spam
Emails or malicious contents, Device takes action as per configured Scanning Rules.

If enabled, specify action for Confirmed Spam Emails and Probable Spam Emails.

Available Options
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Accept: All the spam Emails are forwarded to the recipient after scanning as per the configuration.
Reject: All the spam mails are rejected and a notification is sent to the Email sender. Drop: All the
spam mails are dropped, without notifying the sender.

As it is a global option, if Spam scanning is enabled, all the mails will be first subjected to IP
Reputation filtering followed by filtering based on actions configured in Spam policy.

Default - Disable

SMTP DoS Settings
Enable to configure SMTP DoS Settings which protect the network from SMTP DoS Attacks.

If enabled, specify values for Maximum Connections, Maximum Connections/Host, Maximum
Emails/Connection, Maximum Recipients/Email, Email Rate per Minute/Host and Connections Rate
per Second/Host.

Maximum Connections (Available if SMTP DoS Settings Enabled)

Specify maximum number of connections that can be established with the Email Server.

Default - 1024

Range - 1 - 20000

Maximum Connections/Host (Available if SMTP DoS Settings Enabled)

Specify maximum number of connections allowed to the Email Server from a particular host.

Default - 64

Range - 1 - 10000

Maximum Emails/Connection (Available if SMTP DoS Settings Enabled)

Specify maximum number of Emails that can be sent in a single Connection.

Default - 512

Range - 1 - 1000

Maximum Recipients/Email (Available if SMTP DoS Settings Enabled)

Specify maximum number of Recipients for a single Email.

Default - 100

Range - 1 - 256

Email Rate per Minute/Host (Available if SMTP DoS Settings Enabled)

Specify number of Emails to be sent from a particular host in one Minute.

Default - 512

Range - 1 - 20000

Connection Rate per Second/Host (Available if SMTP DoS Settings Enabled)

Specify number of Connections allowed to the Email Server from a particular host in one Second.

Default - 8

Range - 1 - 20000
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Figure 136: SMTP/S Settings

POP/S and IMAP/S Settings

Don't Scan Emails Greater Than
Specify maximum file size (in KB) for scanning. Files exceeding this size received through POP/
IMAP will not be scanned.

Default - 1024 KB

Specify 0 to increase the default file size restriction to 10240 KB.

Recipient Headers
Specify Header value to detect recipient for POP3/IMAP.

Default - Delivered-To, Received, X-RCPT-TO



 | Device Configuration | 158

Figure 137: POP/S and IMAP/S Settings

SMTP TLS Configuration

TLS Certificate
Select the CA for scanning SMTP traffic over SSL from the available options.

Available Options

DefaultApplianceCertificateSecurityAppliance_SSL_CAList of custom CAs if added. You can
create the custom CA from Device Configuration > Configure > VPN > Certificate Authority
and custom Server certificate from Certificates > Certificates

Allow Invalid Certificate
If enabled, SMTP over SSL connections will be allowed with invalid certificate from the Email
Server. Disable to reject such connections.

Default - Enable

Disable legacy TLS protocols
If enabled, protocols earlier than TLS 1.1 will be disabled. To overcome TLS vulnerabilities, we
recommend that you disable legacy TLS protocols.

Default: Disable

Require TLS Negotiation
Select the remote host (mail server) or network from available options on whose connections
TLS encryption is to be enforced. In other words, the device will always initiate TLS-secured
connections when emails are to be sent or received. If TLS is enforced but connection cannot be
established, then emails to/from that remote host/network are discarded.

Require Sender Email Domain
Specify the sender domain on whose email connections TLS encryption is to be enforced.

Sender domain is the domain of the email sender. Emails from the specified sender domain will
be received over TLS-encrypted connections only. If TLS is enforced but connection cannot be
established, then emails from that sender domain are discarded.

Skip TLS Negotiation Hosts/Nets
Select the remote host (mail server) or network from available options on whose connections TLS
encryption is to be skipped or bypassed. When configured, SMTP connections to the selected hosts
will be established in clear text and unencrypted.
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Figure 138: SMTP TLS Configuration

POP and IMAP TLS Configuration

TLS Certificate
Select the CA for scanning POP and IMAP traffic over SSL from the available options.

Available Options

DefaultSecurityAppliance_SSL_CAList of custom CAs if added Default - Default

Allow Invalid Certificate
If enabled, POP and IMAP over SSL connections will be allowed with invalid certificate from the
Mail Server. Disable to reject such connections.

Default - Enable

Apply
Click to save the configuration.

Figure 139: POP and IMAP TLS Configuration

Email Journaling (Available only in Legacy Mode)

Email being one of the most important communication and business tool in use by organizations, Email Journaling
has become an integral part of every organization. An email journal is a repository to preserve Emails for compliance
and operational purposes.

Using Device Email Journal, the administrator can archive all Emails, Emails of a specific recipient or a group of
recipients coming into the organization and thereby keep a close watch over data leakage.

The Device can archive all Emails intended for a single or multiple recipients and can forward to the single
administrator or multiple administrators.

This section displays list of journals created and provides option to add a new journal, update the parameters of
existing journal, or delete the journal. You can filter the list based on recipient name.

Allowed and blocked senders (available only in MTA mode)

You can specify IP addresses, FQDNs, and email addresses to receive emails over SMTP/S connections to bypass
RDNS, greylisting, IP reputation, recipient verification, as well as, scanning for inbound-outbound spam, DLP, and
RBL.

Blocked email addresses
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To block email addresses, add them here. The device blocks email addresses that belong to both
allowed and blocked lists.

Figure 140: Allowed and blocked senders

Malware Protection

Sophos XG Firewall offers Dual Anti-Virus Scanning, wherein traffic is scanned by Two (2) Anti-Virus Engines.
Traffic is first scanned by the Primary Engine, and then the Secondary Engine. You can configure managed Sophos
XG Firewall device(s) for Malware Protection using the following settings:

Note:  Dual Anti-Virus is not available in Sophos XG Firewall device Models SF100 and SF200. For them,
ONLY Single Anti-Virus CYREN is available.

Note:  You can also view and manage these settings from Device Configuration > Configure > System
Services > Malware Protection.

Note:  You can manage the Anti-Virus service from Device Configuration > Monitor and Analyze >
Diagnostics > Services.

Primary Anti-Virus Engine
Select the Primary Anti-Virus Engine to be used for traffic scanning. For Dual Scan, packets are
first scanned by the Primary Engine and then by the Secondary Engine. For Single Scan, only the
Primary Engine is used.

Available Options

• Sophos Engine
• Avira Engine

Apply
Click to save the configuration.

Smarthost Settings

A smarthost is a Mail Transfer Agent (MTA) which acts as an intermediate server between the sender's and recipient's
mail servers. On configuring a smarthost, the device redirects outbound emails to the designated server, which are
then routed to the recipient's mail server.

You can enable Use Smarthost from Device Configuration > Protect > Email > General Settings.

Hostname
Select the host that will act as a smarthost.

Note:  You cannot configure Smarthost as the device's interface IP address. It will
result in a routing loop.

Port
Enter the port number.

Default: 25

Authenticate Device with Smarthost
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Select if the smarthost requires the device to authenticate before routing emails. Both plain and
login authentication types are supported. Enter a Username and Password.

Figure 141: Smarthost Settings

Advanced SMTP Settings (available only in MTA mode)
Reject invalid HELO or missing RDNS

Select this option if you want to reject hosts that send invalid HELO/EHLO arguments or lack
RDNS entries. Select Do strict RDNS checks if you want to additionally reject email from hosts
with invalid RDNS records. An RDNS record is invalid if the found hostname does not resolve back
to the original IP address.

Scan Outgoing Mails
Enable to scan all outgoing email traffic. Email is quarantined if found to be malware infected, or
marked as Spam.

Apply
Click to save the configuration.

Add Email Journal

This feature requires a subscription in Sophos XG Firewall. It can be configured but cannot be enforced
without a valid Email Protection subscription.

The Add Email Journal page allows you to specify which Recipient's Email you want to archive.

1. Go to Device Configuration > Protect > Email > Common Settings, scroll down to Email Journal section and
click Add.

2. Enter following parameters.
Name

Enter a name for the Email Journal profile.
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Recipient

Select Any to archive all the incoming Emails or specify Address Group for which Emails need to
be archived.

Send Copy of Email To (Only for SMTP/S Protocol)

Specify Email Address to which you want to forward the Email copy.

Figure 142: Add Email Journal
3. Click Save to create Email Journal profile.

Relay Settings

Sophos Central Firewall Manager can be used to configure Sophos XG Firewall device(s) to act as Email relay which
allows specific hosts to relay (i.e., send) emails through it to specified domains.

Note:  This feature is applicable only on Sophos XG Firewall device(s) where MTA Mode is enabled.

Outbound Relay Settings
Allow Relay from Hosts/Networks

Select the hosts/networks which can use Sophos XG Firewall device(s) as an Email relay. You can
use Create New link to create a new host.

It is extremely important not to select Any in Allowed Hosts/Networks, because this would result
in an open relay, allowing anyone on the Internet to send messages through Sophos XG Firewall
device(s). Spammers will quickly recognize this, leading to massive email traffic. In the worst case,
you will be listed on 3rd party spammer blacklists. In most configurations, the only hosts that should
be allowed to relay emails are the mail servers in your network.

Block Relay from Hosts/Networks

Specify the hosts/networks whose outbound Emails should be blocked by Sophos XG Firewall
device(s). You can use Create New link to create a new host.

Inbound Relay Settings
Allow Relay from Hosts/Networks

Specify the upstream hosts/networks from where you want to allow inbound Emails, typically your
ISP or external MX. You can use Create New link to create a new host.

Block Relay from Hosts/Networks
Specify the hosts/networks whose inbound Emails should be blocked by Sophos XG Firewall
device(s). You can use Create New link to create a new host.

Authenticated Relay Settings
Enable Authenticated Relay

Enable to allow the authenticated users or groups selected below to use Sophos XG Firewall
device(s) as Email Relay.
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Users or Groups
Select the users or groups to be allowed to use Sophos XG Firewall device(s) as Email Relay. You
can use the Create New link to create a new user or group.

Apply
Click to save the configuration.

Relay and Routing Scenarios
The table below explains the scenarios in which Sophos XG Firewall device applies routing, inbound relay or
outbound relay on an Email.

Sender Domain Recipient Domain Routing (Static or
MX)

Outbound Relay Inbound Relay

Known Known Yes NA NA

Known Unknown NA Yes NA

Unknown Known Yes NA Yes

Unknown Unknown NA Yes NA

Address Group

Email Policies are applied on Email Addresses. To make configuration easier and simpler, Administrator can group
the addresses that require the same scanning policy. The policy applied to the address group is applicable to all the
group members. Hence when group is used in number of rules, it becomes much easier to add or remove addresses
from the group rather than updating individual rules. Hence, just with the one update, Administrator can re-align the
rules.

Address Group is grouping of:

• Email Address or Domain
• IP Address
• RBL (Real-time Blackhole List) (applicable only for the Spam mails)

An address can be a member of multiple groups.

RBL is a list of IP Addresses whose owners are responsible for Spam or are hijacked for Spam Relay. These IP
Addresses might also be used for spreading virus. The Device checks each RBL for the connecting IP Address and
action configured in the policy is taken if IP Address is found in any of the RBL list. Administrator can directly use
the two default RBL groups shipped with the Device or update them as per the requirement:

• Premium RBL Services
• Standard RBL Services

The Address Group page displays list of all the default and custom groups and provides option to add a new group,
update the parameters, import addresses in the existing group, or delete the group. You can sort the list based on
address group name.

Use this page to add, edit and delete Address Groups for Legacy and MTA modes. Use the Mode Switch option on
the page to switch between Legacy and MTA modes.

Add Address Group (MTA)

This feature is applicable to Sophos XG Firewall devices where MTA Mode is enabled.

This page allows you to add a new Email Address Group, or edit existing groups.

1. Go to Device Configuration > Protect > Email > Address Group and click Add.

Note:  Ensure that MTA Mode is selected for Address Group page. Click Turn Off Legacy Mode to
switch to MTA Mode.
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2. Specify the parameter values of the following Address Group Settings.
Name

Enter a name to identify the Group. A group name must be unique.

Description

Provide the description for the address group.

Group Type

Select type of addresses you want to group from the available options.

Available Options:

RBL (IPv4) and RBL(IPv6):

RBL is a list of IPv4 and IPv6 Addresses, respectively, whose owners refuse to stop the proliferation
of spam, i.e. are responsible for spam or are hijacked for spam relay. The Device will check each
RBL for the connecting IP Address. If the IP Address matches to the one on the list then the
specified action in policy is taken. Specify Domain Name to be added as RBL to the Address
Group.

Email Address / Domain:

Import or manually specify Email Address or Domain Name to be added to the Address Group.

Import – Select to browse and import a CSV file or a text file to add the Email Address/Domain to
address group.

Manual – Select to manually add the Email Address/Domain to address group.

Figure 143: Address Group
3. Click Save to create Address Group.

Add Address Group (Legacy)

This feature is applicable to Sophos XG Firewall devices where MTA Mode is disabled.

This page allows you to add a new Email Address Group, or edit existing groups.

1. Go to Device Configuration > Protect > Email > Address Group and click on Switch to Legacy Mode.
2. Click Add.
3. Specify the parameter values of the following Address Group Settings.

Name
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Enter a name to identify the Group. A group name must be unique.

Description

Provide the description for the address group.

Group Type

Select type of addresses you want to group from the available options.

Available Options:

RBL (IPv4) and RBL(IPv6):

RBL is a list of IPv4 and IPv6 Addresses, respectively, whose owners refuse to stop the proliferation
of spam, i.e. are responsible for spam or are hijacked for spam relay. The Device will check each
RBL for the connecting IP Address. If the IP Address matches to the one on the list then the
specified action in policy is taken. Specify Domain Name to be added as RBL to the Address
Group.

Email Address / Domain:

Import or manually specify Email Address or Domain Name to be added to the Address Group.

Import – Select to browse and import a CSV file or a text file to add the Email Address/Domain to
address group.

Manual – Select to manually add the Email Address/Domain to address group.

Figure 144: Address Group
4. Click Save to create Address Group.

Quarantine Digest Settings

This feature requires a subscription. It can be configured but cannot be enforced without a valid Email
Protection subscription.

This feature is NOT available in SF100 and SF200.

Quarantine Digest is an Email containing a list of quarantined Emails filtered by Device and held in the user
Quarantine Area. If configured, user receives Quarantine Digest as per the frequency in Device Configuration >
Protect > Email > Quarantine Digest Settings. Digest also provides a link to User Portal from where user can
access quarantined Emails and take the required action.
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Quarantine Digest settings can be configured globally for all the users or for individual users. User receives
Quarantine Digest as per the configured frequency.

The Quarantine Digest provides following information for each quarantined message:

• Date and time: Date and time when message was received
• Sender: Email Address of the sender
• Recipient: Email Address of the receiver
• Subject: Subject of the message

Configuring Quarantine Digest for All Users
Enable Quarantine Digest

Enable Quarantine Digest to configure digest service for all the users.

Email Frequency

Specify the mailing frequency for digest.

Digest can be mailed every hour, every day at configured time, or every week on the configured day
and time.

From Email Address

Specify Email Address from which the mail should be sent. Digest mail will be sent from the
configured mail address.

Display Name

Specify mail sender name. Digest mail will be sent with the configured name.

Send Test Email

Click and provide Email Address to which the message is to be sent for Email Address verification.

Reference User Portal IP

Select Interface/Port IP from the ‘Reference User Portal IP’ dropdown list.

User Portal link in Digest mail will point to this IP Address. User can click the link to access
his quarantined messages and take the required action. The users not falling under the specified
Interface will have to access the quarantine mail directly from their MyAccount.

Allow Override

Enable if you want user to override the Digest Settings. If enabled user can disable the digest service
so that they do not receive the Quarantine Digest.

Change User's Quarantine Digest Settings

Click to change the digest settings of the individual users.

It allows selecting the group and updating the Quarantine Digest Setting of group members.

Overriding Quarantine Digest Settings for a Specific User(s)

Click Change User’s Quarantine Digest Settings button to change the digest settings for the individual users. It opens
a new pop-up window named Manage Quarantine Digest which allows you to search groups and users for updating
the Quarantine Digest Settings of group members.

You can individually search for user and user groups.

Select the checkbox against the user to enable the Quarantine Digest. If enabled, configured Quarantine Digest
Settings are applicable for the user.
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Figure 145: Quarantine Digest Settings

File Types
The File Types page allows you to manage file types to be used in filtering policy.

The Device Configuration > Protect > Web > File Types page displays list of both built-in and custom file types
that you can control in policy expressions. For instance, you can restrict access to certain types of files within an
otherwise-permitted category.

A file type group consists of collections of files, identified by either file extenstion or MIME headers. Predefined File
Types are provided, and you can create new collections of file types using templates.

This page lists existing File Types collection. The predefined File Type collections can not be modified. For File
Type groups that you have added, you can edit or delete the by selecting the associated icon under the Manage
heading. To delete multiple File Types, select the associated checkboxes under the Name heading and click Delete at
the top of the page.

Click the Add button at the top to create a new File Type.

Add File Type Category
Create a File Type collection to be used in Internet filter policies.

Use the Device Configuration > Protect > Web > File Type page to create collections of File Types for use in
Internet policies. To create a new File Type collection:

1. Enter a Name for the new collection.
2. Under Template, either leave set to Blank or choose an option from the drop-down menu.

Selections under the Template drop-down will populate the File Extension and MIME Header fields with
information from our predefined File Types. From there, you can add extensions and MIME headers to extend the
definition of your new File Type Category.

3. Add entries to the File Extension and MIME Header text boxes to include those file types in your new category.
4. Add information in the Description text box to provide information about your new category.
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Figure 146: Add File Type Category
5. Click Save to create your new File Type Category.

Web Server
Web Server Protection provides facilities to manage and add web servers, define protection policies for them and set
up certificates.

The following pages are accessible:

• Web Servers on page 168: allows you to manage, add and delete settings of web servers connected to your
device.

• Protection Policies on page 170: let you define methods to protect your web servers against malicious attacks.
• Authentication Policies on page 174: helps to set up authentication policies for direct access to Sophos XG

Firewall.
• Authentication Templates on page 176: sets up customized HTML login forms.
• Certificates on page 178: manages certificates for authentication.
• Certificate Authorities on page 236: manages certificate authorities which issue certificates.
• Certificate Revocation Lists on page 238: gives an overview of revoked certificates.

Web Servers
On this page you can add the web servers that are to be protected by the WAF.

Device Configuration > Protect > Web Server > Web Servers

The page displays all existing web servers. You can add new real servers, edit or delete them. Following is a
description of the table elements:

Name

Displays the name of the web servers.

Type

Displays the type of the web servers.
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Manage

Displays the available managing options for the web servers:

• Edit Allows you to edit the web servers.
• Delete Allows you to delete the web servers.

To either add or delete a web server, click on the corresponding buttons.

Related tasks
Add a Web Server on page 169

Add a Web Server

This page describes how to add a web server.

1. Go to Device Configuration > Protect > Web Server > Web Servers and click Add.
2. Make the following settings:

Name
Enter a descriptive name for the web server.

Description
Enter a description or other information.

Host
Add or select a host, which can either be of the type Host or DNS Host.

Note:  DNS Host is recommended here because hosts listed with their IP address transmit empty host
headers which leads to problems with some browsers.

Type
Select a real web server type. Whether you want the communication between Sophos Firewall OS
and the real server to be encrypted (HTTPS) or plaintext (HTTP).

• Encrypted (HTTPS): Browser-based access to real web server via HTTPS.
• Plaintext (HTTP): Browser-based access to real web server via HTTP. Default.

Port
Enter a port number for the real web server. By default the standard port of the selected real server
type is selected.

Keep alive
Enable Keep alive to keep the connection between Sophos XG Firewall and the real server open
instead of opening a new connection for every single request..

Note:  In rare cases where the real web server does not support keep alive properly, this feature can
provoke reading errors or timeouts and should then be disabled for the affected real server.

Timeout
Enter a timeout for the Keep alive option. Values between 1 and 65535 seconds are allowed.
Default is 300 seconds.
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Figure 147: Add Web Server
3. Click Save to save your settings.

The server is created and appears in the web servers list.

 Protection Policies
With protocol security you can define the modes and levels of protection for your webservers.

Device Configuration > Protect > Web Server > App Protection Policies

The page displays all existing web application protection objects. You can add new protocol security objects, edit or
delete them. Following is a description of the table elements:

Name

Displays the name of the web app protection object.

Manage

Displays the available managing options for the web application protection object:

• Edit Allows you to edit the web app protection object.
• Delete Allows you to delete the web app protection object.

To either add or delete a web app protection object, click on the corresponding buttons.

Related concepts
Additional Information on Static URL Hardening and Form Hardening on page 173
Related tasks
Add Application Protection Policy on page 170
This page describes how to add an application protection policy.

Add Application Protection Policy
This page describes how to add an application protection policy.

1. Go to Device Configuration > Protect > Web Server > Protection Policies and click Add.
2. Specify the following:

Name
Specify a unique name for the protection policy.
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Description
Specify a description for the policy.

Pass Outlook Anywhere
Enable this to allow external Microsoft Outlook clients to access the Microsoft Exchange Server via
theWeb Application Protection. Microsoft Outlook traffic will not be checked or protected by the
Web Application Protection.

Mode
Select a mode from the drop-down list:

• Monitor: HTTP requests are monitored and logged.
• Reject: HTTP requests are rejected.

Cookie Signing
Enable this to protect a web server against manipulated cookies. When the web server sets a cookie,
a second cookie is added to the first cookie containing a hash built of the primary cookie's name,
its value and a secret, where the secret is only known by the Web Application Protection. Thus, if
a request cannot provide a correct cookie pair, there has been some sort of manipulation and the
cookie will be dropped.

Static URL Hardening
Enable this to protect against URL rewriting. For that, when a client requests a website, all static
URLs of the website are signed. The signing uses a similar procedure as with cookie signing.
Additionally the response from the web server is analyzed regarding what links can be validly
requested next. Moreover, static hardened URLs can furthermore be bookmarked and visited later.

Note:  Static URL hardening affects all files with a HTTP content type of text/*
or *xml*, where * is a wildcard. Make sure that other file types, e.g. binary files,
have the correct HTTP content type, otherwise they may get corrupted by the URL
hardening feature. It does not work for dynamic URLs created by client, for example:
JavaScript.

Note:  You can find more information about Static URL Hardening and Form
Hardening under: Additional Information on Static URL Hardening and Form
Hardening on page 173

Entry URLs (only applicable if Static URL Hardening is enabled)
Specify a URL for static URL hardening:

Form Hardening
Enable this to protect against web form rewriting. Form hardening saves the original structure of
a web form and signs it. Therefore, if the structure of a form has changed when it is submitted the
Web Application Protection rejects the request.

Note:  Form hardening affects all files with a HTTP content type of text/* or *xml*,
where * is a wildcard. Make sure that other file types, e.g. binary files, have the
correct HTTP content type, otherwise they may get corrupted by the form hardening
feature.

Note:  You can find more information about static URL hardening and form
hardening under: Additional Information on Static URL Hardening and Form
Hardening on page 173

Anti-Virus
Enable this to protect a web server against viruses.

Mode
Select a mode from the available options.

• Avira
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• Sophos
• Dual Scan

Direction
Select from the drop-down list whether to scan only uploads or downloads or both.

• Uploads
• Downloads
• Uploads and Downloads

Block unscannable content
Enable this to block files that cannot be scanned. The reason for that may be, among other things,
that files are encrypted or corrupt.

Limit scan size
Enable this to enter the scan size limit into an additional field. Provide the limitation in megabytes.

Note:  Please note that the scan size limit refers to the entire upload volume, not to
a single file. If, for example, you limit the scan size to 50 MB and make an upload
containing multiple files (45 MB, 5 MB and 10 MB), the last file will not be scanned.
Thus a virus being in the last file would not be detected due to the limitation.

Note:  If you do not specify a limitation value at all, the limit scan size will be saved
with '0' megabytes, which means the limitation is not active and every uploaded/
downloaded file will be scanned.

Block clients with bad reputation
Enable this to block clients which have a bad reputation according to their classification, based on
GeoIPClosed and RBLClosed information. Sophos uses the following classification providers: RBL
sources:

• Commtouch IP Reputation (ctipd.org)
• http.dnsbl.sorbs.net

The GeoIP source is Maxmind. The WAF blocks clients that belong to one of the following
Maxmind categories:

• A1: Anonymous proxies or VPN services used by clients to hide their IP address or their original
geographical location.

• A2: Satellite providers are ISPs that use satellites to provide Internet access to users all over the
world, often from high risk countries.

Skip remote lookups for clients with bad reputation (only applicable if Block clients with bad reputation is enabled)
Enable to use GeoIP-based classification which uses cached information only and is therefore much
faster. As reputation lookups include sending requests to remote classification providers, using
reputation-based blocking may slow down your system.

Common Threat Filter
Enable this to protect your web servers from several threats. You can specify the threat filter
categories you want to use in the Threat Filter Categories section below. All requests will be
checked against the rule sets of the selected categories. Depending on the results, a notice or a
warning will be shown in the live log or the request will be blocked directly.

Rigid Filtering
Enable this to tighten several of the selected rules. This may lead to false positives.

Skip Filter Rules
Some of the selected threat categories may contain rules that lead to false positives. To avoid false
positives induced by a specific rule, add the rule number that you want to skip in this field.

Protocol Violations
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Enforces adherence to the RFC standard specification of the HTTP protocol. Violating these
standards usually indicates malicious intent.

Protocol Anomalies
Searches for common usage patterns. Lack of such patterns often indicates malicious requests.
These patterns include, among other things, HTTP headers like 'Host' and 'User-Agent'.

Request Limits
Enforces reasonable limits on the amount and ranges of request arguments. Overloading request
arguments is a typical attack vector.

HTTP Policy
Narrows down the allowed usage of the HTTP protocol. Web browsers typically use only a limited
subset of all possible HTTP options. Disallowing the rarely-used options protects against attackers
aiming at these often less well-supported options.

Bad Robots
Checks for usage patterns characteristic of bots and crawlers. By denying them access, possible
vulnerabilities on your web servers are less likely to be discovered.

Generic Attacks
Searches for attempted command executions common to most attacks. After having breached a
webserver, an attacker usually tries to execute commands on the server like expanding privileges
or manipulating data stores. By searching for these post-breach execution attempts, attacks can be
detected that might otherwise have gone unnoticed, for example because they targeted a vulnerable
service by the means of legitimate access.

SQL Injection Attacks
Checks for embedded SQL commands and escape characters in request arguments. Most attacks on
web servers target input fields that can be used to direct embedded SQL commands to the database.

XSS Attacks
Checks for embedded script tags and code in request arguments. Typical cross-site scripting attacks
aim at injecting script code into input fields on a target web server, often in a legitimate way.

Tight Security
Performs tight security checks on requests, like checking for prohibited path traversal attempts.

Trojans
Checks for usage patterns characteristic of trojans, thus searching for requests indicating trojan
activity. It does not, however, prevent the installation of such trojans as this is covered by the
antivirus scanners.

Outbound
Prevents web servers from leaking information to the client. This includes, among other things,
error messages sent by servers which attackers can use to gather sensitive information or detect
specific vulnerabilities.

Figure 148: Add Application Protection Policy
3. Click Save.

Additional Information on Static URL Hardening and Form Hardening

It would be best practice to always enable both URL hardening and form hardening because those two functions are
complementary, especially in the way that they prevent issues you may have when enabling just one of them:

• Only form hardening is activated: When a webpage contains hyperlinks with appended queries (which is the case
with certain CMSs), e.g. http://example.com/?view=article&id=1, such page requests are blocked
by form hardening because it expects a signature, which is missing.
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• Only URL hardening is activated: When a web browser appends form data to the action URL of the form tag of
a web form (which is the case with GET requests), the form data becomes part of the request URL sent to the
webserver, by that rendering the URL signature invalid.

The reason why activating both functions solves those issues is that in case either form hardening or URL hardening
find that a request is valid, the WAF accepts the request.

Related tasks
Add Application Protection Policy on page 170
This page describes how to add an application protection policy.

Authentication Policies
You can define how to use the Web Application Firewall to authenticate users directly instead of leaving the
authentication to the real web servers. Via authentication profiles, the reverse authentication can be used to assign
specific authentication settings to each site path route.

Device Configuration > Protect > Web Server > Authentication Policies

Note:  You can also view and manage the WAF status on the Monitor and Analyze > Diagnostics > Services
page.

The page displays all existing web application authentication profiles. You can add new application authentication
profiles, edit or delete them. Following is a description of the table elements:

Name

Displays the name of the web app authentication profile.

Manage

Displays the available managing options for the web app authentication profile:

• Edit Allows you to edit the web app authentication profile.
• Delete Allows you to delete the web app authentication profile.

To either add or delete a web app authentication profile, click on the corresponding buttons.

Related tasks
Add Web App Authentication on page 174

Add Web App Authentication

This page describes how to add a web app authentication profile.

1. Go to Device Configuration > Protect > Web Server > Authentication Policies and click Add.
2. Enter values for the following settings:

Name
Enter a descriptive name for the web app authentication profile.

Description
Enter a description or other information.

3. Make the settings for the Client Authentication.
Mode

Select how the users should authenticate at the Web Application Firewall.

• Basic: Users authenticate with HTTP basic authentication, entering username and password. As
the credentials are sent unencrypted with this mode, it should be used over HTTPS. With this
mode, no session cookies will be generated and a dedicated logout is not possible.

• Form: Users will be presented a form where they have to enter their credentials. With this mode,
session cookies will be generated and a dedicated logout is possible. The form template to be
used can be selected in the Web App Auth Template list. Besides the default form template, the
list shows the forms that have been defined on the Web App Auth Templates page
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Basic Prompt
(only with Basic mode)

The realm is a unique string that provides additional information on the login page and is used for
user orientation.

Note:  These characters are allowed for the Basic Prompt: A-Z a-z 0-9 , ; . : - _ ' + = )
( & % $ ! ^ < > | @

Web App Auth Template
Select the form template that will be presented to the users for authentication. Form templates are
defined on the Web App Auth Templates page.

User or Groups
Select the users or user groups that should be assigned to this web app authentication profile. After
assigning this profile to a site path route, these users will have access to the site path with the
authentication settings defined in this profile. Typically, this would be a backend user group.

Note:  Sometimes users should be required to use the User Principal Name notation
'user@domain' when entering their credentials, for example when using Exchange
servers in combination with Active Directory servers.

4. Make the settings for the Authentication Forwarding.
Mode

Select how the Web Application Firewall authenticates against the real webservers. The mode has to
match the webservers authentication settings.

• Basic: Authentication works with HTTP basic authentication, providing username and
password.

• None: There is no authentication between WAF and the webservers. Note that even if your real
webservers do not support authentication, users will be authenticated via the frontend mode.

User name affix
(only with Basic Authentication Forwarding mode)

Select an affix for the username and enter it into the concerning field. Affixes are useful when
working with domains and email addresses.

• None
• Prefix
• Suffix
• Prefix & Suffix

Note:  Prefix and suffix will be added automatically if the user enters their username.
Prefix and suffix will not be added if the user enters it. Example: If the suffix is
@testdomain.de and the user enters their username test.user the suffix will be added.
If they enter test.user@testdomain.de the suffix will be ignored.

Remove Basic Header
(only with None Authentication Forwarding)

Enable to not send the basic header from Sophos Firewall OS to the real webserver.
5. Make the settings for the User Session.

Session Timeout
Enable to set a timeout for the user session, which will confirm user credentials by having them log
in again if they do not perform any action on the virtual webserver.

Limit To
(only if Session Timeout is enabled)

Set an interval for the session timeout. Default is 5 minutes.
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Session Lifetime
Enable to set a hard limit for how long users may remain logged in, regardless of activity in the
meantime.

Limit To
(only if Session Lifetime is enabled)

Set a value for the session lifetime. Default is 8 hours.

Figure 149: Add Web App Authentication Policies
6. Click Save.

The Web App Authentication profile is created and appears in the Web App Authentication list.

Authentication Templates
You can upload HTML forms for reverse authentication. A web application authentication template can be assigned to
an authentication profile with frontend mode Form. The respective form will be presented when a user tries to access
a site path to which the authentication profile is assigned.
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Device Configuration > Protect > Web Server > Authentication Templates

The page displays all existing web application authentication templates. You can add new templates, edit or delete
them. Following is a description of the table elements:

Name

Displays the name of the template.

Template

Displays the filename of the template.

Manage

Displays the available managing options for the template:

• Edit Allows you to edit the template.
• Delete Allows you to delete the template.

To either add or delete a web app auth template, click on the corresponding buttons.

Related tasks
Add a Web App Auth Template on page 177

Add a Web App Auth Template

This page describes how to add a web application authentication template.

1. Go to Device Configuration > Protect > Web Server > Authentication Templates and click Add.
2. Make the following settings:

Name
Enter a descriptive name for the template.

Description
Enter a description or other information.

HTML template
Select and upload an HTML template.

Images/Stylesheet
Select and upload images, stylesheets, or JavaScript files that are used by the selected template.

Figure 150: Add Web App Auth Template
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3. Click Save to save your settings.

The web app auth template is created and appears in the Authentication Templates list.

Certificates
The Certificates page displays list of available certificates.

A digital certificate is a document that guarantees the identity of a person or entity and is issued by the Certificate
Authority (CA). Certificates are generated by the third party trusted CA. They create certificates by signing public
keys and identify the information of the communicating parties with their own private keys. This way it is possible
to verify that a public key really belongs to the communicating party only and not been forged by someone with
malicious intentions.

A certificate signed by a Certificate Authority (CA) identifies the owner of a public key. Each communicating party
may be required to present its own certificate signed by a CA verifying the ownership of the corresponding private
key. Additionally, the communicating parties need to have a copy of the CA’s public key. In case private key is lost or
stolen or the information is changed, CA is responsible for revoking the certificate.CA also maintains the list of valid
and revoked certificates.

To use Certificates for authentication, you must have valid CA and a certificate. You need to upload CA if you are
using external CA. You can generate a self signed certificate if you want to use it as CA.

You can also use device to act as a certificate authority and sign its own certificates. This eliminates the need of
having your own certificate authority. If you are using device as CA, you have to generate a self-signed certificate,
which can be used in various VPN policies.

The page also provides option to generate a self-signed certificate, upload a certificate, or generate a Certificate
Signing Request (CSR).This page also provides option to regenerate, revoke, download, or delete the certificates.

If you are using a third party CA, you have to submit a request to CA for issuing a certificate. Once CA issues a
certificate, you have to upload to use it in VPN policy.

This page provides option to:

• Add a New Certificate
• Download the Certificate
• Revoke the Certificate

Add Certificate
Use the Certificate page to add a new certificate.

The Certificate page allows you to generate a self-signed certificate, upload a certificate, or generate a Certificate
Signing Request (CSR).

1. Go to Device Configuration > Protect > Web Server > Certificates or Device Configuration > Configure >
VPN > Certificates and click Add.

2. Choose the action you want to perform.
Action

Select action from the available options.

Available Options:Upload CertificateGenerate Self-Signed CertificateGenerate Certificate Signing
Request

Upload Certificate
Use the Certificate page to upload a certificate.

1. Enter Upload Certificate details.
Name

Specify a name to identify the Certificate.

Certificate File Format
Select the format of Certificate file from the available options.
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Available Options: PEM (.pem): Privacy Enhanced Mail (PEM) is a Base64encoded DER
certificate. It is used for encoding the certificate in ASCII code. The certificate and private key
are stored in separate files. DER (.der): Distinguished Encoding Rules (DER) is a binary form of
ASCII PEM format certificate used on Java platform. The certificate and private key are stored
in separate files. CER (.cer): Canonical Encoding Rules (CER) is a binary format for encoding
certificates. It contains information about the owner of certificate, its public and private keys.
PKCS7 (.p7b): Public Key Cryptography Standards (PKCS) is a format for encoding the certificate
in ASCII code. It contains only certificates and not the private key. PKCS12 (.pfx or .p12): Public
Key Cryptography Standards (PKCS12) is a binary format for encoding certificates. It stores a
private key with a public key certificate. It is used on Windows platform.

Certificate
Specify certificate to be uploaded. Use Browse to select the complete path.

Private Key
Specify private key for the certificate. Use Browse to select the complete path.

Passphrase
Specify and re-confirm a passphrase for a certificate used for authentication. Passphrase must be at
least 4 characters long.

Figure 151: Upload Certificate
2. Click Save to upload the certificate.

Generate Self-Signed Certificate
Use the Certificate page to generate self-signed certificate.

1. Enter details to generate Self Signed Certificate (Option available only after configuring Default CA Parameters)
Name

Specify a name to identify the Certificate.

Valid From and Valid Up To

Specify certificate validity period using Calendar . Validity period is the certificate life and
indicates period up to which the certificate will be considered as valid.

Default - 1 day

Key Length
Select key length. Key length is the number of bits used to construct the key.

Available Options:5121024153620484096

Generally, the larger the key, the less chance that it will be compromised but requires more time to
encrypt and decrypt data than smaller keys.
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Default - 512

Key Encryption
Click to enable the key encryption.

Passphrase
Passphrase for a Certificate used for authentication. Passphrase must be at least 8 characters long.
This option is enabled only if the Key Encryption option is selected.

Confirm Passphrase
Re-enter passphrase for confirmation.

Certificate ID
Specify certificate ID. You can specify any one of the following options:

Available Options: DNSIP Address(IPv4/IPv6 Address) Email Address DER ASN1 DN(X.509)
(Applicable when Authentication Type is Digital Certificate)

Once the certificate is created, you need to download and send this certificate to the remote peer
with whom the connection is to be established.

Country Name
Select the country.

State
Specify the state within the country.

Locality Name
Specify the name of the locality.

Organization Name
Specify the organization name, which will use this certificate and domain name. This domain will
be certified to use the Certificate.

Use unique Domain name only.

Organization Unit Name
Specify the department/unit name, which will use this certificate and domain name. This domain
will be certified to use the Certificate.

Use unique Domain name only.

Common Name
Specify the common name.

A common name comprises of host + domain name or is a fully qualified domain name that is used
to resolve to SSL VPN interface. It must be same as that of the Web address to be accessed when
connecting to a secured site.

Email Address
Specify the Email Address of the contact person for communication.

2. Click Save to generate self-signed certificate.

Generate Certificate Signing Request
Use the Certificate page to generate certificate signing request.

1. Enter details to generate Certificate Signing Request (CSR).
Name

Name to identify the certificate.

Valid Upto
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Specify certificate validity period using Calendar. Validity period is the certificate life i.e. period up
to which the certificate will be considered as valid.

Minimum validity -1 day

Key Length
Select key length. Key length is the number of bits used to construct the key.

Generally the larger the key, the less chance that it will be compromised but requires more time to
encrypt and decrypt data than smaller keys.

Encryption
Click to enable the key encryption.

Passphrase
Passphrase for a Certificate used for authentication. Passphrase must be at least 4 characters long.
This option is available only if the Encryption option is checked.

Confirm Passphrase
Re-enter passphrase for confirmation.

Certificate ID
Specify certificate ID. You can specify any one of the following options:

Available Options: DNS IP AddressEmail Address

DER ASN1 DN(X.509) (Applicable when Authentication Type is Digital Certificate)

Country Name
Select the Country for which the Certificate will be used.

Generally, this would be the name of the country where device is deployed.

State
Select the State for which the Certificate will be used.

Generally, this would be the name of the state where device is deployed.

Locality Name
Select the Locality for which the Certificate will be used.

Generally, this would be the name of the Locality where device is deployed.

Organization Name
Specify your organization name, which will use this certificate and domain name. This domain will
be certified to use the Certificate.

Use unique Domain names only.

Organization Unit Name
Specify your department/unit name, which will use this certificate and domain name. This domain
will be certified to use the Certificate.

Use unique Domain names only.

Common Name
Specify Common Name.

Email Address
Specify Email Address.

2. Click Save to generate certificate signing request.

Download Certificate
Use the Certificate page to download the certificate.
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1. Go to Device Configuration > Protect > Web Server > Certificates .
2.

Under the Manage column, click the Download Icon  against the certificate you want to download.

Note:

• Only self signed certificate and certificate signing request can be downloaded.
• Certificate is downloaded as a .tar.gz file.

Revoke Certificate
Use the Certificate page to revoke the certificate.

1. Go to Device Configuration > Protect > Web Server > Certificates .
2.

Under the Manage column, click the Revoke Icon  to revoke self-signed certificate if lost, stolen or updated.
Revoked certificate is automatically added to the Certificate Revocation List (CRL). You can download revoked
certificate and circulate if required.

General Settings
You can activate SlowHTTP protection and define the TLS version.

The SlowHTTP Protection page helps to protect against Slow HTTP attacks by setting a timeout for request headers.

1. Go to Device Configuration > Protect > Web Server > General Settings.
2. Specify the details for SlowHTTP Protection:

Timeout for request headers
Enable to activate SlowHTTP Protection.

Soft limit
Enter the minimum amount of time in second(s) to receive a request header.

Default value: 10.

Hard limit
Enter the maximum amount of time in seconds(s) to receive a request header.

Defaut value: 30.

Extension rate
Enter the amount of data volume in byte(s) which extends the timeout.

With the extension rate, you can increase the minimal timeout according to the data volume. For
example, the soft limit allows at least 10 seconds to receive request headers, the extension rate is
500, and the hard limit is set to 30. If the client now sends data, the soft limit timeout increases 1
second for every 500 bytes received. After 30 seconds the client will be disconnected.

Default value: 5000.

Skipped Networks/Hosts
Select or add networks/hosts that should not be affected by SlowHTTP Protection.
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3. Click Apply.

TLS Version Settings

1. Select the minimal TLS version that is allowed to connect to the WAF.
If you select TLS version 1.2, clients using Microsoft Internet Explorer 6, 7, or 8, or Microsoft Windows XP will
not be able to connect to the WAF.

2. Click Apply.

Advanced Threat

Advanced Threat Protection
This page allows the administrator to configure the Advanced Threat Protection feature.

ATP can help rapidly detect infected or compromised clients inside the network and raise an alert or drop the
respective traffic.

The Advanced Threat Protection analyzes network traffic, e.g., DNS requests, HTTP requests, or IP packets in
general, coming from and going to all networks. It also incorporates Intrusion Prevention and Antivirus data if the
respective features are activated.

Note:  Advanced Threat Protection module is a subscription module that needs to be subscribed before use.

By default Advanced Threat Protection is disabled. To enable Advanced Threat Protection, click on the slider. This
will make different setting fields editable.

Policy: Select the security policy that the Advanced Threat Protection system should use if a threat has been detected.

Available Options:

• Log and Drop: The data packet will be dropped and logged.
• Log Only: The data packet will be logged.

Network/Host Exceptions: Add or select the source networks or hosts that should be exempt from being scanned for
threats by Advanced Threat Protection. How to add an IP host is explained on the Device Configuration > System > 
Host and Services >  IP Host page.

Threat Exceptions: Add destination IP addresses or domain names that you want to skip from being scanned for
threats by Advanced Threat Protection.

Caution - Be careful with specifing exceptions. By excluding sources or destinations you may expose your network
to severe risks.

Security Heartbeat
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Heartbeat connects cryptographically secure endpoint and Sophos Firewall OS via Sophos Cloud. This allows to
exchange information between endpoint devices and Sophos Firewall OS. These information give a comprehensive
overview of the network security. The administrator is able to define policies for network access based on the health
status of the endpoint.

Endpoint devices and users need to authenticate via Sophos Cloud to connect to Sophos Firewall OS. The
authentication works via a client which is available on Sophos Cloud and must be installed on the endpoint device.
After the installation the endpoint uses the Sophos Endpoint Security and Control which is an integrated suite of
security software, for example, antivirus, behavior monitoring and live protection. Sophos Endpoint Security and
Control ensures that the endpoint device belongs to the system and has the permission to access the network.

Note:  For more information and documentation about Sophos Endpoint Security and Control visit the
Sophos Website.

The endpoint sends a heartbeat signal in regular intervals to the Sophos Firewall OS to show that it is alive.
Furthermore the endpoint also informs the Sophos Firewall OS about potential threats. If Sophos Endpoint Security
and Control detects any threats, the endpoint sends this information to Sophos Firewall OS which declares the
endpoints health status. According to the user policy, which defines the permission of the different colors, the
endpoint is not able to connect to networks, zones or services.

Note:  You can enable Security Heartbeat and set the Minimum Heartbeat Permitted in the User
Application Policy which is managed on the Firewall page in the Security Heartbeat section.

Note:  Please find a description of the enpoints health status colors on the Health Status page.

To use security heartbeat you need to register with your Sophos Cloud account. If you do not have an account you
can create a new one. You can find more information about Sophos Cloud under: https://secure2.sophos.com/en-us/
products/cloud.aspx.

Synchronized Security
The Synchronized Security menu allows you to configure Security Heartbeat to share health information and the
Enhanced Application Control.

This page describes how to login with your Sophos Cloud account and enable Security Heartbeat.

1. Go to Device Configuration > Protect > Synchronized Security.
2. Enter Sophos Cloud login details in the Registration section.

Email Address
Enter the email address of your Sophos Cloud account.

Password
Enter the password of your Sophos Cloud account.

Figure 152: Registration
3. Click Register to register your Sophos Cloud account to the Sophos Firewall OS.
4. Enable Security HeartBeat and add zones to the Missing Heartbeat Zones field.

https://www.sophos.com/en-us/support/documentation/endpoint-security-and-control-for-windows.aspx
https://secure2.sophos.com/en-us/products/cloud.aspx
https://secure2.sophos.com/en-us/products/cloud.aspx
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Figure 153: Security HeartBeat

Missing heartbeats will be detected only in these zones.

Note:  If a zone is blocked by a policy but no zone is added here, the Security Heartbeat widget in the
Control Center shows “Missing”.

5. Enable Enhanced Application Control and click Apply.

Figure 154: Enhanced Application Control

The devices for which the Security Heartbeat is enabled are listed in Devices enabled for Security Heartbeat.

To clear your registration from Sophos Firewall OS, click Clear Registration.

Configure

VPN
VPN section allows you to configure required IPSec, L2TP, PPTP VPN connections.

A Virtual Private Network (VPN) is a tunnel that carries private network traffic from one endpoint system to another
over a public network such as the Internet without the traffic, being aware that there are intermediate hops between
the endpoints or the intermediate hops being aware they are carrying the network packets that are traversing the
tunnel. The tunnel may optionally compress and/or encrypt the data, providing enhanced performance and some
measure of security. VPN allows you to pretend you are using a leased line or a direct telephone call to communicate
between the endpoints. VPNs allow users and telecommuters to connect to their corporate intranets or extranets.
VPNs are cost-effective because users can connect to the Internet locally and tunnel back to connect to corporate
resources. This not only reduces overhead costs associated with traditional remote access methods, but also improves
flexibility and scalability. For all business people traveling or working from home, connecting securely to the
corporate network is essential. With the Device, setting up a VPN is almost effortless.

The two endpoints in Device VPN are referred to as:

• Local - First endpoint is the local machine itself.
• Remote - Second endpoint is the remote peer - the machine you are trying to establish a VPN connection to, or the

machine which is trying to establish a VPN connection with you.

Device VPN automatically encrypts the data and sends it to the remote site over the Internet, where it is automatically
decrypted and forwarded to the intended destination. By encrypting, the integrity and confidentiality of data is
protected even when transmitted over the un-trusted public network. Device uses IPSec standard i.e. IPSec protocol to
protect traffic. In IPSec, the identity of communicating users is checked with the user authentication based on Digital
Certificates, public keys or Preshared Keys.

Device ensures that all the VPN traffic passing through the VPN tunnels is threat free. All the Firewall Rules
and policies are applicable to the traffic going into the VPN tunnels and coming out of the VPN tunnels. Device
inspects all the traffic passing through the VPN tunnels and makes sure that there are no viruses, worms, Spam, and
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inappropriate content or intrusion attempts in the VPN traffic. As VPN traffic is, by default subjected to the DoS
inspection, Device provides a facility by which one can bypass scanning of traffic coming from certain hosts from
VPN zone. The above functionality is achieved by adding one additional zone called VPN zone. VPN traffic passes
through VPN zone and Firewall Rule can be applied to VPN zone.

Device can be used to establish VPN connection between sites, LAN-to-LAN and Client-to-LAN connection. VPN is
the bridge between Local & Remote networks/subnets.

Device supports following protocols to authenticate and encrypt traffic:

• Internet Protocol Security (IPSec)
• Layer Two Tunneling Protocol (L2TP)
• Point-to-Point Tunneling Protocol (PPTP)
• Secure Socket Layer (SSL)

IPsec Connections
IPSec Connections page allows you to create and manage IPSec Connections.

IP Security (IPSec) is a suite of protocols designed for cryptographically secure communication at the IP layer (layer
3).

IPSec protocols:

• Authentication Header (AH) – Used for the authentication of packet senders and for ensuring the integrity of
packet data. The Authentication Header protocol (AH) checks the authenticity and integrity of packet data. In
addition, it checks that the sender and receiver IP Addresses have not been changed in transmission. Packets
are authenticated using a checksum created by using a Hash-based Message Authentication Code (HMAC) in
connection with a key.

• Encapsulating Security Payload (ESP) – Used for encrypting the entire packet and for authenticating its
contents. In addition to encryption, the ESP offers the ability to authenticate senders and verify packet contents.

IPSec Connections

The Connection page displays list of all the IPSec connections. You can filter the list based on policy name, failover
group name, policy name, connection type, status of the connection, local subnet, remote subnet, remote gateway,
local ID, or remote ID. The page also provides option to add a new connection, update the parameters of the existing
policy, or delete a policy. Page also provides option to create a connection manually or through connection wizard. In

case of Remote Access Connection export the connection configuration by clicking Export  icon under the Manage
column.

Note:  You can also view and manage active IPSec connections on the System > Current Activity > IPsec
Connections page. (Only at appliance level)

The page displays status of each connection as follows:

Connection Status Description

Active Connection

Connection is active but not connected. Click to initiate the connection.

Connection is active and connected. Click to disconnect the connection.
When you disconnect, connection will be deactivated and to re-establish the
connection, activate connection.

Connection is active but partially connected. Click to disconnect the
connection. When multiple subnets are configured for LAN and/or remote
network, Device creates sub-connection for each subnet. This status
indicates that one of the sub-connections is not active.
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Connection Status Description

Connection is deactive. Click to activate the connection.

Connection

Device supports the following IPSec connections types:

• Remote Access – This type of VPN is a user-to-internal network connection via a public or shared network. Many
large companies have employees that need to connect to the internal network from the field. These field agents
access the internal network by using remote computers and laptops without static IP Address.

• Site to Site – A Site to Site VPN connects an entire network (such as a LAN or WAN) to a remote network via a
network-to-network connection. A network-to-network connection requires routers on each side of the connecting
networks to transparently process and route information from one node on a LAN to another node on a remote
LAN.

• Host to Host – Host to Host VPN connects one desktop or workstation to another by way of a host-to-host
connection. This type of connection uses the network to which each host is connected to create a secure tunnel
with each other.

Add IPSec Remote Access Connection

Page describes how you can create an IPSec Remote Access Connection

1. Go to Device Configuration > Configure > VPN > IPSec Connections and click Add under IPSec
Connections. Select Connection Type as Remote Access.

2. Enter the parameter values as below.
General Settings

Name

Specify a unique name to identify IPSec Connection.

Description

Provide description for IPSec VPN Connection.

Connection Type
Select Remote Access.

Policy

Select policy to be used for connection.

Policy can also be added by clicking on “Create New” link.

Action on VPN Restart

Select the Action to be taken on the connection when VPN services or Device restarts.

Available Options

Respond Only – Keeps connection ready to respond to any incoming request.

Disable – Keeps connection disabled till the user activates.
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Figure 155: General Settings

Authentication Details

Authentication Type

Select Authentication Type. Authentication of user depends on the type of connection.

Available Options:

Preshared Key

Preshared Key authentication is a mechanism whereby a single key is used for encryption and
decryption. Both the peers should possess the Preshared Key. Remote peer uses the Preshared Key
for decryption. On selecting this option the user shall require to provide the following details:

Preshared Key – Specify the Preshared Key to be used. Preshared Key should be of minimum 5
characters.

Confirm Preshared Key – Provide the same Preshared Key to confirm it.

This Preshared Key will have to be shared or communicated to the peer at the remote end. At the
remote end, client will have to specify this key for authentication.

If there is a mismatch in the key, user will not be able to establish the connection.

Digital Certificate

Digital Certificate authentication is a mechanism whereby sender and receiver both use Digital
Certificate issued by the Certificate Authority. Both sender and receiver must have each other’s
Certificate Authority.

Local Certificate – Select the local certificate that should be used for authentication by the Device.

Remote Certificate – Select the remote certificate that should be used for authentication by remote
peer.

Figure 156: Authentication Details
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Endpoint Details

Local

Select Local WAN port from the list.

IP Aliases created for WAN interfaces will be listed along with the default WAN interfaces.

Remote

Specify an IP Address or domain name of the remote peer.

Figure 157: Endpoints Details

Network Detail

IP Family

IP family will be enabled automatically according to the IP selected in Local WAN port.

Local Subnet

Select Local LAN Address.

Add and Remove LAN Address using Add Button and Remove Button.

Local ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

Note:  In case of Local Certificate, ID and its value is displayed automatically as
specified in the Certificate.

Allow NAT Traversal

Enable NAT traversal if a NAT device is located between your VPN endpoints i.e. when remote peer
has private/non-routable IP Address.

At a time only one connection can be established behind one NAT-box.

Remote LAN Network

Select IP Hosts from the list of IP Hosts available. You can also add a new IP Host and include in
the list by clicking on “Add New Item” link.

Remote ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

Note:  In case of Local Certificate, ID and its value is displayed automatically as
specified in the Certificate.
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Figure 158: Network Detail

User Authentication

User Authentication Mode

Select whether User Authentication is required at the time of connection or not from the available
options.

Available Options:

Disabled – Click Disable if user authentication is not required.

Enable as Client – If enabled as client, specify username and password.

Enable as Server – If enabled as server, add all the users which are to be allowed to connect.

Figure 159: User Authentication

Quick Mode Selectors

Protocol

Select all the protocols that are to be allowed for negotiations.

Tunnel will pass only that data which uses the specified protocol.

Available Options:

All ICMP UDP TCP
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Local Port

Specify Local Port number that the local VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Local port Range: 1 – 65535

To specify any local port, enter *.

Remote Port

Specify Remote Port number that the remote VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Local port Range: 1 – 65535

To specify any local port, enter *.

Figure 160: Quick Mode Selectors

Advanced Settings

Disconnect when tunnel is idle

Click this option to allow Device to delete an Idle VPN Session if it exceeds the specified Idle
session time interval.

Default - Disable

Idle session time interval (Only if Disconnect when tunnel is idle option is “Enabled”)

Specify the time limit after which an Idle VPN Session will be deleted by Device.

Acceptable Range - 120 to 999

Figure 161: Advanced Settings
3. Click Save to create connection.

Add IPSec Site to Site Connection

Page describes how you can create an IPSec Site to Site Connection

1. Go to Device Configuration > Configure > VPN > IPSec and click Add under IPSec Connections. Select
Connection Type as Site to Site.

2. Enter the parameter values as below.
General Settings

Name

Specify a unique name to identify IPSec Connection.
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Description

Provide description for IPSec VPN Connection.

Connection Type
Select Site to Site.

Bind With an Interface

Enable to bind the IPSec VPN tunnel with an interface for configuring Route-based VPN.

In Route-based VPN approach, routing decides which packets to route through the VPN tunnel.

On creation of an interface-based tunnel, a virtual tunnel interface will be created which will be
displayed along with other interfaces for configuring Static and Dynamic routes.

Policy

Select policy to be used for connection.

Policy can also be added by clicking “Create New” link.

Action on VPN Restart

Select the Action to be taken on the connection when VPN services or Device restarts.

Available Options

Respond Only – Keeps connection ready to respond to any incoming request.

Initiate – Activates connection on system/service start so that the connection can be established
whenever required.

Disable – Keeps connection disabled till the user activates.

Route-based IP Address Details (Only if Bind With an Interface is enabled)

Local IP Address

Specify local IP Address for the tunnel interface.

You must configure this interface detail, if you want to use the interface in configuring dynamic
routing.

Remote IP Address

Specify remote IP Address for the tunnel interface.

You must configure this interface detail, if you want to use the interface in configuring dynamic
routing.
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Figure 162: General Settings

Authentication Details

Authentication Type

Select Authentication Type. Authentication of user depends on the type of connection.

Available Options:

Preshared Key

Preshared Key authentication is a mechanism whereby a single key is used for encryption and
decryption. Both the peers should possess the Preshared Key. Remote peer uses the Preshared Key
for decryption. On selecting this option the user shall require to provide the following details:

Preshared Key – Specify the Preshared Key to be used. Preshared Key should be of minimum 5
characters.

Confirm Preshared Key – Provide the same Preshared Key to confirm it.

This Preshared Key will have to be shared or communicated to the peer at the remote end. At the
remote end, client will have to specify this key for authentication. Refer to VPN Client guide, Phase
1 Configuration.

If there is a mismatch in the key, user will not be able to establish the connection.

Digital Certificate

Digital Certificate authentication is a mechanism whereby sender and receiver both use Digital
Certificate issued by the Certificate Authority. Both sender and receiver must have each other’s
Certificate Authority.

Local Certificate – Select the local certificate that should be used for authentication by the Device.

Remote Certificate – Select the remote certificate that should be used for authentication by remote
peer.

RSA Key

RSA Key authentication is a mechanism whereby two keys – Local and Remote RSA - are used for
encryption and decryption.

Local RSA Key – It is known only to the owner and never transmitted over network. Displays
automatically generated key which cannot be modified.

Remote RSA Key – It can be regenerated from CLI Console. Refer to Console guide for more
details.
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Figure 163: Authentication Details

Endpoint Details

Local

Select Local WAN port from the list.

IP Aliases created for WAN interfaces will be listed along with the default WAN interfaces.

Remote

Specify an IP Address or domain name of the remote peer.

Click Add icon  against the option “Remote” to add new endpoint pairs or click Remove icon

 to remove the endpoint pairs.

Figure 164: Endpoints Details

Network Detail

IP Family

Select IP family to configure IPSec VPN tunnels with mixed IP families.

Available Options:

IPv4 IPv6

By default, IPv4 will be selected.

Four types of IPSec VPN tunnels can be created:

4 in 4 (IPv4 subnets with IPv4 gateway)

6 in 6 (IPv6 subnets with IPv6 gateway)

4 in 6 (IPv4 subnets with IPv6 gateway)

6 in 4 (IPv6 subnets with IPv4 gateway)

Local Subnet

Select Local LAN Address.

Add and Remove LAN Address using Add Button and Remove Button.

NAT Local LAN

Enable to NAT the LAN IP Address.

NATed LAN (only if NAT Local LAN is configured)

Select IP Host or Network Host from the available list. The Device assigns the configured IP
address to differentiate between LANs at both the ends of VPN tunnel.
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IP Host can also be added by clicking “Add IP Host” link.

Local ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

Note:  In case of Local Certificate, ID and its value is displayed automatically as
specified in the Certificate.

Allow NAT Traversal

Enable NAT traversal if a NAT device is located between your VPN endpoints i.e. when remote peer
has private/non-routable IP Address.

At a time only one connection can be established behind one NAT-box.

Remote LAN Network

Select IP Addresses and netmask of remote network which is allowed to connect to the Device
server through VPN tunnel. Multiple subnets can be specified. Select IP Hosts from the list of IP
Hosts available. You can also add a new IP Host and include in the list.

Remote ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

Note:  In case of Local Certificate, ID and its value is displayed automatically as
specified in the Certificate.

In a single connection, same subnet for LAN and Remote Network cannot be configured.
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Figure 165: Network Detail

User Authentication

User Authentication Mode

Select whether User Authentication is required at the time of connection or not from the available
options.

Available Options:

Disabled – Click Disable if user authentication is not required.

Enable as Client – If enabled as client, specify username and password.

Enable as Server – If enabled as server, add all the users which are to be allowed to connect.

Figure 166: User Authentication

Quick Mode Selectors

Protocol

Select all the protocols that are to be allowed for negotiations.

Tunnel will pass only that data which uses the specified protocol.

Available Options:

All ICMP UDP TCP
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Local Port

Specify Local Port number that the local VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Local port Range: 1 – 65535

To specify any local port, enter *.

Remote Port

Specify Remote Port number that the remote VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Local port Range: 1 – 65535

To specify any local port, enter *.

Figure 167: Quick Mode Selectors

Advanced Settings

Disconnect when tunnel is idle

Click this option to allow Device to delete an Idle VPN Session if it exceeds the specified Idle
session time interval.

Default - Disable

Idle session time interval (Only if Disconnect when tunnel is idle option is “Enabled”)

Specify the time limit after which an Idle VPN Session will be deleted by Device.

Acceptable Range - 120 to 999

Figure 168: Advanced Settings
3. Click Save to create connection.

Add IPSec Host to Host Connection

Page describes how you can create an IPSec Host to Host Connection

1. Go to Device Configuration > Configure > VPN > IPSec and click Add under IPSec Connections. Select
Connection Type as Host to Host.

2. Enter the parameter values as below.
General Settings

Name

Specify a unique name to identify IPSec Connection.
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Description

Provide description for IPSec VPN Connection.

Connection Type
Select Host to Host.

Policy

Select policy to be used for connection.

Policy can also be added by clicking “Create New” link.

Action on VPN Restart

Select the Action to be taken on the connection when VPN services or Device restarts.

Available Options

Respond Only – Keeps connection ready to respond to any incoming request.

Initiate – Activates connection on system/service start so that the connection can be established
whenever required.

Disable – Keeps connection disabled till the user activates.

Figure 169: General Settings

Authentication Details

Authentication Type

Select Authentication Type. Authentication of user depends on the type of connection.

Available Options:

Preshared Key

Preshared Key authentication is a mechanism whereby a single key is used for encryption and
decryption. Both the peers should possess the Preshared Key. Remote peer uses the Preshared Key
for decryption. On selecting this option the user shall require to provide the following details:

Preshared Key – Specify the Preshared Key to be used. Preshared Key should be of minimum 5
characters.

Confirm Preshared Key – Provide the same Preshared Key to confirm it.

This Preshared Key will have to be shared or communicated to the peer at the remote end. At the
remote end, client will have to specify this key for authentication. Refer to VPN Client guide, Phase
1 Configuration.
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If there is a mismatch in the key, user will not be able to establish the connection.

Digital Certificate

Digital Certificate authentication is a mechanism whereby sender and receiver both use Digital
Certificate issued by the Certificate Authority. Both sender and receiver must have each other’s
Certificate Authority.

Local Certificate – Select the local certificate that should be used for authentication by the Device.

Remote Certificate – Select the remote certificate that should be used for authentication by remote
peer.

RSA Key

RSA Key authentication is a mechanism whereby two keys – Local and Remote RSA - are used for
encryption and decryption.

Local RSA Key – It is known only to the owner and never transmitted over network. Displays
automatically generated key which cannot be modified.

Remote RSA Key – It can be regenerated from CLI Console. Refer to Console guide for more
details.

Figure 170: Authentication Details

Endpoint Details

Local

Select Local WAN port from the list.

IP Aliases created for WAN interfaces will be listed along with the default WAN interfaces.

Remote

Specify an IP Address or domain name of the remote peer.

Click Add icon  against the option “Remote” to add new endpoint pairs or click Remove icon

 to remove the endpoint pairs.

Figure 171: Endpoints Details

Network Detail

IP Family

IP family will be enabled automatically according to the IP selected in Local WAN port.

Local ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.
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Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

Note:  In case of Local Certificate, ID and its value is displayed automatically as
specified in the Certificate.

Allow NAT Traversal

Enable NAT traversal if a NAT device is located between your VPN endpoints i.e. when remote peer
has private/non-routable IP Address.

At a time only one connection can be established behind one NAT-box.

Default-Enabled

Remote LAN Network

Select IP Addresses and netmask of remote network which is allowed to connect to the Device
server through VPN tunnel. Multiple subnets can be specified. Select IP Hosts from the list of IP
Hosts available on the Web Admin Console.

You can also add a new IP Host.

Remote ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

Note:  In case of Local Certificate, ID and its value is displayed automatically as
specified in the Certificate.
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Figure 172: Network Detail

User Authentication

User Authentication Mode

Select whether User Authentication is required at the time of connection or not from the available
options.

Available Options:

Disabled – Click Disable if user authentication is not required.

Enable as Client – If enabled as client, specify username and password.

Enable as Server – If enabled as server, add all the users which are to be allowed to connect.

Figure 173: User Authentication

Quick Mode Selectors

Protocol

Select all the protocols that are to be allowed for negotiations.

Tunnel will pass only that data which uses the specified protocol.

Available Options:

All ICMP UDP TCP



 | Device Configuration | 202

Local Port

Specify Local Port number that the local VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Local port Range: 1 – 65535

To specify any local port, enter *.

Remote Port

Specify Remote Port number that the remote VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Local port Range: 1 – 65535

To specify any local port, enter *.

Figure 174: Quick Mode Selectors

Advanced Settings

Disconnect when tunnel is idle

Click this option to allow Sophos XG Firewall to delete an Idle VPN Session if it exceeds the
specified Idle session time interval.

Default - Disable

Idle session time interval (Only if Disconnect when tunnel is idle option is “Enabled”)

Specify the time limit after which an Idle VPN Session will be deleted by Sophos XG Firewall.

Acceptable Range - 120 to 999

Figure 175: Advanced Settings
3. Click Save to create new connection.

VPN Wizard

The VPN Connection Wizard takes you step-by-step through the configuration of Site-to-Site IPSec VPN connection
between a Head Office (HO) device and multiple Branch Office (BO) devices simultaneously. After the configuration
is complete, the wizard creates new IPSec VPN connections on the HO and BOs.
VPN Wizard set-up

The VPN Wizard takes you step-by-step through the configuration of VPN connection between two managed devices
simultaneously.

1. Go to Device Configuration > Configure > VPN > VPN Wizard and click Add.
On clicking Add, the VPN Wizard starts which contains the following three sections:
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a. Select Device
b. Device Details
c. Security Information

2. Select the managed Head Office and Branch Office devices respectively based on the description shown below.
Head Office
Select Device

Select the Head Office device from the drop-down list of available devices.

Note:  Only one device can be selected as the Head Office device.

Note:  The list of available devices shows only those added devices which are
Connected and Synchronized with Sophos Central Firewall Manager.

Tunnel Name

Specify name to identify the tunnel for Head Office.

IP Family
Specify the IP type of the Head Office device subnet or Local End Point.

Description
Provide description for the Head Office device.

Branch Office
Select Devices

Select the Branch Office device from the drop-down list of available devices. You can select
multiple devices at a time.

Description
Provide description for the Branch Office device.

3. Configure connection details for the Head Office and Branch Office devices respectively.
Head Office Device
Policy

Select policy to be used for Head Office VPN connection. To create a new policy or go to Device
Configuration > Configure > VPN > IPSec page.

Local End Point

Select Local WAN port of the Head Office device from the list.

IP/Domain
Specify IP Address or domain name of the selected Head Office device.

Subnet

Select Local LAN Address of the Head Office device. Click Add IP Host to create a new IP Host.

Branch Office Devices
Policy

Select policy to be used for Head Office VPN connection. To create a new policy or go to Device
Configuration > Configure > VPN > IPSec page.

Note:  Select a policy that is compatible with Head Office Policy.

Local End Point

Select Local WAN port of the Head Office device from the list.

Override End Point



 | Device Configuration | 204

Select to override interface assignment and specify the Default End Point interface for all selected
devices. Alternatively, you can create dynamic interfaces for each device. To add more interfaces,

click the  icon to add more dynamic interfaces.

Subnet
Specify Local LAN Subnet for each managed Branch Office device.

4. Specify Security Information.

Specify Preshared Key for Head Office and all Branch Office devices.

Note:  Preshared Key should be of minimum 5 characters.

5. Click Finish to save the settings. On completing the VPN Wizard, all IPSec connections will be created. The
connections can later be managed from the VPN Wizard main page.

SSL VPN (Remote Access)
The remote access SSL feature of CFM is realized by OpenVPN, a full-featured SSL VPN solution. You can create
point-to-point encrypted tunnels between remote employees and your company, requiring both SSL certificates and
a username/password combination for authentication. This enables access to internal resources. In addition, a secure
User Portal is offered, which can be accessed by each authorized user to download a customized SSL VPN client
software bundle. This bundle includes a free SSL VPN client, SSL certificates and a configuration that can be handled
by a simple one-click installation procedure. The SSL VPN client supports most business applications such as native
Outlook, native Windows file sharing, and many more.

Device Configuration > Configure > VPN > SSL VPN (Remote Access)

Following is a description of the table elements:

Name

Displays the name of the SSL VPN remote access policy.

Use as Default Gateway

Displays if and which default gateway is used for the policy.

Description

Displays the description which was entered for the policy.

Manage

Displays the available managing options for the policy:

• Edit: Allows you to edit the policy.
• Delete: Allows you to delete the policy.

Add SSL VPN Remote Access Policy
This page allows adding SSL VPN remote access policies.

Following is a description of the different sections of this page:

Device Configuration > Configure > VPN > SSL VPN (Remote Access) > Add

General Settings

Name

Enter a descriptive name for the policy.

Description (optional)

Add a description or other information.
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Figure 176: General Settings

Identity

Policy Members

Click Add New Item to select available users/groups from a list or search for users/groups. Click Apply Selected
Items afterwards.

Note:  You can also view and manage active SSL VPN users on the System > Current Activity > SSL VPN
Users page. (Only at appliance level)

Selected items are displayed in the list. To remove an item from the list, click the “-” icon on the right of the item.

Figure 177: Identity

Tunnel Access

Use as Default Gateway

Activate the toggle switch if you want to use this as default gateway.

Permitted Network Resources (IPv4)

Click Add New Item to select available network resources from a list or search for network resources. Click Apply
Selected Items afterwards.

Selected items are displayed in the list. To remove an item from the list, click the Minus icon on the right of the item.

Permitted Network Resources (IPv6)

Click Add New Item to select available users/groups from a list or search for users/groups. Click Apply Selected
Items afterwards.

Selected items are displayed in the list. To remove an item from the list, click the Minus icon on the right of the item.
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Figure 178: Tunnel Access

Idle Timeout

Disconnect Idle Clients

Activate/deactivate by clicking the toggle switch. If activated, clients which are idle will be disconnected from the
session after a specified time.

Override Global Timeout (Default 15 Minutes) (only if Disconnect Idle Clients is activated.

Enter the value for the idle timeout in minutes.

Note:  Values between 15 and 60 minutes are valid.

Figure 179: Idle Timeout

To save the settings click Apply, to cancel, click Cancel.

Note:  New remote access policies immediately appear in the SSL VPN (Remote Access) list.

Note:  For Remote Access connections to work check that LAN and WAN zones are activated for the User
Portal on the System > Administration > Device Access page.

SSL VPN (Site to Site)
Site-to-site VPN tunnels can be established via an SSL connection. SSL VPN connections have distinct roles
attached. The tunnel endpoints act as either client or server. The client always initiates the connection, the server
responds to client requests. Keep in mind that this contrasts IPsec where both endpoints normally can initiate a
connection.

Device Configuration > Configure > VPN > SSL VPN (Site to Site)

Server Connections

This section lists all existing SSL VPN site-to-site server connections. Following is a description of the table
elements:

Status
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Displays if the connection is activated or not. You can activate/deactivate the connection with help of the displayed
toggle switch.

Connection Name

Displays the name of the connection.

Local Networks

Displays the local networks that are allowed to be accessed remotely.

Remote Networks

Displays the remote networks that are allowed to connect to the local network(s).

Manage

Displays the available managing options for the connection:

• Edit: Allows you to edit the connection.
• Delete: Allows you to delete the connection.

A connection can be added or deleted by pressing the concerning buttons.

Client Connections

This section lists all existing SSL VPN site-to-site client connections. Following is a description of the table elements:

Status

Displays if the connection is activated or not. You can activate/deactivate the connection with help of the displayed
toggle switch.

Connection Name

Displays the name of the connection.

Use HTTP Proxy Server

Displays the HTTP proxy server which is used for the connection.

Manage

Displays the available managing options for the connection:

• Edit: Allows you to edit the connection.
• Delete: Allows you to delete the connection.

A connection can be added or deleted by pressing the concerning buttons.

Add SSL VPN Site-to-Site Server Connection

This page describes how to add a SSL VPN site-to-site server connection.

1. Go to Device Configuration > Configure > VPN > SSL VPN (Site to Site) and click Add in the Server section.
2. Enter values for the following settings:

Connection Name
Enter a descriptive name for the connection.

Use Static Virtual IP Address (optional)
Only select this option if the IP address pool is not compatible with the client's network
environment: By default clients are assigned an IP address from a Virtual IP pool. Rarely, it may
happen that such an IP address is already in use on the client's host. In that case enter a suitable IP
address in the Static Peer IP field which will then be assigned to the client during tunnel setup.

Local Networks
Select or add one or more remote networks that are allowed to connect to the local network(s).
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Remote Networks
Select or add one or more remote networks that are allowed to connect to the local network(s).

Description (optional)
Enter a description or other information.

Figure 180: Add SSL Connection
3. Click Save to save your settings.

The new SSL server connection appears on the Server list.

To either edit or delete a server connection, click the corresponding buttons in the Server list.

The next step is the client configuration which has to take place on client side and not on server side. Download the
client configuration file with help of the provided button in the Server list.

Note:  If you want to send the file via mail it is recommended to use the encryption option which is provided
in the download dialog.

How to configure the client is described in chapter System > VPN > SSL VPN Site-to-Site > Add Client Site-to-
Site.
Add SSL VPN Site-to-Site Client Connection

This page describes how to add a SSL VPN site-to-site client connection.

1. Go to Device Configuration > Configure > VPN > SSL VPN (Site to Site) and click Add in the Client section.
2. Enter values for the following settings:

Connection Name
Enter a descriptive name for the connection.

Configuration File
Click the Browse... icon, browse for the client configuration file and click Open.

Note:  The file has to be in .apc or .epc format.

Password (optional)
If the file has been encrypted, enter the password.
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Use HTTP Proxy Server (optional)
Activate if the client is located behind a proxy and enter the proxy settings:

• Proxy Server: Select or add a proxy server.
• Proxy Port: Enter a proxy port.
• Proxy Requires Authentication (optional): Select the checkbox if the client needs to

authenticate against the proxy and enter Username and Password.

Override Peer Host Name (optional)
Select the checkbox and add or enter a hostname if the server system's regular hostname cannot be
resolved from the client host.

Description (optional)
Add a description or other information.

Figure 181: Add SSL Connection
3. Click Save.

The new SSL VPN client connection appears on the Client list.

To either edit or delete a client connection, click the corresponding buttons in the Client list.

L2TP Connections

The L2TP Connections page displays list of all the L2TP connections and you can sort the list based on connection
name. The page also provides option to add a new connection, update existing connection, or delete the connection.
The page displays status of each connection as follows:

Connection Status Description

Active Connection

Connection is active but not connected.
Click to initiate the connection.

Connection is active and connected.
Click to disconnect the connection.
When you disconnect, connection will
be deactivated and to re-establish the
connection, activate connection.

Connection is deactive. Click to activate
the connection.
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Add L2TP Connection

Page describes how you can create an L2TP Connection

1. Go to Device Configuration > Configure > VPN > L2TP Connections and click Add.
2. Enter the parameter values as below.

General Settings

Name

Specify a unique name to identify L2TP Connection.

Description

Provide description for L2TP Connection.

Policy

Select policy to be used for connection.

Policy can also be added by clicking Create New link.

Action on VPN Restart

Select the Action to be taken on the connection when VPN services or Device restarts.

Available Options

Respond Only – Keeps connection ready to respond to any incoming request.

Disable

Keeps connection disabled till the user activates.

Figure 182: General Settings

Authentication Details

Authentication Type

Select Authentication Type. Authentication of user depends on the type of connection.

Available Options:

Preshared Key

Preshared Key authentication is a mechanism whereby a single key is used for encryption and
decryption. Both the peers should possess the Preshared Key. Remote peer uses the Preshared Key
for decryption. On selecting this option the user shall require to provide the following details:

Preshared Key – Specify the Preshared Key to be used. Preshared Key should be of minimum 5
characters.
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Confirm Preshared Key – Provide the same Preshared Key to confirm it.

This Preshared Key will have to be shared or communicated to the peer at the remote end. At the
remote end, client will have to specify this key for authentication.

If there is a mismatch in the key, user will not be able to establish the connection.

Digital Certificate

Digital Certificate authentication is a mechanism whereby sender and receiver both use Digital
Certificate issued by the Certificate Authority. Both sender and receiver must have each other’s
Certificate Authority.

Local Certificate – Select the local certificate that should be used for authentication by the Device.

Remote Certificate – Select the remote certificate that should be used for authentication by remote
peer.

Figure 183: Authentication Details

Local Network Detail

Local WAN Port

Specify the Local Port number that the local VPN peer uses to transport traffic related to TCP or
UDP protocol.

Acceptable Range - 1 to 65535

To specify any local port, enter *.

Local ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509)

(DER ASN1 DN (X.509) is not applicable. In case of Local Certificate, ID and its value is displayed
automatically as specified in the Local Certificate)

Figure 184: Local Network Details

Remote Network Details

Remote Host

Specify IP Address or host name of of remote end-point. Specify * for any IP Address.
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Allow NAT Traversal

Enable NAT traversal if a NAT device is located between your VPN endpoints i.e. when remote peer
has private/non-routable IP Address.

At a time only one connection can be established behind one NAT-box.

Default-Enabled

Remote LAN Network

Select IP Addresses and netmask of remote network which is allowed to connect to the Device
server through VPN tunnel. Multiple subnets can be specified. Select IP Hosts from the list of IP
Hosts available on the Admin Console.

You can also add a new IP Host by click Create New link.

Remote ID

For Preshared Key and RSA Key, select any type of ID from the available options and specify its
value.

Available Options:

DNS IP Address Email Address

DER ASN1 DN(X.509) (DER ASN1 DN (X.509) is not applicable.

Figure 185: Remote Network Details

Quick Mode Selectors

Local Port

Specify Local Port number that the local VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Default: 1701

Local port Range: 1 – 65535

To specify any local port, enter *.

Remote Port

Specify Remote Port number that the remote VPN peer uses to transport the traffic related to TCP or
UDP protocol.

Default: *

Local port Range: 1 – 65535

To specify any local port, enter *.
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Figure 186: Quick Mode Selectors

Advanced Settings

Disconnect when tunnel is idle

Click this option to allow Device to delete an Idle VPN Session if it exceeds the specified Idle
session time interval.

Default - Disable

Idle session time interval (Only if Disconnect when tunnel is idle option is “Enabled”)

Specify the time limit after which an Idle VPN Session will be deleted by Device.

Acceptable Range - 120 to 999 seconds.

Figure 187: Advanced Settings
3. Click Save to create new connection.

PPTP (Remote Access)

Point-to-Point Tunneling Protocol allows organizations to extend their own private network through private tunnels
over the public Internet.

The Device supports several authentication options including Password Authentication Protocol (PAP), Challenge
Handshake Authentication Protocol (CHAP), and Microsoft Challenge Handshake Authentication Protocol (MS-
CHAPv2).

The Configuration page provides option to configure the Device as PPTP server and provide access or disable remote
access through PPTP to various users.

Enable PPTP
Click to enable PPTP.

Assign IP From

Specify IP Address range. PPTP server will lease IP Address to the PPTP client from the specified
IP Address range. The PPTP client uses the assigned IP Address as its source address for the
duration of the connection.

Do not specify the same IP Address range in L2TP configuration and PPTP configuration.

Allow leasing IP Address from Radius server for L2TP, PPTP and CISCO VPN Client

Click to lease IP Address to the PPTP users through the Radius Server.

Radius Server is a protocol that allows network devices to authenticate users against a central
database. It can also store technical information used by network devices.

If enabled, the configured IP Address is overridden with the IP Address provided by the Radius
Server.

Default - Disable
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Primary DNS Server
Specify DNS Server to be used at the client end.

Secondary DNS Server
Specify Alternate DNS server to be used at the client end.

Primary WINS Server
Specify WINS Server to be used at the client end.

Secondary WINS Server
Specify Alternate WINS Server to be used at the client end.

Add Member(s) Button
Click to select users who are to be allowed remote access through PPTP.

Show Members
Click to view list of PPTP members.

Add PPTP Members

The Add PPTP Members page allows you to select users who are to be allowed remote access through PPTP.

1. Click Add Member(s) button to add user or user groups. A window displays list of users and user groups.
2. Select users or user groups who are to be allowed remote access through PPTP. You can add single or multiple

users or user groups.

Figure 188: Add PPTP Members
3. Click Apply to add these users and user groups to the PPTP members list.

Show PPTP Members
Use Show Members page to view list of PPTP members and remove members for whom remote access through
PPTP is to be disabled.

The Show Members page allows you to view list of PPTP members and remove members for whom remote access
through PPTP is to be disabled.

1. Click Show Members button to view list of PPTP members. A window displays list of L2TP users who who are
allowed access through PPTP connection.

2. Select the users for whom you want to disable PPTP access. You can select multiple users or user groups.

Figure 189: Show PPTP Members
3. Click Delete button.
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Clientless Access
For the bookmark function you can define clientless access policies.

Note:  With Safari browser on Mac OSX or iOS, users have to import the CA certificate of SFOS first
before they can use clientless access. The CA certificate can be downloaded under Device Configuration >
Configure > Authentication > Certificate Authority . Usually its name is "Default".

Following is a description of the table elements:

Name

Displays the name of the clientless access policy.

Restrict Web Applications

Displays if the web application restriction is activated (Yes) or not (No).

Description

Displays the description which was entered for the policy.

Manage

Displays the available managing options for the policy:

• Edit: Allows you to edit the policy.
• Delete: Allows you to delete the policy.

Related tasks
Add Clientless Access Policy on page 215
The page allows adding clientless access policies.

Add a Bookmark on page 227
Add a Bookmark Groups on page 231

Add Clientless Access Policy
The page allows adding clientless access policies.

The Add button on the Clientless Access page allows to define a new clientless access policy.

1. Go to Device Configuration > Configure > VPN > Clientless Access and click the Add button.
A new page opens.

2. Make the following settings in the General Settings section:
Name

Enter a descriptive name for the policy.

Description (optional)
Add a description or other information.

Figure 190: General Settings
3. Make the following settings in the Identity section:

Policy Members
Select the requested users/groups from the list.

As soon as an item is selected it is displayed in the list.
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Figure 191: Identity

Note:  With Safari browser on Mac OSX or iOS, users have to import the CA
certificate of SFOS first before they can use clientless access. The CA certificate can
be downloaded under Protection > Web Server Protection > Certificate Authority
or System > VPN > Certificate Authority or Objects > Identity > Certificate
Authority. Usually its name is "Default".

4. Make the following settings in the Clientless Portal section:
Published Bookmarks

Select the requested bookmark(s) and/or bookmark group(s) from the list.

As soon as an item is selected it is displayed in the list.

Restrict Web Applications
Click the toggle switch to activate/deactivate the restriction of web applications.

Figure 192: Clientless Portal
5. Click Apply to save your settings.

The clientless access policy is now available and appears in the Clientless Access list.

IPSec Profiles
The IPSec Profiles displays list all the preconfigured and custom IPSec Profiles.

Policy describes the security parameters used for negotiations to establish and maintain a secure tunnel between two
peers.

Before you set up your secure tunnels, to make their configuration faster and easier, you can create VPN policies that
work on a global level. Rather than configuring the policy parameters for every tunnel you create, you can configure
general policies and then later apply them to your secure tunnels.

Authentication mode

To ensure secure communication, there are two phases to every IKE (Internet Key Exchange) negotiation - Phase 1
(Authentication) and Phase 2 (Key exchange).

The Phase 1 negotiation establishes a secure channel between peers and determines a specific set of cryptographic
protocols, exchanges shared secret keys and encryption and authentication algorithm that will be used for generating
keys.
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The Phase 2 negotiation establishes a secure channel between peers to protect data. During Phase 2 negotiation,
the protocol security association for the tunnel is established. Either of the peers can initiate Phase 1 or Phase 2
renegotiation at any time. Both can specify intervals after which to negotiate.

Key life

Lifetime of key is specified as Key life.

Once the connection is established after exchanging authenticated and encrypted keys, connection is not dropped till
the key life. If the key life of both the peers is not same then negotiation will take place whenever the key life of any
one peer is over. This means intruder has to decrypt only one key to break in your system.

Key generation and key rotation are important because the longer the life of the key, the larger the amount of data at
risk, and the easier it becomes to intercept more ciphered text for analysis.

Perfect Forward Secrecy (PFS)

It becomes difficult for a network intruder to get the big picture if keys are changing and they have to keep cracking
keys for every negotiation. This is achieved by implementing PFS. By selecting PFS, new key will be generated for
every negotiation and a new DH key exchange is included. So every time intruder will have to break yet another key
even though he already knows the key. This enhances security.

Diffie-Hellman (DH) Group (IKE group)

Diffie-Hellman is a public-key cryptography scheme that allows peers to establish a shared secret over an insecure
communications channel. Diffie-Hellman Key Exchange uses a complex algorithm and public and private keys to
encrypt and then decrypt the data.

The Diffie-Hellmann Group describes the key length used in encryption. Group number is also termed as Identifiers.

DH Group Key length (bits)

1 768

2 1024

5 1536

14 2048

15 3072

16 4096

If mismatched groups are specified on each peer, negotiation fails. The group cannot be switched during the
negotiation.

Re-key Margin

Time before the next key is exchanged. Time is calculated by subtracting the time elapsed since the last key exchange
from the key life. By turning Re-keying ‘Yes’, negotiation process starts automatically without interrupting service
before key expiry.

Dead Peer Detection settings

Use to check whether device is able to connect the IP Address or not. Set time interval after which the status of peer is
to be checked and what action to take, if peer is not alive.

Tunnel Negotiation

Negotiation process starts to establish the connection when local or remote peer wants to communicate with each
other. Depending on the connection parameters defined, the key is generated which is used for negotiations. Lifetime
of key is specified as Key life. Once the connection is established, connection is alive/active and data can be
transferred up to the specified key life. Connection will be closed/deactivated once the key expires.

If the connection is to be activated again then the entire negotiation process is to be started all over again. Negotiation
process can be started again automatically by either local or remote peer only if Allow Re-keying is set to ‘Yes’.
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Set the re-keying time in terms of the remaining key life when negotiation is to be started automatically without
interrupting the communication before key expiry. For example, if key life is 8 hours and Re-key margin time is 10
minutes then negotiation process will automatically start after 7 hours 50 minutes of key usage.

Negotiation process will generate new key only if Perfect Forward Secrecy (PFS) is set to ‘Yes’. PFS will generate a
new key from scratch and there will be no dependency between old and new key.

Re-keying Result

Yes Local and remote peer both will be able to initiate request for connection. Depending on PFS,
negotiation process will use same key or generate a new key.

No Only remote peer will be able to initiate request for connection. Depending on PFS, negotiation
process will use same key or generate a new key.

Device provides 5 default policies and you can also create a custom policy to meet your organization’s requirement.

To make VPN connection configuration an easy task, following five preconfigured VPN policies are included for the
frequently used VPN deployment scenarios:

• Road warrior
• L2TP
• Head office connectivity
• Branch office connectivity
• Default

It also provides option to add a new policy, update the parameters of an existing policy, or delete the policy. Instead of
creating a policy from scratch, you can also create a new policy based on the already created policy by duplicating its
parameters.

Duplicate - Click the duplicate icon in the Manage column against the VPN Policy to be duplicated. Add VPN
Policy window is displayed which has the same values for parameters as the existing policy. Click OK to add a new
policy with modification in values for parameters.

Note:  Default policy can be updated but cannot be deleted.

Create a New IPSec Policy
Use the Add  page to quickly configure a new IPSec policy.

The Add page allows you to manually enter details to add IPSec policy.

1. Go to Device Configuration > Configure > VPN > IPSec Profiles and click Add.
2. Enter General Settings Details.

Name
Specify a name to identify the IPSec Policy.

Description
Provide description for the IPSec Policy.

Allow Re-keying
Enable Re-Keying to start the negotiation process automatically before key expiry. Process will start
automatically at the specified time in re-key margin.

If enabled, negotiation process can be initiated by both the local or remote peer. Depending on PFS,
negotiation process will use same key or generate a new key.

Key Negotiation Tries
Specify maximum key negotiation trials allowed. Set 0 for unlimited number of trials.

Authentication Mode
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Select Authentication Mode. Authentication Mode is used for exchanging authentication
information.

Available Options:Main Mode - Main mode consists of 6 messages. It processes and validates
the diffie-hellman in 3 exchanges. Aggressive Mode - Agressive mode consists of 3 messages.
With Aggressive Mode, tunnel can be established faster than using Main Mode as less number of
messages are exchanged during authentication and no cryptographic algorithm is used to encrypt the
authentication information. Use Aggressive Mode when remote peer has dynamic IP Addresses.

Depending on Authentication Mode, the phase 1 parameters are exchanged for authentication
purpose.

In Main Mode, the phase 1 parameters are exchanged in multiple rounds with encrypted
authentication information while in Aggressive Mode phase1 parameters are exchanged in single
message without encrypted information.

Pass Data In Compressed Format
Enable to pass data in compressed format to increase throughput.

Figure 193: IPSec General Settings
3. Enter PHASE 1 details.

Encryption Algorithm
Select encryption algorithm that would be used by communicating parties for integrity of exchanged
data for phase 1.

Supported Encryption algorithms: DES, 3DES, AES128, AES192, AES256, TwoFish, BlowFish,
and Serpent.

3DES – Triple DES is a symmetric strong encryption algorithm that is compliant with the OpenPGP
standard. It is the application of DES standard where three keys are used in succession to provide
additional security.

AES – Advanced Encryption Standard offers the highest standard of security. The effective key
lengths that can be used with AES are 128, 192 and 256 Bits. This security system supports a
number of encryption algorithms.

Serpent – Serpent is a 128-bit block cipher i.e. data is encrypted and decrypted in 128-bit chunks
variable key length to be 128, 192, or 256 bits. The Serpent algorithm uses 32 rounds, or iterations
of the main algorithm.

Serpent is faster than DES and more secure than Triple DES.

BlowFish – BlowFish is a symmetric encryption algorithm which uses the same secret key to both
encrypt and decrypt messages. It is also a block cipher which divides a message into fixed length
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blocks during encryption and decryption. It has a 64-bit block size and a key length of anywhere
from 32 bits to 448 bits and uses 16 rounds of main algorithm.

TwoFish – TwoFish is a symmetric key block cipher with a block size of 128 bits and key sizes up
to 256 bits.

Authentication Algorithm
Select Authentication Algorithm that would be used by communicating parties for integrity of
exchanged data for phase 1.

Supported Authentication algorithms: MD5, SHA1

Maximum three combinations of Encryption and Authentication Algorithm can be selected. The
remote peer must be configured to use at least one of the defined combinations.

Click Add icon  to add more than one combination of Encryption and Authentication Algorithm.

Default - MD5

DH Group (Key Group)
Select one Diffie-Hellman Group from 1, 2, 5, 14, 15 or 16. DH Group specifies the key length used
for encryption.

DH Group 1 uses 768-bit encryption

DH Group 2 uses 1024-bit encryption

DH Group 5 uses 1536-bit encryption

DH Group 14 uses 2048-bit encryption

DH Group 15 uses 3072-bit encryption

DH Group 16 uses 4096-bit encryption

The remote peer must be configured to use the same group. If mismatched groups are specified on
each peer, negotiation fails.

Key Life
Specify Key Life in terms of seconds. Key Life is the amount of time that will be allowed to pass
before the key expires.

Default - 3600 seconds

ReKey Margin
Specify ReKey Margin. Set time in terms of the remaining Key Life. Re-Key Margin is the
time when the negotiation process should be started automatically without interrupting the
communication before the key expiry.

For example, if Key Life is 8 hours and Re-key Margin is 10 minutes then negotiation process will
automatically start after 7 hours 50 minutes usage of Key Life.

Default - 120 seconds

Randomize Re-Keying Margin By
Specify Randomize Re-Keying time.

For example, if Key Life is 8 hours, Re-Key Margin is 10 minutes and Randomize Re-Keying
time is 20% then the Re-Key Margin will be 8 to 12 minutes and negotiation process will start
automatically 8 minutes before the key expiry and will try up to 2 minutes after key expiry.

Default - 0%

Dead Peer Detection
Enable to check at regular interval whether peer is live or not.

Default - Enabled
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Check Peer After Every (Only if Dead Peer Detection option is "Enabled")
Specify time after which the peer should be checked for its status. Once the connection is
established, peer which initiated the connection checks whether another peer is live or not.

Default - 30 seconds

Wait For Response Upto (Only if Dead Peer Detection option is "Enabled")
Specify till what time (seconds) initiated peer should wait for the status response. If the response is
not received within the specified time, the peer is considered to be inactive.

Default - 120 seconds

Action When Peer Unreachable (Only if Dead Peer Detection option is "Enabled")
Specify what action should be taken if peer is not active.

Available Options: Hold - Holds the connectionDisconnect - Closes the connectionRe-initiate -
Re-establishes the connection

Default - Disconnect

Figure 194: IPSec Phase 1
4. Enter Phase 2 Details

Encryption Algorithm
Select encryption algorithm that would be used by communicating parties for integrity of exchanged
data for phase 2.

Supported Encryption algorithms: DES, 3DES, AES128, AES192, AES256, TwoFish, BlowFish,
and Serpent.

3DES – Triple DES is a symmetric strong encryption algorithm that is compliant with the OpenPGP
standard. It is the application of DES standard where three keys are used in succession to provide
additional security.

AES – Advanced Encryption Standard offers the highest standard of security. The effective key
lengths that can be used with AES are 128, 192 and 256 Bits. This security system supports a
number of encryption algorithms.

Serpent – Serpent is a 128-bit block cipher i.e. data is encrypted and decrypted in 128-bit chunks
variable key length to be 128, 192, or 256 bits. The Serpent algorithm uses 32 rounds, or iterations
of the main algorithm.
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Serpent is faster than DES and more secure than Triple DES.

BlowFish – BlowFish is a symmetric encryption algorithm which uses the same secret key to both
encrypt and decrypt messages. It is also a block cipher which divides a message into fixed length
blocks during encryption and decryption. It has a 64-bit block size and a key length of anywhere
from 32 bits to 448 bits and uses 16 rounds of main algorithm.

TwoFish – TwoFish is a symmetric key block cipher with a block size of 128 bits and key sizes up
to 256 bits.

Authentication Algorithm
Select Authentication Algorithm that would be used by communicating parties for integrity of
exchanged data for phase 2.

Supported Authentication algorithms: MD5, SHA1

Maximum three combinations of Encryption and Authentication Algorithm can be selected. The
remote peer must be configured to use at least one of the defined combinations.

Click Add icon  to add more than one combination of Encryption and Authentication Algorithm.

Default - MD5

PFS Group (DH Group)
Select one Diffie-Hellman Group from 1, 2, 5, 14, 15 or 16. DH Group specifies the key length used
for encryption.

DH Group 1 uses 768-bit encryption

DH Group 2 uses 1024-bit encryption

DH Group 5 uses 1536-bit encryption

DH Group 14 uses 2048-bit encryption

DH Group 15 uses 3072-bit encryption

DH Group 16 uses 4096-bit encryption

The remote peer must be configured to use the same group. If mismatched groups are specified on
each peer, negotiation fails.

If “Same as Phase 1” is selected PFS group specified at connection initiator’s end will be used.

If No PFS is selected, this security parameter cannot be added for Phase 2.

Key Life
Specify Key Life in terms of seconds. Key Life is the amount of time that will be allowed to pass
before the key expires.

Default - 3600 seconds

Figure 195: IPSec Phase 1
5. Click Save to add the IPSec policy with the options you have configured.
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SSL VPN
This page describes how to configure general SSL VPN settings.

The SSL VPN tab allows you to define parameters requested for remote access such as protocols, server certificates,
and IP addresses for SSL clients. The SSL VPN client supports most business applications such as native Outlook,
native Windows file sharing, and many more.

1. Go to Configure > VPN > SSL VPN.
2. Specify the SSL VPN settings.

Protocol
Select the protocol to use. You can choose either TCP or UDP. UDP is recommended because it
provides better performance.

SSL Server Certificate
Select a local SSL certificate to be used by the SSL VPN server to identify itself against the clients.

Default: ApplianceCertificate

Note:  The SSL VPN server does not support self-signed certificates that are not
approved by a CA (which is not identical to the Generate self-signed certificate
option in the Certificate section.)

Override Hostname
Here you can set the server IP address for client VPN connection. Usually this should be the
external IP address of Sophos XG Firewall.

Port
If required, change the port number on which the SSL VPN server is listening.

Default: 8443

IPv4 Lease Range
Set an IP address range which is used to distribute IP addresses to the SSL clients. This should be a
private IP address range.

Default Range: 10.81.234.5 to 10.81.234.55

Subnet Mask
Select a netmask for the IP address range above. The netmask must not be greater than 29 bits,
because OpenVPN cannot handle address ranges whose netmask is /30, /31, or /32. The netmask is
limited to a minimum of 16.

IPv6 Lease (IPv6/Prefix)
If you want to lease IPv6 addresses to clients, set the IPv6 prefix in the first field and the netmask in
the last field.

You then also have to select the option IPv4 and IPv6 both in parameter Lease Mode.

Lease Mode
Select if you want to lease only IPv4 addresses to SSL clients or both IPv4 and IPv6 addresses.

IPv4 DNS
Specify up to two IPv4 DNS servers, primary and secondary, of your organization.

IPv4 WINS
Specify up to two IPv4 WINS servers, primary and secondary, of your organization.

Windows Internet Naming Service (WINS) is Microsoft’s implementation of NetBIOS Name Server
(NBNS) on Windows operating systems. Effectively, WINS is to NetBIOS names what DNS is to
domain names—a central mapping of hostnames to IP addresses.

Domain Name
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Enter the hostname of your Sophos XG Firewall as a Fully Qualified Domain Name (FQDN). The
FQDN is an unambiguous domain name that specifies the node’s absolute position in the DNS tree
hierarchy, for example sf.example.com. A hostname may contain alphanumeric characters, dots, and
hyphens. At the end of the hostname there must be a TLD (top level domain) such as com, org, or
de. The hostname will be used in notification messages to identify Sophos XG Firewall.

Disconnect dead peer after
Enter a time limit in seconds after which a dead connection will be terminated by Sophos XG
Firewall.

Default: 180 seconds.

Disconnect idle peer after
Enter a time limit in minutes when an idle connection will be terminated.

Default: 15 minutes.

Figure 196: SSL VPN Settings
3. Specify the Cryptographic Settings.

Encryption Algorithm
Specify the algorithm used for encrypting the data sent through the VPN tunnel. The following
algorithms are supported and all in Cipher Block Chaining (CBC) mode:

• DES-EDE3-CBC
• AES-128-CBC (128 bit)
• AES-192-CBC (192 bit)
• AES-256-CBC (256 bit)
• BF-CBC (Blowfish (128 bit))

Authentication Algorithm

• SHA-1 (160 bit)
• SHA2 256 (256 bit)
• SHA2 384 (384 bit)
• SHA2 512 (512 bit)
• MD5 (128 bit)

Key Size
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The key size (key length) is the length of the Diffie-Hellman key exchange. The longer this key is,
the more secure the symmetric keys are. The length is specified in bits. You can choose between a
key size of 1024 or 2048 bits.

Key Lifetime
Enter a time period after which the key will expire.

Default: 28,800 seconds

Figure 197: SSL VPN Cryptographic Settings
4. Specify the Compression Settings.

Compress SSL VPN Traffic
If enabled, all data sent through SSL VPN tunnels will be compressed prior to encryption.

5. Specify the Debug Settings.
Enable Debug Mode

When enabling debug mode, the SSL VPN log file will contain extended information useful for
debugging purposes.

6. Click Apply.

L2TP
On this page you can enable L2TP and configure the settings for L2TP connections.

Device Configuration > Configure > VPN > L2TP Settings

Following is a description of the settings of this page:

Enable L2TP
Click this checkbox to enable/disable L2TP.

General Settings
Assign IP From

Set an IP address range which is used to distribute IP addresses to L2TP clients. This should be a
private IP address range.

Allow leasing IP address from RADIUS server for L2TP, PPTP and CISCO VPN Client
If this option is enabled and if the user is authenticated via a RADIUS server, the configured IP
address (static and the IP address range) is overridden with the IP address provided by the RADIUS
server. If no IP addresses are configured on the RADIUS server, the static IP address configured for
the user will be assigned, else an IP address will be leased from configured IP address range.

Client Information
Primary/Secondary DNS Server

Specify up to two DNS servers of your organization. If there is no DNS server available in the list,
you can select Other and enter the IP address of a DNS server into a textfield.

Primary/Secondary WINS Server

Specify up to two WINS servers of your organization. If there is no WINS server available in the
list, you can select Other and enter the IP address of a WINS server into a textfield.
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Related tasks
Add L2TP Member on page 226

Show/Remove L2TP Member on page 226

Add L2TP Member

This page describes how to add an L2TP member.

Before you can add L2TP members, L2TP must be enabled. See chapter L2TP on page 225.

1. Go to Device Configuration > Configure > VPN > L2TP Settings and click Add Members at the bottom of the
page.

2. Select users and groups from the table that should be enabled for L2TP.

Figure 198: Add L2TP Member
3. Click Apply.

All selected entries will be added as LT2P members.

Related concepts
L2TP on page 225
On this page you can enable L2TP and configure the settings for L2TP connections.

Related tasks
Show/Remove L2TP Member on page 226

Show/Remove L2TP Member

This page describes how to see which users or groups are members of L2TP and how to remove L2TP members.

Before you can show L2TP members, L2TP must be enabled. See chapter L2TP on page 225.

1. Go to Device Configuration > Configure > VPN > L2TP Settings and click Show Members at the bottom of
the page.
A dialog opens that shows all current members of L2TP.

2. Select users or groups from the table that should be removed from L2TP.

Figure 199: Show L2TP Members
3. Click Delete.

All selected entries will be removed as L2TP members.
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Related concepts
L2TP on page 225
On this page you can enable L2TP and configure the settings for L2TP connections.

Related tasks
Add L2TP Member on page 226

Bookmarks
Bookmarks are the resources whose access will be available through the user portal. Bookmarks are applied through
the Clientless Access policy and are available to users who have web or application access.

Device Configuration > Configure > VPN > Bookmarks

The bookmark feature enables users from external networks to access internal resources via pre-configured
connection types, using only a browser as a client, without installing plug-ins. To do so, the user logs in to the User
Portal. On the SSL VPN tab, a list of all connections available to this user is shown. Clicking the Connect button
initiates the connection to the defined internal resource. As an administrator you have to generate these connections
beforehand, specifying the allowed users, the connection type and other settings. Internal resources can be accessed
using different connection types: for example Remote Desktop Protocol (RDP) or Virtual Network Computing
(VNC) to access remote desktops, a browser to use web applications (HTTP/HTTPS), or Telnet/Secure Shell (SSH)
for terminal sessions. However, the portal does not permit to download content, e.g. via HTTP, to the user's local
computer. Using this feature it is possible to give multiple users access to internal resources which do not support
multi-user access themselves (e.g., network hardware like switches) or easily provide very granular access to just one
specific service instead of giving access to entire systems or networks.

The page displays all existing bookmarks. You can add new bookmarks, update or delete them. Following is a
description of the table elements:

Name

Displays the name of the bookmark.

Type

Displays the type of the bookmark.

URL

Displays the URL which is defined for the bookmark.

Description

Displays the description of the bookmark.

Related tasks
Add Clientless Access Policy on page 215
The page allows adding clientless access policies.

Add a Bookmark

This page describes how to add a bookmark.

1. Go to Device Configuration > Configure > VPN > Bookmarks and click Add.
2. Enter values for the following settings:

Name
Enter a descriptive name for the bookmark.

Type
Select a bookmark type. Depending on the selected connection type, different parameters are
displayed. The following types are available:

• HTTPS: Browser-based access to web applications via HTTPS.
• HTTP: Browser-based access to web applications via HTTP.
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Note:  The URL used for the HTTP/HTTPS connection is composed of the
destination, the port and the path options for this connection.

• RDP: Remote access using the Remote Desktop Protocol (RDP), e.g., to open a remote desktop
session to a Windows host.

• TELNET: Terminal access using the Telnet protocol, e.g., to give access to a switch or a printer.
• SSH: Terminal access using SSH.
• FTP: File Transfer Protocol for exchanging files over packet-switched networks.
• FTPS: Extension of FTP. Additionally supports TLS and SSL protocols.
• SFTP: SSH File Transfer Protocol, or Secure File Transfer Protocol, is a separate protocol

packaged with SSH that works in a similar way over a secure connection.
• SMB: The Server Message Block (SMB) Protocol is a network file sharing protocol.
• VNC: Remote access using Virtual Network Computing (VNC), e.g., to open a remote desktop of

a Linux/Unix host.

Note:  Currently only VNC classic authentication (password only) is supported.
Make sure your server is set up accordingly.

Note:  The default port is displayed next to the drop-down menu.

URL
Enter the URL of the website for which the bookmark is to be created.

Note:  Note the examples displayed below the text box.

Port
Enter a port number for the bookmark. By default the standard port of the selected bookmark type is
given.

Automatic Login
If enabled, users can log in without knowing the authentication data. In this case, you have to
provide the authentication data. The displayed options depend on the selected connection type:

Username
Enter the username users should use to connect.

Password
Enter the password users should use to connect.

Note:  When using the connection type Telnet, for security reasons automatic login
only works when the banner length sent from the Telnet server does not exceed 4096
characters (including the password prompt). If the banner is longer, automatic login
fails. In this case reduce the banner length or switch to manual login.

Referred Domains
(only with bookmark type HTTPS or HTTP)

Search/add one or more domain(s)/URL(s) which are required by the bookmark URL to render it
appropriately.

Domain
(only with bookmark type RDP or SMB)

Enter a domain name.

Protocol Security
(only with bookmark type RDP)

Select the security protocol for the Remote Desktop session. You can choose between RDP, TLS
and NLA (Network Level Authentication). Your settings have to comply with the server settings.
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Note:  NLA requires to enable Automatic Login above.

Public Host Key
(only with bookmark type SSH, FTPS or SFTP)

Add the public key of the SSH host.

Init Remote Folder
(only with bookmark type FTP, FTPS, SFTP or SMB)

Specify the remote directory path.

Note:  After successful authentication the user is redirected to the path on the remote
server.

Authentication Method
(only with bookmark type SFTP)

Select the authentication method. You can either provide the Password for the selected username or
add the Private Key for the SFTP connection.

Share Session
Select this option to allow users to use the connection simultaneously and see the same screen.

Description
Enter a description or other information.
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Figure 200: Add Bookmark
3. Click Save to save your settings.

The bookmark is now available and appears in the Bookmark list.

To either edit or delete a bookmark, click the corresponding buttons.

Bookmark Groups
This page displays all bookmark groups. You can update a group to include bookmarks as group members. Single
bookmarks can be member of multiple groups. You are not allowed to delete groups which contain bookmarks which
are part of any of the SSL VPN policies.

Device Configuration > Configure > VPN > Bookmark Groups

You can add new groups, update or delete them. Following is a description of the table elements:

Name

Displays the name of the bookmark group.

Description

Displays the description of the bookmark group.

Manage

Displays the available managing options for the bookmark group:

• Edit: Allows you to edit the bookmark group.
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• Delete: Allows you to delete the bookmark group.

To either add or delete a bookmark group, click the corresponding buttons.

Related tasks
Add Clientless Access Policy on page 215
The page allows adding clientless access policies.

Add a Bookmark Groups

This page describes how to add a bookmark group.

1. Go to Device Configuration > Configure > VPN > Bookmark Groups and click Add.
2. Enter values for the following settings:

Name
Enter a descriptive name for the bookmark group.

Select Bookmark
Select the bookmark(s) you want to add to the new bookmark group from the Bookmark List.

Description
Enter a description or other information.

Figure 201: Add Bookmark Group
3. Click Save to save your settings.

The bookmark group is saved. It appears in the Bookmark Groups list.

To either edit or delete a bookmark group, click the corresponding buttons.

Certificates
The Certificates page displays list of available certificates.

A digital certificate is a document that guarantees the identity of a person or entity and is issued by the Certificate
Authority (CA). Certificates are generated by the third party trusted CA. They create certificates by signing public
keys and identify the information of the communicating parties with their own private keys. This way it is possible
to verify that a public key really belongs to the communicating party only and not been forged by someone with
malicious intentions.

A certificate signed by a Certificate Authority (CA) identifies the owner of a public key. Each communicating party
may be required to present its own certificate signed by a CA verifying the ownership of the corresponding private
key. Additionally, the communicating parties need to have a copy of the CA’s public key. In case private key is lost or
stolen or the information is changed, CA is responsible for revoking the certificate.CA also maintains the list of valid
and revoked certificates.
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To use Certificates for authentication, you must have valid CA and a certificate. You need to upload CA if you are
using external CA. You can generate a self signed certificate if you want to use it as CA.

You can also use device to act as a certificate authority and sign its own certificates. This eliminates the need of
having your own certificate authority. If you are using device as CA, you have to generate a self-signed certificate,
which can be used in various VPN policies.

The page also provides option to generate a self-signed certificate, upload a certificate, or generate a Certificate
Signing Request (CSR).This page also provides option to regenerate, revoke, download, or delete the certificates.

If you are using a third party CA, you have to submit a request to CA for issuing a certificate. Once CA issues a
certificate, you have to upload to use it in VPN policy.

This page provides option to:

• Add a New Certificate
• Download the Certificate
• Revoke the Certificate

Add Certificate
Use the Certificate page to add a new certificate.

The Certificate page allows you to generate a self-signed certificate, upload a certificate, or generate a Certificate
Signing Request (CSR).

1. Go to Device Configuration > Protect > Web Server > Certificates or Device Configuration > Configure >
VPN > Certificates and click Add.

2. Choose the action you want to perform.
Action

Select action from the available options.

Available Options:Upload CertificateGenerate Self-Signed CertificateGenerate Certificate Signing
Request

Upload Certificate
Use the Certificate page to upload a certificate.

1. Enter Upload Certificate details.
Name

Specify a name to identify the Certificate.

Certificate File Format
Select the format of Certificate file from the available options.

Available Options: PEM (.pem): Privacy Enhanced Mail (PEM) is a Base64encoded DER
certificate. It is used for encoding the certificate in ASCII code. The certificate and private key
are stored in separate files. DER (.der): Distinguished Encoding Rules (DER) is a binary form of
ASCII PEM format certificate used on Java platform. The certificate and private key are stored
in separate files. CER (.cer): Canonical Encoding Rules (CER) is a binary format for encoding
certificates. It contains information about the owner of certificate, its public and private keys.
PKCS7 (.p7b): Public Key Cryptography Standards (PKCS) is a format for encoding the certificate
in ASCII code. It contains only certificates and not the private key. PKCS12 (.pfx or .p12): Public
Key Cryptography Standards (PKCS12) is a binary format for encoding certificates. It stores a
private key with a public key certificate. It is used on Windows platform.

Certificate
Specify certificate to be uploaded. Use Browse to select the complete path.

Private Key
Specify private key for the certificate. Use Browse to select the complete path.

Passphrase
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Specify and re-confirm a passphrase for a certificate used for authentication. Passphrase must be at
least 4 characters long.

Figure 202: Upload Certificate
2. Click Save to upload the certificate.

Generate Self-Signed Certificate
Use the Certificate page to generate self-signed certificate.

1. Enter details to generate Self Signed Certificate (Option available only after configuring Default CA Parameters)
Name

Specify a name to identify the Certificate.

Valid From and Valid Up To

Specify certificate validity period using Calendar . Validity period is the certificate life and
indicates period up to which the certificate will be considered as valid.

Default - 1 day

Key Length
Select key length. Key length is the number of bits used to construct the key.

Available Options:5121024153620484096

Generally, the larger the key, the less chance that it will be compromised but requires more time to
encrypt and decrypt data than smaller keys.

Default - 512

Key Encryption
Click to enable the key encryption.

Passphrase
Passphrase for a Certificate used for authentication. Passphrase must be at least 8 characters long.
This option is enabled only if the Key Encryption option is selected.

Confirm Passphrase
Re-enter passphrase for confirmation.

Certificate ID
Specify certificate ID. You can specify any one of the following options:

Available Options: DNSIP Address(IPv4/IPv6 Address) Email Address DER ASN1 DN(X.509)
(Applicable when Authentication Type is Digital Certificate)

Once the certificate is created, you need to download and send this certificate to the remote peer
with whom the connection is to be established.
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Country Name
Select the country.

State
Specify the state within the country.

Locality Name
Specify the name of the locality.

Organization Name
Specify the organization name, which will use this certificate and domain name. This domain will
be certified to use the Certificate.

Use unique Domain name only.

Organization Unit Name
Specify the department/unit name, which will use this certificate and domain name. This domain
will be certified to use the Certificate.

Use unique Domain name only.

Common Name
Specify the common name.

A common name comprises of host + domain name or is a fully qualified domain name that is used
to resolve to SSL VPN interface. It must be same as that of the Web address to be accessed when
connecting to a secured site.

Email Address
Specify the Email Address of the contact person for communication.

2. Click Save to generate self-signed certificate.

Generate Certificate Signing Request
Use the Certificate page to generate certificate signing request.

1. Enter details to generate Certificate Signing Request (CSR).
Name

Name to identify the certificate.

Valid Upto

Specify certificate validity period using Calendar. Validity period is the certificate life i.e. period up
to which the certificate will be considered as valid.

Minimum validity -1 day

Key Length
Select key length. Key length is the number of bits used to construct the key.

Generally the larger the key, the less chance that it will be compromised but requires more time to
encrypt and decrypt data than smaller keys.

Encryption
Click to enable the key encryption.

Passphrase
Passphrase for a Certificate used for authentication. Passphrase must be at least 4 characters long.
This option is available only if the Encryption option is checked.

Confirm Passphrase
Re-enter passphrase for confirmation.

Certificate ID
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Specify certificate ID. You can specify any one of the following options:

Available Options: DNS IP AddressEmail Address

DER ASN1 DN(X.509) (Applicable when Authentication Type is Digital Certificate)

Country Name
Select the Country for which the Certificate will be used.

Generally, this would be the name of the country where device is deployed.

State
Select the State for which the Certificate will be used.

Generally, this would be the name of the state where device is deployed.

Locality Name
Select the Locality for which the Certificate will be used.

Generally, this would be the name of the Locality where device is deployed.

Organization Name
Specify your organization name, which will use this certificate and domain name. This domain will
be certified to use the Certificate.

Use unique Domain names only.

Organization Unit Name
Specify your department/unit name, which will use this certificate and domain name. This domain
will be certified to use the Certificate.

Use unique Domain names only.

Common Name
Specify Common Name.

Email Address
Specify Email Address.

2. Click Save to generate certificate signing request.

Download Certificate
Use the Certificate page to download the certificate.

1. Go to Device Configuration > Protect > Web Server > Certificates .
2.

Under the Manage column, click the Download Icon  against the certificate you want to download.

Note:

• Only self signed certificate and certificate signing request can be downloaded.
• Certificate is downloaded as a .tar.gz file.

Revoke Certificate
Use the Certificate page to revoke the certificate.

1. Go to Device Configuration > Protect > Web Server > Certificates .
2.

Under the Manage column, click the Revoke Icon  to revoke self-signed certificate if lost, stolen or updated.
Revoked certificate is automatically added to the Certificate Revocation List (CRL). You can download revoked
certificate and circulate if required.
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Certificate Authorities
The Certificate Authorities page displays list of all the certificate authority and you can filter list based on the
certificate authority name.

Device provides a facility to generate a local certificate authority as well as import certificates, signed by commercial
providers, such as VeriSign.

A certificate signed by a Certificate Authority (CA) identifies the owner of a public key. Each communicating party
may be required to present its own certificate signed by a CA verifying the ownership of the corresponding private
key. Additionally, the communicating parties need to have a copy of the CA’s public key. In case private key is lost or
stolen or the information is changed, CA is responsible for revoking the certificate. CA also maintains the list of valid
and revoked certificates.

After your CA has issued a certificate or have local certificate, you can upload it for use in VPN.

You can use default CA and can modify and re-generate it as per your requirement if you are not using any external
CA. Using this CA, you can generate self-signed certificate and use it in VPN policy.

Using Third Party CA involves uploading:

• CA and root certificate
• Certificate
• CRL (Certificate Revocation List)

If the remote peer is using certificate issued by the following third party CA, you are not required to upload CA:

• VeriSign
• Entrust
• Microsoft

Note:  Default CA is regenerated automatically when it is updated.

The page provides option to:

• Download CA
• Add a new CA
• Regenerate CA

Download Certificate Authority
Use the Certificate Authority page to download CA.

If you are using a local CA, you need to download CA and forward to the remote peer.

1. Go to Device Configuration > Configure > VPN > Certificate Authorities . It displays the details of the default
CA.

2.
Click download icon  to download the zip file.

Note:  Default CA cannot be deleted.

Adding a New Certificate Authority

To update and regenerate the default certificate, click on the default certificate.

• CA Parameters
• Default CA Parameters

CA Parameters
Use the Certificate Authority page to update and regenerate the default certificate.

The Certificate Authority page allows you to manually enter details to add a new certificate authority.

1. Go to or Device Configuration > Configure > VPN > Certificate Authorities and click Add.
2. Enter Certificate Authority details.
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Name
Specify a name to identify the Certificate Authority.

Certificate File Format
Select format of the root certificate to be uploaded.

Available Options:PEM (Privacy Enhanced Mail): A format encoding the certificate in ASCII
code. The certificate, request, and private key are stored in separate files.DER: A binary format for
encoding certificates. The certificate, request, and private key are stored in separate files.

Certificate
Specify full path from where the certificate is to be uploaded. Alternately, use Browse button to
select the path.

Private Key
Specify full path from where the Private Key is to be uploaded. Alternately, use Browse button to
select the path.

CA Passphrase
CA Passphrase for authentication. Passphrase must be at least 4 characters long.

Confirm CA passphrase for authentication.

Figure 203: Certificate Authority
3. Click Save to add the Certificate Authority with the options you have configured.

Default CA Parameters
Use the Add Certificate Authority page to update and regenerate the default certificate.

The Add Certificate Authority page allows you to manually enter certificate authority details.

1. Go to Device Configuration > Configure > VPN > Certificate Authorities .
2.

Click on the  icon under Manage tab of the default certificate that you want to update and regenerate.
3. Enter Certificate Authority Details.

Name
Default. This name cannot be changed.

Country Name
Specify the name of the country where the device is installed.

State
Specify the name of the state where the device is installed.

Locality Name
Specify the name of the locality where the device is installed.
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Organization Name
Specify the organization name, which will use this certificate and domain name. This domain will
be certified to use the Certificate.

Use unique Domain name only.

Organization Unit Name
Specify the department/unit name, which will use this certificate and domain name. This domain
will be certified to use the Certificate.

Use unique Domain name only.

Common Name
Specify the common name.

A common name comprises of host + domain name or is a fully qualified domain name that is used
to resolve to SSL VPN interface. It must be same as that of the Web address to be accessed when
connecting to a secured site.

Email Address
Specify the Email Address of the contact person for communication.

CA PassPhrase
Specify Passphrase for a Certificate Authority. Passphrase must be at least 4 characters long.

Re-enter passphrase for confirmation.
4. Click Save to update and regenerate the default certificate.

Regenerating Certificate Authority
Use the Certificate Authority page to regenerate the default certificate.

1. Go to Device Configuration > Configure > VPN > Certificate Authorities .
2.

Under the Manage column, click the Regenerate icon 

Note:  Default CA is regenerated automatically when it is updated.

Certificate Revocation Lists
CA maintains the list of valid and revoked certificates. The page displays the list of available CRLs.

Certificate Revocation List (CRL) page is a way to check the validity of an existing certificate. Certificates which
are stolen, lost or updated are revoked by CA and CA publishes such revoked certificates in Revocation list. VPN
connection cannot be established using revoked certificates, hence it is necessary to update the CRL at regular
interval.

The page provides option to:

• Add/Edit CRL
• Download the CRL

Adding a New CRL
Use the Certificate Revocation List page to add a new CRL.

If you are using External Certificate Authority, you need to upload the CRL obtained from External Certificate
Authority.

1. Go to Device Configuration > Protect > Web Server > Certificate Revocation List or Device Configuration >
Configure > VPN > Certificate Revocation List and click Add.

2. Enter Certificate Revocation List details.
Name

Name to identify the CRL.
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CRL File
Specify CRL file to be uploaded. Use Browse to select the complete path.

Figure 204: Certificate Revocation Lists
3. Click Save.

Downloading CRL
Use the Certificate Revocation List page to download the CRL.

Once CA is generated, default CRL is generated with name Default.tar.gz. Once you revoke the certificate, the details
of the revoked certificate are added to the default file and regenerated. You can download and distribute if required.

1. Go to Device Configuration > Protect > Web Server > Certificate Revocation List or Device Configuration >
Configure > VPN > Certificate Revocation List .

2. Click "Download" link against the CRL name to be downloaded. It downloads the zip file. Unzip the file to check
the details.

Network
Network allows configuration for the following:

This section covers the following topics:

• RED Device Management - Manage RED Device configuration.
• Wireless Networks: Create and manage Wireless Networks.
• Mesh Networks: Create and manage Mesh Networks.
• DNS - Configure DNS settings
• DNS Relay - Create DHCP Relay agent.

RED Device Management

RED Device Management page allows you to view and manage added RED devices. To add new or manage added
RED devices go toDevice Configuration > Configure > Network > RED Device Management page.

The following options are available:

Status

The toggle switch next to the branch name shows the status of the RED device. Click it to turn it on/off.

Edit

This link leads you to the page where you can edit the RED device settings. Find further descriptions on the Add
RED page.

Delete RED

With this option you can delete the RED devices from the list. You will get a message which configurations that the
deletion will affect.

Related tasks
Add RED on page 239

Add RED
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You can configure RED from this page.

1. Ensure that RED is activated. This can be done from Configure > System Services > RED.
2. Go to Device Configuration > Configure > Network > RED Device Management and click Add .
3. Enter the RED settings.

Branch Name
Enter the name for the remote location where the RED will be set up.

Type
Select the client type from the drop-down list depending on the type of RED device you want to
connect:

• RED 10
• RED 15
• RED 15w
• RED 50
• Firewall-RED-Server
• Firewall-RED-Client
• Firewall RED Server Legacy
• Firewall RED Client Legacy

Note:  Firewall RED Server Legacy and Firewall RED Client Legacy are used to
connect Sophos XG Firewall and Sophos UTM via RED Site2Site.

Using Firewall-RED-Server and Firewall-RED-Client you can configure a RED Site-to-Site tunnel
between two Sophos XG Firewall devices which are connected through the RED technology. One
device acts as server while the other is the client.

For more information, refer Configure RED Site-to-Site Tunnel on page 245.

Firewall Device
Select the firewall device from the list of available devices.

RED ID
Enter the RED ID.

The RED ID is a 15-character string printed on a sticker located on the back of the RED. If you do
not want to open the package, you can also find it on the outer carton sticker.

Tunnel ID
Enter the Tunnel ID.

By default, Automatic is selected, this will number tunnels consecutively.

Unlock Code (optional)
Enter the unlock code.

The Unlock code is an 8-character string that is generated when a RED is added to a Sophos XG
Firewall . If this RED is now being deployed for the first time, the unlock code is not required. If
this RED has been deployed before, you will need to enter the unlock code here. The unlock code
is generated during the deployment of a RED device, and is emailed instantly to the address you
provided by activating RED. is emailed instantly to the address you provided for activating RED.
This is a security feature, which ensures that a RED device cannot simply be removed and installed
elsewhere.

For manual deployment via USB stick and automatic deployment via Provisioning Service (see
below), two separate unlock codes are generated. If you switch a RED device from one deployment
method to the other, make sure to use the corresponding unlock code: For manual deployment,
provide the unlock code of the last manual deployment; for automatic deployment, provide the
unlock code of the last automatic deployment.
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2nd Firewall/Hostname (only applicable for client types RED 15 and RED 50)
Enter the hostname of the second Sophos XG Firewall .

Use 2nd IP/Hostname for (only applicable for client types RED 15 and RED 50)
Select from the following options:

• Failover: Select this option if you want to use the second Sophos XG Firewall in case the
primary Sophos XG Firewall fails. The second host will then take over automatically without
loss of connection.

• Load Balancing: Select this option if you want to distribute traffic equally on both, the primary
and the second Sophos XG Firewall .

Firewall IP /Host Name
Enter the hostname of the Sophos XG Firewall .

The Sophos XG Firewall hostname must be a publicly resolvable DNS name or IP address for this
Sophos XG Firewall . The RED will use this name or IP to connect back to the Sophos XG Firewall
.

Description (optional)
Enter a description for the RED settings.

Device Deployment
Select the deployment method:

• Automatically via Provisioning Service
• Manually via USB Stick

Note:  If you select manual deployment, it is extremely important to keep the
unlock code, which is sent by email. If you lose the unlock code, you can never
again connect the RED device to another Sophos XG Firewall .

By default, the Sophos XG Firewall provides the RED's configuration data automatically via Sophos
' RED

• Manually via USB Stick

Note:  If you select manual deployment, it is extremely important to keep the
unlock code, which is sent by email. If you lose the unlock code, you can never
again connect the RED device to another Sophos XG Firewall .

By default, the Sophos XG Firewall provides the RED's configuration data automatically via Sophos
' RED Provisioning Service. In this case, the RED device receives its configuration via Internet.
If for example your RED does not have an Internet connection, you can provide the configuration
manually, via USB stick. If you deploy a RED device manually, you have to ensure that Sophos XG
Firewall is acting as NTP server. Therefore activate NTP on the Sophos XG Firewall and allow the
correct network or at least the IP address of the RED.
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Figure 205: RED Setting
4. Enter the uplink settings.

Uplink Connection
Select the connection type for the uplink:

• DHCP: The RED pulls an IP address from a DHCP server.
• Static: Enter an IPv4 address, a corresponding netmask, a gateway and a DNS server.

3G/UMTS Failover
Enable/disable the 3G/UMTS failover function.

Note:  The RED device offers a USB port, where you can plug in a 3G/UMTS USB
stick. If selected, this stick can serve as Internet uplink failover in case of a WAN
interface failure. For the necessary settings please refer to your Internet provider's data
sheet.

• Mobile Network: Select the mobile network type, which is either GSM or CDMA.
• Username/Password (optional): If required, enter a username and password for the mobile

network.

Note:  Avalable only for CDMA Mobile Network.

• PIN (optional): Enter the PIN of the SIM card if a PIN is configured.

Note:  If you enter a wrong PIN, in case of a WAN interface failure, the
connection via 3G/UMTS cannot be established. Instead, the 3G/UMTS Failover
checkbox of the RED device will automatically be unselected. Thus, the wrong
PIN will only be used once. When the WAN interface comes up again, a warning
will be displayed for the RED device: A wrong PIN was entered for 3G/UMTS
failover uplink. Please change the login data. When you open the Edit RED
dialog box, a message is displayed which tells you that the 3G/UMTS failover was
automatically unselected. Correct the PIN before selecting the checkbox again.
Please note that after three connection attempts with a wrong PIN, the SIM card
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will be locked. Unlocking cannot be done via the RED device or the Sophos XG
Firewall.

Note:  Avalable only for GSM Mobile Network.

• APN (only with GSM): Enter your provider's access point name information.
• Dial String (optional): If your provider uses a different dial string, enter it here. Default is *99#

for GSM and #777 for CDMA.

Figure 206: Uplink Settings
5. Enter the RED network settings.

RED Operation Mode
You can define how the remote network will be integrated into your local network:

• Standard/Unified: The Sophos XG Firewall completely controls the network traffic of the
remote network. Additionally, it serves as DHCP server and as default gateway. All remote
network traffic will be routed through the Sophos XG Firewall .

• Standard/Split: The Sophos XG Firewall completely controls the network traffic of the remote
network. Additionally, it serves as DHCP server and as default gateway. In contrast to the
Unified mode, only certain traffic will be routed through the Sophos XG Firewall />. Define
local networks in the Split Networks box below which can be accessed by remote clients.

Note:  VLAN tagged frames cannot be handled with this operation mode. If you
use a VLAN behind your RED device, use the standard operation mode instead.

• Transparent/Split The Sophos XG Firewall does not control the network traffic of the remote
network, it does neither serve as DHCP server nor as default gateway. On the contrary, it pulls
an IP address from the DHCP server of the remote network to become a part of that network.
However, you can enable access for remote clients to your local network. For that you need to
define Split Networks that are allowed to be accessed by the remote network. Additionally, you
can define one or more Split Domains to be accessible. If your local domains are not publicly
resolvable, you need to define a Split DNS Server, which can be queried by remote clients.

Note:  VLAN tagged frames cannot be handled with this operation mode. If you
use a VLAN behind your RED device, use the standard operation mode instead.

RED IP
(not for Transparent/Split)

Enter the IP address of the RED device.

RED Netmask
(not for Transparent/Split)

Select the netmask from the drop-down menu.

Zone
Select the requested zone:

• LAN
• DMZ
• VPN
• WiFi

Configure DHCP
Enable if you want to configure a DHCP range for RED.
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RED DHCP Range
(only if Configure DHCP is enabled)

Enter the DHCP range.

Split Network
(not for Standard/Unified)

Add one or more split networks.

Note:  Only traffic targeted to networks listed in the Split Network box is redirected
to your local Sophos XG Firewall . All traffic not targeted to the defined split
networks is directly routed to the Internet.

Example: You have a branch office and you want it to have access to your local
intranet or you want to route traffic of the remote network via your Sophos XG
Firewall for security reasons, e.g. to have the traffic checked for viruses or to use an
HTTP proxy.

Split Domains
(only for Transparent/Split)

Add one or more split domains.

Note:  Since the Sophos XG Firewall is only a client of the remote network, routing
traffic to the split networks the same way as with the other modes is not possible.
Therefore, the RED device intercepts all traffic: Traffic targeting to a network listed
in the Split Network box or going to a domain listed in the Split Domain box is
redirected to the Sophos XG Firewall interface. This is accomplished by replacing the
default gateway's MAC address in the respective data packets with the Sophos XG
Firewall's MAC address.

Example: There is a partner or a service provider who should have access to your
intranet or a certain server in your local network. Using a RED device, that partner's
network will stay completely independent of your network, but they can access a
defined part of your network for certain purposes, as if they were connected via LAN.

MAC Filtering Type
To restrict the MAC addresses allowed to connect to this RED device, select Blacklist or Whitelist.
With Blacklist, all MAC addresses are allowed except those listed on the MAC address list selected
below. With Whitelist, all MAC addresses are prohibited except those listed on the MAC address
list selected below.

MAC Address:The list of MAC addresses used to restrict access to the RED device. MAC address
lists can be created on the Objects > Host and Services > MAC Host page. Note that for RED 10,
a maximum of 200 MAC addresses is allowed, whereas for RED 50, the list may contain up to 400
MAC addresses.

Note:

• MAC filtering only works for RED rev. 2 or newer.
• If no MAC Addresses are configured then "No Configured MAC address lists

found" will be displayed.

Tunnel Compression
Enabling tunnel compression will compress all traffic that is sent through the RED tunnel. Data
compression might increase the throughput of the RED device in areas with a very slow Internet
connection such as 1-2 Mbps. However, any performance increase mainly depends on the entropy
of the data being sent (for example, already compressed data such as HTTPS or SSH cannot be
compressed any further). In some circumstances it might therefore be possible that enabling data
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compression could actually reduce the throughput of the RED device. In that case, please disable
data compression.

Figure 207: RED Network Setting

Note:  Tunnel compression is not available for RED 10 rev.1.

6. Click Save to save your settings.

The RED interface is created and appears in the RED Device Management list.
Configure RED Site-to-Site Tunnel
This page describes how to set up a RED Site-to-Site Tunnel.

For such a connection, you need a RED server and a RED client. Ensure that RED is activated on client and server
devices. Go to Device Configuration > Configure > System Services > RED and enable RED for client and server
devices.

1. Configure the Firewall RED server on the server machine.
a) Go to Device Configuration > Configure > Network > RED Device Management, and click Add.
b) Specify Branch Name.
c) Select Type as "Firewall-RED-Server".
d) Select Firewall Device.
e) Select Tunnel ID. It is recommended to set it to "Automatic". Ensure that both ends of the tunnel use the same

tunnel ID.
f) Specify Description.
g) As RED IP, enter the LAN IP of the new RED server interface.
h) Select RED Netmask.
i) Select Zone.
j) Enable Tunnel compression if required.
k) Click Save.

The RED interface will be created and listed on the RED Device Management page.
l) On the new RED interface, click the  icon and select Download Provisioning File.

2. Configure the Firewall RED Client on the client machine.
a) Go to Device Configuration > Configure > Network > RED Device Management, and click Add.
b) Specify Branch Name.
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c) Select Type as "Firewall-RED-Client".
d) Select Firewall Device.
e) As Firewall IP/Hostname specify the IP address of the machine on which the Firwall RED Server was

defined.
f) Upload the Provisioning File downloaded after configuring Firewall-RED-Server.
g) Specify Description.
h) As RED IP, enter the LAN IP of the new RED client interface.
i) Select RED Netmask.
j) Select Zone.
k) Click Save.

The RED interface will be created and listed on the RED Device Management page.
The RED Site-to-Site tunnel will be established and active.

Add RED Tunnel Wizard
This page describes how to set up a RED Site-to-Site Tunnel using wizard.

For such a connection, you need a RED server and a RED client. Ensure that RED is activated on client and server
devices. Go to Device Configuration > Configure > System Services > RED and enable RED for client and server
devices.

1. Configure the RED Server.
a) Go to Device Configuration > Configure > Network > RED Device Management, and click Add RED

Wizard.
b) Specify Branch Name.
c) Select Type as "Firewall-RED-Server".
d) Select Firewall Device.
e) Select Tunnel ID. It is recommended to set it to "Automatic". Ensure that both ends of the tunnel use the same

tunnel ID.
f) Specify Description.
g) As RED IP, enter the LAN IP of the new RED server interface.
h) Select RED Netmask.
i) Select Zone.
j) Enable Tunnel compression if required.
k) Click Next to generate Provisioning File.

2. Provisioning File generation.
a) The generation of Provisioning File will start automatically after you Click Next in the RED Server section.
b) The Provisioning File will be attached to the RED Client in the next step automatically after the generation

process is over.
c) Click Continue to configure RED Client.

3. Configure the RED Client.
a) Specify Branch Name.
b) Select Type as "Firewall-RED-Client".
c) Select Firewall Device.
d) As Firewall IP/Hostname specify the IP address of the machine on which the Firwall RED Server was

defined.
e) Upload the Provisioning File downloaded after configuring Firewall-RED-Server.
f) Specify Description.
g) As RED IP, enter the LAN IP of the new RED client interface.
h) Select RED Netmask.
i) Select Zone.
j) Click Finish.
The RED Site-to-Site tunnel will be established and active.
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Zones
The Zone page displays list of all the zones including system zones and even lets the administrator manage the zones.

A Zone is a logical grouping of ports/physical interfaces and/or virtual sub-interfaces if defined.

Zones provide a flexible layer of security for the firewall. With the zone-based security, the administrator can group
similar ports and apply the same policies to them, instead of having to write the same policy for each interface.

Default Zone Types

LAN - Depending on the device in use and network design, one can group one to six physical ports in this zone.
Group multiple interfaces with different network subnets to manage them as a single entity. Group all the LAN
networks under this zone.

By default the traffic to and from this zone is blocked and hence the most secured zone. However, traffic between
ports belonging to the same zone will be allowed.

DMZ (DeMilitarized Zone) – This zone is normally used for publicly accessible servers. Depending on the device in
use and network design, one can group multiple physical ports in this zone.

WAN - This zone is used for Internet services. It can also be referred as Internet zone.

VPN – This zone is used for simplifying secure, remote connectivity. It is the only zone that does not have an
assigned physical port/interface. Whenever the VPN connection is established, port/interface used by the connection
is automatically added to this zone and on disconnection; port is automatically removed from the zone. Like all other
default zones, scanning and access policies can be applied on the traffic for this zone.

WiFi - This zone is used for wireless Internet services.

The device is shipped with single zone for LAN, WAN, DMZ, VPN and WiFi. These zones are called System Zones.
Administrator can add LAN and DMZ zone types.

Adding a Zone
Use the Add page to create a new Zone.

The Add Zone page allows you to enter zone details.

1. Go to Device Configuration > Configure > Network > Zones and click Add.
2. Enter the zone details.

Name
Provide a name to identify the zone.

Type
Select the type of Zone from the available options. LAN - Depending on the device in use and
network design, one can group one to six physical ports in this zone. Group multiple interfaces with
different network subnets to manage them as a single entity. Group all the LAN networks under this
zone.

By default the traffic to and from this zone is blocked and hence the highest secured zone. However,
traffic between ports belonging to the same zone will be allowed.

DMZ (DeMilitarized Zone) - This zone is normally used for publicly accessible servers.
Depending on the device in use and network design, one can group one to five physical ports in this
zone.

Note:  By default, entire traffic will be blocked except LAN to Local zone service
likes Administration, Authentication, and Network.

Members
Displays all the member ports.

Click the checkbox to select the ports. All the selected ports are moved to 'Selected port' list.

Description
Provide the description for the zone.
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Device Access
Device access defines the type of administrative access permitted on zone.

Admin Services - Enable Administrative Services that should be allowed through Zone:

• HTTP - Allow HTTP connection to the Admin Console through this zone
• HTTPS - Allow secure HTTPS connection to the Admin Console through this zone
• Telnet – Allow Telnet connection to CLI through this zone
• SSH – Allow SSH connection to CLI through this zone

Authentication Services – Enable Authentication Services that should be allowed through Zone:

• Windows/Linux Client
• Captive Portal
• NTLM
• Radius SSO

Network Services - Enable Network Services that should be allowed through Zone:

• DNS – Allow this zone to respond to DNS requests
• Ping/Ping6 – Allow this zone to respond to pings

Other Services - Enable other Services that should be allowed through Zone:

• Web Proxy
• SSL VPN

3. Click Save to add Zone with the options you have configured.

Note:

• If DMZ uses Private IP Address, use NATing to make them publicly accessible.
• One cannot add zone if the device is deployed as Bridge.
• Local and VPN zone cannot be updated or deleted.

DNS
Use DNS page to configure the DNS settings of the Device

DNS server is configured at the time of installation. You can add additional DNS servers to which device can connect
for name resolution. If multiple DNS are defined, they are queried in the order as they are entered.

Note:  You can also view and manage the DNS server status on the Monitor and Analyze > Diagnostics >
Services page.

When you want external domains names to be resolved through internal DNS Servers in your network, you can add
routes to such Servers. This will decrease the Internet traffic over the network and speed up DNS Client requests as
queries will not be forwarded outside the network. Also, DNS information would be less exposed on the Internet thus
enhancing security.

IPv4
Obtain DNS from DHCP

Click to override the device DNS with the DNS address received from DHCP server.

Option is available if enabled from Network Configuration Wizard or if a DHCP interface is
configured.

Obtain DNS from PPPoE

Click to override the device DNS with the DNS address received from PPPoE server.

Option is available if enabled from Network Configuration Wizard or if a DHCP interface is
configured.
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Static DNS

Select to provide static IPv4 DNS server address.

A maximum of three static DNS IPv4 addresses can be provided.

IPv6
Obtain DNS from DHCP

Click to override the device DNS with the DNS address received from DHCP server.

Option is available if enabled from Network Configuration Wizard or if a DHCP interface is
configured.

Static DNS

Select to provide static IPv6 DNS server address.

A maximum of three static DNS IPv6 addresses can be provided.

DNS Query Configuration
Choose server based on incoming requests record type

Select to choose the DNS server to be used for resolving the domain name on the basis of the
incoming requests record type. Incoming request can be of A or AAAA type.

Choose IPv6 DNS server over IPv4

Select to first choose IPv6 DNS server for resolving the DNS and then IPv4 DNS Server.

If both IPv6 and IPv4 DNS servers are configured, then it first selects IPv6 DNS server for all
requests followed by IPv4 DNS server.

Choose IPv4 DNS server over IPv6

Select to first choose IPv4 DNS server for resolving the DNS and then IPv6 DNS Server.

If both IPv6 and IPv4 DNS servers are configured, then it first selects IPv4 DNS server for all
requests followed by IPv6 DNS server.

Choose IPv6 if request originator address is IPv6, else IPv4

Select to choose IPv6 DNS server if request is received from IPv6 source or choose IPv4 DNS
server, if request is received from IPv4 source.

Test Name Lookup

Click and provide IP Address or host name for testing the connectivity with the DNS server.

DNS Host Entry
The DNS Host Entry page displays the list of all the configured host entries. You can filter list based on Host/Domain
name. The page provides the option to add, update, or delete the entries.

DNS Request Route
This section displays list of all the configured DNS Request Routes. You can also update the route configuration and
delete the routes.
Add DNS Host Entry

The Add DNS Host Enry page allows you to create and manage DNS Host Entries.

1. Go to Device Configuration > Configure > Network > DNS > DNS Host Entry and click Add.
2. Enter host entry details

Host/Domain Name
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Provide a Fully Qualified Domain Name (FQDN) for Host/Domain.

Address

Entry Type

Select DNS Host Entry type.

Available Options:

Manual – Manually enter the IP address for the host

Interface IP – Configure Interface as host

Maximum Entries Per Host- 8

IP Address

Specify the IP Address of Host/Domain or select an Interface IP depending on the option selected
for Entry Type.

Time to Live (Seconds)

Specify TTL in seconds.

Default - 60 seconds

Weight

Specify weight for load balancing the traffic. Device distributes traffic across the links in proportion
to the ratio of weights assigned to individual link.

This weight determines how much traffic will pass through a particular link relative to the other
link.

Default - 1

Publish on WAN

Enable to publish DNS Host Entry on WAN.

Default - Disabled

Reverse DNS Lookup

Reverse DNS lookup is the resolution of an IP address to its designated domain name. Enable to
allow reverse DNS lookup.

Figure 208: Add DNS Host Entry

Note:  If there are multiple hosts resolving to same IP Address then Reverse DNS
Lookup can be configured only for one of the IP Address.

Note:

• Only A, AAAA, and PTR type of DNS records are supported.
• Address (A) record - points a hostname to an IP address and returns a 32-bit IPv4 address.



 | Device Configuration | 251

• AAAA record - points a hostname to an IP address and returns a 128-bit IPv6 address.
• Pointer records (PTR) - are just the reverse of A records and are used for reverse lookups. It maps IP

address to a hostname.
• Maximum DNS entries supported - 1024
• If the device interface is used as a DNS in the Client system then a query is sent to the configured DNS

servers prior to querying the ROOT severs.
3. Click Save to create a host entry.

DNS Request Route
To configure DNS Request routes to internal DNS Servers.

Add/Edit DNS Request Route
Host/Domain Name

Specify the domain for which you want to use internal DNS Server.

Target Servers
Select DNS Server to resolve the domain specified above. You can also add IP Address from this
page.

Maximum of eight IP Addresses can be added.

DHCP Relay

The DHCP Relay Agent allows to place DHCP clients and DHCP servers on different networks. Deploying DHCP
in a single segment network is easy. All DHCP messages are IP broadcast messages, and therefore all the computers
on the segment can listen and respond to these broadcasts. But things get complicated when there is more than one
subnet on the network. This is because the DHCP broadcast messages do not, by default, cross the router interfaces.

The DHCP Relay Agent makes it possible for DHCP broadcast messages to be sent over routers that do not support
forwarding of these types of messages. The DHCP Relay Agent enables DHCP clients to obtain IP Addresses from a
DHCP server on a remote subnet, or which is not located on the local subnet. If DHCP Relay Agent is not configured,
clients would only be able to obtain IP Addresses from the DHCP server which is on the same subnet.

The DHCP Relay page displays list of all the interfaces configured as a relay agent and you can filter the list based on
relay agent name and IP Family. The page also provides option to:

• Add a new relay agent
• Update relay agent parameters
• Delete an Agent

Add DHCP Relay Agent

You can configure Interface as DHCP Relay Agent from this page.

1. Go to Device Configuration > Configure > Network > DHCP Relay and click Add
2. Enter DHCP Relay Configuration details.

Name
Provide a name to identify DHCP Relay Agent.

IP Family
Select the IP Family for DHCP Relay Agent.

Available Options: IPv4IPv6

Interface
Select Interface.

Interfaces having Static IP Assignment can act as a DHCP Relay Agent. Device cannot act as DHCP
server and DHCP Relay Agent simultaneously. Hence if device is configured as DHCP Relay
Agent, you will not be able to configure it as a server and vice-versa.
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DHCP Relay agent can be configured on virtual sub-interface but cannot be configured on Interface
alias.

DHCP Server IP
Specify DHCP Server IP Address. You can also configure multiple DHCP servers. This support
deployment where DHCP server running in high availability environment. DHCP Relay will
forward packets to all the configured DHCP Servers and active server will serve the request. In case
active server goes down, backup server serves the request. DHCP server takes care of leasing the IP
Address to a client.

Maximum DHCP servers configures per DHCP Relay - 8

Relay through IPSec (Only if IP Family is IPv4)
Click to enable Relay through IPSec VPN.

Figure 209: Add DHCP Relay Configuration
3. Click Save to add DHCP Relay Agent.

Routing

Routing provides options to configure both static and dynamic routes.

Available configurations:

• Upstream Proxy - Allows to configure parent proxy settings when the web traffic is blocked by the upstream
Gateway.

• Static Routing- Allows to configure packets redirection to a destination other than the configured default gateway.

Upstream Proxy

Enable Parent Proxy when the web traffic is intercepted by an upstream gateway.

When enabled all the HTTP requests will be sent to web parent proxy server via device.

IPv4 Parent Proxy
Parent Proxy

Click to enable the Parent Proxy if the web traffic is intercepted by an upstream gateway.

If enabled, device forwards all the HTTP requests to parent proxy server.

Domain Name/IPv4 Address
Specify Domain Name or IPv4 Address for the Parent Proxy.
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Port
Specify Port number, which is to be used for Parent Proxy.

Default - 3128

Username
Specify Username for authentication.

Password
Specify Password for authentication.

IPv6 Parent Proxy
Parent Proxy

Click to enable the Parent Proxy if the web traffic is blocked by the upstream gateway.

If enabled, device forwards all the HTTP requests to Parent Proxy.

Domain Name/IPv6 Address
Specify Domain Name or IPv6 Address for the Parent Proxy.

Port
Specify Port number to be used for Parent Proxy.

Default - 3128

Username
Specify Username for authentication.

Password
Specify Password for authentication.

Static Routing

A route provides the device with the information it needs to forward a packet to a particular destination. A static route
causes packets to be forwarded to a destination other than the configured default gateway.

By specifying through which interface the packet will leave and to which device the packet should be routed, static
routes control the traffic exiting the device.

Static Routing menu allows configuring IPv4 and IPv6 Unicast Routes.

IPv4 Unicast Route

The IPv4 Unicast Route section displays list of all the configured IPv4 unicast routes. You can filter the list based on
IP address, gateway, Interface, or distance. The page also provides option to add, update the route configuration and
delete the route.

IPv6 Unicast Route

The IPv6 Unicast Route section displays list of all the configured IPv6 unicast routes. You can filter the list based on
IP address, gateway, Interface, or distance. The page also provides option to add, update the route configuration and
delete the route.

Add Unicast Route

You can add Unicast Route from this page.

1. For IPv4 Unicast Route, navigate to Device Configuration > Configure > Routing > Static Routing and click
Add under IPv4 Unicast Route. For IPv6 Unicast Route, navigate to Device Configuration > Configure >
Routing > Static Routing and click Add under IPv6 Unicast Route.

2. Enter Unicast Route details.
Destination IP/Prefix

Specify destination IPv4 or IPv6 Address and select the prefix of subnet mask.
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Gateway
Specify gateway IPv4 or IPv6 Address. The gateway address specifies the next-hop router to which
traffic will be routed.

Interface
Select Interface from the list.

Distance
Specify distance for routing.

For IPv4

Default - 0

Acceptable Range - 0 to 255

For IPv6

Default - 1

Acceptable Range - 1 to 255
3. Click Save to add Unicast Route.

Authentication

Servers
On this page you can manage databases and backend servers of external user authentication services. External user
authentication allows you to validate user accounts against existing user databases or directory services on other
servers of your network.

Device Configuration > Configure > Authentication > Servers

Authentication services currently supported are:

• Novell's eDirectory
• Microsoft's Active Directory
• RADIUS
• TACACS+
• LDAP

The page displays all existing authentication servers. You can add an authentication server, update or delete them.
Following is a description of the table elements:

Name

Displays the name of the authentication server.

IP

Displays the IP address of the authentication server.

Port

Displays the Port of the authentication server.

Type

Displays the type of the authentication server.

Domain/Admin

Displays the domain or admin of the authentication server.

Manage

Displays the available managing options for the authentication server:
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• Edit: Allows you to edit the authentication server.
• Delete: Allows you to delete the authentication server.

To either add or delete a authentication server, click on the corresponding buttons.

Related concepts
Add an External Server on page 255
On this page you can create one or more authentication servers. Follow the links to create them:

Add an External Server
On this page you can create one or more authentication servers. Follow the links to create them:

Active Directory

Active Directory (AD) is Microsoft's implementation of a directory service and is a central component of Windows
2000/2003 servers. It stores information about a broad range of resources residing on a network, including users,
groups, computers, printers, applications, services, and any type of user-defined objects. As such it provides a means
of centrally organizing, managing, and controlling access to these resources. The Active Directory authentication
method allows you to register Sophos Firewall OS at a Windows domain, thus creating an object for Sophos Firewall
OS on the primary domain controller (DC). Sophos Firewall OS is then able to query user and group information from
the domain.

Note:  Sophos Firewall OS supports Active Directory 2003 and newer.

Add Active Directory Server on page 256

LDAP

LDAP, an abbreviation for Lightweight Directory Access Protocol, is a networking protocol for querying and
modifying directory services based on the X.500 standard. Sophos Firewall OS uses the LDAP protocol to
authenticate users for several of its services, allowing or denying access based on attributes or group memberships
configured on the LDAP server.

Add LDAP Server on page 257

RADIUS

RADIUS, the acronym of Remote Authentication Dial In User Service is a widespread protocol for allowing
network devices such as routers to authenticate users against a central database. In addition to user information,
RADIUS can store technical information used by network devices, such as supported protocols, IP addresses,
routing information, and so on. This information constitutes a user profile, which is stored in a file or database on
the RADIUS server. The RADIUS protocol is very flexible, and servers are available for most operating systems.
The RADIUS implementation on Sophos Firewall OS allows you to configure access rights on the basis of proxies
and users. Before you can use RADIUS authentication, you must have a running RADIUS server on the network.
Whereas passwords are encrypted using the RADIUS secret, the username is transmitted in plain text.

Add RADIUS Server on page 259

TACACS+

TACACS+ (the acronym of Terminal Access Controller Access Control System) is a proprietary protocol by Cisco
Systems, Inc. and provides detailed accounting information and administrative control over authentication and
authorization processes. Whereas RADIUS combines authentication and authorization in a user profile, TACACS
+ separates these operations. Another difference is that TACACS+ utilizes the TCP protocol (port 49) while
RADIUSClosed uses the UDPClosed protocol.

Add TACACS+ Server on page 262
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eDirectory

Novell eDirectory is an X.500 compatible directory service for centrally managing access to resources on multiple
servers and computers within a given network. eDirectory is a hierarchical, object-oriented database that represents
all the assets in an organization in a logical tree. Those assets can include people, servers, workstations, applications,
printers, services, groups, and so on.

Add eDirectory Server on page 260

Add Active Directory Server
Use the Add External Server page to configure Active Directory Server settings.

The Add External Server page allows to configure Active Directory which in turn allows the device to map the users
and groups from ADS for the purpose of authentication.

1. Go to Device Configuration > Configure > Authentication > Authentication Server and click Add.
2. On the Add External Server page, select Active Directory for Server Type. If a user is required to authenticate

using ADS, the device needs to communicate with the ADS server for authentication.
3. Enter Active Directory details.

Server Name
Enter a descriptive name for the Active Directory server.

Server IP/Domain
Enter an IP address or domain for the Active Directory server.

Port
Enter the port of the Active Directory server. By default, this is port 389.

NetBIOS Domain
Enter a NetBIOS domain for the Active Directory server.

ADS Username
Enter a username for the admin user of the Active Directory server.

Password
Enter a password for the admin user of the Active Directory server.

Connection Security
Select the type of security to be implemented on the established connection. It provides a method to
login to the external server by sending the username and password in encrypted format instead of
clear text. We strongly recommend using the encryption method to protect user credentials.

• Simple: User credentials will be send unencrypted, for example, as clear text.
• SSL: Secure Sockets Layer. This is the most common method used for secured connection. The

Port will then change from 389 (LDAPClosed) to 636 (ldaps = LDAP over SSL).
• TLS:

Validate Server Certificate
(not with Simple connection security)

Enable to validate the certificate on the external server.

Display Name Attribute
(optional)

Enter the name for the AD server which is displayed as AD username.

Email Address Attribute
(optional)

Enter the alias for the configured email address which is displayed to the user.
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Domain Name
Specify the domain name for which the query is to be added.

Search Queries
Click Add to enter the search query. Use the Move Up and Move Down buttons to move the search
queries in the list. Use Remove to remove the selected item.

If you do not know search DN, refer to NetBIOS name, FQDN and Search DN.

Figure 210: Add External Server

4. Click Test Connection to check the connectivity between Active Directory server and the Sophos XG Firewall. It
also validates Active Directory server user credentials.

5. Click Save.

The AD server is now available and appears in the Authentication Server list.
Add LDAP Server

This page describes how to add a LDAP server.

1. Go to Device Configuration > Configure > Authentication > Authentication Server and click Add.
2. Select the server type LDAP Server.
3. Enter values for the following settings:

Server Name
Enter a descriptive name for the LDAP server.

Server IP/Domain
Enter an IP address or domain for the LDAP server.
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Port
Enter the port of the LDAP server. By default, this is port 389.

Version
Select the version of the LDAP server.

Anonymous Login
Enable to send anonymous requests to the LDAP server. Disable to bind user with the server.

Username
(not with Anonymous Login)

Enter a name for the bind user.

Password
(not with Anonymous Login)

Enter a password for the bind user.

Connection Security
Select the connection security for the LDAP server:

• Simple: User credentials will be send unencrypted, for example, as clear text.
• SSL: Secure Sockets Layer. This is the most common method used for secured connection. The

Port will then change from 389 (LDAPClosed) to 636 (ldaps = LDAP over SSL).
• TLS: Transport Layer Security. Same secure connection as SSL but uses the default port.

Validate Server Certificate
(not with Simple Connection Security)

Enable to validate the certificate on the external server.

Client Certificate
Select a client certificate from the list to establish a secured connection. If you do not want a client
certificate, select None.

Note:  You can manage client certificates under Objects > Identity > Certificate.

Base DN
Enter the Base DN for the LDAP server. The Base DN is the starting point relative to the root of the
LDAP tree where the users are included who are to be authenticated. Note that the Base DN must be
specified by the Fully Distinguished Name (FDN) in LDAP notation, using commas as delimiters
(e.g., O=Example,OU=RnD).

Get Base DN
Click Get Base DN if you are not aware about the Base DN. The Base DN is automatically
retrieved from the directory.

Authentication Attribute
Enter an authentication attribute for searching the LDAP directory. The user authentication attribute
contains the actual login name each user is prompted for, for example by remote access services.

Display Name Attribute
Enter the name for the LDAP server which is displayed as LDAP username.

Email Address Attribute
Enter the alias for the configured email address which is displayed to the user.

Group Name Attribute
Enter the alias for the configured group name which is displayed to the user.

Expire Date Attribute
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Enter the user expire date displayed to the user. The attribute specifies how long a user account is
valid.

Figure 211: Add External Server
4. Click Test Connection to check the connectivity between LDAP and the Sophos Firewall OS. It also validates

LDAP user credentials.
5. Click Save.

The LDAP server is now available and appears in the Authentication Server list.
Add RADIUS Server

This page describes how to add a RADIUS server.

1. Go to Device Configuration > Configure > Authentication > Authentication Server and click Add.
2. Select the server type RADIUS Server.
3. Enter values for the following settings:

Server Name
Enter a descriptive name for the RADIUS server.

Server IP
Enter an IP address for the RADIUS server.

Authentication Port
Enter the authentication port of the RADIUS server. By default, this is port 1812.

Enable Accounting
Enable accounting on RADIUS server.
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Sophos Firewall OS sends the following information to the RADIUS server as soon as the user logs
in:

• Accounting start request
• User login time

Sophos Firewall OS sends the following information to the RADIUS server the moment the user
logs out:

• Accounting stop request
• User logout time

Note:  Supported client types: Windows Client, HTTP Client, Linux Client, Android,
iOS, iOS HTTP Client, Android HTTP Client, API Client.

Note:  The accounting stop message is not sent to the RADIUS server when Sophos
Firewall OS shuts down or reboots.

Accounting Port
(only if Enable Accounting is active)

Enter a RADIUS port number through which the Sophos Firewall OS can communicate with
RADIUS.

Shared Secret
Enter the shared secret which is a text string that serves as a password between a RADIUS client
and a RADIUS server.

Group Name Attribute
Enter the alias for the configured group name which is displayed to the user.

4. Optional. Click Enable Additional Settings and specify settings.
NAS-identifier

String identifying the NAS originating from access request, for example, an FQDN.

NAS-port-type
Type of the physical port of the NAS which authenticates the user.

Figure 212: Add External Server
5. Click Test Connection to check the connectivity between the RADIUS server and the Sophos XG Firewall. It also

validates RADIUS server user credentials.
6. Click Save.

The RADIUS server is now available and appears in the Authentication Server list.
Add eDirectory Server

This page describes how to add a eDirectory server.

1. Go to Device Configuration > Configure > Authentication > Authentication Server and click Add.
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2. Select the server type eDirectory.
3. Enter values for the following settings:

Server Name
Enter a descriptive name for the eDirectory server.

Server IP/Domain
Enter an IP address or domain for the eDirectory server.

Port
Enter the port of the eDirectory server. By default, this is port 389.

Connection Security
Select the connection security for the eDirectory server:

• Simple: User credentials will be send unencrypted, for example, as clear text.
• SSL: Secure Sockets Layer. This is the most common method used for secured connection. The

Port will then change from 389 (LDAPClosed) to 636 (ldaps = LDAP over SSL).
• TLS: Transport Layer Security. Same secure connection as SSL but uses the default port.

Validate Server Certificate
(not with Simple)

Enable to validate the certificate on the external server.

Client Certificate
Select a client certificate from the list to establish a secured connection. If you do not want a client
certificate, select None.

Note:  You can manage client certificates under Objects > Identity > Certificate.

Base DN
Enter the Base DN for the eDirectory server. The Base DN is the starting point relative to the root
of the eDirectory tree where the users are included who are to be authenticated. Note that the Base
DN must be specified by the Fully Distinguished Name (FDN) in LDAP notation, using commas as
delimiters (e.g., O=Example,OU=RnD).

Get Base DN
Click Get Base DN if you are not aware about the Base DN. The Base DN is automatically
retrieved from the directory.
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Figure 213: Add External Server
4. Click Test Connection to check the connectivity between the eDirectory server and the Sophos XG Firewall. It

also validates eDirectory server user credentials.
5. Click Save.

The eDirectory server is now available and appears in the Authentication Server list.
Add TACACS+ Server

This page describes how to add a TACACS+ server.

1. Go to Device Configuration > Configure > Authentication > Authentication Server and click Add.
2. Select the server type TACACS+ Server.
3. Enter values for the following settings:

Server Name
Enter a descriptive name for the TACACS+ server.

Server IP
Enter an IP address for the TACACS+ server.

Port
Enter the port of the TACACS+ server. By default, this is port 49.

Shared Secret
Enter the shared secret which is a text string that serves as a password between a TACACS+ client
and a TACACS+ server.
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Figure 214: Add External Server
4. Click Test Connection to check the connectivity between the TACACS+ server and the Sophos Firewall OS. It

also validates TACACS+ server user credentials.
5. Click Save.

The TACACS+ server is now available and appears in the Authentication Server list.

Services

This menu allows you to configure Authentication for Firewall, VPN and Admin traffic. You can also configure
Global Settings, NTLM Settings, Web Client Settings, Captive Portal parameters and Radius Client settings for Single
Sign-On Server.

Note:  You can also view and manage the authentication status on the Device Configuration > Monitor and
Analyze > Diagnostics > Services page.

Once you have deployed the device, default access policy is automatically applied which will allow complete network
traffic to pass through the device. This will allow you to monitor user activity in your Network based on default
policy.

As device monitors and logs user activity based on IP Address, all the reports are also generated based on IP
Address. To monitor and log user activities based on usernames or logon names, you have to configure the device for
integrating user information and authentication process. Integration will identify access request based on usernames
and generate reports based on usernames.

When the user attempts to access, the device requests a user name and password and authenticates the user’s
credentials before giving access. User level authentication can be performed using the local user database on the
device, External ADS server, LDAP, RADIUS or TACACS+ server.

To set up user database

1. Integrate ADS, LDAP, RADIUS or TACACS+ if external authentication is required.
2. Configure for local authentication.
3. Register user

The device provides policy-based filtering that allows defining individual filtering plans for various users of your
organization. You can assign individual policies to users, or a single policy to a number of users (Group).

Device detects users as they log on to a Windows domain in your network via client machines. Users are allowed or
denied access based on username and password. In order to authenticate a user, you must select at least one database
against which device should authenticate users.

To filter the Internet requests based on policies assigned, the device must be able to identify a user making a request.

The administrator can configure authentication based on the type of – Administrator, Firewall, VPN, and SSL VPN
with multiple servers.

Below are the screen elements with their description:

Firewall Authentication Methods
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Authentication Server List
Select Authentication server.

Authentication Server List displays all the configured servers while Selected Authentication
Server List displays servers that will be used for authentication when the user tries to login.

In case of multiple servers, authentication request is forwarded as per the order configured in the
Selected Authentication Server List.

Default Group
Select the default group for firewall authentication.

VPN (IPSec/L2TP/PPTP) Authentication Methods
Set Authentication Methods Same As Firewall

Enable to use the same authentication method as configured for firewall traffic. If enabled all
the authentication servers configured for the firewall traffic will be available for VPN traffic
authentication configuration.

Authentication Server List displays all the configured servers while Selected Authentication
Server List displays servers that will be used for authentication when user tries to login.

Override authentication method for VPN traffic by selecting or deselecting any Authentication
server.

In case of multiple servers, authentication request will be forwarded as per the order configured in
the Selected Authentication server List.

If RADIUS server authenticates users then PPTP and L2TP connections established using
MSCHAPv2 or CHAP protocol can be authenticated through RADIUS.

Administrator Authentication Methods

Administrator can configure and manage authentication settings for all the Administrator Users except for the super
administrator from this page.

Set Authentication Methods Same As Firewall
Select to use the same authentication method as configured for firewall traffic. If enabled all the
authentication servers configured for the firewall traffic will be available for administrator traffic
authentication configuration.

Authentication Server List displays all the configured servers while Selected Authentication
Server list displays servers that will be used for authentication when user tries to login.

Override authentication method for administrator traffic by selecting or deselecting any
Authentication server.

In case of multiple servers, authentication request will be forwarded as per the order configured in
the Selected Authentication server List.

Global Settings
Maximum Session Timeout

Specify the timeout duration in minutes.

Acceptable Range (minutes) - 3 to 1440

Authentication Session timeout is the time in minutes a user is logged into the device. Exceeding
the period, the user will be logged out automatically and the user must re-authenticate. This is
applicable to administrative sessions only.

Enable “Unlimited” to allow the users to remain logged in.

Simultaneous Logins

Specify the maximum number of concurrent logins allowed to the user.
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Acceptable Range – 1 to 99 concurrent logins

OR

Enable “Unlimited” to allow unlimited concurrent logins to the user.

Login restriction is applicable to only those users who are added after this configuration.

NTLM Settings
Inactivity Time

Specify the inactivity time in minutes.

User Inactivity timeout is the inactive/idle time in minutes after which user will be logged out and
has to re-authenticate.

Acceptable Range (Minutes) - 6 to 1440

Default – 6

Data Transfer Threshold

Specify the minimum data to be transferred.

If the minimum data is not transferred within the specified time, the user will be marked as inactive.

Default – 1024 Bytes

HTTP challenge redirect on Intranet Zone

Select to Enable or Disable the redirection of NTLM HTTP challenge on Intranet Zone.

When any site hosted on the Internet initiates the NTLM web proxy challenge for authentication, the
client is transparently authenticated by the browser through device by sending credentials over the
Internet.

To secure and to prevent the user credential from going out on the Internet, device will redirect
NTLM authentication challenge on Intranet Zone. Client will be transparently authenticated through
device's Local Interface IP and credentials will be exchanged in Intranet zone only.

Default - Enable

Web Client Settings (iOS and Android and API)
Inactivity Time

Specify the inactivity time in minutes.

User Inactivity timeout is the inactive/idle time in minutes after which user will be logged out and
has to re-authenticate.

Acceptable Range (Minutes) - 6 to 1440

Default – 6 minutes

Data Transfer Threshold

Specify the minimum data to be transferred.

If the minimum data is not transferred within the specified time, the user will be marked as inactive.

Default – 1024 Bytes

SSO using radius accounting request

Device can authenticate users transparently who have already authenticated on an external RADIUS server. Click 

to add,  to delete or Edit hyperlink to edit Radius Client configurations.

Radius Client IPv4

Specify IPv4 Address of Radius Client.
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Only request from specified IP Address will be considered for SSO.

Shared Secret

Provide Shared Secret for authentication.

Show Shared Secret

Click Show to view the configured Shared Secret.

Captive Portal Settings
Unauthenticated users redirection

Select "Yes" to redirect the access request of unauthenticated user either to the Captive Portal or
Custom Message page.

Select "No" to display "Access Denied" message to unauthorized user.

Unauthenticated users settings
Configure where the unauthenticated user access requests should be redirected.

Available Options:

• Captive Portal
• Custom Message

Select Captive Portal, if an unauthenticated user access request is to be forwarded to captive
portal.

HTTPS Redirection Enable to provide access of the Captive portal
page through secure channel.

User Portal Link Enable/Disable to make the “User Portal” link
available on the Captive Portal page.

Default – Enable

URL Redirection after Login Enable to redirect request to the user requested
page or custom page.

URL to redirect If request is to be redirected to the custom page,
click Custom URL and specify URL, else click
User requested URL.

Preserve captive portal after login Select “Yes” to minimize the captive
portal popup, once the user is successfully
authenticated.

Selecting “No” lets the Captive Portal to be
displayed on system screen after successful
authentication.

Keep Alive Request For Captive Portal Keep-Alive request is constantly exchanged
between the device and user to check whether
user has logged out or idle. If the device does
not receive the response, user is logged out
automatically.

More number of concurrent HTTP Captive
Portal users, more number of keep-alive
requests. In case of more concurrent HTTP
Captive Portal users we recommend to disable
it.
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Default – Enable

If disabled, user is logged out after the
configured inactivity time. If disabled, specify
user inactivity time and data transfer threshold.

User Inactivity Timeout User Inactivity timeout is the inactive/idle time
in minutes after which user will be logged out
and has to re-authenticate.

Enable and specify timeout duration in minutes.

Acceptable Range (minutes) - 3 to 1440

Default - Disable

Data Transfer Threshold Specify threshold value in Bytes for Data
Transfer.

If the minimum data is not transferred within
the specified time, the user will be marked as
inactive.

Select Custom Message, if unauthenticated user is to be displayed custom message.

Windows Corporate Client Download Link

Enable to publish a link to download the Windows Corporate Client in the custom message.

Linux Corporate Client Download Link

Enable to publish a link to download the Linux Corporate Client in the custom message.

MAC Corporate Client Download Link

Enable to publish a link to download the MAC Corporate Client in the custom message.

Page Header Image

Display the default image shipped with the device at the top of the custom message page or use
Browse and upload the custom image.

Supported Image format - JPG, PNG or GIF

Size - 700 X 80 pixels

Page Footer Image

Display the default image shipped with the device at the bottom of the custom message page or use
Browse and upload the custom image.

Supported Image format - JPG, PNG or GIF

Size - 700 X 80 pixels

Custom Message

Specify message. You can customize the message to include client IP Address, category, and URL.

Blink Custom Message Enable Blink Custom Message to display
blinking message.

Preview Preview and check how message will be
displayed before saving the configuration.

SSL VPN Authentication Methods
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Enable to use the same authentication method as configured for VPN or Firewall or configure authentication server
for SSL VPN.

Authentication Server List displays all the configured servers while Selected Authentication server list displays
servers that will be used for authentication when user tries to login.

Override authentication method for SSL VPN traffic by selecting or deselecting any Authentication server.

In case of multiple servers, authentication request will be forwarded as per the order configured in the Selected
Authentication server List.

One-time Password

On this page, you can configure the one-time password (OTP) service, and monitor or edit the tokens of the one-time-
password users.

One-time passwords are a method to improve security for password-based authentication. The user-specific password,
which is sometimes too weak, will be amended with a one-time password that is valid for only one login. Thus, even
if an attacker gets hold of it, he will not be able to log in with it.

One-time passwords generally change consistently, in regular intervals, being calculated automatically by a specific
algorithm. Soon after a new password is calculated, the old password expires automatically. To calculate one-time
passwords, the user needs to have either a mobile device with an appropriate software, or a special hardware or
security token. Hardware tokens are ready to use from the start. On the mobile device, the end user needs to install
Sophos Authenticator or a similar software and deploy the configuration, which is available on the start page or
on the OTP Token page. Having done that, the device calculates one-time passwords in token-specific intervals. It
is important that date and time are correct on the mobile device as the time stamp is used for one-time password
generation.

Note:  To authenticate on the facilities where the one-time password is required, the user has to enter his user-
specific device password, directly followed by the one-time password.

The administrator can also generate one-time passwords while editing the token, also known as passcodes, manually.
In this case, you have to ensure that these are not time-limited one-time passwords and are safely transmitted to the
end user.

The page displays all existing one-time passwords. You can add , update or delete an OTP. For each OTP, the list
shows:

Username

Displays the user name of the OTP owner.

Note:  QR code will not be displayed for tokens where User is not assigned.

Status

Displays the status of the OTP.

Secret

Displays the 32-hex secret of the OTP.

Description

Displays description of OTP.

Manage

Displays the available management options:

• Info: Click to view the QR code.
• Edit: Allows you to edit the OTP.
• Delete: Allows you to delete the OTP.
• Synchronize:Click to synchronize OTP with Sophos XG Firewall device(s).
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To add or delete a token or configure the general OTP settings, click on the corresponding buttons.

Related tasks
Add OTP Token on page 269

One-time Password Settings on page 269

Add OTP Token

This page enables you to add and edit one-time password tokens.

1. Go to Device Configuration > Configure > Authentication > One-time Password and click the Add button.
2. Specify the following details while adding an OTP token:

Secret
This is the shared secret of the user's hardware token or soft token. A hardware token has an
unchangeable secret, given by the hardware producer. The soft token is created randomly by
Firewall, when Auto-create OTP tokens for users is enabled in OTP Settings. The secret should
have a hexadecimal format and consist of at least 32 characters.

User (optional)
Select the user to whom the token should be assigned.

Note:  Clientless Users cannot be assigned.

Description (optional)
Add a description upto 255 characters. This text will be displayed for the administrator with the QR
code. If you define different tokens for one person, e.g., a hardware token and a soft token for the
mobile phone, it is useful to enter some explanation here as the user will be displayed all QR codes
side by side.

Use custom token timestep
If you need another timestep for a token than the default token timestep defined in the OTP Settings
section, enable this toggle switch and enter the value. The timestep defined here has to correspond
with the timestep of the user's password generation device, otherwise authentication fails.

Timestep
Enter the value for the timestep.

Acceptable range: 10 - 300 seconds.

Additional Codes (Available only when editing OTP token)
You can add one-time passwords manually for a token. Click the Plus icon to generate the one-time
passwords (maximum 10). These one-time passwords are not time-limited. A one-time password
will be deleted automatically when the user has logged in with it.

3. Click Save.

The OTP token for the specific user will be created and will appear in the one-time password list on the One-time
Password page. Default Status of the token will be enabled.
One-time Password Settings

This page allows you to enable and configure the one-time password service.

1. Go to Device Configuration > Configure > Authentication > One-time Password and click the Settings button.
2. Activate the one-time password service by clicking on the One-time Password ON/OFF switch.
3. Specify the OTP service status.

OTP for all users
If enabled, all users have to use one-time passwords. If only specific users should use one-time
passwords, disable this option and select Add New Item and add users or groups from the list.

Auto-Create OTP Tokens for users



 | Device Configuration | 270

If enabled, a QR code for configuring the mobile device software will be presented to the authorized
users the next time they log in to the User Portal. For this to work, make sure that the users have
access to the User Portal. When a user logs in to the User Portal, the respective token will appear
in the OTP Tokens list. Enabling this feature is recommended when you are using soft tokens on
mobile devices. If your users only use hardware tokens you should instead disable this option and
add the tokens before enabling the OTP feature.

Enable OTP for facilities
Here, you select the Sophos XG Firewall device facilities that should be accessed with one-time
passwords by the selected users. When you select the Auto-create OTP tokens for users option,
the User Portal needs to be enabled for security reasons: As the User Portal gives access to the OTP
tokens, it should have no weaker protection itself.

Note:  When selecting WebAdmin you have to ensure that the selected users
have access to the one-time password tokens. Otherwise you may log them out
permanently.

4. Specify the timestep settings.
Default token timestep in seconds

To synchronize one-time password generation on the mobile device and on the CFM, the timestep
has to be identical on both sides. Some hardware tokens use 60 seconds. Other software OTP
tokens use a timestep of 30 seconds which is the default value here. If the timestep does not match,
authentication fails.

Acceptable Range: 10 - 300 seconds

Default: 30 seconds

Maximum passcode offset steps
With help of this option you can set the maximum passcode offset steps. This means for example
you set 3 steps you restrict the clock of a token to drift no more than 3 timesteps between two
logins.

Acceptable range: 0 - 10 steps

Default: 1 step

Maximum initial passcode offset steps
With help of this option you can set the maximum initial passcode offset steps. This means for
example you set 10 steps you restrict the clock of a token to drift no more than 10 timesteps between
two logins. This option is only applied when the user employs the token for the very first time.

Acceptable range: 0 - 600 steps

Default range: 10 steps
5. Click Apply.
6. Select Sophos XG Firewall device(s) on which you want to apply this configuration and click Save.

The one-time password settings will be saved and immediately applicable.

Groups
The Groups page displays list of all the default and custom groups.

Group is a collection of users having common policies that can be managed as a single unit and a mechanism of
assigning various policies to a number of users in one operation/step. Users that belong to a particular group are
referred to as a group user.

A group can contain default as well as custom policies.

Various policies that can be grouped are:

• Surfing Quota policy which specifies the duration of surfing time and the period of subscription
• Access Time policy which specifies the time period during which the user will be allowed access
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• Web Filter Policy which controls and blocks access to inappropriate web sites
• Application Filter Policy which controlling access to application like IM and P2P, VOIP
• QoS policy which specifies the bandwidth usage limit of the user
• Data Transfer Policy which specifies the data transfer quota of the user
• SSL VPN Policy which determines the access mode and controls access to private network resources.

The page also provides option to add new group, update group parameters, add new members to the existing group,
view user group membership, or delete a group.

Creating a New User Group
Use the Add Group page to create a group of policies.

The Add Group page allows you to configure a group of policies. Once the appropriate Group is assigned, the user
will automatically inherit all the policies added to the group.

1. Go to Device Configuration > Configure >  Authentication >  Groups and click Add.
2. Enter user group details.

Group Name
Provide a name to identify the group.

Description
Provide group description.

Group Type
Select Group Type.

Available Options:

Normal - User of this group needs to log on using the device client to access the Internet. Clientless
- User of this group does not need to log on using the device client to access the Internet and is
symbolically represented as Group name(C). Access control is placed on the IP Address.

Figure 215: Add Group details
3. Configure the policies.

Surfing Quota
Select the Surfing Quota Policy from the list.

Note:  Unlimited policy is automatically applied to Clientless Group.

Access Time (Not applicable to Clientless Group)
Select the Access Time Policy from the list.

Note:  Unlimited policy is automatically applied to Clientless Group.

Network Traffic (Not applicable to Clientless Group)
Select the Network Traffic Policy from the list.

Configured policy will be applicable to all the users who are member of this group.

Traffic Shaping
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Select the Traffic Shaping policy from the list.

Configured policy will be applicable to all the users who are member of this group.

Remote Access

Clientless
By default, user will inherit its group policy. To override the group policy, select the policy from the
list.

You can also create a new policy directly from this page itself or from System >  VPN >  SSL VPN
page.

If user is not to be provided the SSL VPN access then select "No Policy Applied".

Quarantine Digest
Configure Quarantine Digest.

Quarantine digest is an Email containing a list of quarantined spam messages filtered by the device
and held in the user quarantine area. If configured, device will mail the digest on hourly, daily or
weekly basis to the user. Digest also provides a link to User Portal from where user can access and
take the action on quarantined messages.

Available Options:Enable - User will receive the Quarantine Digest on configured frequency and
overrides Group setting. Disable - User will not receive Quarantine Digest and overrides Group
setting.

MAC Binding (Not applicable to Clientless Group)

Enable/disable “MAC Binding”. By binding User to MAC Address, you are mapping user with a
group of MAC Addresses.

L2TP (Not applicable to Clientless Group)

Enable if group users can get access through L2TP connection.

PPTP (Not applicable to Clientless Group)

Enable if group users can get access through PPTP connection.

Login Restriction (Not applicable to Clientless Group)
Select the appropriate option to specify the login restriction for the user group.

Available Options: Any Node - Select to allow user to login from any of the nodes in the
network.Selected Nodes - Select to allow user to login from the specified nodes only. Specify IP

Address and click Add icon  to add more nodes and remove icon  to delete nodes. You

can even edit the added IP Address by first clicking on the edit icon  and then on the save icon

.

Note:  Editing and removing IP Address options are only provided for the Groups that
have been already added.

Node Range - Select to allow range of IP Address. Specify IP Address range.

Only IPv4 Addresses must be provided for options “Selected Nodes” and “Node Range”.
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Figure 216: Add Group Policies
4. Click Save to create the new user group.

Note:  User Configuration - MAC binding and policies is given precedence over Group configuration.

Adding Users to the Existing Groups
Use Add Group Member page to add a user to the existing groups.

This page allows you to add group member to the existing groups.

1. Go to Device Configuration > Configure >  Authentication >  Groups .
2.

Select the Group in which you want to add the users by clicking Manage icon  in the Manage column.
3. Click Add Member(s) button. A pop-up Add Group Member appears providing list all the users along their details

that can be added in the group. To search user filter the list based on Username and/or current group.
4. Select the user you want to add in the group. You can select single or multiple users on a single page.
5. Click Apply and click OK to confirm adding member in the group.

Viewing List of Group Members
Use this page to view group members.

This page displays the list of group members.

1. Go to Device Configuration > Configure >  Authentication >  Groups.
2.

Click the Group in which you want to add the users by clicking Manage icon  in the Manage column.
3. Click Show Group Member(s) button. A pop-up Group Members appears providing the list all the users with the

details who are member of the selected group.
4.

Click Close or Close icon  to close the Group Member pop-up.



 | Device Configuration | 274

User
The User page displays the list of all the users added in the device.

Users are identified by an IP Address or a Username and assigned to a user group. All the users in a group inherit the
policies defined for that group.

Media Access Control (MAC) Address is a unique identifier (hardware address) assigned to a host by the
manufacturer for identification and is intended to be immutable. MAC Addresses are 48 bit values that are expressed
in 6 byte hex-notation separated by colon for example 01:23:45:67:89:AB.

To improve the security of your network and provide spoofing protection, you can enable User-MAC Address
binding. By binding User to MAC Address, you are mapping user with a group of MAC Addresses. It means a user
would be able to login through a group of pre-specified machines only making it more difficult for a hacker using
random MAC Addresses or spoofing a MAC Address to gain access to your network.

User types

Device supports five types of Users:

• Normal
• Clientless
• Single Sign on
• Thin Client User
• WWAN User

Normal User has to logon to the device. Requires client (client.exe) on the User machine or user can use HTTP Client
component and all the policy-based restriction are applied.

Clientless does not require client component (client.exe) on the User machines.

Users are automatically logged to the device if Single sign on settings are configured.

Use the given decision matrix below to choose which type of the user should be created.

Table 1: Decision matrix for adding a User

Feature Normal User Clientless User Single Sign On User

User Login required Yes No No

Type of Group

Normal Yes No Yes

Clientless No Yes No

Apply Login restriction Yes Yes Yes

Apply Surfing Quota policy Yes No Yes

Apply Access Time policy Yes No Yes

Apply Traffic Shaping
policy

Yes Yes Yes

Apply Web Filter Policy Yes Yes Yes

Apply Application Group
policy

Yes Yes Yes

Apply Network Traffic
policy

Yes No Yes

You can filter the list of user's Name, Username, Group, Web and Application Filter policy applied to the user, and
date on which users were added.
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Note:  You can also view and manage live users on the Monitor and Analyze > Current Activity > Live
Users page.(Only at appliance level)

The page also provides options to:

• Register new user
• Reset User Accounting
• View Usage
• Add users by importing user details from the file
• Export user details
• Change Status
• Purge AD users

Registering a New User
Use the Add User page to enter a new user and quickly configure a related policy.

The Add User page allows you to manually enter user details and configure related policies for a user on your
system.

Once a user is registered successfully, the page provides two more options:

• Reset User Accounting- Click to reset the usage accounting i.e. internet usage time and data transfer of the user.
• View Usage- Click to view the Internet usage and data transfer usage.

1. Go to Device Configuration > Configure >  Authentication >  User and click Add.
2. Enter user details.

Username
Enter Username, which uniquely identifies user and to be used for login.

Name
Enter Name of the user.

Password
Enter password and re-enter same password for confirmation.

Password is case-sensitive.

User Type
Select the type of user from the available options. UserAdministrator

Profile (Only when User Type is Administrator)
Select the administrator profile. Administrator will get access of various Admin Console menus as
per the configured profile.

Create a new profile directly from this page or from the profile page.

Email
Specify Email Address of the user.

Use comma to seperate multiple Email Addresses.

Description
Provide user description.
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Figure 217: Add User details
3. Enter policies details.

Group
Select Group in which the user is to be added. User will inherit all the policies assigned to the group.

Surfing Quota
By default, user will inherit its group policy. To override the group policy, select the policy from the
list.

You can also create a new policy directly from this page itself or from Protection > Web
Protection >  Surfing Quota or Objects >  Policy >  Surfing Quota page.

Access Time
By default, user will inherit its group policy. To override the group policy, select the policy from the
list.

You can also create a new policy directly from this page iteself or from Objects >  Policy >  Access
Time page.

Network Traffic
By default, user will inherit its group policy. To override the group policy, select the policy from the
list.

You can also create a new policy directly from this page itself or from Objects >  Policy >  Data
Transfer page.

Traffic Shaping
By default, user will inherit its group policy. To override the group policy, select the policy from the
list.

You can also create a new policy directly from this page itself or from Objects > Policy >  Traffic
Shaping page.
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Figure 218: Add User Policies
4. Enter SSL VPN Policy details.

Remote Access
By default, the user will inherit its group policy. To override the group policy, select a policy from
the list.

You can also create a new policy directly from this page itself or from System >  VPN >  SSL VPN
(Remote Access) page.

If user is not to be provided SSL VPN access then select No Policy Applied.

Clientless
By default, the user will inherit its group policy. To override the group policy, select a policy from
the list.

You can also create a new policy directly from this page itself or from System >  VPN >  Clientless
Access page.

If user is not to be provided clientless access then select No Policy Applied.

L2TP
By default, user is provided remote access through L2TP. Disable if remote access is not to be
provided to the user.

Provide the IP Address (IPv4/IPv6) to be leased to the user for L2TP access.

PPTP
By default, user is provided remote access through PPTP. Disable if remote access is not to be
provided to the user.

Provide the IP Address (IPv4/IPv6) to be leased to the user for PPTP access.

Quarantine digest is an Email containing a list of quarantined spam messages filtered by the device
and held in the user quarantine area. If configured, device will mail the digest daily to the user.
Digest also provides a link to User My Account from where user can access and take the action
quarantined messages.

CISCO™ VPN Client
By default, user is provided remote access through CISCO VPN Client. Disable if remote access is
not to be provided to the user.

Provide the IP Address (IPv4/IPv6) to be leased to the user for CISCO VPN access.

Note:  To use this feature, CISCO™ VPN Client needs to be configured from VPN >
CISCO

Quarantine Digest
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Configure Quarantine Digest.

Quarantine digest is an Email containing list of quarantined spam messages filtered by the device
and held in the user quarantine area. If configured, device will mail the digest at the configured
frequency to the user. Digest also provides a link to User Portal from where user can access and take
the action on quarantined messages.

Available Options:Enable - User will receive the Quarantine Digest daily and overrides Group
setting.Disable - User will not receive Quarantine Digest and overrides Group setting.

Simultaneous Logins
Specify number of concurrent logins that will be allowed to user OR Click 'Unlimited' for allowing
unlimited Concurrent logins.

Default - 1

Acceptable Range - 1 to 99

Note:  The specified setting will override the global setting specified in the client
preferences.

MAC Binding
Enable/disable "MAC Binding". By binding User to MAC Address, you are mapping user with a
group MAC Addresses.

If enabled, specify MAC Addresses for example 01:23:45:67:89:AB.

Once you enable MAC binding, user will be able to login through pre-specified machines only.

Use comma to seperate multiple MAC Addresses. For example 01:23:45:67:89:AB,
01:23:45:67:89:AC.

Login Restrictions
Select the appropriate option to specify the login restriction for the user.

Available Options: Any Node - User will be able to login from any of the nodes in the network.
User Group Node(s) - User will be able to login only from the nodes assigned to her group.
Selected Nodes - User will be able to login from the specified nodes only.Node Range - User will
be able to login from any of the IP Address from the configured range.

Note:  Only IPv4 Addresses must be provided for options "Selected Nodes" and
"Node Range".
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Figure 219: Add User SSL VPN Policy
5. Select Advanced settings (Only if User Type is Administrator)

Schedule for Device Access
Schedule the device access.

Administrator will be able to access the device only during the time configured in schedule.

Login Restriction for Device Access
Select the appropriate option to specify the login restriction for the user.

Available Options:Any Node - Administrator will be able to login from any of the nodes in the
network.Selected Nodes - Administrator will be able to login from the specified nodes only. Node
Range - Administrator will be able to login from any of the IP Address from the configured range.

Reset User Accounting (Displayed only after user is added)
Click to reset the usage accounting i.e. internet usage time and network traffic of the user.

View Usage (Displayed only after user is added)
Click to view the Internet usage and data transfer usage.

Figure 220: Add Administrator Advanced Settings

Note:  User configuration is given precendence over Group configuration.

6. Click Save to register a new user.

Reset User Accounting

This option lets you reset the usage accounting i.e. internet usage time and data transfer of the user.

1.
Edit the user account of the user whose data accounting you want to reset by clicking Manage icon  in the
Manage column.
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2. Click Reset User Accounting  and OK button to confirm.

Note:  You cannot reset user accounting for the liver user.

View Usage

This option lets you view the Internet usage and data transfer usage.

1.
Edit the User account of the user whose data usage you want to view by clicking Manage icon  under the
Manage column.

2. Click View Usage button. A pop-up displays information of policies applied on the user account, upload and
download data transferred by the user.

Importing User Information
The Import Users page allows you to add new users by importing user details from the file.

Instead of creating users again in the device, if you already have users detail in a csv file, you can upload csv file.

Click the Import Button to import csv file. Select the complete path for migrating user’s information file.

csv file format and processing:

1. Header (first) row should contain field names. Format of header row:
2. Compulsory field: username
3. Optional fields: password, name, group, email address.
4. Fields can be configured in any order.
5. Subsequent rows should contain values corresponding to the each field in header row.
6. Number of fields in each row should be same as in the header row.
7. Error will be displayed if data is not provided for any field specified in the header.
8. Blank rows will be ignored.
9. If password field is not included in the header row then it will set same as username.
10. If group name is not included in the header row, administrator will be able to configure group at the time of

migration.

Exporting Users

Click the Export button to export the user details in a csv file. csv file is generated with the following headers: Name,
Username, Enc_password, Email Address, and Group.

Purging Active Directory Users
This page allows you to purge AD Users.

Click Purge AD Users button to synchronize the device’s Active Directory users with external Active Directory
server.

Note:

• Purge operation will not interrupt user login/logout and accounting events.
• If HA is configured, user details are deleted from both, the Primary Device as well as Auxiliary Device at

the same time.

Change Status

Select a user and click on the Change Status button to change the status of the user. If the current status is 'Active',
the status of the user will change to 'Inactive' when clicked on this button and vice-versa.

Clientless Users
The Clientless Users page displays list of all the clientless users.

Clientless Users are the users who can bypass Client login to access the Internet and are managed by the device
itself. As clientless users can bypass device login, create clientless users when your network has few Non-windows
machines, VOIP boxes, or servers.
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You can filter the list based on name or username of the user, IP address, group of the user, web and application filter
policy, or created date. The page also provides option to add a single clientless user or multiple users, delete or change
status of the user. The administrator can also reset user accounting data or view the usage statistics.

The page also provides options to:

• Add a Single Clientless User
• Reset User Accounting
• View Usage
• Add Multiple Clientless Users
• Changing Policies of the Clientless User

Add a Single Clientless User
Use the Add Clientless User page to add a single clientless user.

The Add Clientless User page allows you to manually enter details to add a single clientless user that can bypass
device login.

Once a user is registered successfully, the page provides two more options:

• Reset User Accounting - Click to reset the usage accounting i.e. internet usage time and data transfer of the user.
• View Usage- Click to view the Internet usage and data transfer usage.

1. Go to Device Configuration > Configure > Authentication > Clientless Users click Add.
2. Enter Clientless Users details.

Username
Enter username, which uniquely identifies user and will be used for login.

IP Address
Specify IP Address(IPv4/IPv6) for the Clientless user.

Group
Select Group in which user is to be added. User will inherit all the polices assigned to the group.

Change the policies applied to the user by editing the user details.

Name
Enter name of the user.

Email
Enter Email Address.

Quarantine Digest
Configure Quarantine Digest. Quarantine Digest is an Email and contains a list of quarantined spam
messages filtered by the device and held in the user quarantine area. If configured, device will mail
the Quarantine Digest every day to the user. Digest provides a link to User Portal from where user
can access quarantined messages and take the required action.

Available Options:Enable - User will receive the Quarantine Digest daily and overrides Group
setting.Disable - User will not receive Quarantine Digest and overrides Group setting. Apply
Group's Settings - User will receive Quarantine Digests as per configured for the Group user
belongs to.

Description
Specify user description.

Figure 221: Add Clientless User
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3. Click Save to add a single clientless user.

Reset User Accounting

This option lets you reset the usage accounting i.e. internet usage time and data transfer of the user.

1.
Edit the user account of the user whose data accounting you want to reset by clicking Manage icon  in the
Manage column.

2. Click Reset User Accounting  and OK button to confirm.

Note:  You cannot reset user accounting for the liver user.

View Usage

This option lets you view the Internet usage and data transfer usage.

1.
Edit the User account of the user whose data usage you want to view by clicking Manage icon  under the
Manage column.

2. Click View Usage button. A pop-up displays information of policies applied on the user account, upload and
download data transferred by the user.

Add Multiple Clientless Users
Use the Add Multiple Clientless Users  page to add multiple clientless users.

The Add  page allows you to enter details to add multiple clientless users.

1. Go to Device Configuration > Configure > Authentication > Clientless Users and click Add Range.
2. Enter the required details.

From
Specify Starting IP Address for the range.

To
Specify Ending IP Address for the range.

Group
You can change the policies applied to the user by editing the user details. If you change the policies
for the user, user specific policies will take precedence over user group policies.

Figure 222: Add Clientless User
3. Click Save to add multiple clientless users.

Changing Policies of the Clientless User
This page lets you change the policies configured of the clientless user.

Change the policies applied to the user by updating the user details. If you change the policies for the user, user
specific policies will take precedence over user group policies.

1. Go to System > Authentication > Clientless Users or Objects > Identity > Clientless Users.
2.

Select the user for which you want to change the policies by clicking Manage icon  in the Manage column.
3. Update the user details.

Username
Name with which user logs in.

Name
Name of the User.
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IP Address
IP Address (IPv4/IPv6) from which the user logs in.

Group
Group in which user is added. User will inherit all the policies assigned to the group.

Change the group, if required.

Email
Email Address of the user.

Description
Provide the clientless user description.

Internet Usage Time
Displays total Internet usage time information.

4. Update the policy details.
Traffic Shaping

Traffic Shaping policy applied to the user.

Change the policy, if required.

Policy applied here will take the precedence over the group policy.

Quarantine Digest
Configure Quarantine Digest.

Quarantine Digest is an Email and contains a list of quarantined spam messages filtered by the
device and held in the user quarantine area. If configured, device will mail the Quarantine Digest
every day to the user. Digest provides a link to User My Account from where user can access his
quarantined messages and take the required action.

Available Options:Enable - User will receive the Quarantine Digest daily and overrides Group
setting. Disable - User will not receive Quarantine Digesst and overrides Group setting.

5. Click Save to update the changes made to the user.

Captive Portal

Device provides flexibility to customize the Captive portal Login page. This page can include your organization name
and logo.

External users, who need to use authentication services, are required to log in over the Captive Portal once before
they get access to the User Portal. External users can access the Captive Portal by browsing to https://<Sophos
Device IP Address>:8090. After login, external users have access to the User Portal and are listed on the Device
Configuration > Configure > Authentication > User page. External users can access the User Portal by browsing to
https://<Sophos Device IP Address> or clicking "Click here for User My Account" on the Captive Portal page.

Below are the screen elements with their description:

General Settings
Logo

Click "Custom" to upload the custom logo and specify Image file name to be uploaded else click
“Default”.

Use “Browse” to browse and select the complete path.

The image size should not exceed 125 X 70 pixels.

Logo URL

Provide a URL to be redirected to on clicking the Logo.

Default -http://www.sophos.com.

http://www.cyberoam.com/


 | Device Configuration | 284

Page Title

Provide a title to modify the Page title.

Default - Network Authentication

Login Page Header

Provide the text to be displayed on the Captive Portal login page.

Login Page Footer

Provide message to be displayed in the footer of Captive Portal login page.

Username Caption

Provide label for the textbox to be displayed on the Captive Portal login page.

Default - Username

Password Caption

Provide label for textbox to be displayed on the Captive Portal login page.

Default - Password

Login Button Caption

Provide label for the button to be displayed on the Captive Portal login page.

Default – Login

Logout Button Caption

Provide label for the button to be displayed on the Captive Portal login page.

Default - Logout

User Portal Link Caption

Provide a text to be displayed for User Portal login page link. By clicking the link, user will be
directed to the User Portal login page.

Default - Click here for User Portal

Color Scheme

Customize the color scheme of the Captive portal if required. Specify the color code or click the square box to pick
the color.

Custom HTML Template
Use Custom HTML Template

Select to fully customize captive portal using custom HTML code.

HTML Text

Provide HTML code to render captive portal according to your requirement. Dynamic contents
like banners from external web servers, customizable “Message of the day” box and so on can be
integrated in the HTML code.

By default, sample HTML will be displayed.

Note:

It is essential to have one HTML div element in the HTML text. Device’s Login box
will be placed in this div element.

Preview Button

Click to view the custom settings before saving the changes.



 | Device Configuration | 285

Reset to Default Button

Click to revert to default settings.

Related concepts
Servers on page 254
On this page you can manage databases and backend servers of external user authentication services. External user
authentication allows you to validate user accounts against existing user databases or directory services on other
servers of your network.

Sophos Transparent Authentication Suite (STAS)

STAS Activation Settings
Enable Sophos Transparent Authentication Suite

Enable or disable Sophos Transparent Authentication Suite.

Activate STAS/Confirm Removal of STAS configuration
Use to apply/remove STAS Activation Configuration.

STAS Settings
Enable User Inactivity

Select to enable or disable user inactivity setting.

When users logs in the Device and performs no activity, remaining idle for specific time span, they
are considered inactive. By default, User Inactivity is disabled.

Inactivity Timer (Only if Enable User Inactivity is enabled)
Specify the inactivity time in minutes.

The user inactivity timeout is the inactive/idle time in minutes after which the user will be logged
out and has to re-authenticate.

Acceptable Range (Minutes) - 3 to 1440 Default - 3 minutes

Data Transfer Threshold (Only if Enable User Inactivity is enabled)
Specify the minimum data to be transferred. Default - 100 bytes

Apply
Click to apply configuration changes.

Collector
Add

Collector collects the user authentication request from multiple agents, processes the request and
sends to CFM for authentication.

Click to add collector IP address and Port for clientless single sign on configuration. Refer Add
Collector for details.

VPN Zone Network
Add

Click to add VPN Zone Network. Refer Add VPN Zone Network on page 286 for details.

Add Collector
Use the Add Collectors.

Collector

1. Go to Device Configuration > Configure > Authentication > STAS > Collector and click Add.
2. Enter Collector details:

Collector IP
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Enter IP for Collector.

Collector Port
Enter port for Collector.

Collector Group
Enter group for Collector.

Figure 223: Add Collector
3. Click Save.

Add VPN Zone Network
Use this to add VPN Zone Networks.

VPN Zone Network

1. Go toDevice Configuration > Configure > Authentication > STAS > VPN Zone Network and click Add.
2. Enter VPN Zone Network details:

Network
Enter network name for VPN Zone.

NetMask
Select net mask for VPN Zone.

Figure 224: VPN Zone Network
3. Click Save.

Guest Users Settings

Guest Users Settings menu allows you to configure general settings, registration settings and SMS Gateway for Guest
Users.

Users without a pre-existing user account wanting to access Internet using a hotspot, or via a network available at
airport, hotels, hostels, etc. are called “Guest Users”. These users, that are otherwise considered unauthenticated
and/or denied access, are allowed to make request to connect to the Internet for a limited period by authenticating
themselves. On being authenticated, these users are authorized to access Internet as Guest Users. At such locations,
Internet access is secured by configuring access policies to restrict any malicious use of the network.

Sophos allows administrator to pre-configure single or multiple Guest Users using Admin Console. The credentials of
Guest Users configured via Admin Console can be printed and handed over to Guest User. Alternately, Guest Users
can register themselves using Guest User Portal. The credentials and Internet access details of Guest Users registered
via Guest User Portal can either be sent via SMS or can be printed.

In case of successful authentication Guest User is granted access according to applicable group, or else is redirected to
captive portal page.

The page allows configuring general parameters to provide secured Internet access for guest users. Below are the
screen elements with their description:
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Guest User General Settings
Username Prefix

Enter prefix to be used for Auto-Generation of username for guest users.

Group

Select a group of policies to assign to Guest users.

Alternately, you can also add group of policies.

Password Length

Specify the length of the auto-generated password for Guest Users.

Minimum password length - 3 characters

Maximum password length - 60 characters

Default - 8 characters

The password length is a basic security parameter, the value of which affects the strength of
password against brute force attack.

Password Complexity

Select a type of password from the available options to be used for complexity of an auto-generated
password:

Available Options:

• Numeric Password - Password will include only numeric characters.
• Alphabetic Password - Password will include only alphabetic characters.
• Alphanumeric Password - Password will include numeric as well as alphabetic characters.
• Alphanumeric with Special Character Password - Password will include numeric, alphabets and

special characters.

The password strength is a function of its length, complexity, and unpredictability. Combining
password length with password complexity makes a password difficult to guess.

Disclaimer

Provide the disclaimer message to be printed below every user’s login credentials.

Disclaimer once configured can be edited but cannot be removed.

Auto Purge on Expiry
Check to enable automatic purging of user details on expiry of user validity.

Note:  Details of a user who is bound to rules (like firewall, IM, etc.) will not be
purged automatically.

Guest User Registration Settings
Enable Guest Users Registration

Enable to allow secured Internet access to guest users.

SMS Gateway

Select the Gateway using which the SMS should be sent.

Alternately you may add the SMS gateway from this page itself by clicking Create New link.

Guest Username

Select the method of generating Username using the following option:

• Use Cell Number as Username
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If Guest Username checkbox option is not selected, by default, the new user name will be
generated with the value specified in Username Prefix.

User Validity (Duration in Days)

Specify guest user validity in days.

Default Country Code

Enable to configure a default country code on the Guest User Registration page.

Selected country is displayed as default option in Cell Number selection at Guest User registration
page.

CAPTCHA Verification

Select to Enable or Disable CAPTCHA (Completely Automated Public Turing Test To Tell
Computers and Humans Apart) code verification on Guest User Registration page to ensure the
request is received for human being.

By enabling CAPTCHA Verification, the user will be displayed a picture with characters that user
must insert in a provided textbox below picture. The administrator can therefore protect device
against attacks generated by automated programs.

Default - Enable

SMS Gateway

An SMS Gateway allows sending and receiving Short Message Service (SMS) to/from a home network for Guest
User registration. The device supports HTTP and HTTPS protocol based SMS service.

This section displays list of all the configured SMS Gateways and provides option to add, delete and edit the SMS
gateway configuration.

Configure SMS Gateway

You can configure SMS Gateway for Guest User registration from this page.

1. Go to Device Configuration > Configure > Authentication > Guest User Settings and click Add under SMS
Gateway section.

2. Enter SMS Gateway details.
Name

Enter a name of the SMS Gateway.

URL
Specify URL of the SMS Gateway for sending SMS request.

HTTP Method
Select the method for sending SMS request to SMS Gateways from the options available:

Available Options:

Get: Requests data from a specified resource.Post: Submits data to be processed to a specified
resource.

Cell Number Format
Select to use country code with cell number.

Number Prefix
Specify the prefix value to be used with the cell number.

Number Prefix can include alpha-numeric and ASCII special characters.

It can be up to 4 characters long.

Request Parameters
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Specify the following request parameters to configure the SMS Gateway.

Name Name is a descriptor used to describe the
meaning of the value. E.g. username, password,
mobile

Value Value of variables that are defined against name.

Response Format
Response describes delivery status of the message such as success, failed, limit exceeded. Status
message can be in various formats. Few of them are described below:

For Example

Response Format

{0} | {1} | {2}

Response Received

success | mbno | msgid/transactionid

Response Format

<status>500</status><transactionid>{0}</transactionid><reason>{1}</reason>

Response Received

<status>500</status><transactionid>2323</transactionid><reason>Limit Exceeded</reason>

When the response format is different for success and failure, it is recommended that the response
format string should have a single content holder. E.g. {0}

Response Parameters
Response Parameter is the value presented by content holder {0,1, 2...n} that will be displayed in
log viewer.

Parameter Index: Parameter Index is the content holder value {0,1, 2...n}.

Name: Name represents the content holder in the Log Viewer.

For Example 1:
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Parameter Index Name

0 Status

1 Recipient

2 SMSID

For Example 2:

Parameter Index Name

0 SMSID - 2323

1 SMS Status Message – Length Exceeded

Figure 225: Add SMS Gateway
3. Click Save to add SMS Gateway.

Testing Connectivity with SMS Gateway

Once you configure SMS Gateway, check whether you are able to connect with the gateway or not from this page.

1. Go to Device Configuration > Configure > Authentication > Guest User Settings > SMS Gateway and click
Test Connection.

2. Enter Cell Phone Number details.
Cell Phone Number

Provide cell phone number.

You will receive SMS through the gateway configured if you are able to connect to the gateway.
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System Services

System Services allows configuration of device components along with the associated services.

Available Configurations:

• Security Heartbeat - Allows to configure Heartbeat settings.
• Web Proxy- Web proxy is the engine used to enforce web protection policies.
• Authentication Services - Authentication allows to configure profile attributes for Firewall, VPN and

Administration servers. You can also configure NTLM settings, Captive Portal parameters, Web Client settings,
Radius Client settings for Single Sign-On Server, global settings like Session Timeout and Simultaneous Logins.

• Guest User Settings- Guest User Settings allows configuring general parameters to provide secured internet access
for guest user.

• DoS - Configure general settings for DoS protection.
• Web Content Filter - Allows to configure and manage web filtering through the device, includes scanning and

restricting all the HTTP/HTTPS/FTP traffic.
• Traffic Shaping Settings - QoS traffic shaping allows network bandwidth to be limited or guaranteed.
• RED - Sophos RED allows seamless, encrypted, and tightly integrated connections between branch locations.
• Wireless - Allows to configure your firewall to act as a wireless controller for Sophos access points.
• Advanced Threat Protection - Allows to enable and configure ATP features to secure ingress and egress traffic.
• Malware Protection - Allows to configure Dual Anti Virus Scanning.
• Log Settings - Provides extensive logging capabilities for traffic, system and network protection functions.

Traffic Shaping Default

Use Traffic Shaping Settings page to configure default Traffic Shaping settings. All the bandwidth related data are
displayed only with unit KBps (Kilo bytes per second).

Below are the screen elements with their description:
Total Available WAN Bandwidth

Specify maximum bandwidth limit in KB. It is generally a sum of all WAN links maximum limits.

Default - 100000 KB

Acceptable Range (KB) - 1 to 2560000

Optimize for Real-Time (VoIP)
Enable to give priority to real time traffic like VOIP over all other traffic.

If disabled, priority will be applicable only for excess bandwidth i.e. bandwidth remaining after
guaranteed bandwidth allocation.

Enforce Guaranteed Bandwidth
Administrator can enforce all internet bound traffic to be handled by any Traffic Shaping Policy
applied on it. If there is no policy applied on the traffic then it will be handled by the Default Policy.

Enable to enforce bandwidth restriction on the traffic on which the Traffic Shaping Policy is not
applied.

Disable, if you do not want to enforce bandwidth restriction on the traffic on which the Traffic
Shaping Policy is not applied. It will only handle traffic on which Traffic Shaping Policy is applied.

Default Policy
Default Policy will be applicable on the traffic which does not have any Traffic Shaping Policy
applied.

Guarantee Specify bandwidth which is the minimum
guaranteed bandwidth that the user can use.

Default – 1 KBps
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Acceptable Range (KBps) - 1 to 2560000

Limit Specify bandwidth which is the maximum
bandwidth that the user can use, if available.

Default – 100000 KBps

Acceptable Range (KBps) - 1 to 2560000

Priority Set the bandwidth priority. Priority can be set
from 1 (highest) to 7 (lowest) depending on the
traffic required to be shaped.

Available Options:

1 – Business Critical2 to 5 – Normal6 – Bulky -
FTP7 – Best Effort – e.g. P2P

Show Bandwidth Usage
Click to view Bandwidth Usage.

RED
This chapter describes how to configure RED. RED is short for Remote Ethernet Device and is a means to connect
remote branch offices and the like to your main office as if the branch office is part of your local network.

System > System Services > RED

The setup consists of Sophos Firewall OS in your main office and a Remote Ethernet Device (RED) in your remote
office. Establishing a connection between the two is utmost easy as the RED appliance itself does not need to be
configured at all. As soon as the RED appliance is connected to Sophos Firewall OS it behaves like any other
Ethernet device on Sophos Firewall OS. All traffic of your branch office is safely routed via Sophos Firewall OS
which means that your branch office is as secure as your local network.

The page shows the RED status. It is deactivated by default.

Disable RED

Disabling RED will not cause the deletion of the REDs. If you disable the RED functionality, RED devices will
be deactivated and lose their connection. If you re-enable the RED functionality, the REDs will be activated again.
To disable RED, click the toggle switch on the RED page and confirm by clicking the Confirm removal of RED
configuration button.

Related tasks
Configure RED on page 292
Automatic Device Deauthorization on page 293
Add RED on page 239

Configure RED

This page describes how to configure RED.

1. Go to Device Configuration > Configure > System Services > RED.
2. Make the following settings:

Organization Name
Enter the name of the organization.

City
Enter the city where the organization is located.

Country
Select the country where the organization is located.
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Email
Enter an email address.

Figure 226: RED Configuration
3. Click Apply to Managed Devices to apply the settings to managed Devices. On clicking Apply to Managed

Devices, Set Schedule page opens where the settings can be pushed to all or selected devices..

You can enable the Automatic Device Deauthorization.
Related tasks
Automatic Device Deauthorization on page 293

Automatic Device Deauthorization

When RED is enabled, you can specify if disconnected RED appliances should automatically be deauthorized after a
certain time span. With this feature, you can prevent stolen RED appliances from connecting to Sophos Firewall OS.

Note:  The Automatic Device Deauthorization does not work for a RED Tunnel between 2 Sophos XG
Firewall Devices.

1. Ensure that RED is activated.
2. Select Enable next to Automatic Device Deauthorization.
3. Enter a time span for Deauthorize After.
4. Click Apply.

Automatic Device Deauthorization has been successfully configured.

When a RED appliance reconnects after being disconnected for a time span longer than the defined time span, it will
automatically be disabled.

Malware Protection

Sophos XG Firewall offers Dual Anti Virus Scanning, wherein traffic is scanned by Two (2) Anti Virus Engines.
Traffic is first scanned by the Primary Engine, and then the Secondary Engine.

Note:  Dual Anti Virus is not available in Device Models SF 100 and SF 200. For them, ONLY Single Anti
Virus CYREN is available.

Note:  You can also view and manage the Anti Virus status on the Device Configuration > Monitor and
Analyze > Diagnostics > Services

General Settings
Primary Anti Virus Engine
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Select the Primary Anti-Virus Engine to be used for traffic scanning. For Dual Scan, packets are
first scanned by the Primary Engine and then by the Secondary Engine. For Single Scan, only the
Primary Engine is used.

Available Options

Sophos EngineAvira Engine

Log Settings
Device Configuration > Configure > System Services > Log Settings

Device provides extensive logging capabilities for traffic, system and network protection functions. Detailed log
information and reports provide historical as well as current analysis of network activity to help identify security
issues and reduce network abuse. To view logs, relevant modules must be subscribed.

Device can log many different network activities and traffic including:

• Security Policies log
• Anti Virus infection and blocking
• Web filtering, URL and HTTP content blocking
• Signature and anomaly attack and prevention
• Spam filtering
• Administrator logs
• User Authentication logs
• SSL VPN logs
• WAF logs
• Advanced Threat Protection logs

Device can either store logs locally or send logs to external syslog servers for storage and archival purposes. Traffic
Discovery logs can be stored locally only.

Syslog is an industry standard protocol/method for collecting and forwarding Logs from devices to a server running a
syslog daemon usually via UDP Port 514. Logging to a central syslog server helps in aggregation of logs and alerts.

If configured, device sends a detailed log to an external syslog server in addition to the standard event log. Device
Syslog support requires an external server running a syslog daemon on any of the UDP Port. When configuring
logging to a syslog server, one needs to configure the facility, severity and log file format. One can also specify
logging location if multiple syslog servers are defined.

Device logs all activity and includes every connection source and destination IP Address (IPv4 / IPv6), IP service, and
number of bytes transferred.

A Syslog service simply accepts messages, and store them in files or prints. This form of logging is the best as
it provides a central logging facility and a protected long-term storage for logs. This is useful both in routine
troubleshooting and in incident handling.

Use this page to configure below settings:

• Syslog Servers - Configure Syslog server for logs storage and archival purposes.
• Log Settings - Configure logs to be sent to the Syslog server.

Syslog Servers

The Syslog Servers section displays list of configured syslog servers. You can sort the list based on server name. The
page also provides option to add, update, or delete the server.

Log Settings

After configuring syslog server, configure logs to be sent to the syslog server. If multiple syslog servers are
configured, you can send various logs on different servers.
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To record logs you must enable the respective log and specify logging location. Administrator can choose between
On-Device (local) logging or Syslog logging. Administrator can also disable logging temporarily. Below are the
screen elements with their description:

Log Type (System)

Security Policy

Security Policy Log records invalid traffic, local ACL traffic, DoS attack, ICMP redirected packets, source routed and
fragmented traffic.

• Policy Rules

Log records the entire traffic for Firewall.
• Invalid Traffic

Log records the dropped traffic that does not follow the protocol standards, invalid fragmented traffic and the
traffic whose packets or device is not able to relate to any connection.

• Local ACLs

Log records the entire (allowed and dropped) incoming traffic.
• DoS Attack

The DoS Attack Log records attacks detected and prevented by the device i.e. dropped TCP, UDP and ICMP
packets.

To generate logs, go to System > System Services > DoS and click Apply Flag against SYN Flood, UDP Flood,
TCP Flood, and ICMP/ICMPv6 Flood individually.

• Dropped ICMP Redirected Packet

Log records all the dropped ICMP redirect packets.

To generate log, go to System > System Services > DoS and click Apply Flag against Disable ICMP/ICMPv6
Redirect Packet.

• Dropped Source Routed Packet

Log records all the dropped source routed packets.

To generate log, go to System > System Services > DoS  and click Apply Flag against Drop Source Routed
Packets.

• Dropped Fragmented Traffic

Log records the dropped fragmented traffic.
• MAC Filtering

Log records the dropped packets when filtering is enabled from Spoof prevention.
• IP-MAC Pair Filtering

Log records the dropped packets when filtering is enabled from Spoof prevention.
• IP Spoof Prevention

Log records the dropped packets when filtering is enabled from Spoof prevention.
• SSL VPN Tunnel

Log records of SSL VPN traffic.
• Virtual Host

Log records of Virtual Host traffic.

IPS

Records detected and dropped attacks based on unknown or suspicious patterns (anomaly) and signatures.

Anti Virus

Virus detected in HTTP, SMTP, FTP, POP3, IMAP4, HTTPS, SMTPS, IMAPS and POPS traffic.
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Anti Spam

SMTP, POP3, IMAP4, SMTPS, POPS, IMAPS spam and probable spam mails.

Content Filtering

Web filtering and Application Filtering logs.

Log records of the name of applications/URLs accessed and their categories.

Note:  To view the logs:

• Web Filter and Application Filter Policies should be applied in Security Policy.
• Log Firewall Traffic under Policies should be enabled.

Events

Admin Events: Log records of configurations done through Admin Console.

Authentication Events: Log records of all authentication related events.

System Events: Log records of all system related events like Gateway Up/Down, Anti Virus updates etc.

WAF

WAF Events.

Note:  WAF logs are not available in CR10iNG, CR15i, CR15wi, CR15iNG, CR15wiNG, CR25ia, CR25wi,
CR35ia and CR35wi Sophos Devices.

Advanced Threat Protection

ATP Events: Log records of drop or alert event.

Heartbeat

Endpoint Status: Log records of the health status of the endpoint.

System Health

Usage: Log records of CPU usage, memory usage, no. of live users, interface and disk partition information.

Sandbox

Sandbox Event: Log records of all Sandstorm events.

Add Syslog Server

You can add Syslog server from this page.

1. Go to Device Configuration > Configure > System Services > Log Settingsand click Add under Syslog Servers
section.

2. Enter server details.
Name

Enter a unique name for syslog server.

IP Address / Domain

Specify IP Address (IPv4 / IPv6) or domain name of the Syslog Server. Logs from the device will
be sent to the server.

Port

Specify the port number for communication with the Syslog Server. Device will send logs using the
configured port.

Facility

Select syslog facility for logs to be sent to the Syslog Server.
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Facility indicates to the Syslog Server the source of a log such as operating system, the process or
an application. It is defined by the syslog protocol.

Device supports following syslog facilities for received logs:

Available Options:

DAEMON

Daemon logs (Information of Services running in device as daemon).

KERNEL

Kernel log

LOCAL0 – LOCAL7

Log level information.

USER

Logging based on users who are connected to the Server.

Severity Level

Specify severity levels of logs.

Severity level is the severity of the log that has been generated.

Device logs all the messages at and above the logging severity level you select. For example,
select ‘ERROR’ to log all messages tagged as ‘ERROR,’ as well as any messages tagged with
‘CRITICAL,’ ‘ALERT’ and ‘EMERGENCY’ and select ‘DEBUG’ to log all messages.

Device supports following severity levels:

EMERGENCY - System is not usable ALERT – Action must be taken immediately CRITICAL
- Critical condition ERROR -Error condition WARNING - Warning condition NOTIFICATION
- Normal but significant condition INFORMATION - Informational DEBUG - Debug level
messages.

Format

Device produces logs in the specified format. Device currently produces logs in Device Standard
Format.

Note:  You can configure maximum five syslog servers.

Figure 227: Log Settings
3. Click Save to add Syslog server.



 | Device Configuration | 298

Once you add the server, go to Device Configuration > Configure > System Services > Log Settings page and
enable all those logs, which are to be sent to the syslog server.

System

Profiles
Device Configuration > System >  Profiles

Profiles describes the security parameters used for establishing and maintaining a secure connection between two
peers.

This section covers the following topics:

• Schedule - Schedule defines a time schedule for applying Firewall Rule or Web & Application Filter policy. This
page displays a list of schedules and also provides various options to manage it.

• Access Time - Schedule Internet access for individual users by defining Access Time policy. This page displays
list of all the default as well as custom policies.

• Surfing Quota - Control individual user surfing time by defining Surfing Quota policy. This page displays the list
of all policies and also provides option to add, update or delete surfing quota policies.

• Network Traffic Quota - Limit total as well as individual upload and/or download data transfer by defining
Network Traffic Quota. This page displays default as well as custom policies. The page also provides option to
manage these policies.

• Network Address Translation- The Network Address Translation page displays list of all the NAT policies
and you can sort the list based on policy name.The page also provides option to add a new policy, update the
parameters of the existing policy, or delete a policy.

• IPSec - An IPsec policy defines IKE (Internet Key Exchange) and IPsec proposal parameters of an IPsec
connection.This page displays list all the preconfigured and custom IPsec policies. It also provides option to add a
new policy, update the parameters of an existing policy, or delete the policy.

• Intrusion Prevention - Create and deploy IPS Policies to block malicious or suspicious traffic and increase
security and productivity. This page displays the list of all the pre-defined and custom IPS policies.

• Web Filter- Configure and manage web filtering through the device with Web Filter policies. This page displays
the list which includes predefined and custom policies. You can filter or sort the list based on the policy name.

• Traffic Shaping - Traffic Shaping policy allocates & limits the maximum bandwidth usage of the user and
controls the web and network traffic. This page displays list of predefined and custom policies and also provides
various options to manage it.

• Web App Protection - The page displays all existing web application protection objects. The page also provides
option to add new protocol security objects, edit or delete them.

• Web App Authentication - The page displays all existing web application authentication profiles. The page also
provides option to add new application authentication profiles, edit or delete them.

• Device Access Profile - This page shows the default and custom profiles and also provides options to manage
these profiles.

• Global App Traffic Shaping - This page displays list of all the global application traffic shaping policies. The
page provides option to edit the category or application to apply the traffic shaping policy.

• Application Filter - This page displays list of all the predefined and custom policies. The page also provides
option to add a new policy, update parameters of the exisiting policy, delete a policy, add a filtering rule to a policy
or delete a filtering rule attached to a policy.

• Hotspot Voucher Definition - This page displays a list of hotspot voucher definition and also provides various
options to manage it.

Schedule
The Schedule page displays the list of all the predefined and custom schedules.

Schedule defines a time schedule for applying Security Policies or Web & Application Filter policy. It is used to
control when these policies are active or inactive.
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Schedule also defines the system triggered scan for Rogue AP Scan.

Types of Schedules:

• Recurring - use to create policies that are effective only at specified times of the day or on specified days of the
week.

• One-time - use to create Security Policies that are effective once for the period of time specified in the schedule.

The device is shipped with the following predefined schedules which can be applied to various security policies:
Work hours (5 Day week), Work hours (6 Day week), All Time on Weekdays, All Time on Weekends, All Time
on Sunday, All Days 10:00 to 19:00. You can also create new schedule, modify the existing schedules or delete a
schedule.

Note:  Schedule used by Security Policies or any policies cannot be deleted.

Add a New Schedule
Use the Add Schedule page to add a new schedule.

The Add Schedule page allows you to manually configure a new schedule.

1. Go to Device Configuration > System >  Profiles > Schedule and click Add.
2. Enter the details.

Name
Enter a name to identify a Schedule.

Description
Specify schedule description.

Recurrence
Select recurrence type.

Available Options: Recurring - Use to create policies that are effective only at specified times
of the day or on specified days of the week. One Time - Use to create policies that are effective
once for the period of time specified in the schedule. It can be implemented from Firewall >  User
Application Policy or Firewall >  Network Policy page.Start & End Date - Specify Start and
Stop date. This is applicable for the one time schedule only.

Also, select the days of the week and specify time for the schedule to be active. Stop time cannot be
greater than start time.

Figure 228: Add Schedule
3. Click Save to add the schedule with the options you have configured.

Access Time
The Access Time page displays list of all the default as well as custom policies.
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Access time is the time period during a day in which user can be allowed/denied the Internet access. An example
would be “only office hours access” for a certain set of users.

Access time policy enables to set time interval - days and time - for the Internet access with the help of schedules. See
Schedules for more details.

A time interval defines days of the week and times of each day of the week when the user will be allowed/denied the
Internet access.

Two strategies based on which Access time policy can be defined:

• Allow strategy - By default, allows access during the schedule
• Deny strategy - By default, denies access during the schedule

Device is shipped with the following predefined policies: Allowed all the time, Denied all the time, Allowed only
during Work Hours, Denied during Work hours. These predefined policies are immediately available for use until
configured otherwise. You can also define custom policies to define different levels of access for different users to
meet your organization’s requirements.

The page also provides option to add, update, or delete the access time policies.

Note:  Among all the policies applied, device takes into account the policy that first reaches its threshold
limit.

Create a New Access Time Policy
Use the Add Access Time Policy page to add a new access time policy.

The Add Access Time Policy  page allows you to manually add an access time policy.

1. Go to Device Configuration > System >  Profiles > Access Time and click Add.
2. Enter the details.

Name
Enter name to identify the policy.

Strategy
Specify strategy to be applied during the scheduled time interval.

Available Options:Allow - Allows the Internet access during the scheduled time interval.Deny -
Denies Internet access during the scheduled time interval.

Schedule
Select schedule from the available options. Only Recurring schedule can be applied.

Available Options:All the TimeWork hours (5 Day Week)Work hours (6 Day Week)All time on
WeekdaysAll time on WeekndsAll time on SundayAll Days 10:00 to 19:00

Depending on the policy strategy, access will be allowed/denied for the scheduled time interval.

Description
Provide policy description.
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Figure 229: Add Access Time Policy

Note:  Changes made in the policy becomes effective immediately on saving the changes.

3. Click Save to add the access time policy with the options you have configured.

Surfing Quotas
The Surfing Quota Policy page displays the list of all the default as well as custom surfing quota policies.

Surfing quota policy defines the duration of Internet surfing time. Surfing time duration is the allowed time in hours
for a Group or an Individual User to access Internet.

Surfing Quota Policy:

• Allows allocating Internet access time on a cyclic or non-cyclic basis.
• Single policy can be applied to number of Groups or Users.

Device is shipped with the following predefined policies: Unlimited Internet Access, 1 Month Unlimited Access, 1
month 100 hours, Monthly 100 hours Cyclic, Daily 1 hour Cyclic, Weekly 7 hours Cyclic. These predefined policies
are immediately available for use until configured otherwise. You can also define custom policies to define different
levels of access for different users to meet your organization’s requirements.

The page also provides option to add, update, or delete surfing quota policies.

Note:  Among all the policies applied, device takes into account the policy that first reaches its threshold
limit.

Create a New Surfing Quota Policy
Use the Add Surfing Quota page to configure a new surfing quota policy.

The Add Surfing Quota page allows you to manually enter details to configure surfing quota policy.

1. Go to Device Configuration > System > Profiles > Surfing Quotas and click Add.
2. Enter the details.

Name
Specify name to identify the Policy. Duplicate names are not allowed.

Cycle Type
Select Cycle type.

Available Options:Cyclic - Once the cycle ends, user is automatically registered for new cycle.
Non-Cyclic - Once the specified time limit ends, user will be disconnected.

Cycle Hours
Specify Cycle Hours. Cycle hours define the upper limit of surfing hours for cyclic types of policies
i.e. Daily, Weekly, Monthly and Yearly.

At the end of each Cycle, cycle hours are reset to zero i.e. for "Weekly" Cycle type, cycle hours will
reset to zero every week even if cycle hours are unused.
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Validity
Specify Validity in number of days. Validity defines the upper limit of total surfing days allowed i.e.
restricts total surfing days to valid allotted days.

OR

Click Unlimited Days, if you do not want to restrict the total surfing days.

Maximum Hours
Specify Maximum Hours. Maximum hours define the upper limit of total surfing hours allowed i.e.
restricts total surfing hours to maximum hours.

OR

Click Unlimited Hours, if you do not want to restrict the total surfing hours.

Description
Provide description for Surfing Quota Policy.

Figure 230: Add Surfing Quota Policy
3. Click Save to add the surfing quota policy with the options you have configured.

Network Traffic Quota
The Network Traffic Quota page displays list of all the default as well as custom network traffic policies.

Once the user logs on, the bandwidth is available and the total available bandwidth is shared among all the active
users at the particular time. Bandwidth being the limited resource, bandwidth shortage and congestion problems
is common. The device facilitates limiting data transfer allowed to individual user according to the requirement.
Bandwidth is limited using the Traffic Shaping policy while network traffic quota policy defines the upper limit for
data transfer carried out by the user.

Network Traffic Quota policy:

• Allows limiting data transfer on a cyclic or non-cyclic basis.
• Single policy can be applied to number of Groups or Users.

Data transfer restriction can be based on:

• Total Data transfer (Upload + Download)
• Individual Upload and/or Download

Device is shipped with the following predefined policies: 100 MB Total Data Transfer policy, Daily 10 MB. These
predefined policies are immediately available for use until configured otherwise. You can also define custom policies
to define different levels of access for different users to meet your organization’s requirements.
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The page also provides option to add, update, or delete network traffic quota policies.

Note:  Among all the policies applied, device takes into account the policy that first reaches its threshold
limit.

Create a New Network Traffic Quota Policy
Use the Add Network Traffic Quota page to quickly configure a new network traffic policy.

The Add Network Traffic Quota page allows you to manually enter details to configure network traffic policy.

1. Go to Device Configuration > System >  Profiles > Network Traffic Quota and click Add.
2. Enter the details.

Name

Enter a name to identify the Policy. Duplicate names are not allowed.

Description
Specify Network Traffic Policy description.

Restriction Based On

Specify whether the network traffic restriction is on Total Network Traffic or on Individual Network
Traffic (Upload and Download).

Cycle Type
Select Cycle Type.

Available Options: Cyclic - Once the cycle ends, user is automatically registered for new cycle.
Non Cyclic - On reaching the upper limit of the network traffic quota specified, user will be unable
to send or receive data.

3. Restriction based on Total Network Traffic and Cyclic Policy.
Cycle Period

Specify Cycle Period. Cycle period defines the duration for cyclic types of policies i.e. Day, Week,
Month and Year.

Cycle Network Traffic
Specify Cycle Network Traffic limit. It is the limit of network traffic allowed to the user per cycle.
User will be disconnected if limit is reached.

Maximum Network Traffic
Specify Maximum Network Traffic limit. It is the network traffic allowed to the user and if the limit
is reached user will not be able to log on until the policy is renewed.

OR

If you do not want to restrict amount of network traffic, click Unlimited Maximum Network Traffic.
4. Restriction based on Total Network Traffic and Non-Cyclic Policy.

Maximum Network Traffic
Specify Maximum Network Traffic limit. It is the network traffic allowed to the user and if the limit
is reached user will not be able to log on until the policy is renewed.

OR

If you do not want to restrict amount of network traffic, click Unlimited Maximum Network Traffic.
5. Restriction based on Individual Network Traffic and Cyclic Policy.

Cycle Period
Specify Cycle Period. Cycle period defines the duration for cyclic type of policies i.e. Day, Week,
Month and Year.

Cycle Upload Network Traffic
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Specify Cycle Upload Network Traffic limit. It is the upper upload network traffic limit allowed to
the user per cycle. User will be disconnected if the limit is reached.

OR

If you do not want to restrict amount of network traffic per cycle, click Unlimited Cycle Upload
Network Traffic.

Cycle Download Network Traffic
Specify Cycle Download Network Traffic limit. It is the upper limit of download network traffic
allowed to the user per cycle. User will be disconnected if limit is reached.

OR

If you do not want to restrict amount of download network traffic per cycle, click Unlimited Cycle
Download Network Traffic.

Maximum Upload Network Traffic
Specify Maximum Upload Network Traffic limit. It is the maximum upload network traffic allowed
to the user and if the limit is reached user will not be able to log on until the policy is renewed.

OR

If you do not want to restrict amount of upload network traffic, click Unlimited Upload Network
Traffic.

Maximum Download Network Traffic
Specify Maximum Download Network Traffic limit. It is the maximum download network traffic
allowed to the user and if the limit is reached user will not be able to log on until the policy is
renewed.

OR

If you do not want to restrict amount of download network traffic, click Unlimited Download
Network Traffic.

6. Restriction based on Individual Network Traffic and Non-Cyclic Policy.
Maximum Upload Network Traffic

Specify Maximum Upload Network Traffic allowed to the user. Once the limit is reached user will
not be able to log on until the policy is renewed.

OR

If you do not want to restrict amount of upload network traffic, click Unlimited Upload Network
Traffic.

Maximum Download Network Traffic
Specify Maximum Download Network Traffic allowed to the user. Once the limit is reached user
will not be able to log on until the policy is renewed.

OR

If you do not want to restrict amount of download network traffic, click Unlimited Download
Network Traffic.

Description
Provide Policy Description.
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Figure 231: Add Network Traffic Quota

Note:  Cycle Network Traffic limit cannot be greater than Maximum Network Traffic limit.

7. Click Save to add the network traffic policy with the options you have configured.

Network Address Translation
The Network Address Translation Policy page displays list of all the NAT policies and you can sort the list based on
the policy name.

Network Address Translation (NAT) is the process of rewriting the source addresses of IP packets as they pass
through a router or Firewall. Mostly NAT is used to enable multiple hosts on a private network to access the Internet
using a single public IP Address. When a client sends an IP packet to the router, NAT translates the sending address to
a different, public IP Address before forwarding the packet to the Internet. When a response packet is received, NAT
translates the public address into the original address and forwards it to the client.

NAT policy tells Securities Policies to allow access but only after replacing the source IP Address with the IP Address
specified in the NAT policy. Use NAT to change or remap source or destination address of the packet.

Using NAT eliminates the need for public IP Addresses for all computers on your LAN. It is a way to conserve
IP Addresses available from the pool of Public IP Addresses for the Internet. NAT also allows you to conceal the
addressing scheme of your network.

The page also provides option to add a new policy, update the parameters of the existing policy, or delete a policy.

Add a NAT Policy
Use the Add NAT Policy page to quickly configure a new NAT policy.

The Add NAT Policy page allows you to manually enter details to configure NAT policy.

1. Go to Device Configuration > System >  Profiles > NAT and click Add.
2. Enter the details.

Name
Enter a name to identify the NAT Policy.

IP Address
Select IP Address for source NATing.

Available Options: IP Address - It will replace source IP Address with the specified IP Address.
IP Range - It will replace source IP Address with any of the IP Address from the specified range.
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You can search and select a particular IP Address based on the Host name. If IP Host or range is
not already added, it can be added from here itself or can be added from Device Configuration >
System >  Host and Services >  IP Hosts.

Figure 232: Add NAT Policy

Note:  MASQ is a default NAT policy and cannot be updated or deleted.

3. Click Save to add the NAT policy with the options you have configured.

Traffic Shaping
The Traffic Shaping Policy page displays list of predefined and custom policies and provides option to create a new
traffic shaping policy, schedule traffic shaping policy, update parameters or delete the policy.

Bandwidth is the amount of data passing through a media over a period of time and is measured in terms of kilobytes
per second (KBps) or kilobits per second (kbits) (1 Byte = 8 bits). The primary objective of traffic shaping policy is to
manage and distribute the total bandwidth on certain parameters and user attributes. Traffic shaping policy allocates &
limits the maximum bandwidth usage of the user and controls the web and network traffic.

To configure traffic shaping policy:

• Define for whom you want to create policy
• Define policy type
• Define the implementation strategy of the policy
• Define bandwidth usage

Policy can be defined/created for:

• Users - It restricts the bandwidth of a particular user.
• Rules - It restricts the bandwidth for any entity to which the rule is applied.
• Web Categories - It restricts the bandwidth for the URL categorized under the Web Categories. To implement

restriction, policy is to be assigned through Security Policies.
• Applications - It restricts the bandwidth for the application. To implement restriction, policy is to be assigned

through Security Policies.

Types of policies

Two types of bandwidth restriction can be placed:

1. Limit - user cannot exceed the defined bandwidth limit.
2. Guarantee - user is allocated the guaranteed amount of bandwidth and can draw bandwidth up to the defined

burst-able limit, if available.

It enables to assign fixed minimum and maximum amounts of bandwidth to the users. By borrowing the excess
bandwidth when available, users are able to burst above guaranteed minimum limits, up to the burst-able rate.
Guaranteed rates also assure minimum bandwidth to critical users for receiving constant levels of bandwidth during
peak and non-peak traffic periods.

Guaranteed represents the minimum guaranteed bandwidth and burst-able represents the maximum bandwidth that the
user can use, if available.

Limit Upload/Download Seperately:

Policy can be implemented in two ways depending on the policy Type:

• Total (Upload + Download)
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• Individual Upload and Individual Download

Limit Policy

In this type of bandwidth restriction, user cannot exceed the defined bandwidth limit. Two ways to implement strict
policy:

• Total (Upload + Download)
• Individual Upload and Individual Download

Implementation Strategy Bandwidth specified Example

Total (Upload + Download) Total bandwidth Total bandwidth is 20 kbps upload
and download combined cannot cross
20 kbps

Individual (Upload / Download) Individual bandwidth i.e. separate for
both

Upload and Download bandwidth is
20 kbps then either cannot cross 20
kbps

Guarantee Policy

Implementation Strategy Bandwidth specified Example

Total (Upload + Download) Guaranteed bandwidth Burst-able
bandwidth

Guaranteed bandwidth is 20 kbps
upload and download combined will
get 20 kbps guaranteed (minimum)
bandwidth. Burst-able bandwidth
is 50 kbps upload and download
combined can get up to 50 kbps of
bandwidth (maximum), if available.

Individual (Upload / Download) Individual Guaranteed and Burstable
bandwidth i.e. separate for both

Individual guaranteed bandwidth
is 20 kbps Individually get 20 kbps
guaranteed (minimum) bandwidth.
Individual burstable bandwidth is
50 kbps Individually get maximum
bandwidth up to 50 kbps, if available.

Bandwidth Usage Type

Policy can be configured for two types of bandwidth usage:

• Individual - Allocated bandwidth is for the particular User/Rule/Web Category/Application only.
• Shared - Allocated bandwidth is shared among all the Users/Rules/Web Categories/Applications who have been

assigned this policy.

The device is shipped with predefined traffic shaping policies. These predefined policies are immediately available for
use until configured otherwise. You can also define custom policies to meet your organization’s requirements.

Create a New Traffic Shaping Policy
Use the Add Traffic Shaping (QoS) Policy page to quickly configure a new traffic shaping policy.

The Add Traffic Shaping (QoS) Policy page allows you to manually enter details to create a traffic shaping policy.

1. Go to Device Configuration > System >  Profiles > Traffic Shaping and click Add.
2. Enter Traffic Shaping Policy details.

Name
Enter a name to identify the Policy.

Policy Association
Select an option to specify for whom the policy is to be created.
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Available Options:Users - Restricts the bandwidth for a particular user.Rules - Restricts the
bandwidth of any entry to which Security Policies is applied.Web Categories - Restricts the
bandwidth for the URL categorized under the Web category.Applications - Restricts the bandwidth
for the applications categorized under the Application category.

Policy Type
Select the type of policy.

Available Options:Limit - In this type of policy, user cannot exceed the defined bandwidth
limit.Guarantee- In this type of policy, user is allocated the guaranteed amount of bandwidth and
can draw bandwidth up to the defined Limit, if available.

It enables to assign fixed minimum and maximum amounts of bandwidth to the users. By borrowing
excess bandwidth when available, users are able to burst above guaranteed minimum limits, up to
the defined Limit. Guaranteed rates also assure minimum bandwidth to critical users to receive
constant levels of bandwidth during peak and non-peak traffic periods.

Guarantee represents the minimum guaranteed bandwidth and Limit represents the maximum
bandwidth that the user can use, if available.

Limit Upload/Download Separately
Select from the available options.

Available Options:

Disable - Limits total (Upload + Download) bandwidth.

Enable - Limits Upload and Download bandwidth separately.

Priority
Set the bandwidth priority. Priority can be set from 0 (highest) to 7 (lowest) depending on the traffic
required to be shaped.

0 - Real Time for example, VOIP1 - Business Critical2 to 5 - Normal6 - Bulky - FTP7 - Best Effort
for Example, P2P

By default, priority is given to the real time traffic. However, if administrator does not want this
preference, feature can be disabled from System > System Services > Traffic Shaping Settings
page.

If Optimize for Real-Time (VoIP), under System > System Services > Traffic Shaping Settings
page is disabled then priority will be applicable only for excess bandwidth i.e. bandwidth remaining
after guaranteed bandwidth allocation.

If Optimize for Real-Time (VoIP), under System > System Services > Traffic Shaping Settings
page is enabled then Real-time traffic (Traffic Shaping policy with priority 0) like VOIP will be
given precedence over all other traffic.

As priority is given to the real time traffic, it is possible that some non real-time traffic will not get
their minimum guaranteed bandwidth. Specifically, if sum of Limit (max allowed) of all Traffic
Shaping policies (real-time and non real-time) is greater than total max-limit then guaranteed
bandwidth of the real-time policies will be fulfilled but non real-time might not get the minimum
guaranteed bandwidth.

Limit (in KBps) (Only if Policy Type is 'Limit' and Limit Upload/Download Separately is disabled)
Specify allowed total bandwidth.

Total Bandwidth Range: 2 – 2560000KBps

Limit bandwidth should be greater than or equal to guaranteed bandwidth.

Upload Bandwidth (in KBps) (Only if Policy Type is 'Limit' and Limit Upload/Download Separately is enabled)
Specify upload bandwidth.

Total Bandwidth Range: 2 – 2560000KBps
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Download Bandwidth (in KBps) (Only if Policy Type is 'Limit' and Limit Upload/Download Separately is enabled)
Specify download bandwidth.

Total Bandwidth Range: 2 - 2560000KBps

Guarantee -Limit (in KBps) (Only if Policy Type is 'Guarantee' and Limit Upload/Download Separately is disabled)
Specify range for guaranteed bandwidth limit.

Total Bandwidth Range: 2 – 2560000KBps

Guarantee - Limit Upload (in KBps) (Only if Policy Type is 'Guarantee' and Limit Upload/Download Separately is
enabled)

Specify range for guaranteed upload bandwidth.

Total Bandwidth Range: 2 – 2560000KBps

Guarantee - Limit Download (in KBps) (Only if Policy Type is 'Guarantee' and Limit Upload/Download Separately
is enabled)

Specify range for guaranteed download bandwidth.

Total Bandwidth Range: 2 - 2560000KBps

Bandwidth Usage Type
Select the type of bandwidth usage.

Available Options:Individual - Allocated bandwidth is for the particular User/Rule/Web
Category/Application only.Shared - Allocated bandwidth is shared among all the Users/Rules/Web
Categories/Applications who have been assigned this policy.

Description
Provide description for the policy.

Figure 233: Add Traffic Shaping (QoS) Policy
3. Select Save to add the traffic shaping policy with the options you have configured.

Schedule Traffic Shaping Policy
Use the Add Traffic Shaping (QoS) Policy Detail  page to schedule a traffic shaping policy.
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The page allows you to add a schedule-wise traffic shaping policy to override default traffic shaping policy details.

1. Go to Device Configuration > System >  Profiles > Traffic Shaping.
2.

Click on the Manage icon  under the Manage column.
3. Click on the Add button.
4. Enter Traffic Shaping Policy details.

Name
Displays policy name.

Policy Type
Displays default Policy Type set at the time of creation of policy, modify if required.

Note:  Configured policy type will override the default policy and will be applicable
only for the selected scheduled time interval.

Limit Upload/Download Separately
Displays default implementation strategy set at the time of creation of policy, modify if required.

Note:  Configured policy type will override the default policy and will be applicable
only for the selected scheduled time interval.

Limit (in KBps) (Only if Policy Type is 'Limit'and Limit Upload/Download Seperately is disabled)
Displays allocated Total bandwidth. Modify if required.

Note:  The modified bandwidth restriction is applicable only for the selected time
interval.

Upload Bandwidth (in KBps) (Only if Policy Type is 'Limit'and Limit Upload/Download Seprately is enabled)
Displays allocated Individual upload bandwidth. Modify if required.

Note:  The modified bandwidth restriction is applicable only for the selected time
interval.

Download Bandwidth (in KBps) (Only if Policy Type is 'Limit'and Limit Upload/Download Seprately is enabled)
Displays allocated Individual download bandwidth. Modify if required.

Note:  The modified bandwidth restriction is applicable only for the selected time
interval.

Guarantee -Limit (in KBps) (Only if Policy Type is 'Guarantee' and Limit Upload/Download Seprately is disabled)
Displays range for total guaranteed bandwidth. Modify if required.

Total Bandwidth Range: 2 – 2560000KBps

Guarantee - Limit Upload (in KBps) (Only if Policy Type is 'Guarantee' and Limit Upload/Download Seprately is
enabled)

Displays range for guaranteed upload bandwidth. Modify if required.

Total Bandwidth Range: 2 – 2560000KBps

Guarantee - Limit Download (in KBps) (Only if Policy Type is 'Guarantee' and Limit Upload/Download Seprately
is enabled)

Displays range for guaranteed download bandwidth. Modify if required.

Total Bandwidth Range: 2 - 2560000KBps

Schedule
Select Schedule from the available list during which the traffic shaping policy will be applied.

Only Recurring Schedule can be applied.

If you are not sure about the Schedule details, check Schedule to view the details.
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Figure 234: Add Traffic Shaping (QoS) Policy Detail
5. Click Save to add a schedule-wise traffic shaping policy.

Device Access
Device Configuration > System >  Profiles > Device Access

Role-based administration capabilities are provided to offer greater granular access control and flexibility.

It allows an organization to separate super administrator's capabilities and assign through Profiles. Profiles are
a function of an organization's security needs and can be set up for special-purpose administrators in areas such
as policy administration, network administration, and logs administration. Profiles allow granting permissions to
individual administrators depending on their role or job need in the organization.

The profile separates device features into access control categories for which you can enable none, read only, or read-
write access.

The Profiles list shows the default and custom profiles you have created and enables you to add, edit, and delete the
profiles.

For ease of use, by default the device provides 5 profiles:

• Administrator – super administrator with full privileges
• Audit Admin – read-write privileges for Logs & Reports only
• Crypto Admin – read-write privileges for Certificate configuration only
• HA Profile – read-only privileges. If HA is configured, any user accessing Web Admin Console of Auxiliary

device will have privileges as defined in HA Profile.
• Security Admin – read-write privileges for all features except Profiles and Log & Reports

An Administrator with full privileges can create other custom administrators and assign them restricted/full privileges.
A custom administrator so created, if has restricted privileges, can only update their Email Address and password.

Note:

• You cannot delete the default profiles.
• You cannot delete the profile which is already assigned to administrator.
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Access Denied page

Device provides role-based administration capabilities and privileges are assigned to the Administrator through
Profiles. Administrator can have read only, read-write or no access privilege for the pages of Web Admin Console.

Access denied page is displayed when the Administrator tries to access a page or perform the operation, which is not
allowed to him/her.

Add a new Profile

The Add Profile page allows you to add administrator profiles.

1. Go to Device Configuration > System >  Profiles > Device Access and click Add.
2. Enter Profile details.

Profile Name
Specify a name to identify the profile.

Configuration
Click on the access level you want to provide to a profile. There are three levels of access each of
the created profile can have.

Available Options:

None: No access to any page Read-Only: View the pages Read-Write:Modify the details

Access levels can be set for individual menus as well. You can either set a common access level for
all the menus or individually select the access level for each of the menu.

Click  icon against a menu to view the items under that menu.

For example, if you set access level as Read-Only against the Web Filter, the profile user would only
be able to view the Web Filter menu but would not be able to make any modifications. To make
modifications, Read-Write option is to be used.
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Figure 235: Add Device Access Profile
3. Click Save to save the settings.

Hosts and Services
Device Configuration > System >  Hosts and Services

Hosts and Services allows defining and managing system hosts and services.

This section covers the following topics:
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• IP Host - The page displays the list of all dynamic and default hosts. The page also provides options to add a new
host, update the existing host, or delete a host.

• IP Host Group - Host Group is a grouping of hosts. Security Policies can be created for the individual host or
host groups. This page displays the list of all the host groups. It also provides options to manage these host groups.

• MAC Host - Device allows creating a host based on MAC Address. One can create a MAC Host of either a single
MAC Address or multiple MAC Addresses. This page displays the list of all the available MAC host. The page
also provides option to add a new MAC host, update the existing host, or delete a host.

• FQDN Host - This page displays the list of all the available FQDN host.
• FQDN Host Group - FQDN Host Group is a grouping of FQDN hosts. This page displays the list of all the

available FQDN host groups.
• Country Host - The device allows to create Country based Host. With Country based Host one can apply all

Security and UTM Policies based on the traffic coming from the country and/or going out of the country. This
page displays the list of all the available Country hosts.

• Country Host Group - Country Host Group is a grouping of Country Hosts. Multiple countries can be selected
to block or allow incoming traffic by using Country Host Group. This page displays the list of all the available
Country host groups.

• Services - You can use services to determine the types of traffic allowed or denied by the firewall. This page
displays the list of all the default and custom services. It also provides options to manage services.

• Service Group - Service Group is a grouping of services. Custom and default services can be grouped in a single
group. The page displays the list of all the default and custom groups.

IP Host
The IP Host page displays the list of all the dynamic hosts, default hosts and manually added hosts.

Hosts allow the entities to be defined once and be re-used in multiple referential instances throughout the
configuration. For example, consider an internal Mail Server with an IP Address 192.168.1.15. Rather than repeated
use of the IP Address while configuring Security Policies or NAT Policies, it allows to create a single entity Internal
Mail Server as a Host name with an IP Address 192.168.1.15. This host, Internal Mail Server can then be selected in
any configuration that uses Host as a defining criterion.

By using host name instead of numerical address, you only need to make changes in a single location, rather than in
each configuration where the IP Address appears.

Using Hosts, reduces the error of entering incorrect IP Addresses, makes it easier to change IP Addresses, and
increases readability.

The IP Host page displays the list of all the dynamic hosts which are automatically added on creation of VPN
Remote access connections (IPSec and SSL) and the default hosts (IPv6 and IPv4) for remote access connection -
##ALL_RW, ##WWAN1, ##ALL_IPSEC_RW and ##ALL_SSLVPN_RW along the manually added hosts. The page
also provides option to add a new host, update the existing host, or delete a host.

Note:

• System hosts cannot be updated or deleted.
• Dynamic hosts which are automatically added on creation of VPN Remote Access connections cannot be

deleted.
• Default hosts (IPv6 and IPv4) for remote access connection - ##ALL_RW, ##WWAN1,

##ALL_IPSEC_RW and ##ALL_SSLVPN_RW cannot be updated or deleted.

Adding a IP Host

The Add IP Host page allows you to manually add IP host.

1. Go to Device Configuration > System > Hosts and Services > IP Host and click Add.
2. Enter IP Host details.

Name
Enter a name to identify the IP Host.

IP Family
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Select the type of IP Family from the options available:

Available Options:IPv4IPv6

Type
Select the type of host.

Available Options: Single IP AddressNetwork IP Address with subnetIP RangeIP List - To add
assorted IP Addresses. Use comma to specify assorted multiple IP Addresses. Create IP list to
configure single policy for multiple IP Address which are not in a range.

Note:  Only Class B IP Addresses can be added in IP list. IP Addresses can be added
or removed from IP list.

IP Address
Specify IPv4 Address or IPv6 Address based on the Host Type selected.

IP Host Group
Select host group. Single host can be member of multiple host groups.

You can also add a host group from Add Host page itself or from Objects >  Assets >  IP Host
Group page.

Note:

• Single host can be member of multiple host groups.
• A Group with IPv4 and IPv6 hosts cannot be created.
• IP Host Group is not available for "IP List" Type.

Figure 236: Add IP Host
3. Click Save to add the IP Host with the options you have configured.

IP Host Group
The IP Host Group page displays the list of all the host groups.

Host Group is a grouping on hosts. Security policies can be created for the individual host or host groups.

Note:  Dynamic host groups which are automatically added on creation of VPN Remote Access Connections
cannot be deleted.

The page also provides option to add a new host group, update the parameters of the existing host group, add
members to the existing host group, or delete a host group.

Adding a IP Host Group
Use the Add IP Host Group page to create a new Host Group.

The Add IP Host Group page allows you to configure an IP Host Group.
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1. Go to Device Configuration > System > Hosts and Services > IP Host Group and click Add.
2. Enter IP Host Group details.

Name
Enter a name to identify the IP Host Group.

IP Family
Select the type of IP Family from the options available:

Available Options:IPv4IPv6

Description
Describe the IP Host Group.

Select Host
'Host List' displays all the hosts including default hosts.

Click the checkbox to select the hosts. All the selected hosts are moved to 'Selected host' list.

Single host can be a member of multiple host groups.

A Group with IPv4 and IPv6 hosts cannot be created.

Figure 237: Add IP Host Group
3. Click Save to add the IP Host Group with the options you have configured.

MAC Host
The MAC Host page displays the list of all the available MAC hosts.

Device allows to create a host based on MAC Address. One can create a MAC Host of either a single MAC Address
or multiple MAC Addresses.

MAC Hosts allow entities to be defined once and be re-used in multiple referential instances throughout the
configuration. For example, test has a MAC Address as 00:16:76:49:33:CE or 00-16-76-49-33-CE. Rather than
remembering the MAC Address of the intended machine while applying policies, you can simply provide its MAC
Host name.

By using MAC hosts, you only need to make changes in a single location, rather than in each configuration where the
MAC Address appears.

Using MAC Hosts reduces the error of entering incorrect MAC Addresses, makes it easier to change addresses, and
increases readability.

The page also provides option to add a new MAC host, update the existing host, or delete a host.
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Adding a MAC Host
Use the Add MAC Host page to create a MAC Host.

The Add MAC Host page allows you to manually create a MAC Host of either a single MAC Address or multiple
MAC Addresses.

1. Go to Device Configuration > System > Hosts and Services > MAC Host and click Add.
2. Enter MAC Host details.

Name
Enter a name to identify a MAC Host.

Type
Select the MAC Host Type.

Available Options:MAC Address - Select to add a single MAC Address.MAC List - Select to add
multiple MAC Addresses.

MAC Address (Applicable only if Type is selected as MAC Address)
Specify MAC Address based on the Host Type selected in the form of 00:16:76:49:33:CE or
00-16-76-49-33-CE.

List of MAC Addresses (Applicable only if Type is selected as MAC List)
Specify MAC Address based on the Host Type selected in the form of 00:16:76:49:33:CE or
00-16-76-49-33-CE.

Use comma to configure multiple MAC Addresses.

Figure 238: Add MAC Host
3. Click Save to add a MAC Host.

FQDN Host
The FQDN Host page displays the list of all the available FQDN host.

FQDN (Fully Qualified Domain Name) Hosts allow entities to be defined once and be re-used in multiple referential
instances throughout the configuration. For example, www.example.com has an IP Address as 192.168.1.15.
Rather than remembering the IP Address of the intended website while accessing it, you can simply provide
www.example.com in the browser. The FQDN www.example.com will now be mapped to its respective IP Address,
and the intended webpage opens.

The page also provides option to add a new FQDN host, update the existing host, or delete a host.

Adding a FQDN Host
Use the Add FQDN Host page to create a new FQDN host.

The Add FQDN Host page allows you to manually configure a new FQDN host.

1. Go to Device Configuration > System > Hosts and Services > FQDN Host and click Add.
2. Enter FQDN Host details.

Name
Specify a name to identify the FQDN Host.

FQDN
Specify FQDN Address. You can also specify a Wildcard FQDN by adding the prefix “*”.

http://www.example.com/
http://www.example.com/
http://www.example.com/
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FQDN Host Group
Select FQDN Host Group. Single FQDN Host can be member of multiple host groups.

You can add a new FQDN Host Group from this page itself or from Objects > Assets > FQDN
Host Group page.

Figure 239: Add FQDN Host
3. Click Save to add a FQDN Host.

FQDN Host Group
The FQDN Host Group page displays the list of all the available FQDN host groups.

FQDN Host Group is a grouping of FQDN hosts. Security Policies can be created for the individual FQDN host or
host group to allow or deny access to any website.

The page also provides option to add a new FQDN host group, update the parameters of the existing host group, add
members to the existing host group, or delete a group.

Adding a FQDN Host Group
Use the Add FQDN Host Group page to create a new FQDN host group.

The Add FQDN Host Group page allows you to configure a new FQDN host group.

1. Go to Device Configuration > System > Hosts and Services > FQDN Host Group and select Add.
2. Enter FQDN Host Group details.

Name
Enter a name to identify the FQDN Host group.

Description
FQDN Host Group description.

Select Host
"Host" List displays all the hosts including default hosts.

Click the checkbox to select the hosts. All the selected hosts are moved to "Selected host" list.

Single host can be a member of multiple host groups.
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Figure 240: Add FQDN Host Group
3. Click Save to add a FQDN Host Group.

Country Host
The Country Host page displays the list of all the available Country hosts.

The device allows to create Country based Host. With Country based Host one can apply all Security and Sophos
UTM Policies based on the traffic coming from the country and/or going out of the country.

Country Hosts created once can be re-used in multiple referential instances throughout the configuration. For
example, you want to deny incoming traffic from country “X”. You can select the country “X” and select the option to
block the traffic coming from “X”.

Adding a Country Host
Use the Add Country Host page to create country based host.

The Add Country Host page allows you to manually enter details to add a country based host.

1. Go to Device Configuration > System > Hosts and Services > Country Host and click Add.
2. Enter details.

Name
Enter a name to identify the Country Host.

Country
Select the Country.

Country Host Group
Select Country Host Group. Single host can be member of multiple host groups.

You can add a new Country Host Group from this page itself or from Objects >  Assets >  Country
Host Group page.

Figure 241: Add Country Host
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3. Click Save.

Country Group
The Country Group page displays the list of all the available Country Groups.

Country Group is a grouping of Countries. You can deny or allow incoming traffic for multiple countries by using
Country Group. You can also apply security policies for an individual Country or Country Groups.

The device provides pre-defined continent specific groups. You can directly use them without any modifications or
you can edit/delete them as per your requirements. On factory reset, device boots up with the pre-defined country
groups removing all the customizations.

The page also provides option to add a new group, update the parameters of the existing group, add members to the
existing group, or delete a group.

Adding a Country Group
Use the Add Country Group page to create a new country group.

The Add Country Group page allows you to manually configure parameters to add a new country group.

1. Go to Device Configuration > System > Hosts and Services > Country Group and click Add.
2. Enter Country Group details.

Name
Enter a name to identify the Country Group.

Description
Country Group description.

Select Country
Click Add New Item to select and add countries in the group.

A country can be a member of multiple country groups.

Figure 242: Add Country Host Group
3. Click Save.

Services
The Services page displays the list of all the default and custom services.

Services are definitions of certain types of network traffic and combine information about a protocol such as TCP,
ICMP or UDP as well as protocol-related options such as port numbers. You can use services to determine the types
of traffic allowed or denied by the firewall.

Certain well-known traffic types have been predefined in services. These predefined services are defaults, and cannot
be updated or deleted. If you require service definitions that are different from the predefined services, you can add
them as custom services.
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The page also provides option to add a new service, update the parameters of the existing service, or delete a service.

Note:

• Service used by Security Policies cannot be deleted.
• Default Services can neither be updated nor deleted.

Adding a New Service
Use the Add Service page to add a new Service.

The Add Service page allows you to manually configure parameters to add a new Service.

1. Go to Device Configuration > System > Hosts and Services > Services and click Add.
2. Enter Service parameters.

Name
Enter a name to identify the Service.

Type
Select a protocol for the service.

Available Options:TCP/UDP - Enter Source and Destination port. You can enter multiple ports for
the same service. IP - Select Protocol Number for the Service. You can select multiple ports for the
same service. ICMP - Select ICMP Type and Code. You can enter multiple types and codes for the

same service. Use Add icon and Remove icon  to add and delete the parameters respectively.
ICMPv6 - Select ICMPv6 Type and Code. You can enter multiple types and codes for the same
service.

Use Add  and Remove  to add and delete the parameters.

Figure 243: Add Service
3. Click Save to add a Service.

Service Group
The Service Group page displays the list of all the default and custom service groups.

Service Group is a grouping of services. Custom and default services can be grouped in a single group.

Use to configure Security Policies to:

• block group of services for specific zone
• limit some or all users from accessing group of services
• allow only specific user to communicate using group of service

Create groups of services and then add one firewall to allow or block access for all the services in the group. A service
group can contain default services as well as custom services in any combination. A single service can be a member
of multiple service groups.

The page also provides option to add a new group, update the parameters of the existing group, add members to the
existing group, or delete a group.



 | Device Configuration | 322

Note:

• Default Service Groups can neither be updated nor deleted.
• Service Group used by the Security Policies cannot be deleted.

Adding a Service Group
Use the Add Service Group page to add a new customized Service Group.

The Add Service Group page allows you to manually enter details and configure a new service group.

1. Go to Device Configuration > System > Hosts and Services >  Service Group and click Add.
2. Enter Service Group details.

Name
Enter a name to identify the Service Group.

Description
Service Group Description.

Select Service
Service List displays all the services including default services.

Click the checkbox to select the service. All the selected services are moved to the Selected Service
list.

Single service can be a member of multiple groups.

Use Search to search a service from the list.

You can create a group containing IPv4 and IPv6 services.

Figure 244: Add Service Group
3. Click Save to add a Service Group.

Administration
Device Configuration > System > Administration

Administration provides options to configure general settings of the device.

Available configurations:

• Settings: Settings allows configuring the port settings, login security settings and Admin Console logon settings.
• Device Access: Device access allows limiting the administrative access of the device services from default as well

as custom zones. It also allows changing/resetting Administrator Password and Adding/Removing Local Service
ACL Rules.

Admin Settings
Device Configuration > System > Administration > Settings
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Use Settings page to make modifications in the general port settings and Web Admin Login parameters. Make
changes to the login parameters for restricting the local and remote users based on the time.

Admin Port Settings
Web Admin HTTP Port

Provide the port number to configure HTTP Port for Admin Console access.

Default - 80

Web Admin HTTPS Port
Provide the port number to configure HTTPS Port for secured Admin Console access.

Default - 4444

User Portal HTTPS Port
Provide the port number to configure HTTPS Port for Secured User Portal access..

Default - 443

Certificate
Certificate to be used by User Portal and Captive Portal.

Login Security (Remote Admins)

To prevent the unauthorized access to the Admin Console and CLI, configure Admin Session Lock, Admin Session
Logout time and Block Admin Login to block the access after number of failed login attempts.

Lock Admin Session After

Configure inactivity time (in minutes) for the administrative session after which the device will be
locked automatically. This configuration will be applicable to following components:

• Admin Console
• Telnet Console
• IPSec Connection Wizard
• Network Wizard
• Group Import Wizard

Default - 3 Minutes

Logout Admin Session After
Configure time of admin inactivity in minutes after which the administrator will be logged out
automatically.

Default - 10 Minutes

Note:  Admin Session Logout time value must be greater than Lock Admin Session
time.

Block Admin Login
Enable to block login to the Admin Console and CLI after configured number of failed attempts
within configured time span.

Configure number of allowed failed login attempts from the same IP Address within the time limit.

Specify number of minutes for which the administrator will not be allowed to login. The
administrator account will locked for the configured minutes if allowed failed login attempts
exceeds.

Administrator Password Complexity Settings

Password Complexity can be configured to ensure that administrators are using secure passwords.

Enable Password Complexity Settings to enforce following constraints:

• Minimum Password length. Configure minimum characters required in the password.
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Default - 8 Characters
• Require minimum one upper and lower case alphabet
• Require minimum one number (0 - 9)
• Require at least one special character e.g. @, $, %
• Password cannot be same as username.

Note:  All the enabled constraints are applied to password of administrator user only.

Login Disclaimer Settings

The Login Disclaimer allows setting a written message that administrators must read and agree prior to logging on to
the Admin Console and CLI for device administration. If a disclaimer is set, it must be accepted before administrator
can login.

Default disclaimer can be customized as per the requirement from the Messages page System > Administration >
Messages. One can also review the customized message before setting.

Sophos Adaptive Learning

The product sends information periodically to Sophos which is used for the purpose of improving stability,
prioritizing feature refinements, and protection effectiveness. It includes configuration and usage information, and
Application usage and threat data.

Configuration and usage data such as Device information (hardware version, vendor), Firmware version and license
information (not the owner), Features in use (status, on / off, count, HA status, Central Management status), amount
of configured objects (count of hosts, policies), Product errors, CPU, memory and disk usage (in percentage), is
collected by default.

No user-specific information or personalized information is collected. The information is transmitted to Sophos over
HTTPS.

Send App & Threat data
Following Application usage and Threat data is gathered:

• Unclassified applications to improve and enlarge the network visibility and application control
library.

• Data for IPS alerts, virus detected (also URL for which virus found), spam, ATP threats such as
threat name, threat URL/IP, source IP, and applications used.

Default - Enable

SFOS Hot-fix

Allow auto-install of important Hot-fixes Hot-fixes are applied automatically if available. Disable if you do not want
to apply hot-fix. Default - Enable

Licensing

After migrating firewall device from Cyberoam OS (CROS) to Sophos Firewall OS (SFOS), one has to upgrade
license of the firewall device by navigating to Device Configuration > System > Admin > Licensing. Available
options are:

• 30 Day Full Guard Trial (Evaluating) - All module licenses will be applied to the firewall for 30 days. The
existing Cyberoam licenses will remain intact. During this period, seamless rollback to CROS is possible by
rebooting the firewall device with the Cyberoam firmware.

• Migrate License - All the existing CROS licenses will be migrated to SFOS. This will result in a license of
equivalent value to your current one.

License Migration
Migrate CR licenses to SFOS
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Click to migrate your Cyberoam (CR) licenses that are currently on 30 Day Full Guard Trial
(Evaluating) to SFOS licenses on selected firewall devices. This will migrate your CR licenses
permanently to SFOS with no roll-back possible. This can also be done using Migrate License
option from Sophos XG Firewall.

Note:  This page will be applicable to only those managed devices that are on 30 Day
Full Guard Trial (Evaluating) mode.

Notification Settings
Device Configuration > System > Administration > Notification Settings

Device allows configuration of Email notifications for certain system-generated events and reports (as specified by
administrator). Such Email notifications can be configured to inform administrator about:

• Change in gateway status
• Change in HA (high availability) link status (if HA cluster is configured)
• Change in State of IPSec Tunnel(s)

Configure a Mail Server IP Address, Port, and Email Address for the device to send and receive alert Emails. Below
are the screen elements with their description:

Mail Server Settings
Send Notifications via

Built-in Email Server- Select if you want to use the built-in Email Server in the Device to send
system-generated emails.

External Email Server - Select to configure an External Email Server to send system-generated
emails.

Mail Server IPv4 Address/ FQDN - Port

Specify the Mail Server IPv4 Address or FQDN Address and Port number.

Default - 25

Authentication Required

Enable to authenticate user before sending an Email.

Specify user credentials.

Username

Specify the User Name, which uniquely identifies user and will be used for login.

Password

Specify the password.

Connection Security

Select Connection Security mode, to be used for establishing a secured connection between SMTP
Client and the SMTP Server for SMTP Mail Notification.

Available Options:

• None – Select if your SMTP Server does not support TLS (Transport Layer Security) or a
secured connection between SMTP Client and the SMTP Server is not required. If selected, a
normal TCP connection is established, without any security.

• STARTTLS - SMTP Client establishes a TCP connection with the SMTP Server to learn about
the TLS capabilities of the server. If the SMTP Server supports STARTTLS, the connection is
upgraded to TLS. If the SMTP Server does not support STARTTLS, the SMTP Client continues
to use the normal TCP connection.
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• SSL/TLS - SMTP Client establishes a TLS connection with the SMTP Server. In case the SMTP
Server does not support TLS, no connection is made between the SMTP Client and the SMTP
Server.

Default – None

Certificate

Select a Certificate, to be used for authentication by SMTP Client and the SMTP Server.

Default - Applicance Certificate

Email Settings
From Email Address

Specify the Email Address from which the notification is to be mailed.

Send Notifications to Email Address

Specify the Email Address to which the notification is to be mailed.

Email Notification
IPSec Tunnel UP/Down

Enable to receive Email notification if the IPSec VPN tunnel connectivity is lost.

Email alerts are sent to Administrator on the configured Email Address. All the IPSec tunnels
follow the single configuration done from this page.

An Email is sent only for Host to Host and Site to Site tunnel connections; if it flaps due to one of
the following reasons:

• A peer is found dead (DPD)
• Failed to re-establish connection after Dead Peer Detection (DPD)
• IPSec Security Association (SA) is expired and is required to be re-established.
• IPSec Tunnel comes up without administrator intervention after losing the connectivity.

Email shall contain following basic information:

• IPSec Connection name
• IP Addresses of both participating hosts/network
• Current state of the IPSec Tunnel connection, viz, Up or Down
• Time when IPSec Tunnel was disconnected
• Reason for lost of IPSec Tunnel connection
• Device Model Number
• Firmware version and build number
• Device Key (if registered)
• Device LAN IP Address
• HA configuration – Primary/Auxiliary (if configured)

Note:

• An Email is sent for each subnet pair in case of Site to Site connections, having
multiple local/remote networks.

• An Email sent with respect to IPSec Tunnel coming up; do not have any reason
mentioned within.

• Description of IPSec Tunnel connection is included in the Email, only if the
information for same is provided by the Administrator.

Note:  Mail Server configuration changes automatically when changed from the Network Configuration
Wizard and vice versa.
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Device Access
Device Configuration > System > Administration > Device Access

Device access allows limiting the Administrative access of the following device services from various default zones,
LAN, WAN, DMZ, VPN and custom zones :

• Admin Services – HTTP, HTTPS, Telnet, SSH
• Authentication Services – Client Authentication, NTLM, Captive Portal, Radius SSO
• Network Services – DNS, Ping/Ping6
• Other Services – Wireless Protection, SSL VPN, Web Proxy, User Portal, Dynamic Routing

Default ACL

When device is connected and powered on for the first time, it will have a default Access configuration.

Admin Services – HTTP (TCP port 80), HTTPS (TCP port 443), Telnet (TCP port 23) and SSH (TCP port 22)
services will be enabled for administrative functions in LAN and WiFi zone. HTTP (TCP port 80), HTTPS (TCP
port 443), Telnet (TCP port 23) and SSH (TCP port 22) services will be enabled for administrative functions in WAN
zone. HTTP (TCP port 80) services will be enabled for administrative functions in DMZ zone.

Authentication Services – Client Authentication (UDP port 6060), Captive portal Authentication (TCP port 8090) and
Radius SSO will be enabled for User Authentication Services in LAN and WiFi zone. User Authentication Services
are not required for any of the Administrative functions but required to apply user based internet surfing, bandwidth,
and data transfer restrictions.

Network Services – Ping/Ping6 and DNS services will be enabled for LAN, WAN and WiFi zone.

Other Services – Web Proxy service will be enabled for LAN and WiFi zone. SSL VPN (TCP port 8443) service will
be enabled for LAN, WAN, DMZ and WiFi zone. User Portal and Dynamic Routing service will be enabled for LAN
and WAN zone.

Local Service ACL

Use access control to limit the access to the device for administrative purposes from the specific authenticated/trusted
networks only.

Admin Services – Enable/disable access to the device using following service from the specified zone: HTTP,
HTTPS, Telnet and SSH.

Authentication Services – Enable/disable following service from the specified zone: Client Authentication, Captive
Portal, NTLM, Radius SSO.

Network Services – Enable/disable following service from the specified zone: DNS, Ping/Ping6.

Other Services – Enable/disable following service from specified zone: Wireless Protection, SSL VPN, Web Proxy,
User Portal and Dynamic Routing.

Local Service ACL Rule

Use Local Service ACL Rule to allow access to the device Admin Services from specified network/host. The section
displays list of all the configured IPv4 and IPv6 Local Service ACL rules. The page provides option to add, update
and delete the rules.

Default Admin Password Settings

The device is shipped with one global super admin with the credentials – username & password as “admin”. Both
the consoles – Admin Console and CLI, can be accessed with the same credentials. This administrator is always
authenticated locally i.e. by device itself.

Note:  We recommend you to change the password for this user name immediately after deployment.
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You can change the default password from this section. The screen elements and their description are mentioned
below:

Username
The default admin username is –“admin”.

Current Password
Enter the current admin password.

New Password
Password - Specify new admin password.

Confirm Password - Confirm the specified new admin password.

Reset to Default
Click to reset the password to factory default password.

Public Key Authentication

Use this to configure Public Key Authentication on multiple Sophos XG Firewall devices.

Username
The default admin username is –“admin”.

Public key authentication for admin
Select this to enable public key authentication for admin.

Authorized keys for admin
Add or remove authorized SSH keys from here.

Devices on which configuration was pushed in the last session
This displays list of devices on which configuration was pushed in the last session.

Select devices that have same admin password.
Select this to enable selecting devices with same admin password. If this is not selected then
passwords for all the devices have to be specified separately.

Device
Select device(s) on which public key authentication is to be applied.

Password
Specify password for the device(s).

Add Local Service ACL Rule
Use Local Service ACL Rule to allow access to the device Admin Services from specified network/host.

You can add Local Service ACL rule from this page.

1. Go to Device Configuration > System > Administration > Device Access and click Add under Local Service
ACL Rule

2. Enter Rule details.
Rule Name

Specify name to identify the rule.

Description
Provide a description for the rule.

IP Family
Select the type of IP Family from the options available:

Available Options:

IPv4IPv6
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Network/Host
Click Add New Item button to select host or network address to which the rule applies. You can
also create new Network/Host from this page itself by clicking Create New button.

Services
Click Add New Item to select Admin Services to which the rule applies.

Available Options:

HTTPHTTPSTelnetSSH

Figure 245: Local Service ACL Exception Rule
3. Click Save to add the rule.

Time
Device Configuration > System > Administration > Time

Device current date and time can be set according to the device’s internal clock or synchronized with an NTP server.
Device clock can be tuned to show the right time using global Time servers so that logs show the precise time and
device internal activities can also happen at a precise time.

Below are the screen elements and their description for setting the Time and Date for the Device:
Current Time

Displays the current system time.

Time Zone
Select time zone according to the geographical region in which the device is deployed.

Use pre-defined NTP Server
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Select to use the pre-defined NTP servers – asia.pool.ntp.org & in.pool.ntp.org.

NTP stands for Network Time Protocol, and it is an Internet standard protocol used to synchronize
the clocks of device to some time reference.

Use Custom NTP Server
Specify the NTP server IPv4 Address or IPv6 Address or domain name to synchronize time with it.
If custom NTP server is defined, time is synchronized with custom server and not with pre-defined
servers.

Devices use NTP Version 3 (RFC 1305). One can configure up to 10 NTP servers. At the time of
synchronization, it queries each configured NTP server sequentially. When the query to the first
server is not successful, device queries second server and so on until it gets a valid reply from one of
the NTP servers configured.

Sync Status
Click Sync Now to synchronize device clock with the NTP Server.

Do Not use NTP Server
Select to configure the date and time for device’s clock.

Date

Specify the date by clicking calendar .

Time
Specify the time in HH:MM:SS format.

SNMP
Device Configuration > System > Administration > SNMP

Simple Network Management Protocol (SNMP) is used as the transport protocol for network management.
Network management consists of a station or manager communicating with network elements such as hosts,
routers, servers, or printers. The agent is the software on the network element (host, router, and printer) that runs the
network management software. In other words, agent is the network element. The agent will store information in
a Management Information Base (MIB). Management software will poll the various network elements/agents and
get the information stored in them. The manager uses UDP port 161 to send requests to the agent and the agent uses
UDP port 162 to send replies or messages to the manager. The manager can ask for data from the agent or set variable
values in the agent. Agents can reply and report events.

SNMP collects information in two ways, if SNMP agent is installed on the devices:

• The SNMP management station/manager will poll the network devices/agents.
• Network devices/agents will send trap/alert to SNMP management station/Manager.
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SNMP terms

• Trap - An alert that is sent to a management station by agents.
• Agent - A program at devices that can be set to watch for some event and send a trap message to a management

station if the event occurs
• SNMP community – An SNMP community is the group that devices and management stations running SNMP

belong to. It helps define where information is sent. The community name is used to identify the group. A SNMP
device or agent may belong to more than one SNMP community. It will not respond to requests from management
stations that do not belong to one of its communities.

Use SNMP to configure agent, community and the SNMPv3 users. Device supports SNMPv1& SNMPv2c protocols.
Agent configuration page is used to configure agent name, agent port and the contact person for the program. The
community page is used for adding, managing and deleting the communities for protocols SNMPv1 and SNMPv2c.
Use SNMPv3 user page to add, manage and delete v3 users. Apart from IPv4 Addresses, SNMP now supports IPv6
Addresses also.

Below are the screen elements with their description:

Agent Configuration

Use Agent configuration section to configure SNMP agents. The configuration details include name, description,
location, contact person, agent port and manager port.

Below are the screen elements with their description:
Enable SNMP Agent

Select to enable SNMP Agent.

Name
Specify a name to identify the agent.

Description
Specify Agent Description.

Location
Specify the physical location of the device.

Contact Person
Specify the contact information for the person responsible for the maintenance of above specified
device.

Agent Port
Specify the port which device should use to send traps.

Default - 161

Manager Port
Remote SNMP Management station/Manager uses this port to connect to the device.

Default - 161

Community

Community is a group of SNMP Managers. SNMP Agent may belong to one or more than one community. Agents do
not respond to the requests from management stations that do not belong to its communities.

Each Community can support SNMPv1, SNMPv2c or both. Device sends traps to all the communities. You must
specify a trap version for each community.

The section provides list of all the communities added and you can sort the list based on community name. The
section also provides the option to add a new community, update the parameters of the existing community, or delete
the community.
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v3 User

SNMP version 3 has the capability of using authentication. Only the authenticated user can request the information.

The section displays the list of all the v3 users. The section also provides the option to add a new v3 user, update the
password of the user, or delete the user.

Add a new SNMP Community

You can add SNMP Community from this page.

1. Go to Device Configuration > System > Administration > SNMP > Communityand click Add.
2. Enter Community details.

Name
Enter the name to identify the community.

Description

Enter the description for community.

IP Address

Specify IP Address (IPv4/IPv6 Address) of the SNMP Manager.

Protocol Version

Select the required SNMP protocol version support.

SNMP v1 and v2c compliant SNMP managers have read-only access to device system information
and can receive device traps.

Trap Support

Select the required version for trap support.

Traps will be sent to the SNMP Managers who support the specified versions only.

Figure 246: Add Community
3. Click Save to add SNMP community.

Add a new V3 User

You can add V3 user from this page.

1. Go to Device Configuration > System > Administration > SNMP > v3 Userand click Add.
2. Enter User details.

Name
Enter a name to identify the v3 user.
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Password
Provide a password for authentication.

Confirm the password for authentication.
3. Click Save to add v3 User.

Netflow
Device Configuration > System > Administration > Netflow

Netflow is a flow technology used for network bandwidth monitoring. Details of the traffic passing through the
Security Policies can be exported as Netflow records to the Netflow Server. Based on the records received by the
Netflow Server, data analyzing tools like Open Source Data Analyzer and PRTG software can generate reports.

The Netflow page displays list of configured netflow servers. The page also provides option to add, update, or delete
the server.

Below are the screen elements with their description:

Netflow Configuration
Server Name

Specify a unique name for Netflow server.

Netflow Server IP/Domain

Specify IP Address (IPv4 / IPv6) or domain name of the Netflow Server.

Netflow Server Port

Specify the UDP port number for communication with the Netflow Server. NetFlow records will be
sent on the specified port.

Default - 2055

Note:

• Only traffic of Security Policies where "Log Firewall Traffic" is enabled will be sent to the NetFlow
Server.

• You can configure maximum five Netflow Servers.
• Sophos supports NetFlow v5 and all the parameters of v5 can be exported.

Messages
Device Configuration > System > Administration > Messages

Messages page allows Administrator to send messages to the various users. Messages help Administrator to notify
users about problems as well as Administrative alerts in areas such as access, user sessions, incorrect password, and
successful log on and log off etc.

Message, up to 256 characters can be sent to a single user or multiple users simultaneously, whenever an event occurs.

Click the Edit icon against the message to be customized, update the message and click the Apply icon  to save

the edited message or click Reset icon  to reset it to the default message.

Predefined Messages
Authentication

User account blocked (AD Policy)
Login failed. Your AD Server account is locked.

User account disabled (AD Policy)

Login failed. Your account on AD Server is disabled.
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User account expired (AD Policy)

Login failed. Your account on AD Server has expired.

Clientless User Login Not Allowed

Clientless user is not required to login.

Data Transfer Exhausted

Your data transfer has been exceeded. Please contact the Administrator.

Deactive User

You have been deactivated by the Administrator.

Delete User

You have been disconnected.

Disconnect User

You have been disconnected by Admin.

Guest User Validity Expired

Guest User validity has expired.

Login not allowed at this time (AD Policy)

Login failed. You are not permitted by AD Server to login at this time.

Invalid Machine

Message is sent if User tries to login from the IP Address not assigned to him/her

Login not allowed at this workstation (AD Policy)

Login failed. You are not permitted by AD Server to login at this workstation.

Someone else is logged in from same IP Address

Message is sent if someone else has already logged with the same IP Address.

Logged Off Successful Message

Message is sent when User logs off successfully.

Logged On Successful Message

Message is sent when User logs on successfully.

Max Login Limit

Message is sent if User has reached the maximum login limit.

Not Authenticate

Message is sent if User name or password is incorrect.

Not Currently Allowed

Message is sent if User is not permitted to access at this time

Access Time policy applied to the User account defines the allowed access time and not allowed
access at any other time.

User password expired (AD Policy)

Login failed. Your password on AD Server has expired.

User needs to reset the Password (AD Policy)

Login failed. You must reset your AD Server password.
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Logged Off Due To Session Time Out

Message is sent when session has timed out and user is logged of automatically.

Surfing Time Exhausted

Message is sent when User is disconnected because his/her allotted surfing time is exhausted

The surfing time duration is the time in hours the User is allowed Internet access that is defined in
Surfing time policy. If hours are exhausted, User is not allowed to access.

Surfing Time Expired

Administrator has temporarily deactivated the User and will not be able to log in because User
surfing time policy has expired.

Logout Notification

You will be logged off automatically after sometime. If you wish to continue browsing tap this
notification.

SMTP
CTIPD Rejection

Message will be sent when Administrator has blacklisted the sender’s IP Address.

CTIPD Temporary Rejection

Message will be sent when Administrator has temporarily blacklisted the sender’s IP Address.

Probable Spam Rejection

Message will be sent when mail is suspected as probable spam mail and is rejected.

Probable Virus Outbreak Rejection

Message will be sent when outbreak detection engine rejects mail because it seems to be a Probable
Virus outbreak.

Spam Rejection

Message will be sent when spam mail is rejected.

Virus Outbreak Rejection

Message will be sent when outbreak detection engine rejects mail because it is identified as a Virus
outbreak.

DPP Rejection
Message will be sent when mail is rejected by Sophos DPP.

Email Domain Rejection

Message will be sent when Administrator has blocked the mail sender domain.

Destination IP Address Rejection
Message will be sent when Administrator has blocked the destination IP.

Spam Mail Rejection

Message will be sent when Administrator has blocked the mail sender.

Mail Header Rejection

Message will be sent when mail is rejected as it contains a restricted mime header.

Mail/Virus Rejection

Message will be sent when virus infected mail is rejected.
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IP Address Rejection

Message will be sent when Administrator has blocked the mail sender IP.

Oversized Mail Rejection

Message will be sent when mail is rejected because message size exceeds the maximum allowed
size.

Undersized Mail Rejection

Message will be sent when mail is rejected because the message size is less than the allowed size.

Delivery Notification (to Sender)

Message will be sent to the mail sender when mail is successfully delivered to the receiver.

Attachment Infection

Message will be sent when mail is rejected due to virus infected attachment.

RBL Rejection

Message will be sent when the sender IP Address is blacklisted.

Source IP Address Rejection
Message will be sent when mail is rejected because the source IP has been blocked.

Suspected Infection

Message will be sent when mail is suspected as virus infected mail and is rejected.

Administration
Disclaimer Message

Message will be displayed when Administrator logs on to the Admin Console or CLI. Administrator
has to accept the disclaimer to proceed further.

SMS Customization
Default SMS Text

Default SMS to be sent to Guest User.

Note:  A Clientless User is not required to login.

Updates
Device Configuration > System > Administration > Updates

By default pattern updates are updated automatically. Updates page displays the status of various patterns for
different models like Sophos AV, IPS, WAF. The page also allows to update patterns or set auto-update time interval.

Below are the screen elements with their description:

Updates Status
Pattern

Pattern name whose definitions are updated.

Current Version

Version of the Pattern

Last Successful Update

Status along with date of the last update

Update Pattern Now Button

Click ‘Update Pattern Now’ button to update the pattern definitions.
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Pattern Download/Installation
Auto Update

To update pattern definitions automatically, enable "Auto Update".

Interval
If "Auto Update" is set as off, set the time limit in which you want to receive updates.

Available Options: Every hourEvery 2 hoursEvery 4 hoursEvery 12 hoursDailyEvery 2 days

Configuration
Device Configuration > System > Configuration

Configuration menu allows basic administrative settings for the device.

Use this menu to configure below details:

• CLI Configuration - Configure CLI settings.
• Transparent Authentication - Configure transparent authentication for users.

CLI Configuration

To configure CFM CLI settings go to Device Configuration > System > Configuration > CLI Configuration.

IPS MAX Packets
Set IPS MAX Packets

Set number of packets to be sent for Application Classification.

• All - pass all of the session packets for application classification
• Default - pass first 8 packets of the session of each direction for application classification (total

16)
• Value – any number between 8 and 65535

Route Precedence

Route List

• Static System Routes
• VPN Routes

Change the Order

Use Move Up & Move Down buttons to change the order of routes.

Note:  Do not forget to click Apply after changing the order.

HTTPS Unknown Protocol

Deny HTTPS Unknown Protocol

Select action for HTTPS unknown protocol.

Available options:

On : Deny invalid traffic through HTTPS port Off : Allow invalid traffic through HTTPS port

By default, it is On.

Note:  Do not forget to click Apply after changing the action.

HTTPS Certificate
Invalid HTTPS Certificate

If you enable HTTPS scanning, you need to import SSL Proxy certificate in Internet Explorer,
Firefox Mozilla or any other browsers for decryption on SSL Inspection otherwise browser will
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always give a warning page when you try to access any secure site. “Invalid Certificate error”
warning appears when the site is using an invalid SSL certificate. The device blocks all such sites.
Allow or block access to such sites.

Note:  Do not forget to click Apply after changing the action.

Thin Client

Add

Click to add IP address of a Citrix server.

IP Address

List of added Citrix servers IP addresses.

Manage
Click to remove Citrix server.
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