Skip to content

Appendix A – DHCPv4 options

A DHCP server can provide optional configuration settings to clients. Sophos Firewall supports the following DHCP options.

To set the options, see DHCP.

Note

Some table content may not be visible. Use the horizontal scroll bar at the bottom of the table, or click and drag horizontally, to see the remaining content.

Option number Name Description Data type Data format Data value (example) RFC
2 Time_Offset Time offset in seconds from Coordinated Universal Time (UTC) Four-byte numeric value Four-byte numeric value 18000 RFC 2132
4 Time_Servers N/4 time server addresses Array of IP addresses array of "192.0.2.10,192.0.2.11" RFC 2132
5 IEN116_Name_Servers N/4 IEN-116 server addresses Array of IP addresses array of "192.0.2.5,192.0.2.6" RFC 2132
6 Domain_Name_Servers DNS name servers list Array of IP addresses array of "192.0.2.1,192.0.2.2" RFC 2132
7 Log_Servers N/4 logging server addresses Array of IP addresses array of "192.0.2.7" RFC 2132
8 Cookie_Servers N/4 quote server addresses Array of IP addresses array of "192.0.2.8" RFC 2132
9 LPR_Servers N/4 printer server addresses Array of IP addresses array of "192.0.2.9" RFC 2132
10 Impress_Servers N/4 impress server addresses Array of IP addresses array of "192.0.2.10" RFC 2132
11 Resource_Location_Servers N/4 RLP server addresses Array of IP addresses array of "192.0.2.11" RFC 2132
12 Host_Name Client host name String String "myhost.example.com" RFC 2132
13 Boot_Size Boot file size in 512-byte blocks Two-byte numeric value Two-byte numeric value 512 RFC 2132
14 Merit_Dump Path for client core dump file String String "/var/crash/dump" RFC 2132
15 Domain_Name Domain name for client DNS resolution String fqdn "example.com" RFC 2132
16 Swap_Server Swap server addresses IP addresses ipv4-address "192.0.2.16" RFC 2132
17 Root_Path Client root disk path String String "/export/root" RFC 2132
18 Extension_Path Extensions path for TFTP options file String String "/tftp/extensions" RFC 2132
19 IP_Forwarding Enable or disable IP forwarding Boolean Boolean on RFC 2132
20 Non_Local_Source_Routing Enable or disable source routing Boolean Boolean off RFC 2132
21 Policy_Filter Policy filter for non-local source routing Array of IP addresses array of "10.229.0.128,255.255.255.128,10.27.129.0,255.255.255.0" RFC 2132
22 Max_Dgram_Resssembly Maximum datagram reassembly size Two-byte numeric value Two-byte numeric value 576 RFC 2132
23 Default_IP_TTL Default IP Time-to-Live value One-byte numeric value One-byte numeric value 64 RFC 2132
24 Path_MTU_Aging_Timeout Path MTU aging timeout in seconds Four-byte numeric value Four-byte numeric value 600 RFC 2132
25 Path_MTU_Plateau_Table MTU plateau table for Path MTU Discovery Array of two-byte numeric values Array of two-byte numeric values "68,296,508,1006,1492,1500" RFC 2132
26 Interface_MTU Interface MTU value Two-byte numeric value Two-byte numeric value 1500 RFC 2132
27 All_Subnets_Local All subnets are local Boolean Boolean on RFC 2132
28 Broadcast_address Broadcast address IP addresses ipv4-address "192.0.2.255" RFC 2132
29 Perform_Mask_Discovery Perform mask discovery Boolean Boolean off RFC 2132
30 Mask_Supplier Provide mask to others Boolean Boolean off RFC 2132
31 Route_Discovery Perform router discovery Boolean Boolean off RFC 2132
32 Router_Solicitation_Address Router solicitation address IP addresses ipv4-address "192.0.2.1" RFC 2132
33 Static_Routes Static route entries (destination/gateway pairs) Array of IP addresses array of "10.0.0.0,192.0.2.1,172.16.0.0,192.0.2.1" RFC 2132
34 Trailer_Encapsulation Trailer encapsulation Boolean Boolean off RFC 2132
35 ARP_Cache_Timeout ARP cache entry timeout in seconds Four-byte numeric value Four-byte numeric value 60 RFC 2132
36 IEEE802_3_Encapsulation Ethernet encapsulation Boolean Boolean off RFC 2132
37 Default_TCP_TTL Default TCP segment TTL value One-byte numeric value One-byte numeric value 64 RFC 2132
38 TCP_Keepalive_Interval TCP keepalive interval in seconds Four-byte numeric value Four-byte numeric value 7200 RFC 2132
39 TCP_Keepalive_Garbage TCP keepalive garbage Boolean Boolean on RFC 2132
40 NIS_Domain Network Information Service domain name String String "nisdomain" RFC 2132
41 NIS_Servers NIS server addresses list Array of IP addresses array of "192.0.2.41,192.0.2.42" RFC 2132
42 NTP_Servers NTP server addresses list Array of IP addresses array of "192.0.2.42,192.0.2.43" RFC 2132
43 Vendor_Encapsulated_Options Vendor-specific encapsulated options String String "0x01020304" RFC 2132
44 Netbios_Name_Servers NetBIOS name server (WINS) addresses Array of IP addresses array of "192.0.2.44,192.0.2.45" RFC 2132
45 Netbios_DD_Server NetBIOS datagram distribution server addresses Array of IP addresses array of "192.0.2.45" RFC 2132
46 Netbios_Node_Type NetBIOS node type One-byte numeric value One-byte numeric value 8 RFC 2132
47 Netbios_Scope NetBIOS scope identifier String String "mynetbios" RFC 2132
48 Font_Servers X Window font server addresses Array of IP addresses array of "192.0.2.48" RFC 2132
49 X_Display_Manager X Window display manager addresses Array of IP addresses array of "192.0.2.49" RFC 2132
50 DHCP_Requested_Address Requested IP address IP addresses ipv4-address "192.0.2.100" RFC 2132
51 DHCP_Lease_Time IP address lease time in seconds Four-byte numeric value Four-byte numeric value 86400 RFC 2132
52 DHCP_Option_Overload Overload sname/file fields One-byte numeric value One-byte numeric value 1 RFC 2132
53 DHCP_Message_Type DHCP message type identifier One-byte numeric value One-byte numeric value 1 RFC 2132
54 DHCP_Server_Identifier DHCP server identifier address IP addresses ipv4-address "192.0.2.1" RFC 2132
55 DHCP_Parameter_Request_List Requested DHCP option codes list Array of one-byte numeric values Array of one-byte numeric values "1,3,6,15,28,51" RFC 2132
56 DHCP_Message Error or status message from DHCP server String String "Requested address not available" RFC 2132
57 DHCP_Max_Message_Size Maximum DHCP message size accepted by the client Two-byte numeric value Two-byte numeric value 1500 RFC 2132
58 DHCP_Renewal_Time Renewal (T1) time value in seconds Four-byte numeric value Four-byte numeric value 43200 RFC 2132
59 DHCP_Rebinding_Time Rebinding (T2) time value in seconds Four-byte numeric value Four-byte numeric value 75600 RFC 2132
60 Vendor_Class_Identifier Vendor class identifier string String String "MSFT 5.0" RFC 2132
61 DHCP_Client_Identifier Client unique identifier String Hex format data "1A BB AD AB BA D0 00 00 00 00 00 00 00 00 CA FE" RFC 2132
62 NWIP_Domain NetWare/IP domain name String String "netware.example.org" RFC 2242
63 NWIP_SubOptions NetWare/IP suboptions String String "1A BB AD AB BA D0 00 00 00 00 00 00 00 00 CA FE" RFC 2242
64 NISPlus_Domain NIS+ domain name String String "nisplus.example.org" RFC 2132
65 NISPlus_Servers NIS+ server addresses Array of IP addresses array of "192.0.2.65" RFC 2132
66 TFTP_Server_Name TFTP server name String String "tftp.example.org" RFC 2132
67 Bootfile_Name Boot file name String String "pxelinux.0" RFC 2132
68 Mobile_IP_Home_Agent Mobile IP home agent addresses Array of IP addresses array of "192.0.2.68" RFC 2132
69 SMTP_Server Simple Mail Transfer Protocol server addresses Array of IP addresses array of "192.0.2.69" RFC 2132
70 POP_Server Post Office Protocol server addresses Array of IP addresses array of "192.0.2.70" RFC 2132
71 NNTP_Server Network News Transfer Protocol server addresses Array of IP addresses array of "192.0.2.71" RFC 2132
72 WWW_Server WWW server addresses Array of IP addresses array of "192.0.2.72" RFC 2132
73 Finger_Server Finger server addresses Array of IP addresses array of "192.0.2.73" RFC 2132
74 IRC_Server Internet Relay Chat server addresses Array of IP addresses array of "192.0.2.74" RFC 2132
75 Streettalk_Server StreetTalk server addresses Array of IP addresses array of "192.0.2.75" RFC 2132
76 Streettalk_Dir_Asst_Server StreetTalk directory assistance server addresses Array of IP addresses array of "192.0.2.76" RFC 2132
77 User_Class User class information String String "engineering" RFC 3004
78 SLP_Directory_Agent Service Location Protocol directory agent information String boolean,array of "on,192.0.2.78" RFC 2610
79 SLP_Service_Scope Service Location Protocol service scope information String boolean,string "on,engineering" RFC 2610
85 NDS_Servers Novell Directory Services server addresses Array of IP addresses array of "192.0.2.85,192.0.2.86" RFC 2241
86 NDS_Tree_Name Novell Directory Services tree name String String "CORP_TREE" RFC 2241
87 NDS_Context Novell Directory Services context String String "OU=Engineering.O=Corp" RFC 2241
88 BCMS_Controller_Names BCMCS controller domain name list fqdn Array fqdn Array "bcms1.example.org,bcms2.example.org" RFC 4280
89 BCMS_Controller_Address BCMCS controller IPv4 addresses Array of IP addresses array of "192.0.2.89,192.0.2.90" RFC 4280
93 Client_System Client system architecture type String Array of two-byte numeric values "0,6,7" RFC 4578
94 Client_NDI Client network device interface identifier String Three one-byte numeric values "1,2,1" RFC 4578
97 UUID_GUID Client machine UUID/GUID String Hex format data "4d,36,e9,67,11,22,33,44,55,66,77,88,99,aa,bb,cc" RFC 4578
98 UAP_Servers User Authentication Protocol server addresses Array of IP addresses array of "192.0.2.98" RFC 2485
99 Geoconf_Civic Civic location configuration information String String "civic-location-data" RFC 4776
100 PCode Postal code String String "SW1A1AA" RFC 4833
101 TCode Tax area code String String "TCODE001" RFC 4833
112 Netinfo_Server_Address NetInfo parent server addresses Array of IP addresses array of "192.0.2.112" RFC 3679
113 Netinfo_Server_Tag NetInfo parent server tags String String "corporate-netinfo" RFC 3679
114 V4_Captive_Portal Captive portal URI String URI "https://portal.example.org/captive" RFC 7710
116 Auto_Config Auto-configuration setting Boolean Boolean on RFC 2563
117 Name_Service_Search Name service search list fqdn Array fqdn Array "corp.example.org,eng.example.org" RFC 2937
119 Domain_Search DNS domain search list fqdn Array fqdn Array "example.org,branch.example.org" RFC 3397
121 Classless_Static_Route Classless static route information String array of "10.0.0.0/8,192.0.2.1,172.16.0.0/12,192.0.2.2" RFC 3442
124 Vivco_Suboptions Vendor-identifying vendor class suboptions String String "vendor-suboption-data" RFC 3925
125 Vivso_Suboptions Vendor-identifying vendor-specific suboptions String String "vendor-specific-data" RFC 3925
136 Pana_Agent PANA agent addresses Array of IP addresses array of "192.0.2.136" RFC 5192
137 V4_Lost LoST server FQDN String fqdn "lost.example.org" RFC 5223
138 Capwap_AC_V4 CAPWAP AC addresses Array of IP addresses array of "192.0.2.138" RFC 5417
141 SIP_UA_CS_Domains SIP UA CS domains fqdn Array fqdn Array "sip.example.org" RFC 6011
143 V4_Sztp_Redirect Secure ZTP redirect servers String array of "https://sztp1.example.com:8443,https://sztp2.example.com:8444" RFC 8572
146 Rdnss_Selection RDNSS selection information String One-byte numeric value, IPv4 address, IPv4 address, array of "1,192.0.2.70,192.0.2.71,example.com,example.org" RFC 6731
159 V4_Portparams Port parameters String uint8,PSID "2,3/4" RFC 7618
212 Option_6rd IPv6 Rapid Deployment configuration String One-byte numeric value, One-byte numeric value, IPv6 address, array of "24,96,2001:db8::f001,192.0.2.72,192.0.2.73" RFC 5969
213 V4_Access_Domain Access network domain name String fqdn "access.example.org" RFC 5986
Custom Custom Create a custom DHCP option. Specify the option code, select the option type, and enter the option value. User-defined Depends on the selected type User-defined N/A