Skip to content

Appendix B – DHCPv6 options

A DHCP server can provide optional configuration settings to clients. Sophos Firewall supports the following DHCP options.

To set the options, see DHCP.

Note

Some table content may not be visible. Use the horizontal scroll bar at the bottom of the table, or click and drag horizontally, to see the remaining content.

Option number Name Description Data type Data format Data value (example) RFC
7 Preference Server preference value (0-255, higher is preferred) One-byte numeric value One-byte numeric value 255 RFC 8415
12 Unicast Server unicast address for client communication IP addresses ipv6-address "2001:db8::1" RFC 8415
21 SIP-Servers-Names Domain names of SIP outbound proxy servers String array of "sip.example.org,sip2.example.org" RFC 3319
22 SIP-Servers-Addresses IPv6 addresses of SIP outbound proxy servers Array of IP addresses array of "2001:db8::21,2001:db8::22" RFC 3319
23 Name-Servers IPv6 addresses of DNS recursive name servers Array of IP addresses array of "2001:db8::53,2001:db8::54" RFC 3646
24 Domain-Search Domain search list for hostname resolution String array of "example.com,eng.example.org" RFC 3646
27 NIS-Servers IPv6 addresses of NIS servers Array of IP addresses array of "2001:db8::27,2001:db8::28" RFC 3898
28 NISP-Servers IPv6 addresses of NIS+ servers Array of IP addresses array of "2001:db8::29,2001:db8::30" RFC 3898
29 NIS-Domain-Name NIS domain name for the client String array of "nis.example.org" RFC 3898
30 NISP-Domain-Name NIS+ domain name for the client String array of "nisplus.example.org" RFC 3898
31 SNTP-Servers IPv6 addresses of SNTP time servers Array of IP addresses array of "2001:db8::31,2001:db8::32" RFC 4075
32 INFO-Refresh-Time Upper bound in seconds for DHCPv6 info refresh Four-byte numeric value Four-byte numeric value 86400 RFC 8415
33 BCMS-Server-D BCMS controller domain names String array of "bcmcs.example.org" RFC 4280
34 BCMS-Server-A BCMS controller IPv6 addresses Array of IP addresses array of "2001:db8::33,2001:db8::34" RFC 4280
36 GeoConf_Civic Civic address location information String One-byte numeric value, Two-byte numeric value, Array of Hex format data "0,0x5553,15 9D,A3 FF" RFC 4776
37 Remote_Id Remote identifier for relay agent String Four-byte numeric value, Hex format data "4294967295,1A BB AD AB BA D0 00 00 00 00 00 00 00 00 CA FE" RFC 4649
38 Subscriber_Id Subscriber identifier for relay agent String Hex format data "A3 FF" RFC 4580
39 Client_FQDN Client's fully qualified domain name String One-byte numeric value, fqdn "224,client.example.org" RFC 4704
40 Pana_Agent PANA agent IPv6 addresses Array of IP addresses array of "2001:db8::40" RFC 5192
41 New_Posix_Timezone POSIX timezone string (IEEE 1003.1) String String "EST5EDT,M3.2.0,M11.1.0" RFC 4833
42 New_Tzdb_Timezone IANA timezone database name String String "America/New_York" RFC 4833
43 ERO Option codes server should echo back Array of two-byte numeric values Array of two-byte numeric values "16,32,42" RFC 4994
44 LQ_Query_1 Leasequery query option (query type + address) String One-byte numeric value, IPv6 address "1,2001:db8::100" RFC 5007
46 Clt_Time_1 Leasequery client last transaction time Four-byte numeric value Four-byte numeric value 3600 RFC 5007
47 LQ_Relay_Data_1 Leasequery relay data (address + message) String IPv6 address, Hex format data "2001:db8::18,1A BB AD AB BA D0 00 00 00 00 00 00 00 00 CA FE" RFC 5007
48 LQ_Client_Link_1 Leasequery client link addresses Array of IP addresses array of "2001:db8::1,2001:db8::2" RFC 5007
51 V6_Lost LoST (Location-to-Service Translation) server FQDN String fqdn "lost.example.org" RFC 5223
52 Capwap_AC_V6 CAPWAP Access Controller IPv6 addresses Array of IP addresses array of "2001:db8::52,2001:db8::53" RFC 5417
53 Relay_Id Unique relay agent identifier String Hex format data "1A BB AD AB BA D0 00 00 00 00 00 00 00 00 CA FE" RFC 5460
57 V6_Access_Domain Access network domain name String fqdn "access.example.org" RFC 5986
58 SIP_UA_CS_List SIP UA CS domains list String array of "sipcs.example.org" RFC 6011
59 Bootfile_URL URL for network boot file String String "tftp://[2001:db8::1]/bootfile.efi" RFC 5970
60 Bootfile_Param Boot file parameters list String array of "root=/dev/sda2,quiet,splash" RFC 5970
61 Client_Arch_Type Client system architecture (UEFI/BIOS) Array of two-byte numeric values Array of two-byte numeric values "1,3,5,7" RFC 5970
62 NII Network interface type and version String One-byte numeric value, Array of one-byte numeric values, One-byte numeric value "1,2,11,13" RFC 5970
64 AFTR_Name DS-Lite AFTR tunnel endpoint FQDN String fqdn "aftr.example.org" RFC 6334
65 ERP_Local_Domain_Name EAP Re-auth Protocol local domain name String fqdn "erp.example.org" RFC 6440
67 PD_Exclude Prefix to exclude from delegated prefix String Hex format data "2001:db8:1:1::/64" RFC 6603
74 RDNSS_Selection Recursive DNS server selection info String IPv6 address, uint8, array of "2001:db8::23,1,example.com,example.org" RFC 6731
79 Client_LinkLayer_Addr Client hardware address (from relay) String Hex format data "1A BB AD AB BA D0 00 00 00 00 00 00 00 00 CA FE" RFC 6939
80 Link_Address Link address for leasequery IP addresses ipv6-address "2001:db8::1" RFC 6977
82 SolMax_RT Maximum Solicit timeout value in seconds Four-byte numeric value Four-byte numeric value 3600 RFC 8415
83 Inf_Max_RT Maximum Information-Request timeout in seconds Four-byte numeric value Four-byte numeric value 86400 RFC 8415
88 DHCPv6_Server_Addr DHCPv4-over-DHCPv6 server addresses Array of IP addresses array of "2001:db8::88,2001:db8::89" RFC 7341
103 V6_Captive_Portal URL for captive portal detection String String "https://portal.example.org/captive" RFC 8910
136 V6_SZTP_Redirect Secure Zero Touch Provisioning redirect URLs String array of "https://sztp1.example.com:8443,https://sztp2.example.com:8444" RFC 8572
143 IPv6_Address_ANDSF Access Network Discovery server addresses Array of IP addresses array of "2001:db8::143" RFC 6153
Custom Custom Create a custom DHCP option. Specify the option code, select the option type, and enter the option value. User-defined Depends on the selected type User-defined N/A